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About this Guide

About this Guide

SQL Direct is available to both AVEVA Plant and AVEVA Marine customers. The SQL Direct
User Guide is written using AVEVA Plant but can be equally used by Marine customers.

Scope of this Guide

This guide tells you how to use AVEVA SQL Direct on a PC running Windows XP.

For information about training courses, see AVEVA's worldwide sales and support offices,
see the Customer Support pages on our website at http://www.aveva.com/location.

About this User Guide

SQL Direct Components

Using SQL Direct
Components

Using SQL Direct - Some
Examples

Using SQL Direct with
Microsoft SQL Server

Describes the components of SQL Direct - SQL Direct
Configuration, the PDMS Provider, the Table Designer and
some potential data consumers. It describes what each
component does and how they all fit together to form SQL
Direct.

Tells you how to use SQL Direct Configuration, the PDMS
Provider, and the Table Designer.

Gives some examples of how to use SQL Direct with simple
data consumers.

Describes how to use SQL Direct with Microsoft SQL Server /
SQL Desktop Engine (MSDE) and Microsoft Access.

Note: This User Guide assumes that you are familiar with PDMS DESIGN/Outfitting

Design.
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Some Useful WWW Addresses

Site

URL

Microsoft Data Access and Storage web site:  http://msdn2.microsoft.com/en-us/data/

default.aspx

Microsoft Developer Network web site: http://msdn.microsoft.com/default.asp

Microsoft SQL Server web site: http://www.microsoft.com/sql/

Reference Material

System Administrators may find the following useful:

Microsoft OLE DB 2.0 Programmer's Reference and Data Access SDK
(Microsoft Professional Editions). Microsoft Corp (Editor); paperback.
Microsoft Press; ISBN: 0735605904; November 1998.

Teach Yourself OLE DB and ADO in 21 Days (Teach Yourself).
John W. Fronckowiak; paperback. Sams; ISBN: 067231083X; August 1997.

Learn OLE DB Development with Visual C++ 6.0.
Nathan Wallace; paperback. Wordware Publishing; ISBN: 1556226349.

Learn Advanced OLE DB Development with Visual C++ 6.0.
Nathan Wallace; paperback. Wordware Publishing; ISBN: 1556226586.

Visual C++ 6.0 OLE DB Programming.
Craig McQueen; paperback. Wrox Press; ISBN: 1861001614
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2 Introducing SQL Direct 12.0

SQL Direct enables you to access the DESIGN Database directly from within software
products that support Microsoft Universal Data Access interfaces such as ODBC, OLE DB
and ADO.

Products that support these interfaces include the Microsoft Office applications Word, Excel
and Access, other proprietary databases such as ORACLE and SYBASE, end-user
applications written in Visual Basic and Visual C++, and of course SQL Direct. We
collectively refer to these products as data consumers or data providers, according to
whether they consume or provide data access services (irrespective of whether data is read
from or written to any particular database). Some products can act both as consumers and
providers.

Using SQL Direct tools, you can query any data that the DESIGN module can access i.e.
attributes, pseudo-attributes, and UDAs.

The following diagram gives an overview of the software components that make up SQL
Direct (shown in pale blue) in relation to data consumer applications and PDMS.

Data Consumers

MS Excel @

SOL Server

SQL DirectConfiguration
PDMS |Data Provider _ ; ‘
‘ PDMSProv OLE DB Provider.dll ‘ i

SQOLDirectConfig.exe ‘

/
‘ TableDesigner.exe ‘

FPDMS Server

‘ PDMSServer.exe
‘ PDMS;heII.dII } ffffffff TableSchemaltsf P
PDMS
‘ Toolbox dfis ‘
< PDMS T
| POMS Ses;gn i g
Database
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Although not necessary to access data through OLE DB and ADO, you can enhance SQL
Direct using Microsoft SQL Server (or Microsoft SQL Desktop Engine (MSDE), which is an
equivalent but earlier product).

SQL Server provides access to additional functionality by acting as a data consumer and
then providing a relational view of the data to other applications, for example Microsoft
Access, through its "linked server" facility. This mode of data access can be further wrapped
as an ODBC data source.

We have tested SQL Direct with MSDE 2000, Service Pack 4. However, throughout the rest
of this document we will refer to Microsoft SQL Server, or simply SQL Server.

Using SQL Direct - Setting Up

To use SQL Direct 12.0 you must have AVEVA 12.0 or later installed, as well as have some
project data.

If you want to use the intended functionality based on SQL Server, you will also need to
have this product installed.

Then, you need to:

« configure SQL Direct with the necessary paths and environment variables to match
the particular project database or databases you wish to access.

« design a set of tables that defines the structure of the data to be passed to the data
consumer. SQL Direct comes with some preconfigured tables, although you may also
design your own.

If you want to use SQL Server, you also need to:

e configure SQL Server with the necessary data views to match the tables you have
defined.

See SQL Direct Components, Using SQL Direct Components and Using SQL Direct - Some
Examples for more details of these operations.
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SQL Direct Components

There are two components of SQL Direct that are visible to the user - SQL Direct
Configuration and the Table Designer. These are both related to initial set-up.

Normal day to day operation of SQL Direct proceeds, invisibly to the user, through the
PDMS Provider component and the PDMS Server which interacts with PDMS itself.

SQL Direct Configuration

Introduction to SQL Direct Configuration
Start SQL Direct Configuration from the Start menu, ;.'_staj',._t , by selecting the program
from the AVEVA entry:

The main SQL Direct Configuration window looks like this:

AVEVA SQL Direct Configuration  [= |51 /[X]
Connection Edit Tools Help

SAM2
MON

SQL Direct Configuration allows you to configure SQL Direct with connection information to
match the particular project databases you want to access. Using the tools menu, you can
also start the Table Designer, start and stop the PDMS Server and SQL Server processes,
and configure data views within SQL Server.
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SQL Direct Configuration - Menu Options

SQL Direct Configuration has three function menus plus the help menu. The options
available are described in the following sections.

The Connection Menu

(el Edt Tools Help

AVEVA SOL Direct Configuration EE

New Connection...

Exit

Menu Option

Function

New Connection...

Allows you to add a new set of connection details. This
invokes an empty Connection Properties form.

Test Connection...

Tests connection to PDMS using the currently selected set of
connection details. (A simple ADO based test program is
provided for this purpose.)

Properties... Invokes the Connection Properties form for the currently
selected connection.

Exit Exits the SQL Direct Configuration program.

Edit Menu

AVEVA SOL Direct Configuration [E@

Connection 28l Tools Help
Cut
Copy

Faste

Menu Option Function

Cut Removes the currently selected set of connection details from
the list. The details are retained in the paste buffer.

Copy Copies the currently selected set of connection details into the
paste buffer.

Paste Replaces the currently selected set of connection details with

the set from the paste buffer.
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Menu Option Function

Paste New Adds a new set of connection details populated with the
settings from the paste buffer.

Delete Removes the currently selected set of connection details from
the list. They are not retained in the paste buffer.

Tools Menu

AVEVA SQL Direct Configuration  [=][E1/[3]
Connection Ed& Wit Help
Start Table Desigrer... h

Stop PDIMS Server

Choose SQL Server Instance »

ark MSSQLSERVER

Stop MSSQLSERYER

Configure MSSQLSERYER

Menu Option Function

Start Table Designer... Starts the Table Designer program.

Start PDMS Server Starts the PDMS Server process.

Stop PDMS Server Stops the PDMS Server process.

Choose SQL Server Allows you to choose the SQL Server instance on your

Instance -> machine (if more than one) that the Start, Stop and Configure
options will apply to.

Start SQLEXPRESS Starts the SQL Server process (for the chosen SQL Server
instance).

Stop SQLEXPRESS Stops the SQL Server process (for the chosen SQL Server
instance).

Configure SQLEXPRESS | Creates the necessary metadata within the chosen SQL
Server instance to provide data views consistent with the
table schema file defined in the currently selected connection
details.
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Table Designer

& TableSchema-tsf - AVEVA SQL Direct Table Designer

File Edit WView Insert Schema Help

L= == 4

ol Rowsof | REFMO | MAME | TYPE | OWNER | LOCK | DESCRIPTION FLNCTION
[ SUBEQUIFMERNT equi REFMO MAME TYPE OWHER LOCK DESCRIPTION FUNCTION
B nozzlE

= PIPELIME
BRANCH
COMPONENT
VALVE
TMSTRUMENT
STRUCTURE
SUBSTRUCTURE
FRAME
SUBFRAME

0= H

[n]
m
Ia]
=
=]
=

O O O =

(I T ) ) Y G T T T T 0

l
=
=
m
-
o

Ready @ @

The Table Designer enables you to define tables of PDMS data. Within each table, you can
define one or more row types and column names, and the data item to fetch for each. Once
you have defined and saved your table definitions, SQL Direct can use them to determine
which data to pass to a data consumer that requests information from the database.

See Using the Table Designer for full details

PDMS Provider

The software component that coordinates the provision of data to a data consumer (i.e. a
client application) is called the data provider.

During normal, day-to-day operation of SQL Direct, the PDMS data provider works invisibly,
automatically forming data rowsets in response to data requests from client programs.

The underlying technology that supports the interaction between data providers and data
consumers is called Object Linking and Embedding Database (OLE DB), and data providers
and consumers are more fully known as OLE DB Providers and OLE DB Consumers.

PDMS Server

All data access by SQL Direct to and from PDMS is handled by a program called the PDMS
Server. This program is started up automatically as required by the PDMS Provider, and
also Table Designer.

PDMS Server uses the connection details defined in SQL Direct Configuration to link to
named projects and MDBs.
Login to PDMS uses normal user names and passwords, and access levels are determined
by the access levels granted to that user.
When a client first connects to PDMS Server, these three pieces of connection information
must be established:

« the connection identity (connection string)

» the user name
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« the password.

For convenience you can store this information in a client application's cache or save file.
Microsoft Office clients, for example, offer the opportunity to store this information for future
access. If a client application supplies this information, operation of PDMS Server is
completely invisible.

Note: You should be aware that retaining passwords in client caches weakens data
security.

If security is important then you should not retain passwords in client caches. When a client
connects to PDMS Server without full connection information, PDMS Server will invite you
to provide the missing information on a login form:

AVEVA SOL Direct Login

User Name |

Pazsword |

ConnectString |

Cancel |

After login, the operation of PDMS Server is normally automatic and requires no user
intervention. PDMS Server will run until you log out of Windows, or shut down your machine.
However, you can also start and stop PDMS Server manually through the Tools menu of
SQL Direct Configuration.

You can also start PDMS Server through the shortcut on the SQL Direct program menu. In
this case, a Command window is displayed once PDMS has been connected to, providing
diagnostic output of commands as they are executed by PDMS Server.

Use on Shared PCs

SQL Direct is a single user tool. Once you have logged in to PDMS through any of the SQL
Direct tools, it is not possible for another user to log in during the same session, or for you to
access PDMS with a different connection string from the one you logged in with. Other login
details will be rejected with "access denied" errors.

To access SQL Direct with new user credentials, you must first shutdown PDMS Server,
either through the SQL Direct Configuration Tools menu, or by closing the "PDMS
Command Line" window (if visible), or by executing the following command from a
command prompt window:

<SQL Direct install path>PDMS Server /STOP

Once PDMS Server has been shut down, you can either restart PDMS Server through the
SQL Direct Configuration Tools menu, or allow it to start up automatically as required.
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Using SQL Direct Components

Using SQL Direct Configuration

This section describes the SQL Direct Configuration menu options. For an introduction to
and a general description of the SQL Direct Configuration, see SQL Direct Configuration.

Specifying PDMS Connection Details

Before OLE DB clients can use the services of the PDMS Provider, you must use SQL
Direct Configuration to set up one or more sets of connection details.

A set of connection details is identified by a connection string identifying the project and
MDB it will open for the connection, and a number of environment variable settings needed
for PDMS to operate correctly.

You can input completely new sets of connection details by selecting the Connection>New
Connection... menu option.

You can view or modify an existing set by selecting the Connection>Properties... option.

Either option will invoke the Connection Properties form:
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PDMS Connection Properties

Connection String: |SAM1 j

Standard Y ariables

FOMSERE  |CosvEvaPdms12.0 Browse...

FOMSWE  |CATemp Browse...

FOMSLI |CABMEN A Pdms 12 DVPDMS LI Browse. .

111

PHLLIE |CAAWE YA Pdms T2 INPMLLIE Browse...

Froject Details

Froject Mame |sam

MOEB |SaMPLE

Table Schema |C\ A EYAVS OL-Direct] 2 NS amplesh T ableSchem  Brawse. .

D atabaze Wariables

sami00 |C W EraAPdms1 2. Dhprojectsam000 Browse. ..
FAMMAs |I::'~.~’-‘-.VEVA'\F'dms1 2 0\ projectysammac Browse. .

sampic |ChaWEraAPdms1 2. Dhprojectysampic Browse. ..

samiso |C W EraAPdms1 2. Dhprojectsamisn Browse. ..

bore Ere Vars |0 Ay EVaAS DL-Direct] 2. WS amples\EstraE vars.d - Brawse...

PREE 1

Test Connect 0K | LCancel | Apply |

i

The fields on this form have the following meaning:

Field

Purpose

Connection String

A unique identifier for this set of connection details. This
is the connection string to quote when setting up a
PDMS Provider link from a client.

Standard Variables

These are all mandatory.
Set PDMSEXE to point to the install directory for PDMS.
Set PDMSWK to a suitable PDMS working directory.

Set PDMSUI to where you store PML form definitions
and related code

Set PMLLIB to where you store the files for general PML
application ware.

You may use the Browse... button to locate these
directories and reduce typing.
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Field Purpose

Project Details These are all mandatory.
Project Name is the PDMS project name.

MDB is the PDMS MDB that should be opened on
connection.

Table Schema is the location of the file containing the
definition of the tables exported from this PDMS project
through PDMS Provider. You create and modify table
schema files with the Table Designer program.

You may use the Browse... button to locate this file.

Database Variables These tell PDMS where the database files are for your
project. Note that the labels reflect the name of the
project: so if the project is "SAM" the labels are SAMO00O,
SAMMAC, etc. You need to fill in only these: the PIC and
ISO fields are for future use and you can leave them
blank.

More Env Vars gives you the opportunity to define any
further environment variable setting required for this
PDMS project, for example foreign database locations.
The field contains the name of a file holding further
environment variable definitions, one per line, in the
format: SET <varName>=<value>.

You may use the Browse... button to locate these
locations.

When editing with this form, the OK and Apply buttons allow you to save the changes. The
OK button additionally dismisses the form; and you can discard changes using the Cancel
button.

You can test to see if the connection details are correct using the Test Connection button.
This launches a separate program, ADOTest, to test the connection as a Microsoft Active
Data Object (ADO) client.

Using the Table Designer

Starting the Table Designer

You can start the Table Designer in one of two ways:

e Select Start>All Programs>AVEVA>SQL-Direct 12.0>Table Design for SQL Direct
from the Start menu.

¢ Choose Tools >Start Table Designer... from the SQL Direct Configuration menu.
Whichever route you choose you will need to complete the login details for the project you

wish to connect to (unless PDMS Server is already running and logged in to PDMS with the
correct details):
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AVEVA SOL Direct Login

Uszer Name |

Password |

ConnectString |

Cancel |

Field Purpose

User Name Your user name.

Password Your password.

Connect String The set of connection details to use.

When a Table Schema file already exists for this connection, Table Designer displays the
main form for that table schema (see below). If no table schema file already exists the main
window is empty:

[z Untitlad - SQL-Direct Table Designer

File Edit Wwiews Insert 3Schema  Help
== a & ?
Ready ®

4.2.2 Basic Concepts

The Table Designer opens showing the current table schema, if there is one. The table
schema maps to the current project database. SQL Direct uses table schemas to define
which data to pass to a data consumer when requested.

You can use the Table Designer to add new tables or modify or delete existing ones.
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Term

Definition

Project Schema file

This file lists all the element types available in a project
along with their attributes. All Table Schema files (see
below) refer to a Project Schema file to map the columns
in a table to element attributes.

In general, one Project Schema file can serve many Table
Schema files.

Table Schema file

This file describes the tables used to retrieve data.
Different table schemas may be appropriate for different
reporting disciplines.

Table

A logical grouping of data.

A table consists of columns (attribute values) and table
rows (element types).

When data is retrieved, the PDMS Provider searches for
all elements of the types listed in the table rows and
extracts the value of the attribute specified in the
appropriate table row for each column.

Column

Each column in the table describes one element attribute
whose value is to be returned when the table is queried.
The column name is often the same as the attribute name,
but does not have to be.

Table row

A table row describes what sort of data are to be returned.
Each table row in a table specifies an element type and a
list of bindings, one for each column.

A table contains one or more table rows.

In this document, "row" usually means "table row".

Data row

A row of data returned from the database corresponding to
a single element. The values returned are determined by
the entries in the table rows for that element type for the
table.

Binding

A mapping in a table between the column and an attribute
of an element. Each table row consists of an element type
and a binding for each column of the table describing
which attribute of the element supplies the data for that
column.

Key column

A column in the table that uniquely identifies an object in
the database.

A table must have a key column before any other column
can be made writeable.

Practically, the key column must be either REFNO or
NAME (REFNO is preferred). Key columns are always
read-only.
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4.2.3 Creating a New Table Schema
To create a new table schema from scratch:
1. Generate a Project Schema file if one does not already exist using the
Schema>Generate Project Schema... menu option.

2. This procedure extracts the element type and attribute information from PDMS. Project
Schemas are project specific since different PDMS projects will typically define different
User Defined Attributes (UDAS).

3. Select the File>New menu option or click the ol button on the toolbar and select the
Project Schema file from the dialogue screen displayed:

Choose A Project Schema File

Lok, in: | ) Samples j =5 BB

L) AD0Test
ProjectSchema.dat
samfaoreign. dat

File name: Frojectschema.da
Files of type: | Diata files [*.dat] | Cancel

4. Create tables, columns, and rows as described below.
5. When complete, save the table schema to file using the File>Save As menu option or
click [ on the toolbar.

4.2.4 Editing an Existing Table Schema

Table Designer will normally open the currently active table schema when it starts. You can
open a different table schema file using the File>Open menu option or selecting from the

File>most recently used list or clicking i on the toolbar.

With a populated table schema, the Table Designer main form looks like this:
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[ TableSchema.tsf - SQL-Direct Table Designer

File Edit Wiew Insert Schema Help
X ahn | & 7
Rowsof |REFNo  |owner [ TveE |
sctn REFNO OVWHER, TYPE
& CWMER
# TYPE
25 NAME
== PIPEL
- BRAMCH
- EQUIP
- MOZZLE
< >
Ready @ @

The left hand pane lists the tables and column names as a tree. The right hand pane list the
table rows and associated column attribute bindings in a grid.

Creating a Table
To create a table:

1. Open an existing Table Schema or create a new one as described above.
2. Insert a new table and give it a name.
3. Define the table columns and the table rows.

Inserting and Naming a New Table
Choose Insert>Table, click = on the toolbar, or right-click in the left-hand pane and select

Insert Table.

Table Designer creates a new table and selects the default name ""NEWTABLE". We
recommend you change this to a more meaningful name.

Choose a name that describes the purpose of this table, e.g. ""SITES" or ""PIPING". You
can use letters, numbers and underscores in the table name, but you cannot use spaces.
The right hand pane should now show a column heading labelled "Rows of".

This column lists all the element types that provide the data for this table.
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Lintitled - SQL -Direct Table Designer;

File Edit “iew Insert Schema Help

= = X @t 3 B2 ee ?
Rows of |

Ready @ ﬁ

Adding Columns to the Table

Select Insert>Column, click & on the toolbar, or right-click on the table name and select
Insert Column.

Similarly to when you create a new table, the column will have a default name,
“NEWCOLUMN?’. Choose a new name (e.g. ""REFNO"" or ""NAME'") and press Enter. Note
that column names can contain spaces.

The new name appears in the right-hand pane. Repeat this process for all the columns that
you need. Note that Table Designer inserts the new column to the right of the current
selection, so if you select a column, it inserts the new column to the right of the selected
column; but if you select the table name, it inserts the new column as the first column in the
list.

Note: If you select a column in the left-hand pane, only that column will appear alongside
the "Rows of" column in the right-hand pane.
If you select the table name, the right-hand pane shows all columns of that table.

When you've inserted the columns, your Table Designer should look something like this:
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Untitled - SQL -Direct Table Designer,

File Edit Wew Insert Schema Help
(== ® AR o ae 7
== FIFING Rowsof | REFMO |
i REFNOD
Ready ® @

Important: If you want to write data back to the database, one of your columns must map to
REFNO or NAME. We recommend you use REFNO.

¢ Adding Rows to the Table

You can now enter the rows that tell SQL Direct Configuration where to get the data from.
Select the table name and then select Insert>Row or click 5= on the toolbar.

A drop-down list will appear under the "Rows of" column in the right-hand pane. Click on the
down-arrow and select an element type from the list. PDMS Provider locates all elements of
this type when it retrieves data.

If you labelled any columns with the exact name of an element attribute, e.g. ""/REFNO"",
Table Designer fills in the attribute for you; Table Designer assumes if the name of a column
matches an attribute name, then that is the attribute you want.

If there are any entries along your row under the headings marked "‘'unset", then you
need to tell Table Designer which attribute provides the data for that column, i.e. you need to
set the binding for that column. Double click on the word ""unset' and select the attribute
you want from the drop-down list. The list contains all the attributes for the type listed in that
row.

Having selected an attribute for an "unset" (or changed one that Table Designer put in by
default), Table Designer will attempt to re-use that attribute in any subsequent rows you may
add. In other words, it looks at the bindings for the row immediately above the new row
when choosing defaults, and uses the column names for the first row. It is quicker therefore,
to get the first row exactly right, then add new rows, rather than add all the rows before
checking the bindings.

Repeat from Inserting and Naming a New Table to create all the tables that you need.

To save the table you just defined as a .tsf file, select File>Save, or File>Save As..., or
click [ on the toolbar.
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Editing Existing Tables

Change a Table

To change a table (or column) name, select the table (or column) in the left-hand pane,
select Edit>Rename, or right-click on the name and choose Rename or select the name,
pause, then click on the name again (note: not a double-click).

Delete a Table or Column

To delete a table or column, select the table or column in the left-hand pane, select
Edit>Delete, click 3 on the toolbar, or right-click on the name and select Delete.

Delete a Row

To delete a row, select the row in the right-hand pane, select Edit>Delete, or click ¥ on the
toolbar.

Loading and Saving Tables Data

Save a Table

To save the table you just defined, select File>Save, File>Save As..., or click [ on the
toolbar and save the schema as a .tsf file.

Load a Table

u

To load a table schema, select File>Open..., or click (2 on the toolbar. Table Designer
displays the currently active table schema on startup.

Note that Schema>Reload Table Schema (g on the toolbar) discards all changes you
have made to the current table schema.

Writeable Data

If you have followed the above procedure, you now have a set of read-only tables. You
should also notice that every Edit menu command (Edit>Undo, Cut, Copy, Paste and
Change, and the equivalent toolbar buttons) and the Toggle read-only flag toolbar button

( ) is disabled.
This is because you can only mark rows as writeable if you also define a key column.

SQL Direct Configuration uses the key column to identify an element when it is writing data
back, so you need to specify either the REFNO or the NAME as the key column. Table
Designer does not enforce this - in theory you can mark any column as the key, but in
practice only REFNO or NAME are useable.

Select the required column in the left-hand pane, then select Schema>Key Column, the #
button, or right-click on a column name and select Key Column.

Once you have marked a key column, you can turn off the read-only flag for any other
column by selecting Schema>Read Only, clicking [# on the toolbar, by or right-clicking on
a column name and selecting Read Only).
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Remember that the onus is on the person designing the table to ensure that writing to that
attribute is sensible. Table Designer does not enforce any rules about attributes that must be
read-only.

Checking a Table

At any time you can select Schema>Check Selected Table or click 44 on the toolbar to
check your table file for consistency. This process involves checking:

¢ you have one or more rows and columns in the table;
» there is a valid binding for each column/row intersection.

Checking the Table Schema

At any time you can select Schema>Check Table Schema (or click on the toolbar) to
check your table schema file for consistency. This process involves checking:

< you have one or more rows and columns in all tables;
« there is a valid binding for each column/row intersection.

Note: Valid binding here means the attribute specified is an attribute of the element type,
not that it necessarily makes sense in the overall context of the table.

If the check does detect any errors, you can correct them as they are discovered.

Note: If you are working on the active table schema, you cannot save it to the same file if it
contains any errors. You have to save to a different file.

Schema>Check Table (4 on the toolbar) checks the individual table currently selected in
the tree view.

Activating a Table Schema

Once you have created your table schema, checked it, and saved it, you can make it active
by returning to the SQL Direct Configuration program and adding the table schema file to
the connection details.

‘Smiley’ in the Status Bar

The "smiley" is an indication of how valid your table is.

If he’s happy @1, then your table schema has been checked and is OK (within reason - see
below).

If he’s sad @ then the table schema has been checked but there are errors.
If he’s undecided @ it means that you have made some changes but haven’t yet checked
the table schema.

The panel to the right of the smiley indicates whether or not you are editing the "active" table
schema file (i.e. the one that SQL Direct Configuration is configured to use for the current

connection). The 2ej icon in here reminds you that making changes may be dangerous.

The third icon panel ﬁ indicates whether or not you have made changes to the file and
have not yet saved them.
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Querying Tables and Table Columns

The Table Designer Properties form shows properties of the currently selected table or

column. Invoke this form by selecting File>Properties, the button or right-clicking on a
table or column name in the right-hand pane and selecting Properties.

You can leave the Table Designer Properties form active while you navigate around the
table schema. You can use this form to change the name of a table or column and to set the
data properties of columns (how the data is returned: STRING, INTEGER or REAL [REFNO
is equivalent to STRING]). The default data type is STRING which is usually adequate for
most reporting purposes (although you may wish to change the default size of 22 to
something bigger).

The Table Schema Properties form lets you change the project schema file associated

with the table schema. Bring up this form by selecting File>Schema Properties or the [§]
button. The form also allows you to specify how the table schema file should point to the
project schema file - using relative or absolute pathnames.

Absolute vs Relative Pathnames

From the Table Schema Properties form you can specify whether the table schema file
should refer to the project schema file with an absolute or a relative pathname. Which you
choose depends how you wish to use and distribute these files.

If you will have one centralised project schema file and multiple table schema files
distributed in different places, then choose Absolute. However, if you will distribute the
project schema file with the table schema file, or you use centralised files of both types,
choose Relative.

Remember that Absolute means that the table schema file points to a particular project
schema, no matter where the table schema file is located, whereas Relative means that the
project schema file is assumed to be at or below the hierarchical level of the table schema
file. The Change... button enables you to assign a different project schema file to be
associated with the current table schema file. This operation also changes the pathname
addressing to Relative.

Note that until you have saved the table schema file at least once (i.e. Table Designer has a
directory to work from) you can'’t select Relative.
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5 Using SQL Direct - Some Examples

This chapter gives examples of using SQL Direct to access PDMS data with some of the
principal data consumer applications available, but without having to have SQL Server
installed. It is assumed that:

« PDMS is correctly installed
e SQL Direct is correctly installed

* You have used the Table Designer to set up some tables. See Table Designer and
Using the Table Designer.

Full details of the installations are in the relevant installation guides.

Example database files for each of the applications named in this chapter are supplied as
part of your installation. You can find them in:

C:\AVEVA\SQL-Direct12.0\Samples

5.1 Reading PDMS Data into Microsoft Excel

A ScreenCam video demonstration file (excel.exe) showing the use of Excel to read in
PDMS data comes with your installation.
1. Start Microsoft Excel

2. Select Data>Import External Data>Import Data.... The Select Data Source dialog
box appears:
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(x]

Look in: | My Data Sources
. te (Default) EQUIP, ade
‘_““5 ‘e (Default) PIPE 1050505, odc
My Recent ] (Default) STRUCTURAL_ITEM,adc
Documents | 1FES e faulk) NOZZLE . ade
o el (Default) PIPE . odc
[ ‘e (Default) BRANCH, odc
Deskiop w|+onnect ko Mew Data Source,odo

@l orade IPE.dsn
@l oracle IPEZ.dsn
S SaM EQUIP, odc

% M3 MoneyCentral Investor Currency Rates.iqy
M3 MoneyCentral Inveskor Major Indicies.igy
aM3M MoneyCentral Investor Stock Quotes.igy

. 2 et | ~ | | Mew Source o
il 5 Cpen
My Metwork ] | | [ l I ]
Places Files of type: |.0.II Data Sources (*.ode; * mdb; *.mde » | Cancel

Note: The list of data sources may differ from that shown above.

3. Any previous data source connections appear in this list and can simply be selected
and opened using the Open button. This takes you directly to the Import Data screen

shown at Step 10 below.

4. To create a connection to a new data source, click the New Source... button and select

Other/Advanced on the Data Connection Wizard list displayed:

Data Connection Wizard

Welcome to the Data Connection Wizard
This wizard will help wou connect ko a remote data source,

what kind of data source do you wank to conneck to?

Microsoft 30L Server

Micrasoft SOL Server QOLAP Services
QDEBC DSM

Cracle

Citherfadvanced

Cancel

5. Click the Next> button and select PDMSProv OLE DB Provider 12.0 on the Data Link

Properties list displayed:
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B2 Data Link Properties

Provider ] Connection] Advanced] All ]

Select the data you want to connect to;

JLE DB Providerlz) ~

tdicrozaft OLE DB Provider Faor D ata Mining Services
ticrozaft OLE DB Provider for DTS Packages
tdicrozaft OLE DB Provider for Indexing Service
ticrozoft OLE DB Provider for Intermet Pubizhing
Hicrozoft OLE DE Provider for ODBC Drivers
Hicrozoft OLE DB Provider for OLAR Services 8.0
Hicrozoft OLE DB Provider for Oracle

Hicrozoft OLE DB Provider for Outlook, Seach
Hicrozoft OLE DB Provider for SOL Server

ticrozoft OLE DB Sirple Provider

5D ataShape

OLE DB Pravider for Microsoft Directony Sewvices
POMSProv OLE DB Frovider 12.0
S0L Mative Client

SOL Server Replicatich OLE DB Provider far DTS

VSEE Yersioning Enlistrent M anager Prosy Data Source . ™
< >

Mext »>

Cancel | Help |

6. Clicking the Next>> button will take you to the Connection tab of this Data Link
Properties form:

B5 Data Link Properties gl

Frovider Conmection l.&dvanced] All ]

Specify the following o connect to thiz data;
1. Enter the data zource and/or location of the data;
Data Source |S.~’-‘-.M1

Location: |

2. Enter information to log on to the server;
~

* Use a specific user name and password:

|dzer name; |SYSTEM
xxxxx>1

[ Blank password | Allow saving password

Pazzward:

| =l
Test Connection

QK | Cancel | Help |
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7. Fill in the Data Source field with the connect string for the connection, and fill in the
User Name and Password. You may have to uncheck the Blank Password check box
before you can supply the password.

8. Clicking the OK button brings you to the Select Database and Table page of the Data
Connection Wizard:

Data Connection Wizard @

Select Database and Table
Select the Database and TablefCube which corkains the data ywou want,

Select the database that contairs the data you want:

Zonnect ko a specific table;

Marme Description Modified  Created  Type
STRUCTURAL_ITEM STRUCTURAL_ITEM TRELE
PIFE1 PIFE1 TRELE
ERANCH ERANCH TAELE
EQUIP EQUIP TAELE
MNOZZLE MNOZIE TRELE
< >
[ Cancel | [ < Back H Mext = ] | Finish ]

9. Select the table you wish to display and click the Next> button. This gives you an
opportunity to name and save the link on the Save Data Connection File and Finish

page:

Data Connection Wizard

Save Data Connection File and Finish

Enter a narme and descripkion for your new Data Connection file, and press Finish to
save,

File Mame:

|(Default) PIFE1.odc | Browse. .,

[] 5ave passward in file

Description:
IPE1

Search Kevwwords:

[ Cancel ][ < Back ]

10. Click the Finish button and Open the new link on the next screen. This leads to the
final Import Data screen:

5:4 12.0



_AV:VA SQL Direct User Guide

Using SQL Direct - Some Examples

Import Data E|
WWhere do wou want ko put the datar
() Existing worksheet:

() Mews worksheet

i3] Create a PivotTable report. ..

11. Finally press the OK button and the table will be displayed on the Excel page:

Microsoft Excel - Book1
|E_1 File Edit Wiew Insert Format Tools D

FANEA" RENRE NENT: NN - R
Al - #

A E | r [
REFNO BORE PSPEC
=15392/5367 0 /A3E
=15392/5439 0/A3B
=15392/5467 0 /A1A
=15392/5478 0 /A3E
=15392/5487 0 /A3B
=15392/5803 0 /A3B
=15392/5509 0 /A3E
=15392/5564 0 /A3B
=16392/5577 0/A3B
=15392/5R.34 0 /A3E
=15392/5658 0 /A1A
=16392/5670 0/FiC
=15392/5678 0/Fic
=16392/5721 0 =01
=15392/5739 0 =01
=15392/5749 0 /A3E
18 |=1539246772 0 /A1A

AR | —A 50T [ =] =]

Y Y

]

Note: Data read into an Excel spreadsheet in this way can be edited if desired. However,
there is no link back to PDMS, and changes made this way will not be reflected in the
database.

Data can be modified when necessary using PDMS itself (e.g. a modify, create or
delete operation) and should be followed by a Savework operation. When this has
been done, executing a Refresh Data command in Excel will result in a
corresponding change taking place in the spreadsheet (the Refresh Data command

is on the Data menu, or you can click the ¥ icon.)

If you configure SQL Direct for use with SQL Server (see Using SQL Direct with
Microsoft SQL Server) you can modify the data with an SQL Query. To do this,
position the cursor outside the imported data, and select Data>Import External
Data>New Database Query. Select New Data Source... and click OK. Enter any
name of your choosing for the data source, and select SQL Server as the driver.
Click the Connect... button and enter (local) as the server; click OK, then OK again.
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With your new data source highlighted, click OK; this brings up the Microsoft Query
window. Close the Add Tables dialog that appears, and click the SQL button in the
menu bar or select View>SQL... Enter an SQL Query to update your data and click
OK. Click OK to the 'SQL Query can't be represented graphically..." warning, and
again to the 'SQL statement has been executed successfully' message. Close the
Microsoft Query window, clicking Yes to the "You have not created a query containing
data..." warning. Finally, execute a Refresh Data command in Excel to see your
updated data.

You can save your Excel spreadsheet. After reloading, you may find that the Refresh
Data command does not work. This is because your password will not be saved in
the file by default. Edit the query (right click the data grid and select Edit Query...)
and add the Password=<password>; option to the connection details.

You can email your Excel spreadsheet, with its current content, to another SQL
Direct user. The recipient can refresh the data from his own SQL Direct
configuration, providing he edits the query (right click the data grid and select Edit
Query...) to enter his own connection details. He will also need the right table
definitions in his table schema file.

Reading PDMS Data Using ADO from a Microsoft
Visual Basic Program

See example at C:\AVEVA\SQL Direct 12.0\Samples

The sample program ADOTEST is a simple example containing an ADO data control and
an ADO data grid. A combo-box illustrating use of ADO connection and recordset objects
lists the available PDMS tables. Selecting a table displays it in the grid.

This application requires Visual Basic 6. The executable depends on MSVBVM60.DLL
which you will have if you have installed Visual Basic 6.

To use ADOTEST:

1. Start the program from within SQL Direct Configuration by highlighting a connection
and selecting Connection>Test Connection... (see Specifying PDMS Connection
Details). On start up the main screen will look like this:
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58 AVEVA SOL Direct ADO Test

Fil= PDMS Table

Tables:

Table Query:

Cell Text: I deateCeIlI

2. Select PDMS>Connect to display the login screen:

AVEVA SOL Direct Login

User Mame ISYSTEM

Pazsword I xxxxxx

ConnectString |5;:-._|‘.n

Cahizel |

3. Fill this in for the connection you want to test and the main form will be populated as

follows:
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@ AVEVA SOL Direct ADO Test
File PDMS Table

Tables: Table Query:

EQILIIPMENT
SUBEQUIPMENT
NOZZLE
FIFELINE
BRAMCH
COMPONENT
YALVE
IMSTRUMEMNT
STRUCTURE
SUBSTRUCTURE
FRAME
SUBFRAME
SECTION
FPANEL

Cell Text: I Update Cell |

4. Select a table from the list and then the Table>Query Rows menu option (or you can
simply double-click the table). This displays the data in the right hand pane:

M5 AVEVA SOL Direct ADD Test
File PDMS Table

Tahles: Table Query:

NAME _ [TYPE OwWNER _[LOCK DESCRIPTI[FUNCTION [FU
a%BZEEé”PMEN T JE1301 EQUI JEQUIP falye unzet unget urs
PIPCLING /D12m EQUI EQUIP fale unzet unset unis
BRAMCH /C1101 EQUI JEQUIP false unset unset unis
\EgthFéDNE NT JE13028  [EQUI JEQUIP false unzet unget uns
ce b Emmcaa
STRUCTURE
SUBSTRUCTURE /P1501B | EQUI /EQUIP fal:e unzet unget uns
FRAME JP1B024  [EQUI JEQUIP falze unzet unzet uns
SUBFRAME /P15028 [EQUI /EQUIP [fake uriset unset uns
T AENTILAT |EQL] JEQUIP__[fake unset unset s

JCONT-PAR EQUI JELECT falze unzet uhzet unis
JCONT-PAR EQUI /ELECT false unzet unset unis
JELECO1-NI| EQUI JELECT false unzet unzet urs
/DRNACCT | EQUI /UNDERGF | fal:= unzet uhzet unis
/DREMNACCZ /UNDERGF| false unzet unzet

Cell Text: Update Cell |

Writing Data Fields Back to PDMS

The following extends the ADO example of the previous section.

After executing a Table>Query Rows command (see the previous section), the right-hand
pane displays the writeable fields on a white background, while the read only fields are
displayed on a grey background.
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Select a cell to edit by clicking inside it with the mouse cursor. The field editor box labelled

Cell Text displays the field's

&0 AVEVA SOL Direct ADO Test

value:

File PDMS Table
Tables: T able Queny:
NAME _ |TYPE OwNER [ LOCK DESCRIPTI[FUNCTION [ PU
ﬁ%BZEEé”PMENT JE1301 EQUI EQUIP false unzet unzet uns
FIPELINE /D120 EQUI JEQUIP false unset unzet uns
BRAMCH SC1101 EQUI AEQUIP false unset uns
\CISEEDNENT JE13024 EQLI JEQUIR falze unsat 7 funzet unsz
e e e e L
STRUCTURE 3
SUBSTRUCTURE /P1SME | EQUI JEQUIP falze unget unzet uhig
FRAME /P15024  |EQUI JEQUIP false unset unzet uns
SUBFRAME /P15028  |EGUI JEQUIF_ [false unset unzet uns
Fri AENTILAT [EQUI JEQUIP | false unset nset uns
SCOMT-PAN| EQUI /ELECT false unset unzet uns
JCONT-PAK| EGUI AELECT false unzet unzet uns
JELECO1-NI) EQUI AELECT false unzet unzet uhig
/DRMNACCT | EQUI AUNDERGF| false urzet Linset (g
/DRMACCZ | EQUI AUNDERGF| false unget unzet

Cell Text:

|mset

Update Cell

Type the new value into the editor and press the Update Cell button to copy the value back

to the cell in the grid:

@ AVEVA SOL Direct ADO Test
File PDM5 Tabk

T ables: Table Query:
NAME TYPE OWNER [ LOCK DESCRIPTI[FUNCTION [PU
ﬁ%BZEEIE”PMENT AE1301 EQUI JEQUIP false unizet unset uns
FIPELINE /D120 EQUI JEQUIP false unset unzet uns
BRAMCH 01100 EQUI JEQUIP falze unzet |umeet—__ | uns
COMPOMENT AE13024, EQUI JEQUIP falze unset (’\ COOLER ) ung
WALVE JE1302E [EQUI JEQUIP false unset unsel uns
INSTRUMENT AR08 EQUl JEQUIR falze unset unzet unz
STRUCTURE
SUBSTRUCTUFRE P1S0E  [EQUI /EQUIP falze unzet unget uns
FRAME AP15028 | EQUI JEQUIP false unset unzet uns
SUBFRAME AP1502E  [EQUI EQUIP false unzet unzet uns
i AENTILAT | EGQLI JEQUIP_ [fabse urset unset uns
ACONT-PAk| EQUI /ELECT falze unizet unset uns
ACONT-Pak| EQUI /ELECT false urset uriget Ui
AELECOT-MI| EQUI /ELECT false unizet unset uns
/DRMACCT [EQUI /UNDERGF| false unset unzet uns
ADRMNACC2 /UNDERGF unset unzet uhg

Cell Text:

|COOLER

Continue to edit fields in this way as desired. The values have not been written back to
PDMS yet. This happens when you close the connection, for example by selecting the
PDMS> Close Connection menu option. This gives you the opportunity to accept or reject

the changes:
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@ AVEVA SOL Direct ADO Test
File PDMS Table

Tables: Table Quen:
ECILIPMENT MNaME TYPE 0wWrHER LOCK DESCRIPTI| FUNCTION |PU
PAEEDHIPMENT JET301 | Equ JEQUIF__|fakse unset unset uns
PIPELINE /01201 EQUI JEQUIP falze upget uhzet uns
ERAMCH A0101 EQUI JEQUIP false uniget unset uhs
COMPOMNENT = 3
aLwe AVEVA SQL Direct X T el
ISNTSHTLTEUTTIEET ) i unse unzet uns
SUBSTRUCTURE \“.’/ Do you wark to save any changes?  fse unsel unset unis
FRAME se unset unzet R
SUBFRAME z8 urse unzet ung
E.E.EI;LDN ho ze unzet unzet uns
8 unsE unzat uh
ACOMT-PAK EQUI JELECT falze upget uhzet uns
AELECOT-MI| EQUI JELECT false urigE unzet uhs
/DRMACCT [EQUI J/UMDERGF| false Ut unzet uns
ADRMACCE | EQUI JUNDERIGF| falze [iE unzet Lhs

Cell Text: |ED OLER

If you click Yes the changes will be committed in PDMS. Clicking No aborts the changes. In
either case the connection is subsequently closed.

To see the code behind this example you can look at the ADOTest Visual Basic source
provided in the samples directory.
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Using SQL Direct with Microsoft SQL Server

Using SQL Direct with Microsoft SQL Server

Introduction

This chapter details using SQL Direct with Microsoft SQL Server.

Note that you can use PDMS Provider from many clients, for example Excel, or clients using
Microsoft Active Data Object (ADO) technology, without the involvement of SQL Server.
Using SQL Direct - Some Examples details some of these methods of use.

However if you want to make more sophisticated SQL queries against the PDMS tables, or
if you want to join PDMS rowsets with data obtained from other providers, SQL Direct
requires SQL Server to do the SQL processing involved.

Setting up SQL Server

For details on obtaining SQL Server, see the Microsoft SQL Server web site (address at the
front of this document). Normally it is downloaded - SQL Server Express (and MSDE before
it) are available free of charge.

Install SQL Server by following the instructions provided by Microsoft. The software comes
with tools to start and stop the SQL Server service. You can also start and stop the service
through the SQL Direct Configuration Tools menu.

You can if you wish also configure SQL Server as an OBDC datasource. To do this, first start
SQL Server, then select Control Panel> Administrative Tools> Data Sources (ODBC),
select File DSN (you can also use a System DSN), click Add and select SQL Server from
the list of drivers.

Click Finish, then name and create a new datasource which connects to the local server.
Use the default configurations, i.e. keep clicking Next until the sequence is complete.

Using SQL Server with SQL Direct

If SQL Server is installed, the SQL Direct Configuration program Tools menu will have the
SQL Server menu items enabled. The Configure SQL Server option will be enabled once
you have created and highlighted a set of connection details.

Configuring SQL Server

Following saving a set of tables from Table Designer, (See Loading and Saving Tables
Data) you must use the Configure SQL Server menu option before you can view the tables
using any application that accesses the data through SQL Server.

You must configure SQL Server after installing both SQL Server and SQL Direct and before
using any application that accesses SQL Server data.
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Accessing PDMS Data through SQL

Once you have configured SQL Server using the SQL Direct Configuration Configure SQL
Server option, you can access PDMS data using SQL queries. To do this, you need a
software application that provides a SQL command window. Examples of such tools are:

* Microsoft SQL Server Management Studio 2005
e Microsoft Visual Studio .NET 2003 (Server Explorer window)
* Microsoft SQL Server Enterprise Manager 2000

(Unfortunately, there is no suitable tool actually provided with MSDE 2000, but all the above
products can be used successfully with data in MSDE.)

These products initially provide a "tree view" of the data within SQL Server. You can expand
each branch, down through different databases to individual tables and data views. The
SQL Direct Configuration Configure SQL Server option will have created data views within
the "master" database on your SQL server, the views being named according to the tables
you created in Table Designer, and saved in your table schema file referenced in your
connection settings.

You can retrieve data from data views by right-clicking on them and selecting Open View or
Retrieve Data From View (depending on which product you are using).

You can also open a SQL command window and execute SQL statements. (In Visual Studio
.NET 2003 you need to have retrieved data from the view first in order to open the SQL
window, as the 'SQL' option on the query menu bar is greyed out until you have done this.)

Once you have opened a SQL command window you can access PDMS data using SQL
queries. For example:

SELECT *
FROM EQUIPMENT
WHERE REFNO = '=12345/67"

Where EQUIPMENT is a table you created in Table Designer, REFNO is a column name
and =12345/67 is a value of REFNO. Note the use of single quotes around character data
values.

Full documentation of the SQL Query language and its use is beyond the scope of this user
guide. There are many texts available, both online and in book form.

Writing PDMS Data through SQL

SQL provides statements to update and delete data in a database as well as simply query it.
For example:

UPDATE EQUIPMENT
SET AREA =100
WHERE REFNO ='=12345/67"

and:

DELETE
FROM EQUIPMENT
WHERE REFNO ='=12345/67"

are fairly self explanatory.

You can also update data by editing the values in the output grid produced by retrieving data
from the view or executing a SELECT Query. Position the text cursor by clicking on the item
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you wish to change, edit the value, then move the cursor off the row. SQL will update the
data in the database.

Note: If you are using SQL Server 2000 / MSDE, you need to make sure that the Microsoft
Distributed Transaction Coordinator (DTC) is running before you can update data by
editing the output grid. The DTC can by started up / stopped through the SQL Server
Service Manager

The SQL INSERT statement is not supported by PDMS Provider at this time, neither
is inserting data by adding rows to the output grid.

Using Microsoft Access with SQL Direct

Microsoft Access (version 2002 onwards) has the ability to create "Linked Tables". These
are tables of data that are held outside of Access in an external database or file. Linked
tables can be based, for example, on data in SQL Server. With SQL Direct, you can base
linked tables on data that is actually in PDMS rather than a native SQL database. Access
will not know the difference.

Two methods of defining linked tables are presented. The first method requires that an
ODBC resource has first been created. The second method defines linked tables directly
using OLE DB.

For further details about linked tables, see your Microsoft Access documentation.

Method 1 - Linking to PDMS Data through ODBC (recommended)

This example covers the steps necessary to create a linked table of PDMS data through a
previously created ODBC resource. Linked tables thus created can be used to write data
back to PDMS as well as fetch data.

The ODBC resource must point to the SQL Server database in which our table definitions
have been configured (in our case the MASTER database, in which the PDMS data views
have been created by SQLDirectConfig). See Setting up SQL Server for information on how
to create the ODBC resource.

Note: Itis also possible to create a copied (unlinked) table. The procedure is similar to that
given below, but start with File>Get External Data>Import...

1. Start Microsoft Access.

2. Open an existing database, or create a new database, as appropriate. Select File>Get
External Data>Link Tables... The Link dialog box will appear.

3. From the "Files of type:" pull-down list, select ODBC Databases( ). The Select Data
Source dialog box will appear:
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Select Data Source
File Data Source | tachine Data Source I
Look in: IData Sources j |

dBASE Files [not zharable].dsn @ Test Filez [not sharable). dsn
Excel Files [not sharable]. dzn

FowPro Filez [not sharable). dsn

WS Access 97 Databaze [not sharable)dsn

PDMS.dzn
<]

DSH Mame: I

Hew...

Select the file data zource that describes te diiver that pou wish to connect Lo,
Y'ou can uze any file data source that refeis to an ODBC driver which iz installed
an pour machine,

QK I Cancel | Help

The list of data provider applications may differ from that shown

above.)

4. Select the PDMS ODBC data source you created earlier (see Setting up SQL Server).
If you created a System DSN (rather than a File DSN) it will be on the "Machine Data

Source" tab (rather than the "File Data Source" tab). Click
box will appear:

Link Tables

Tahles |

OK; the Link Tables dialog

2%

dbo, BRANCH

dbio, COMPOMENT

dbo, dtproperties

dbo  EQUIFMENT

dbo, FRAME

dbo, INSTRIUMEMT

dbo, M3replication_options
dbio NOZZLE

dbo, PAREL

dbio, PIPELIME

dbo, SECTION
dbio.spt_datatype_info

i

[8]4 I
Cancel |
Select Al |
Deselect Al |

=l [ Save password

5. The list in the Tables tab will show the available PDMS t
SQL Direct Table Designer) as well as a number of SQL
can be ignored. Select the required table(s), then click OK.

ables (as defined using the
Server system tables which

6. The Link Tables dialog box will change its appearance and the Select Unique Record

Identifier dialog box will appear:
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Select Unique Record Identifier d |
Figlds in table 'dbo_EQUIPMENT': ok I

REFHD T

MAMF Cancel |

TYRE
CINER:

LocK

DESCRIPTICON

FUNCTION

PURPOSE

MUMEER x|

To ensure data integrity and to update records, wau
musk choose a field or fields that uniquely identify each
record. Select up ko ten Fields.

7. The Select Unique Record Identifier dialog box asks you to select a field (or fields)
from the selected table that will uniquely identify each record. Choose REFNO, and
click on OK.

The requested table(s) will now appear within the Tables tab of the Database dialog box in
Access. Double-click on the appropriate table name to view the data in tabular form.

Note: Data in the output grid corresponding to updatable attributes in PDMS can be
updated by changing the value(s) and moving the text cursor off the row. In order for
this to work, however, you must have started the Microsoft Distributed Transaction
Coordinator (DTC) through the SQL Server Service Manager tool.

Method 2 - Linking to PDMS Data through OLE DB

This example covers the steps necessary to create linked tables of PDMS data directly
through the PDMS OLE DB Provider / SQL Server without using ODBC.

Unfortunately, linked tables created in this way cannot be used to write data back to PDMS,
due to apparent limitations in Access. If write access is important to you, please use Method
1 (above).

Note: Itis also possible to create a copied (unlinked) table. The procedure is similar to that
given below, but start with File>Get External Data>Import...

1. Start Microsoft Access (version 2002 or later), and also make sure that SQL Server is
running.
2. Goto Access File menu, select New, and create a Project using new data...

3. In the database wizard presented, select the appropriate SQL Server (i.e. the one on
the machine where SQL Direct is installed) and enter the SQL Server login credentials.
Click Next and then Finish.

4. Go to the File menu again, and select Get External Data->Link Tables...
5. Make sure Linked Server is selected and click Next.

6. Select the data source. This is similar to the procedure described in Reading PDMS
Data into Microsoft Excel for Excel. If you have a saved data source that you want to
use, select it from the list, click Open and proceed to step 12. If you don't have a data
source saved, click the New Source... button and proceed to step 7.

7. Make sure Other/Advanced is selected, and click Next.
8. Select PDMSProv OLE DB Provider 12.0 from the list and click Next.
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Fill in the Data source - the connection settings name you saved in SQL Direct
Configuration, your User name and Password (deselect the "blank password" option),
and select "Allow saving password" if you wish. Then click OK.

10. You are now offered the option to select your database - there should only be one so

11.

just click Next.

Fill in a file name for the connection (if you wish, or just use the default) and again
select the "save password in file" option if you wish. Then click Finish.

12. You can now select which table(s) you wish to link to the current project (or all tables if

you wish). Make your selection and click Finish.

Access will now create the linked tables. Double-click on the appropriate table name to view
the data in tabular form.

The linked tables created in this way are once again data views, very similar to the ones that
SQL Direct Configuration creates, except that Access creates a separate database for each
Access project in which to place the views.

Reading PDMS Data into Microsoft Word

The following procedures can be used to read PDMS data into a Microsoft Word table. Both
the methods given here use ODBC and SQL Server.

Note: Using Microsoft Word, it is not possible to provide a dynamic link back to the data. If

the PDMS data changes in the database, the Word table must be recreated to see
the changed data. Neither is it possible to write any data changes made in Word
back to the database.

Method 1 - through a Named Data Source

©® N o u

10.

Start Microsoft Word and open a .doc file.
If it is not already displayed, display the Database toolbar by selecting

View>Toolbars>Database. Click the Insert Database icon (EE) on the Database
toolbar. The Database dialog box will appear.

Click on Get Data... The Select Data Source form will appear.

If you have not already created a named data source, click on New Source... The
Data Connection Wizard will appear. Choose Microsoft SQL Server, and click
Next>.

Enter a single dot (".") for the server name and click Next>.
Highlight the table you wish to use, and click Next> again.
Select a file name for your data connection, and click Finish.

The Select Data Source form reappears - make sure your named data connection is
highlighted and click Open.

The Database dialog box reappears. Optionally click on the Query Options... button,
and enter any data restrictions you wish to impose on the data returned.

Finally click on the Insert Data... button and select the data records you want from the
Insert Data dialog box.

The requested data will now appear in your current Word document as a table.

Method 2 - through MS Query

1.

Start Microsoft Word and open a .doc file.
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2. If it is not already displayed, display the Database toolbar by selecting

View>Toolbars>Database. Click the Insert Database icon (EE) on the Database
toolbar. The Database dialog box will appear.

3. Click on Get Data... The Select Data Source form will appear.

4. Select MS Query... from the Tools menu. Microsoft Query will start up, and the
Choose Data Source dialog box will appear.

Choose Data Source

x|
Databases | Qusnies I
<Mew Data Souwces
dBASE Files* ﬂl
E wcel Files®
M5 Access Database” Erowze... |
DS
‘Wizua FoxPro Databaze® Options.. |
Wizua FouPro Tables™
»treme Sample Database 20037 Delete |
#treme Sample [atabaze 2005% —

@l v Use the Query Wizard to createedt queries

(The list of data provider applications may differ from that shown above.)

5. Select the Use the Query Wizard to create/edit queries check box.

6. Click on the ODBC resource in the list corresponding to the database where the PDMS
views were created (see Method 1 - Linking to PDMS Data through ODBC
(recommended) for a description of how to do this) and OK the dialog box. The Query
Wizard - Choose Columns dialog box appears:

Query Wizard - Choose Columns 7| x|

WWhat courmng of data do you want ta include in your querny?

Avwailable tables and columnz: LColurnz inyour querny:

N -
[ BRANCH =
ERANCH MEMBERS | r-
EQUIP |

HIERARCH

TEES

I+ TFST ﬂ

Freview of data in selected colunn:

@l EreviewNowl < EETh | e | Cancel I

7. The Available tables and columns: list will show the available PDMS data tables
(defined using the SQL Direct Table Designer). Select the required table, then click

b I The column headings for the selected table will appear in the Columns in
your query: box.
8. Click Next>. Keep clicking Next> as the wizard dialog progresses (unless you wish to
perform other operations at each stage) until the Query Wizard - Finish dialog box
appears. Click Finish.
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9. Returning to the Database dialog box, click Insert Data... The Insert Data dialog box
then appears, which gives you some options for the formatting and content of the
imported data. OK the form.

The requested data will now appear in the current Word document as a table.

6.6 Reading PDMS Data into Crystal Reports

This example covers the steps necessary to import data from Microsoft Access and from
PDMS to form a merged table within Crystal Reports. This section does not give general
information on how to use Crystal Reports - see the online help for that product.

1. Start Crystal Reports.
2. Select File>New... The Create New Report dialog box will appear.

3. Select Zmem tO activate a "wizard" to create a standard report. The Create Report
Expert dialog box will appear:

Create Report Expert

|2: Fields |3: Sort |4: Total |5: Select IB: Style I

Step: Choosze data to repart on. “'ou can choose multiple tables and add indexes.

SALAODEC

peleie | [Addinder. |

Cancel | BreviewBEepor | Erevier Sample

< Hach |

4. Step 1 (the Tables tab) enables you to specify the type of data source. Click on sarape:
and select ODBC - PDMS from the list in the resulting Log On Server dialog box (your
System Administrator may have installed and configured your SQL Direct service
provider to show text other than 'PDMS') and OK the dialog box.

5. The Choose SQL Table dialog box will appear. From the SQL Tables list choose the
table (previously defined using SQL Direct's Table Designer) which contains the data
you wish to report on. Having selected the table, click Add; the selected table name will
appear in the main list area on the Create Report Expert dialog box (Tables tab).

6. On the Choose SQL Table dialog box click M to redisplay the Log On

Server dialog box. Now select ODBC - MS Access 7.0 Database from the list to
specify (in this example) the source of the data which is to be merged with the already-
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specified data table, and which is to be reported on. OK the dialog box. The Select
Database dialog box appears.

7. Navigate to the appropriate Access .mdb file and OK the Select Database dialog box.
The Choose SQL Table dialog box will reappear. From the SQL Databases list select
the MS Access 7.0 Database previously selected. The SQL Tables list will become
populated with the names of the tables present in the selected Access database.
Having selected the table, click Add, then Done.

This completes step 1 of the Create Report Expert process.

8. Step 2 of the Create Report Expert process consists of linking the PDMS data table
with the Access data table. The Links tab shows lists of column headings in the two
tables. 'Join' the tables by selecting (left mouse button) a common column heading in
one table; with the mouse button held down, move the cursor over to the same column
heading in the other table and release the button. A line will appear joining the two
tables via the common column heading. The ‘joint' table to be reported on has now

been defined. Click on [_H=st>>

This completes step 2 of the Create Report Expert process.

9. Step 3 of the Create Report Expert process consists of setting the fields (column
headings) which are to appear in the report. From the Database Fields list on the left
of the Links tab select the column headings you wish to see in the report, choosing
fields from the 'PDMS table' and from the 'Access table'. Select each required field,

clicking on EI after each selection to assemble the required report fields in the

Report Fields: list. Click on when you have completed this process.

This completes step 3 of the Create Report Expert process.

10. Step 4 of the Create Report Expert process consists of choosing report fields to sort
and group by. From the Report Fields list on the left of the Sort tab, select the report

fields you wish to sort and group by, clicking EI after each selection to

assemble the required group fields in the Group Fields: list. Click when you
have completed this process.

This completes step 4 of the Create Report Expert process.

11. Steps 5, 6 and 7 of the Create Report Expert process enable you to further refine the
content and detail of the report to be produced. Options chosen for each of these steps
will be up to individual user requirements and so are outside the scope of this
description. See the Crystal Reports online help for details of the options available at
each of these steps.

12. Having selected the required report style from the Style tab, click @I to
see the report.
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