AV=VA

Graphical Model

Manipulation Guide

Www.aveva.com




AVEVA Solutions Ltd

Disclaimer

Information of a technical nature, and particulars of the product and its use, is given by AVEVA
Solutions Ltd and its subsidiaries without warranty. AVEVA Solutions Ltd and its subsidiaries disclaim
any and all warranties and conditions, expressed or implied, to the fullest extent permitted by law.

Neither the author nor AVEVA Solutions Ltd, or any of its subsidiaries, shall be liable to any person or
entity for any actions, claims, loss or damage arising from the use or possession of any information,
particulars, or errors in this publication, or any incorrect use of the product, whatsoever.

Copyright

Copyright and all other intellectual property rights in this manual and the associated software, and every
part of it (including source code, object code, any data contained in it, the manual and any other
documentation supplied with it) belongs to AVEVA Solutions Ltd or its subsidiaries.

All other rights are reserved to AVEVA Solutions Ltd and its subsidiaries. The information contained in
this document is commercially sensitive, and shall not be copied, reproduced, stored in a retrieval
system, or transmitted without the prior written permission of AVEVA Solutions Ltd. Where such
permission is granted, it expressly requires that this Disclaimer and Copyright notice is prominently
displayed at the beginning of every copy that is made.

The manual and associated documentation may not be adapted, reproduced, or copied, in any material
or electronic form, without the prior written permission of AVEVA Solutions Ltd. The user may also not
reverse engineer, decompile, copy, or adapt the associated software. Neither the whole, nor part of the
product described in this publication may be incorporated into any third-party software, product,
machine, or system without the prior written permission of AVEVA Solutions Ltd, save as permitted by
law. Any such unauthorised action is strictly prohibited, and may give rise to civil liabilities and criminal
prosecution.

The AVEVA products described in this guide are to be installed and operated strictly in accordance with
the terms and conditions of the respective license agreements, and in accordance with the relevant
User Documentation. Unauthorised or unlicensed use of the product is strictly prohibited.

First published September 2007
© AVEVA Solutions Ltd, and its subsidiaries
AVEVA Solutions Ltd, High Cross, Madingley Road, Cambridge, CB3 OHB, United Kingdom

Trademarks

AVEVA and Tribon are registered trademarks of AVEVA Solutions Ltd or its subsidiaries. Unauthorised
use of the AVEVA or Tribon trademarks is strictly forbidden.

AVEVA product names are trademarks or registered trademarks of AVEVA Solutions Ltd or its
subsidiaries, registered in the UK, Europe and other countries (worldwide).

The copyright, trade mark rights, or other intellectual property rights in any other product, its name or
logo belongs to its respective owner.



_AV:VA Graphical Model Manipulation Guide

Graphical Model Manipulation Guide

Contents Page

Graphical Model

Introducing the Design Model Editor ........................ 1.1
ScopeofthisGuide . . ..... ... .. . 1:1
GlOSSarY .o 1:1
Selection . ... . 2:1
Introducing Element Selection .. .......... ... . . . . . . 2:1
Selecting Piping COmpoNnents . ... 2:1
Menus on Selection SetsS. .. ... .. 2:5
EQUIPMENt temS . . 2:5
Piping COmMPONENTS . . . .. 2:6
Component Deselection . .......... . 2:6
Introducing the Model Editor3BD View. ....................... 3:1
BD VIiew WINAOWS. . ..o e 3:1
Manipulating the Design Model View . . ....... ... ... . . 3:1
BD VIEW MENU . .. 3:2
Middle BUON Drag . . . .. .ottt e e e e e 3:3
Printing the 3D VieW . . . ..o 3:4
Copying the 3D View to the Windows Paste Buffer .. .......... .. . .. . . . . 34
4o oo 0 1 L 34
WAl TO . e 3:5
Save View and ReStOre VieW . . .. ... 35
Look, Plan and ISOMELTIC. . . . . . .ottt e e e e e e 3.5
Set Centre Of ViBW . . . 3:6
SOt INgS . oot 3:6
Mouse Wheel Zoom . . .. ... 3.7

i 12.0



_AV:VA Graphical Model Manipulation Guide

Design tem ENtries . . ... o e 3:8
View Manipulation Toolbar BUttons . . . ... ... 3:9
Clipping and Capping. . . . .« vt e e e 3:9
Model Editor Operations. . ... e 4:1
Model Editor Mode. .. ... o 4:1
Element Selection inthe Model Editor. . . . ... ... . 4:2
Locator Handle. . . ... ... e 4:3
MOVEM BN . . . e 4:4
ROtatiON .. 4:5
AlGNMENt e 4:6
Locator Handle as a Frame of Reference . ....... ... ... . . . . . . . . i 4:7
Feedback .. ... e 4:7
Unconstrained POSItioNiNg . . . . . ... ... 4:7
Undoand Redo . ... e 4:7
PerformanCe. . . ... 4:7
Element Selection inthe Model Editor. . ......... ... .. . . ... 4:8
Selection Feedback . .. ... . e 4:8
Modifiable and non-modifiable elements. . . . ... ... . 4:8
Selecting Items Using the Mouse Pointer . ... ... . . . 4:8
Fence Selection . . ... 4:9
Fence select using the left mouse button . .. ... .. . . . 4.9
Fence Select using the Right MouSEe BULION . . . . . ...t e e e 4:10
Adding to an existing Graphical Selection with afence selection . ............. .. ... .. ... ... ...... 4:11
Removing selected items from an existing Graphical Selection with a fence selection ................ 4:11
ltem-Specific Selection Operations . . ........ .. 4:11
Select Pipe and BranCh OWNErS . . . ... oo e e 4:12
SelECt BranCh . . . e e 4:12
SElECE PP . .o 4:12
Select Attached Steelwork SECHIONS . . . ... e 4:12
Clearing the Graphical Selection . . . ... . . . 4:13
Reinstating the Previous Graphical Selection ................ ... ... ... ... ...... 4:13
Selection MENU. . . . .ot e 4:13
Feature Highlighting . . . . ..o 4:14
Sl INCIEMENES . . .o e 4:14
Set Handle ColoUr. . ... e 4:14
Drag Image . . . ..o e 4:14
SeleCt RECIANGIE . . . . .o 4:14
Positioning and Orientation using the Locator Handle .................. 4:15
OV IV W .ttt e 4:15
Aligning the Graphical Selection with points or lines on other displayed items. ... ................... 4:15
AUtomMaALic SCrolliNg . . . . oo e 4:16
Linear Movement Handle. . . ... ... . e 4:16
Moving one Movement Incrementat a Time. . . . ... ...t e 4:16

ii 12.0



_AV:VA Graphical Model Manipulation Guide

Feedback . ... e 4:17
Point feature AligNmeEnt. . . . .. ... 4:18
Alignment with a Line or P-line Feature . .. ... ... .. e 4:19
Alignment with a P-point Feature . . . ... ... .. . e 4:19
Planar Movement Handles. . . ... ... . . i e 4:22
Feedback . ... e e 4:22
Point feature AligNmeENt. . . . ... 4:24
Alignment with a Line or P-line Feature . . ... ... . ... e 4:24
Rotation Handle . . ... . 4:25
Feedback . ... 4:26
Rotation Handle. . ... ... e 4:26
Feature Highlighting . . . . . . ... 4:29
Cancelling the Drag. . . . . ..ot e 4:30
Moving the Locator Handle Independently of the Graphical Selection. . .............. 4:31
Positioning and Orientation Using the Edit Menu. . ..................... 4:31
Move Selectionand Move Handle . . ......... ... . . . i e 4:31
Move Selection/Handle>Offset in BD... ... ... 4:31
Move Selection/Handle Set 3D POSItioN. ... ... ... 4:32
Move Selection/Handle>Snap to POiNt . . ... ... .. 4:32
Rotate Selectionand Rotate Handle . . ... ... .. . . i 4:33
Rotate Selection/Handle>To World. . . .. ... .o e 4:33
Rotate Selection/Handle>About X/Y/Z . . .. . . 4:33
CliPPING o 4:34
Clipping SUbMENU . . . ... 4:34
SiX-Plane ClippiNg . . . . oo 4:35
Undo and Redo. . ... . 4:40
Delete Selection . ... 4:40
Selectable ltems . . . ... . 4:41
Graphical Equipment Modification .......................... 5:1
Introducing Graphical Equipment Modification ......................... 5:1
Equipment Modification Characteristics and Facilities .. ................. 5:2
Display CharacteristiCs. . . ... ... e 5:2
Modification Facilities. . . ... ... . e 5:3
Graphical Component Modification. . ........................ 6:1
Introducing Graphical Component Modification. . ....................... 6:1
Selection Set for GCM . . ... .. 6:2
Component Modification Handle ............. ... .. .. .. . . . . . . . . 6:3
Operations iN GCM. . . ... . e 6:4
Movement Handle . ......... . . . . . 6:4
DraggINg . .o 6:5

iii 12.0



_AV:VA Graphical Model Manipulation Guide

Feature Highlighting. . . . ........ ... .. . . . . . . 6:5
Nudgingthe Handle . . . .. ... . 6:6
Rotation Handle . . ... .. . 6:7
DrAggING . 6:7
Feature Highlighting . . . .. ... .. e 6:8
Nudging the Handle . . . ... ... e 6:8
Repositioningthe Handle . . . ... ... 6:8
Movement and Rotation Characteristics .. ............. ... .. ... 6:9
Movement Handle . ... e e 6:9

Offsetting the Selection . . .. .. ... e 6:13
Feature Highlighting . . . .. ... 6:14
Rotation Handle . . ... ... e 6:14
Feature Highlighting . . . .. .. o 6:14
Align With DIr€CHION . . . . o e e e e 6:15
NNt 10 POINt . . .. e 6:15
EXPICIt DIrECHON . . . . 6:15
Feedback ........ ... . . . . . 6:15
Movement Handle . ... .. i e e 6:15
Rotation Handle . . ... 6:17
Popup Menus on the Component Modification Handle .. ................ 6:17
Movement Handle . .. ... .. ... e 6:17
BefOre A Drag . . . oottt 6:17
ON Completion Of @ Drag. . . . . v vt 6:18
Rotation Handle . . . ... .. e 6:18
Before Drag. . . . .o 6:18
On Completion Of @ Drag. . . . . oottt e 6:19
HOTKEY S . 6:20

iv 12.0



_AV:VA Graphical Model Manipulation Guide

1.1

1.2

Introducing the Design Model Editor

Introducing the Design Model Editor

The Design Model Editor enables you to reposition selected objects in a model using the
mouse pointer. Model manipulation using the Model Editor takes place within the Model
Editor 3D View, which incorporates features specific to that View type.

Scope of this Guide

This guide introduces the facilities in both the Model Editor 3D View and the Model Editor
itself. This manual is set out as follows:

Selection introduces element Selection, and the meanings of the different Selection
graphics.

Introducing the Model Editor 3D View introduces the Model Editor mode of operation
within a 3D View Window.

Model Editor Operations introduces the Model Editor itself, describing the selection,
positioning and orientation facilities available within Model Editor mode.

Graphical Equipment Modification introduces the facilities that have options to speed
the modification of Equipment.

Graphical Component Modification introduces the modification facility which allows you
to interactively move piping Components along the legs of a pipe route and rotate them
about the centreline of the pipe tube.

Glossary

Feature Point, P-point, line or P-line on the 3D model that can be used for

alignment.

Graphical Selection  One or more elements selected for subsequent manipulation

using the Locator Handle.

Selection Set When in Navigate mode, the elements selected by a pointer click.

For an Equipment, all the constituent primitives will be selected,
for a piping Component, all connected Components will be

selected.
Linear Movement A handle situated on the Locator Handle, which when selected for
Handle a drag operation, constrains movement of the selection to be

along the direction of the selected major axis.

Locator Handle A collection of handles which together provide a mechanism for

positioning and orientation of selected elements.
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Movement The incremental step in current distance units that a selection will
Increment move in the direction of a major axis of the Locator Handle when a
planar movement handle or a linear movement handle is dragged.

Movement Axis The axis identified by the Linear Movement Handle. During a drag
operation, the current selection will be constrained to move in the
direction of the movement axis only, while following the movement
of the pointer.

Movement Plane The plane identified by the Planar Movement Handle. During a
drag operation, the current selection will be constrained to move
in the Movement Plane only, while following the movement of the

pointer.
Planar Movement A handle situated on the Locator Handle, which when selected for
Handle a drag operation constrains movement of the selection to be in the

plane indicated by the Planar Movement Handle. That is, the XY,
XZ or YZ plane of the Locator Handle.

Rotation Increment  Incremental step in degrees that a selection will rotate when a
Locator rotation handle is dragged.

Reference Point Position used as a datum point for subsequent movement of the
Graphical Selection.

Ship Item A Design database element that represents an engineering item
that can be individually selected and manipulated to modify Ship
layout. For example, Equipment, Steel Section, Piping
Component.
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2.1

2.2

Selection

Selection

Introducing Element Selection

Selecting an element (when not in Model Editor mode) highlights that element and all of its
constituent primitives with a green line:

The highlight colour used is the same irrespective of whether you have read/write access
rights or read-only access rights.

Note: This is not the case in Model Editor mode.

Selecting Piping Components

When selecting a piping Component, all related items are also selected. For example, when
selecting a Valve, the related Flanges and Gaskets are selected as well:
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Selection

Note: The selected elements (known as the Selection Set), only constitute the graphical
selection (as highlighted with a green line) - the selected current element is (in the
above case) still only the Valve element itself.

The above situation only applies where the arrive and leave directions of the selected piping
Component are in line with each other. In the case of (for example), an Elbow, only the
Elbow itself and any connected zero-length Components (e.g. Welds) are selected. See
below:

Diagrammatically, the above situation is:

Picked
Component

st Selected
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Selection

If a Component which has arrive and leave directions which are in line also has
Components which are directly connected to it, then those Components are selected as
well. For example:

Connected Components are selected up to, but not including:
< An element which changes direction, e.g. Elbow, Bend, etc.
» A'directly connected-to element’, e.g. Tee, Cross, etc. where the CREF or CRFA is set
« A bad alignment between Components, e.g. bad offset, alignment, etc.

Further examples of Component selection sets are shown below:

Example: Flanged Valve within a straight leg of a Branch.

Picked
Component
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Selection

Example: Flanged Valve with weld-neck Flanges connected to an Elbow:

Picked
Component

dem gy

Example: Connected assembly between a change in direction and connected Tee:

S

Picked
Component

IR p==

Example: Connected assembly between a change in direction and an unconnected
Tee:

), 4
X

Fa
S

Picked
Component

X

X

S
A
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Selection

Example: Bad alignment, between Valve assembly and one of its flanges:

— — ——

Picked
Component

2.3 Menus on Selection Sets

231 Equipment Items

In the example shown above, De-Select All would de-select the entire pump; De-Select
Current would clear the graphical selection of the current element but leave the rest of the
elements in the selection selected.
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2.3.2

2.4

Selection

Piping Components

Connected
Le
De-Select Al J
De-3elect Current BRAM J100-B-1-B3
PIPE [100-B-1
Hide !

Remove From Draw Lisk

Zoam To
Walk Ta

Cancel

Note: The above menu is for selection using the right-hand mouse button - only the
element under the pointer is selected. Selection using the left-hand mouse button
selects the element under the pointer and connected elements.

Select Connected selects all Components connected to the current Component. Select
Leg. selects Components in the same Pipe leg as the current Component.

All other options are as for Model Editing mode.

Component Deselection

Ctrl-click on a selected item removes it from the current selection set.

Holding the G key down while dragging out a selection rectangle removes the selected
items from the current selection set.

Connected zero length or connected invisible components should never be left orphaned
when either of their adjacent components are removed from the selection set.

Example: De-selection of a flanged break in line:

| Deselected Component
el |

=

Selection Set
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1¥ Flange Deselected y 4 ‘ X

—

as adjacent item is not

Automatically deselected,

Selection

selected
Deselected Component |
2™ Flange Deselectad b 4
Automatically deselected, as Automatically deselected, as
adjacent item is not selected adjacent itern is not selected
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3.1

3.2

Introducing the Model Editor 3D View

Introducing the Model Editor 3D View

3D View Windows

3D Views within Outfitting Design may be used in one of three modes of operation:
« Navigate mode
« Event Driven Graphics mode
* Model Editor mode
3D View windows can be used to display all or part of the design model. No graphics are

displayed in a 3D View window until model elements are added to the draw list and view
limits are set.

In Navigate Mode (the default setting), view windows allow you to select an element simply
by clicking on it, which navigates to it in the database and makes it the current element. In
this mode, the prompt bar across the top of the viewing area contains the prompt Navigate:.

In Event-Driven Graphics (EDG) mode, mouse pointer picks are used as part of an event-
driven graphics routine. You are invited to perform a graphical pick on an element or a
graphical feature in the displayed model. The prompt bar contains an instruction which
prompts you to perform a graphical selection. You are not able to enter Model Editor mode
whilst in EDG mode (and vice versa).

In Model Editor mode, one or more elements can be selected, and those elements can be
moved or rotated dynamically by dragging with the mouse pointer. The prompt bar contains
the prompt Modify.

In this User Guide, a 3D View that can be switched into Model Editor mode is called a 3D
Model Editor View. Outfitting Design normally starts with a 3D Model Editor View shown.
New 3D Model Editor Views can be created by selecting Display>Graphical View from the
menu bar, or by using the Create button on the 3D View Control form.

Manipulating the Design Model View

View manipulation operations are accessed using:
e the View menu on the main menu bar

« the 3D View , obtained by clicking on the 3D View background with the right mouse
button

* buttons located next to the 3D view on a 3D View Window
< function keys on the keyboard

¢ menus on Design items

« direct manipulation of the 3D view using the mouse.
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Introducing the Model Editor 3D View

This section describes the 3D View Window manipulation operations. Many of these
operations can be accessed using more than one method. The View menu selections are
introduced, along with a note on other methods that may be used to invoke the same
operations.

3.2.1 3D View Menu

View

Middle Button Drag

-

Print Graphics. ..

Copy Image k
Zoam Ta 4
walk To 3
Save View

Restore Yiew g
Loak, 3
Flan 3
Isametric 4

Sek Centre OF Wiew

Settings ]

View menu

Middle Butkon Drag  #

Zoom To 4
walk To »
Save View L
Restore Yiew 4
Loak, »
Plan 2
Isomekric 4

Set Centre of Yiew

Zancel

3D View
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Introducing the Model Editor 3D View

. Middle Button Drag

Middle Button Drag  » gl lt=lar:Igls =
Zoom In0ut
Rotata

Fan

Wl

The Middle Button Drag menu is used to set the action of subsequent middle mouse
button drag operations on a 3D View.

The model displayed in a 3D View can be zoomed, rotated or panned (according the menu
option selected) by pressing the middle mouse button or mouse wheel over the 3D View
and moving the mouse.

Middle mouse button drag operations can also be set using function keys and buttons on
the 3D View: F2 for Zoom In/Out, F3 for Pan and F5 for Rotate.

Note: Walk mode is inactive unless the 3D view is displayed in perspective.

>Zoom Rectangle

Enables you to perform a zoom-in operation by dragging out a rectangle around the volume
required to fill the 3D View.

>Zoom In/Out

Enables you, with the middle mouse button held down, to magnify or reduce the view by
moving the mouse up (away from you) to zoom in, or down (towards you) to zoom out.

The middle mouse button can be set in this mode by using the View main menu, the View ,
the Zoom In/Out button on the 3D View Window and the F2 button on the keyboard.
>Rotate

In this mode, hold down the middle button and move the mouse up/down to rotate the view
vertically or left/right to rotate the view horizontally. The initial movement determines the
axis of rotation; to rotate about the other axis, release and press again the middle button.

The middle mouse button can be set in this mode by using the View main menu, the View,
the Rotate button on the 3D View Window and the F5 button on the keyboard.
> Pan

Lets you move across the view in any direction. In this mode, hold down the middle button
and move the mouse towards the part of the view that you want to see.

The middle mouse button can be set in this mode by using the View main menu, the View,
the Pan button on the 3D View Window and the F3 button on the keyboard.
> Walk

Selects walkthrough mode, in which the eye point moves towards or away from the model
(only works in perspective views). In this mode, hold down the middle button and move the
mouse up to walk towards the model or down to walk away from the model.
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The middle mouse button can be set in this mode by using the View main menu, the View,
the Walk button on the 3D View Window and the F6 button on the keyboard.
. Printing the 3D View

The content of the active 3D View Window can be output to a printer by clicking on
View>Print Graphics...

This displays a standard Windows Print form, giving you the ability to select a printer, set
the number of copies to produce, and set properties of the print.

. Copying the 3D View to the Windows Paste Buffer

Middle Butkon Drag  #

Print Graphics. ..

Copy Image 40480

N . 200600

walk To . 1024x765
16001200

[l | R [

The content of the active 3D View Window can by copied to the Windows paste buffer by
clicking on one of the View>Copy Image options. The options 640x480 up to 1600x1200
refer to the resolution of the image copied to the paste buffer.

The copied image can be pasted into another Windows application that supports picture
objects, such as a Word Processor or picture-editing package.

. Zoom To

Zoom To Selection
Walk To 3 Identify Element. ..
Entire Draw Lisk

Save Yiew

Zoom To zooms and pans the 3D View to get the required part of the 3D model to fill the
view window.
>Selection

The current element, or the graphical selection if one exists, fills the 3D View.

>|dentify Element

This allows you to centre the view on an identified element in the graphics, and zooms the
view such that the identified element fills the 3D View window.

Note: Identifying an element with a pointer pick in this way does not set the selected
element to be the Current Element.
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>Entire Draw List

This centres the view on the centre point of the entire draw list and zooms the view so that
all the elements in the display list fill the 3D View window.

. Walk To

Walk To zooms and pans the 3D View to get the required part of the 3D model to fill the
view. Walk To differs from Zoom To in that it removes items between your eye position and
the target item that are not in the immediate vicinity of the target item. Items in the
immediate vicinity of the target will continue to be displayed, so it may be necessary to
remove items still obscuring the target item by removing them from the Draw List.

. Save View and Restore View

Save Yiew View 1 Save View k
Restare Yisw r Wigw 2 Restore Yiew Wigw 1
View 3 View 2
Look, »
Lock ¢ View 4 o0 View 3
Plan 3 Plan »
Isometric L4

Save View stores the current state of a 3D view so that the view direction and magnification
can be restored when required. Up to four views can be saved at any one time.

Restore View allows you to select a saved view and change the active 3D view settings to
the saved values. Any of the views 1 to 4 that do not contain saved view details are greyed
out.

Views can also be restored by using the Restore View buttons on the left side of the 3D
View Window.

. Look, Plan and Isometric

Look

Allows you to select from a range of orthogonal views.

Plan

Allows you to view the model from above.

Isometric

Lets you select any of the four isometric views.
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Introducing the Model Editor 3D View

. Set Centre Of View

* Selection
Identify Element...
Screen Pick. .

Settings

Set Centre Of View allows you to pan the 3D view such that the identified element or
screen position is centred in the 3D view.
>Selection

This centres the 3D view on the current element, or on the graphical selection if one exists.
>|dentified Element...

This allows you to centre the 3D view on an element picked with the mouse pointer.

Note: ldentifying an element with a pick in this way does not set the picked element to be
the Current Element.
>Screen Pick

This allows you to identify a position (which could be in free space) in a 3D view to become
the centre of view.

Clicking on the 3D view with the middle mouse button also performs this operation.

. Settings

Setkings Eve
Shaded
Borders
Perspective

Black Background
White Background

High Cuality
Show Tooltips
Anirmakions

The View>Settings menu appears on the main View menu only. It is not on the view .

>Eye, >Shaded, >Borders and >Perspective

These menu commands control the Eye, Shaded, Borders and Perspective modes.

>Black Background and >White Background

Sets the background colour of the currently active 3D View to black or white. Black is
recommended as the standard working colour for the view background. White can be the
best choice of background colour if a 3D view is to be printed, or its contents copied to
another application.
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Introducing the Model Editor 3D View

Other 3D view background colours can be set by using the 3D View Options form found
under Settings>Graphics, 3D Views tab, and the 3D View Control form found under
Display>View Control....

>High Quality

This feature can be used to toggle between ‘high’ and ‘standard’ quality images of the
Design model. A high quality image is slower to draw and manipulate than a standard
quality one.

This option does not affect the Arc Tolerance property on the Representation tab of the
Graphics Settings form (Settings>Graphics). This is an independent property that allows
you to control the display quality of some of the more complex elements in Outfitting.

>Show Tooltips
This feature toggles a ‘Tooltip’ function. If enabled, the name of the element under the
mouse pointer is displayed in the Tooltip.

>Animations

This feature toggles smooth pan and zoom operations in 3D View when the Zoom To and
Walk To options are used. The zoom operation is animated to show the transition from the
original view definition to the final view definition. This feature only operates if the system
determines that the hardware is capable of performing a smooth pan and zoom with the size
of model displayed in the 3D View.

Mouse Wheel Zoom

Z0omin

W

Rolling the mouse wheel forwards zooms in on the currently active 3D View. Rolling the
mouse wheel backwards zooms out on the currently active 3D View.

In both cases, holding down the @ or Ctrl key at the same time as rolling the mouse wheel
controls the speed of the operation. Holding the Ctrl key down makes the mouse wheel

zoom in and out faster. Holding the @ key down makes the mouse wheel zoom in and out
slower.
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3.2.3 Design Item Entries

This section describes view options on elements in the Model Editor. The element must be

selected.

Edit Equiprnent

De-Select All
De-Select Current

Hide
Femaove From Draw Lisk

Zoam Ta
Walk To

Cancel

(Equipment Selected)

Connecked
Leg

De-3elect Al
De-3elect Current

ERAM [100-B-1-B3

PIPE J100-B-1
Hide: !

Remawve From Draw Lisk

Ise 30 Handle

Zoam To
walk To

Cancel

(Piping Component Selected)

The following viewing options are available on a design item:

Menu Option

Description

Edit >Equipment

Removes the Movement Handle (if present) from the
Equipment item, allowing only Equipment editing functions

to be carried out. (The Movement Handle can be reinstated
= 4

if required by double-clicking on the == icon on the main
toolbar.

Select>Connected

(Piping Components only). Selects Components connected
to the selected Component.

Select>Leg

(Piping Components only). Selects Components in the
same pipe leg as the selected Component.

Select>BRAN . ..

(Piping Components only). Selects the owning Branch.

Select>PIPE . ..

(Piping Components only). Selects the owning Pipe.

De-Select All

Clears the current graphical selection.

De-Select Current

Clears the graphical selection of the current element (but
leaving the rest of the elements in the selection selected
(for example, Components in a selected Branch)).

Hide

Removes the graphical selection from the display, but does
not remove it from the drawlist

Remove from Draw List

Remove the graphical selection from the drawlist

Use 3D Handle

(Piping Component selected) Switch back to 3D Movement
Handle (see below for further details).
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Introducing the Model Editor 3D View

Menu Option Description

Zoom To Centres the view on the current graphical selection, or on
the current element if there is no graphical selection. The
current element or graphical selection fills the graphics
window

Walk To Same as Zoom To except that Walk To removes any item

between your eye position and the target object if that item
is not in the immediate vicinity of the target item.

Note: Selecting a Piping Component while in Model Edit mode causes the Graphical
Component Modification facilities to be entered. The Use 3D Handle menu selection
switches from the Graphical Component Modification Handle to the 3D Movement

Handle.

View Manipulation Toolbar Buttons

The View Manipulation toolbar on the left side of the 3D View window provides quick access
to the most commonly used view manipulation operations.

Clipping and Capping

Clipping displays only those parts of the model which fall inside a clipping box. Capping
allows the faces cut by the clip box to be filled with a colour. Capping is available only on
machines with graphics cards that support this feature.

On Model Editor 3D Views, these features are made available from the 3D View toolbar.

See Clipping for a description of the clipping features.
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Model Editor Operations

Model Editor Mode
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The Model Editor is a mode of operation in Oultfitting Design which enables you to reposition
selected Iltems using the mouse pointer.

You enter Model Editor mode by clicking the Model Editor button on the main
toolbar, and return from the Model Editor to Design Navigate mode by clicking the

button again. Alternatively, the Edit>Model Editor menu selection may be used to
enter and leave Model Editor mode.

In this user guide, a 3D View that can be switched into Model Editor mode is called a 3D
Model Editor View. See Introducing the Model Editor 3D View for details of the 3D Model
Editor View. The features described here for selecting, moving and rotating items by using
the mouse are available only in the Model Editor.
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Model Editor Operations

Element Selection in the Model Editor

Groups of selected Items can be moved or rotated in a single operation. The collection of
selected items is called the Graphical Selection. The Items that can be selected and
modified using the Model Editor are listed in Selectable ltems.

Iltems can be added to or removed from the current Graphical Selection by picking them
using the mouse pointer. Selection facilities are provided which allow you to select groups of
related items in a single selection operation.

Drag rectangle (Fence) selection allows groups of elements to be selected easily. You can
define whether to select only those elements that are wholly within the rectangle or to
include those that are partially within the rectangle.

A Re-Select function is provided to go back to the previous Graphical Selection. This is
useful if the Graphical Selection has been lost by accidentally using a clear selection
operation or beginning another selection.

Clicking in blank space in a 3D Model Editor View, or using De-Select All on elements
clears the Graphical Selection.

A Locator Handle appears when a Graphical Selection is present. This is used to
manipulate the position and orientation of the entire Graphical Selection.

Note that if the element is marked as Read-Only, the selection is highlighted using a red line
(rather than a green line):
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4.1.2 Locator Handle

Planar movement handles

Rotation about single axis

7

Linear movernent in axis direction

The Locator Handle is a collection of individual graphical manipulation handles grouped
together. The Locator Handle can be used to drag the entire Graphical Selection to a new
position or rotate the entire Graphical Selection through an angle about a selected axis.

This combination of direct graphical manipulation handles offers you the ability to move
selected items constrained in a direction or to lie in a plane, or rotate the selection about an
axis.

See Positioning and Orientation using the Locator Handle for details of using the locator
handle.
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4.1.3 Movement

A Graphical Selection is moved using linear and
planar handles on the Locator Handle, or by using
the Edit menu.

Dragging a linear or planar handle with the mouse
pointer moves the current Graphical Selection. The
movement is made in steps, the size of which can
be controlled by you (the Movement Increment).
This allows the Graphical Selection to be
positioned accurately in relation to its original

position.
BRY -8200.00 The Graphical Selection can be moved until it is
AN aligned with another item in the display by using

[y

Z -10900.00

. G

Locator Handles, the Edit menu, or by dragging
with Feature Identification mode switched on (see
Alignment).

Clicking and dragging one of the three Linear Movement Handles constrains the
movement of the selection to be in the direction of the selected axis.

. N

650.00

Linear Constrained Movement

Linear Movement Handles
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Clicking and dragging one of the three Planar Movement Handles constrains the
movement of the selection to be in the plane of the selected planar handle.

| Z -400.00
R ' 2350.00

-
-

Planar Movement Handles Movement Constrained to be in a Plane

414 Rotation

The Graphical Selection is rotated using a
Rotation handle. The selection rotates in
angular steps as it is dragged with the mouse,
the size of which can be controlled by you (the
Rotation Increment). This allows the Graphical
Selection to be rotated accurately from its
original orientation.

The Graphical Selection can be rotated until an
axis of the Locator Handle is aligned with
another item in the display by using Locator
Handles, or by dragging with Feature
Identification switched on (see Alignment).
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Clicking and dragging one of the three Rotation Handles constrains the rotation of the
selection to be about the axis corresponding to the selected rotation handle.

Constrained Rotational Movement
Rotation Handles

415 Alignment

The Graphical Selection can be moved or rotated until it aligns with a point, P-point, P-line

or straight line (edge) in the model. In this document, the target points and lines are called
features.

Through Ppoint Feature

The origin of the Locator Handle is the reference datum for aligning the Graphical Selection.
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4.1.6

4.1.7

4.1.8

4.1.9

4.1.10

Model Editor Operations

Locator Handle as a Frame of Reference

The Locator Handle can be moved or rotated independently of the Graphical Selection. This
allows you to set a datum for movement and alignment operations, or to set an axis of
rotation about which the Graphical Selection can be rotated.

Feedback
The locator handle changes shape to show movement or rotation constraints.

Movement and rotation feedback for freehand operations is displayed both in the 3D View
and on the status bar. This allows both world position and displacement from the starting
position to be shown. The distance values are output in the style and units set on the
Current Session Units form (Settings>Units).

If feature alignment is in use, feedback is given on features as the mouse pointer passes
over them, and graphical feedback is provided to help achieve the correct alignment in a 3D
model.

Unconstrained Positioning

The Locator Handle provides functions for positioning the Graphical Selection constrained
in a given direction or in a plane. However, it is sometimes necessary to specify a new
position without any constraints applied to movement of the Graphical Selection.

An unconstrained position can be specified by typing world co-ordinates into a form, by
typing a 3D offset from the current Location Handle position, or by snapping to a Point
feature.

Undo and Redo

Undo and Redo functions in Model Editor mode allow you to step backwards or forwards
through one or more movement or rotation operations. Undo and Redo operate on a
sequence of direct graphical manipulation operations in the Model Editor.

Note: Undo/Redo operations can also take place outside of Model Editor Mode. If the Undo
operation involves moving into or out of Model Editing mode, then the switch into that
mode happens automatically, and the Model Editor button and menu option reflect
the change. The selection set and handle appropriate to the editing operation that
was being used will also be restored.

Note: Other ‘undoables’ (operations or sequences of operations that can be undone) can
be defined as a PML ‘undoable object’ - see the Software Customisation Guide.

Performance

The speed of interactive selection and dragging operations is dependent on both the
specification of the hardware being used, and on the complexity of the model displayed in
the 3D View. Generally, it is advisable to minimise the size and complexity of the displayed
model in order to obtain good interactive feedback from the system.

Performance tips when using Model Editor:

- Display only those elements that are necessary for the modification that you are
performing. As you drag a graphical selection on the screen, the display is continuously
redrawn.
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42.1

4.2.2

Model Editor Operations

« Avoid using large graphical selections. It may be better to make bulk moves in small
groups.

« Avoid drawing the model with high levels of detail. For example, do not display the
model with holes drawn; do not use a fine arc tolerance.

« Avoid drawing the model with P-points switched on.

Element Selection in the Model Editor

In order to move or rotate items, you must first select the items to modify. The collection of
selected items is called the Graphical Selection. Items may be added to or removed from
the current Graphical Selection by various selection methods:

» picking with the mouse pointer

« dragging a rectangular fence around items to be selected

e using selection operations to select related groups of items
« clearing the Graphical Selection.

The Outfitting Design database elements that can be selected and modified using the Model
Editor are listed in Selectable Items.

Selection Feedback

Selected elements are highlighted so that they stand out from all the other elements in the
graphics display.

A Locator Handle appears when a Graphical Selection is present. This can be used to
manipulate the position and orientation of the entire Graphical Selection.

Modifiable and non-modifiable elements

Elements that can be moved or rotated by you are highlighted with a green wireframe
highlight when you click on them in Model Editor mode. If you do not have permission to
move or rotate an element, it is highlighted in a red wireframe.

It is not always possible to determine whether a move or rotation operation can be carried
out when items are selected. It is possible that a move or rotation operation could be
rejected if Outfitting Data Access Control determines that the current user is not permitted
carry out the operation.

Selecting Items Using the Mouse Pointer

Items are selected by clicking on the item with the left mouse button in the 3D graphics view.
The Ctrl key is used to add unselected items to the current selection or remove selected
items from the Graphical Selection. Available selection methods are:

« Single click on an unselected item creates a new Graphical Selection containing that
one item.

» Single Ctrl-click on an unselected item to add it to the current Graphical Selection.
« Single Ctrl-click on a selected item to remove it from the current Graphical Selection.

e Picking implied tube, or using a Select Leg operation on a Piping Item (see Item-
Specific Selection Operations), selects a Pipe leg. Using the Ctrl key with a Pipe leg
selection adds to the Graphical Selection if an unselected item is picked. Ctrl with
selected implied tube pick removes the Pipe leg.
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4.2.3

Model Editor Operations

Note: That the Ctrl with a selection on a selected item does not remove the selection from
the list.

Fence Selection

A group of items can be selected by using a fence selection. There are two fence selection
options - Wholly Within and Wholly And Partially Within.

Wholly Within selects items that are entirely contained inside the rectangular boundary of a
fence selection.

Wholly And Partially Within selects both items that are entirely contained inside the
rectangular boundary of a fence selection, and items that cross the boundary.

Fence selection can be carried out with either the right or left mouse button. The ‘Within’
setting is achieved from a right mouse button fence select - see below.

Fence select using the left mouse button

Drag a rectangle surrounding the items to be selected by pressing the left mouse button
down at one corner of the rectangle, and drag the mouse pointer to the opposite corner. The
selection takes place when the mouse button is released.

The items selected depend on the current ‘Within’ setting - see Fence Select using the
right mouse button below.

The illustrations below show the effects of each selection.
! o

o

selection rectangle
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if Wholly Within is selected

if Wholly And Partially Within is selected

Pressing the Esc key during the drag aborts the selection.

. Fence Select using the Right Mouse Button

Drag a rectangle surrounding the items to be selected by pressing the right mouse button
down at one corner of the rectangle, and drag the mouse pointer to the opposite corner. The
menu shown in the picture below appears when the mouse button is released.
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4.2.4

Model Editor Operations

Wihally Within
Whally And Fartally WWithin

Zancel

The selection takes place when one of the options on the menu is selected.

Pressing the Esc key during the drag or prior to selecting from the menu aborts the
selection. Clicking away from the selection or selecting Cancel on the menu also aborts the
selection.

Adding to an existing Graphical Selection with a fence selection

Holding the Ctrl key down while performing a fence selection adds the selected items to the
existing Graphical Selection.

Removing selected items from an existing Graphical Selection with a fence
selection

Holding the @ key down while performing a fence selection removes the selected items
from the existing Graphical Selection.

Item-Specific Selection Operations

Item-specific selection operations can be found on some Ship items.

Connecked
Le
De-3elect Al d
De-3elect Current BRAM [100-B-1-B3
PIPE jl00-B-1
Hide: !

Remawve From Draw Lisk
Ise 30 Handle

Zoam To
walk To

Cancel
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Model Editor Operations

on a Piping Component showing selection options

. Select Pipe and Branch Owners

Zonnecked
Leg

ERAMN fE0-B-14-B2
FIPE [f30-E-14

»  Select Branch
The Select BRAN option selects the owning Branch, highlighting it with a green line:

A

. Select Pipe

The Select An Owner>PIPE option selects the owning Pipe, highlighting it with a green
line:

. Select Attached Steelwork Sections

The Select> options on a Steelwork Section have a similar function to that with Piping
Components.
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4.2.5

4.2.6

4.2.7

Model Editor Operations

ck k Atkached
De-3elect all SBFR. JEQIIPRACKMAIMMCOLUMMS
De-Select Current FRIMW JEQUIPRACK/MAIN

Hide
Remave From Draw List

Zoom Ta
Walk Ta

Zancel

If a Section is selected, then Select>SBFR selects all elements in the owning
Subframework.

Select >FRMW . . . selects the owning Framework.

Clearing the Graphical Selection

There are four methods to clear a Graphical Selection:
e Click in blank space in the graphics 3D view.
e Select De-Select Current on a selected element in the 3D view.

e Select De-Select All on an element in the 3D view. (This is provided for the case where
the 3D view is full, so no part of the 3D view background can be seen.)

* Leave Model Editor mode.

Reinstating the Previous Graphical Selection

If a Graphical Selection has been lost accidentally by clearing the selection or by starting a
new selection, the previous selection can be reinstated by selecting Edit>Re-Select from
the main menu bar.

Leaving Model Editor mode clears the Graphical Selection, but you can reinstate the last
Graphical Selection on return to Model Editor mode by using Edit>Re-Select.

Selection Menu

The Selection menu on the main menu bar contains commands for setting properties of the
Locator Handle and the Graphical Selection.

Selection

Feature Highlighting
Set Increments. ..

Set Handle Colour »
Drag Image 4

Select Rectangle »
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. Feature Highlighting

Enables or disables Feature Identification Mode. Feature Identification Mode is described
in Positioning and Orientation using the Locator Handle.

If the mouse pointer is over a 3D Model Editor view, and the Model Editor is active, pressing
the F key on the keyboard toggles between feature identification mode being switched on or
off.

. Set Increments

Set Increments shows a form for setting the active movement or rotation increments:

Set Increments E|E|@
Linear incrememnt 50.00
Fine linear increment A.00
Angular increment 5.00 deg
[ F, ] [ Cancel

The Linear increment is specified in the currently active units, or units can be specified by
using Outfitting units of measure syntax.

. Set Handle Colour
Allows you to change the colour of the Locator Handle. The list of available colours is shown
on the submenu.

. Drag Image

During a drag operation using the Locator Handle, an image of the Graphical Selection
follows a constrained path defined by the current mouse pointer position. The style of
feedback for all items in the Graphical Selection can be selected from the submenu list.

. Select Rectangle

Sets the mode of operation of Select Rectangle on the left mouse button to be Wholly
Within or Wholly And Partially Within.
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431

Model Editor Operations

Positioning and Orientation using the Locator Handle

Planar movement handles

Rotation about single axis

7

Linear movement in axis direction

The Locator Handle consists of a family of graphical manipulation handles, each of which
applies a constraint to the way in which the Graphical Selection is moved.

This section describes how to move or rotate the current Graphical Selection using the
Locator Handle.

Overview

The Locator Handle provides three ways to move or rotate a Graphical Selection:
« dragging the linear, planar or rotation handles freehand with the mouse pointer

< aligning with points, P-points, P-lines or straight lines (edges) on other displayed Ship
items

« typing in offset distance or angular displacement values

Aligning the Graphical Selection with points or lines on other displayed items

When aligning a Graphical Selection with other Ship items in the displayed model, you enter
feature identification mode, where the mouse pointer is sensitive to finding features on
the Design graphics. Features are points, straight lines (edges), P-points or P-lines. Points
are located at vertices on the model, such as the corner of a box, and at the mid-point of
lines. Lines are straight edges on the model (Design Aid graphics cannot be used as a
feature).

Feature identification mode is turned on and off by selecting Feature Highlighting on the
Selection menu, or by pressing the F key when the mouse pointer is over a 3D Model
Editor View, and the Model Editor is active.

Some operations turn on feature identification mode temporarily to allow you to pick a
feature. For example, Edit>Move Selection>Snap To Point. Once the required feature is
identified, the mode reverts to its state before the command was actioned.

Aligning the Locator Handle with features in the model is described in Linear Movement
Handle to Rotation Handle.
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Model Editor Operations

Automatic Scrolling

If the target location for a drag operation is outside of the 3D view, the mouse pointer can be
moved to an edge of the view, where the view will pan automatically up, down, left or right
according to the 3D view edge that the mouse pointer hits. The mouse pointer must move in
order for the panning to continue. This may necessitate you making a small movement of
the pointer near to the view edge to keep the pan operation going.

This technique for panning the view is appropriate for locating a target position that is just
out of view.

Linear Movement Handle

The Linear Movement handle allows you to move the Graphical Selection constrained in the
direction of the linear handle axis. The size of each step of the movement is defined by the
current movement increment.

Dragging a linear handle with the left mouse button moves the Locator Handle and
Graphical Selection in the direction of the linear handle.

To initiate a linear drag, press the left mouse button down over one of the linear movement
handles. With the left button still pressed, moving the mouse drags the Graphical Selection
constrained in the selected direction, in steps defined by the movement increment.

Moving one Movement Increment at a Time

If the movement increment is small relative to the magnification of the 3D view, it can be
difficult to move the mouse freehand to a precise displacement from the Locator Handle’s
original position. Fine control over positioning can be achieved by dragging with a linear
handle so that it is close to the required position then, while continuing to hold down the
mouse button, press the plus (+) or minus (-) key on the numeric keypad. This moves the
Graphical Selection by one movement increment in the direction of the linear handle if + is
pressed, or in the opposite direction if - is pressed.

Using the arrow keys in this way moves the Graphical Selection by 0.1 of the current
movement increment for each press of the key.
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Model Editor Operations

. Feedback

When moving a selection in a constrained direction, the Locator Handle changes to a cut-
down version of the full handle to show the direction of movement, as shown below. The
current World position of the Locator Handle is displayed on the status bar, and an offset
from the original position of the handle is displayed on the 3D View.

Locator handle reducesto lingar
drag handle with arowhead

Feedback on distance

Criginal position of
7

element p

As the mouse moves over a linear handle, the pointer symbol changes to the linear drag
pointer.

A Linear Handle has the following movement operations on its shortcut menu:

Enker Yalue. .,
align with Feature, ..

Snap ko Poink. ..
Move Handle »

Cancel

Enter Value®

This command shows the following form:

Move Selection

Freview 0] 4 Cancel
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The field corresponding to the selected axis is activated for input. In this case, entering 2500
in the X field tells the Graphical Selection to move by 2500mm in the X direction of the
Locator Handle.

Align with Feature®

-

o

Through Ppoint Feature

Repositioning a Graphical Selection to align with a Nozzle using the linear handle and
feature alignment.

This method allows you to position the Graphical Selection in relation to another object on
the screen, but forces the Graphical Selection to move only along the selected axis. The
sequence of operations is as follows:
1. Make a Graphical Selection.
Optional: Position the Locator Handle at the required datum position.
2. Select Align with Feature on the linear handle .

3. Move the mouse to the target feature. This highlights the target feature, and the mouse
pointer changes shape to indicate that the Graphical Selection will be aligned with the
target position if the mouse button is clicked.

4. Click the left mouse button to move the Graphical Selection to the target position.
Linear drag can align with a point feature or a line feature.

. Point feature Alignment

When positioning the Graphical Selection to a point feature, the origin of the Locator Handle
is aligned with the target point such that the target point is projected onto the line of
movement.

This situation is illustrated below (in two dimensions):
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« Alignment with a Line or P-line Feature

There are two cases to consider:
« Selected line feature is orthogonal to the line of movement

If the line selected line feature is orthogonal to the line of movement, then the feature line is
treated as a feature point. Any position along the feature line projects onto the same point
on the movement line.

« Selected line feature not orthogonal to the line of movement

If the line selected line feature is not orthogonal to the line of movement, then the
intersection of the extended feature line with the line of movement becomes the new
Locator Handle origin position. If the extended feature line and the movement line do not
intersect in 3D, then the point chosen is the nearest point on the line of movement to the
extended feature line.

-

Mew position of Locator Handle Ongm_q*"

- L]
- L]

Direction W )
‘I\

This situation is illustrated below (in two dimensions):

Target Point Feature

* Alignment with a P-point Feature

There are two cases to consider:
e P-point as point feature

A P-point feature may be treated as a point feature, and works as described above for
points.

e P-point as a Line feature

A P-point has a direction, which is indicated by the arrow on a P-point feature symbol. If the
mouse pointer is moved over the P-point arrow, then the intersection of the P-point direction
with the line of movement becomes the new Locator Handle origin position. If the P-point
direction and the movement line do not intersect in 3D, then the point chosen is the nearest
point on the line of movement to a line projected from the P-point position in the P-point
direction.

The following pictures illustrate the difference between P-point as a point and P-point as a
line:
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Mouse over P-point position
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=

e

‘ w—“_—":l]""/

Mouse over P-point arrow

Snap To Point

Snap To Point allows the Graphical Selection to be moved to a Point feature. The Graphical
Selection is not constrained to move along the direction of the Linear Handle. This is
described in Positioning and Orientation Using the Edit Menu.

Move Handle

Enter Walue. ..
aligr with Feature. ..

Snap ko Paint. ..

Mowe Handle Enter Value, ..
Align with Feature. .,

Cancel

Snap ko Point...

The Move Handle submenu provides the same movement commands as the main Linear
Handle menu, but these commands move the Locator Handle only. They do not move the
Graphical Selection.
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The Locator Handle may be moved independently of the Graphical Selection in order to
change the datum position for the next operation on the Graphical Selection.

Planar Movement Handles

Each of the planar movement handles constrains the drag operation such that the Graphical
Selection moves only in the plane of the selected handle. The handle moves in steps
determined by the current Movement Increment setting.

A7

To initiate a planar drag, you press the left mouse button down over one of the planar
movement handles. With the left button still pressed, moving the mouse drags the Graphical
Selection constrained in the selected plane, in steps defined by the movement increment.

Feedback

A triangle is displayed on the current constraint plane, between the original position of the
handle and the current position. The relative movement distances are shown on the sides of
the triangle. The current World position of the Locator Handle is displayed on the status bar.
All values are shown in the current selected units.

Locator handle reduces to the planar handle
and two linear drag handles in the drag plane

Original position
of elerment

]

~¢. #" Feedback on digtance moved

[

The Locator Handle changes to a simple version of the full handle to show the plane of
movement as shown below.

As the mouse moves over a planar handle the pointer symbol changes to the planar drag
symbol.

A Planar Handle has the following movement operations on its shortcut menu:
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Enter Yalues. ..
Align with Feature, ..

Snap to Paink. ..
Maove Handle k

Cancel

Enter Values®

This command shows the following form.

Move Selection

E |2000

¥

Z 4000

Freview | 0] | Cancel |

The fields corresponding to the selected plane are activated for input. In this case, entering
8000 in the X field and 4000 in the Z field tells the Graphical Selection to move by X8000mm
Z4000mm in the XZ plane of the Locator Handle.

Align with Feature...

«:.-..-.--.-.--.- -
-2050.90

o

This facility allows you to position the Graphical Selection in relation to another object on the
screen, but forces the Graphical Selection to move only in the selected plane. The
sequence of operations is as follows:

1. Make a Graphical Selection.
Optional: Position the Locator Handle at the required datum position.
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2. Select Align with Feature... from the planar handle.

3. Move the mouse to the target feature. A marker appears at the target point, and the
mouse pointer changes shape to indicate that the Graphical Selection will be aligned
with the target position if the left mouse button is clicked.

4. Click the left mouse button to move the Graphical Selection to the target position.

. Point feature Alignment

When positioning the Graphical Selection to a point feature, the origin of the Locator Handle
is aligned with the target point such that the target point is projected onto the plane of
movement. For example, the picture above shows the target P1 P-point position being
projected onto the plane of movement of the Graphical Selection.

. Alignment with a Line or P-line Feature

If a planar move is to be aligned with a line feature, then the Locator Handle origin is placed
where the extended feature line or P-point direction intersects with the movement plane. For
example, in the following picture, the handrail is dragged in a horizontal plane, with the
bottom of the first post positioned where the top of the stringer intersects with the plane. The
feature selected is an edge on the top of the stringer.

l-..‘-
-

Y,

Snap To Point®

Snap To Point... allows the Graphical Selection to be moved to a Point feature. The
Graphical Selection is not constrained to move in the plane of the Linear Handle. This is
described in Positioning and Orientation Using the Edit Menu.
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Move Handle

Enter Yalues. .,
Align with Feature, ..

Snap to Paint.,..

Move Handle Enter Walues, .,

Align with Feature...

Cancel

Snap to Paint, ..

The Move Handle submenu provides the same movement commands as the main Planar
Handle menu, but these commands move the Locator Handle only. They do not move the
Graphical Selection.

The Locator Handle may be moved independently of the Graphical Selection in order to
change the datum position for the next operation on the Graphical Selection.

Rotation Handle

Y

The rotation handles allow you to rotate the Graphical Selection around the relevant axis
using the current angular increment to control the angular step size.

Dragging a Rotation handle with the left mouse button rotates the handle and the Graphical
Selection about the axis of rotation. To perform a rotation, press the left mouse button over
the relevant rotation handle. With the left button still depressed, drag the mouse to perform
the rotation.
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. Feedback

Locator handle reduces to linear
handles and the rotation handle.

Axis
orientation

Feedback on angular
displacement

The angular movement from the original orientation is shown as the Locator Handle is
rotated. The angular displacement is also shown in the status bar.

As the mouse moves over a rotation handle, the pointer symbol changes to the rotation drag
symbol, and half of the Rotation Handle arc changes to show two arrows. This feedback
indicates which of the axes will be aligned with a feature when feature alignment is used.

. Rotation Handle

A Rotation Handle has the following movement operations on its shortcut menu:

Enker Yalue, .,

Orient Ta Poink. ..
Align with Direction, ..

Align with, ..
Move Handle *

Cancel

Enter Value®

Rotate Selection About Z EEIE
Enter Value: |g)0 deg
Freview | 0)54 | Cancel |

This allows the Graphical Selection to be rotated about one of the Locator Handle axes.
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Orient to Point

Rotating an elbow to align with a Nozzle using a rotation handle and feature alignment
The sequence of operations is as follows:

1. Make a Graphical Selection
Optional: Position the Locator Handle at the required datum position
2. Select Orient to Point... from the Rotation handle

Move the mouse to the target point. The mouse pointer changes to indicate that a point
has been located, and the axis is directed towards the point.

Click the primary mouse button to rotate the Graphical Selection to the target
orientation.
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Align with Direction

Rotating a pump to align with a flange using a rotation handle and feature alignment
The sequence of operations is as follows:

1. Make a Graphical Selection
Optional: Position the Locator Handle at the required datum position
2. Select Align with Direction... from the Rotation Handle .

3. Move the mouse to the target line (edge) or P-point direction. The mouse pointer
symbol changes to indicate that the axis will be directed parallel to the edge. If the

Graphical Selection is shown 180 degrees out of alignment, press the 4} key to get

the alternate alignment. On a P-point, this can be achieved by choosing one of the
arrows on the P-point feature.

4. Click the left mouse button to rotate the Graphical Selection to the target orientation.

Align with

Enter Direction For, X Axis JlE)

Directiun:|N i0 H

Freview | ]%4 | Cancel |

Rotates the selection until the chosen axis points in the given direction. The Graphical
Selection is rotated about one of the Locator handle axes, such that the chosen axis points
as close to the direction specified as possible.
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Rotate Handle

Enter Yalues. .,
Align with Feature, ..

Snap to Paint.,..

Move Handle Enter Walues, .,

Align with Feature...

Cancel

Snap to Paint, ..

The Rotate Handle submenu provides the same rotation commands as the main Rotation
Handle menu, but these commands rotate the Locator Handle only. They do not rotate the
Graphical Selection.

The Locator Handle may be rotated independently of the Graphical Selection in order to
change the frame of reference for the next operation on the Graphical Selection.

Rotate Handle>To World

This command aligns the Locator Handle with the World co-ordinate system, without
rotating the Graphical Selection. The Locator Handle Y axis points North, and the Z axis
points Up.

Feature Highlighting

Having made a graphical selection in Model Editor mode, use Selection>Feature
Highlighting to switch into a mode where features are identified as the mouse pointer
passes over them on a 3D view. If Feature Highlighting is on, selecting it again switches
feature snapping off. Alternatively, the F key can be used to toggle feature identification on
and off if it is pressed over the 3D View while in Model Editor mode.

If the Graphical Selection is dragged using the Locator Handle while Feature
Highlighting is on, it aligns itself with key features on the displayed model as the mouse
pointer passes over them. See the sections on Linear, Planar and Rotation Handles for a
description of how feature highlighting works for each handle.

There is an alternative method to select a feature. Moving the mouse over the 3D model
without dragging the locator handle still highlights features. Pressing the right mouse button
over a highlighted feature shows a menu that allows the Graphical Selection or the Locator
Handle to be moved to the selected position.
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for a point feature while in feature identification mode
Selecting Move Handle Here in the picture above moves the handle to the selected point.

In order to select features of an item, it is necessary to move the mouse pointer over the
item before features are shown. In most cases, the target P-point or P-line lies on, or inside,
an item, so selecting a feature is straightforward. In the few cases where the P-point or P-
line is outside of the item, or partly obscured by another item in the scene, it is necessary to
make sure that the mouse pointer first passes over the associated item.

On steelwork items with P-lines, the JUSL P-line is shown as a feature.

Feature identification:
* The Locator Handle can be moved to features on selected or unselected items.

* The Graphical Selection cannot be moved to a reference point on selected items,
because the selected items are shown in their new location when a reference point is
found.

. Cancelling the Drag

At any point of the move, you can cancel the drag operation by pressing the Esc key. This is
a standard way of cancelling a drag operation on Windows. When the drag is cancelled the
selection reverts to its original position and remains selected.
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Moving the Locator Handle Independently of the Graphical Selection

A Locator Handle can be moved independently of the Graphical Selection. This allows a
datum position to be set for subsequent move operations, or an axis of rotation to be set for
subsequent rotation operations.

The Locator Handles and the Edit menu provide commands for moving and rotating the
Locator Handle on its own. In order to drag the Locator Handle without the Graphical
Selection, select the linear, planar or rotation handle by pressing the left mouse button
down, and then press the H key on the keyboard. This detaches the Locator Handle from
the Graphical Selection. The H key can be used to toggle between moving the Locator
Handle on its own, and moving the Graphical Selection with the Locator Handle.

Positioning and Orientation Using the Edit Menu

Move Selection and Move Handle

Edik
v [Model Editor

Unda
Redo
Re-3elect

Maove Selection Offset in 30...
Rotate Selection  » Set 30 Position, ..

Move Handle » Snap To Paint, ..
Rotate Handle r

Delete Selection

Move Selection moves the Graphical Selection. Move Handle moves the Locator Handle
only. The three operations described below apply to both Move Selection and Move
Handle.

Move Selection/Handle>Offset in 3D...

Move Selection

X (1000

¥ |2000

Z (3000

Freview QE Cancel
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The Graphical Selection can be moved relative to its original position, in the co-ordinate
system of the Locator Handle. The position of the Graphical Selection only changes if OK is
clicked.

. Move Selection/Handle Set 3D Position...

Set Position Of Selection

|East : | [7510

|Horth: | [12645

o | [164F]

Preview | 0K | Cancel |

This form shows the current position of the Locator Handle in World co-ordinates. Changing
the settings and clicking OK moves the selection to the specified world co-ordinates.

. Move Selection/Handle>Snap to Point
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Repositioning an Equipment to align with the centre of a SCTN

This facility allows you to position the Graphical Selection at a selected position in relation to
another object on the screen. The sequence of operations is:

1. Add one or more Ship items into a Graphical Selection
Optional: Position the Locator Handle at the required datum position
2. Select Move Selection/Handle>Snap to Point from the Edit menu

3. Move the mouse pointer to the target position. The pointer changes to indicate that the
Graphical Selection will snap to the target feature

4. Click the left mouse button to move the Graphical Selection to the target position.

Rotate Selection and Rotate Handle

Edit
v [Model Editor

Unda

Re-3elect

Move Selection  #
Rotate Seleckion To World

Move Handle » abouk i, .,
Rotate Handle » Abouk ...

. Abouk £, ..
Delete Selection

Rotate Selection rotates the Graphical Selection. Rotate Handle rotates the Locator
Handle only. The four operations described below apply to both Rotate Selection and
Rotate Handle.

Rotate Selection/Handle>To World

This operation reorientates the Locator Handle and Graphical Selection such that the Y axis
of the Locator Handle points in the World North direction, and the Z axis points in the World
Up direction.

Rotate Selection/Handle>About X/Y/Z

These three operation show the Rotate Selection/Handle About axis form for the selected
axis.

Rotate Selection About Z =N

Enter Value: |60 deg

Freview | (0] | Cancel |

This allows the Graphical Selection to be rotated about one of the Locator Handle axes.
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Clipping

Clipping Submenu

Clipping lets you display only those parts of the model which fall inside a clipping box. The
Clipping submenu is displayed by right-clicking on the Clipping & Options icon on the 3D
View toolbar. The options available from this menu are:

Enable

Controls whether the clipped model or the whole model is displayed. The default is for
clipping to be off.

Capped

When you use clipping, only the parts of the model which lie within the clipping box will be
displayed. Where items are intersected by the clipping box, they can have a coloured cap
added to show that they extend beyond the displayed region. Note that this feature is not
available on all graphics cards.

To control whether or not caps are added, set Cap on or off. The default is for capping to be
off.

Colour...

To change the colour used for capping, select the required colour from the displayed Clip
Cap Colour form.

CE

Sets the clipping box to the current element.

Owner

Sets the clipping box to the owner of the current element.

Limits Box

Sets the clipping box to the dimensions of your explicitly defined Limits Box.

Pick Item

Sets the clipping box to the element you select from the 3D View.

Pick Limits

Lets you specify the extent of the clipping box by constructing a box between two points
identified by picking on the displayed graphics. Positioning options for picking are controlled
using by selecting from the options on the Positioning Control form.

Explicit

Selecting the Explicit... option displays the Clip - 3D View and Positioning Control forms.
If a clipping box has previously been defined its dimensions and origin are shown on the
Clip - 3D View form; if not, a default sized box is placed at the origin of the view. The current
settings for the box are shown in the 3D View as a box, in the default aid line colour.

These forms allow you to define a new clipping box by either:
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« Entering the dimensions and co-ordinates of the origin (centre) directly into the text-
boxes on the Clip - 3D View form. You can use the drop-down list boxes to set the
North/South, East/West and Up/Down axes as necessary.

« Entering the dimensions directly into the text-boxes on the Clip - 3D View form, and
then picking the required origin in the 3D View with the cursor. Note that the Clip — 3D
View form will be automatically updated with the picked co-ordinates. You can use the
EDG facilities on the Positioning Control toolbar to select the type of item to be
picked in the 3D View, and the mode the software will use to derive the point.

and then clicking Apply.

You can also change the orientation of the clipping box, by defining a plane through which it
passes. The icon buttons at the top of the Orientation frame allow you to define a plane by
picking either three explicit points or two points, the third point is taken as the current
working plane. Alternatively, you can edit the Y is and Z is test boxes, to set the orientation
of the clipping box.

To extend the clipped volume by a specific amount, enter a number into the Extend Clipped
Volume by gadget.

Dismiss the forms when you are satisfied with the settings.

You must also select the Enable menu option to make the setting take effect in the view.

Planes

Allows up to six individual planes to be defined to clip the model - see Six-Plane Clipping.

Six-Plane Clipping

As an alternative to the clipping box, up to six individual planes may be defined to clip the
model. The planes may be aligned on Ship items such as panels and beams, or by
selecting ship grid lines.

The 6-plane clipping feature and the clipping box are mutually exclusive. Enabling one has
the effect of disabling the other and clearing any related forms and aid graphics.

Clipping planes can be at any angle, for example to suit tapered compartments on a ship.
Up to six planes can be defined, and the direction of a plane is considered to point into the
region of interest.

Right-clicking on the Clipping & Options icon on the 3D View toolbar and selecting the
Planes option displays the Clip - 3D View form.
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clip - 30 View (1) [2][00[X]

Tools
Define clipping plamns 1 vl
Pozition |

|East v :143:312.00 |
|Sl:uuth v :4804_?2 |
||_|r:| v :?asmun |
Direction

E |

it |.l'* |

Dizahle plane ]

Slicle plane out or in
4 Mudge out or in P

Slide by |0.00

Ot 1] It

Cloze |

The Define Clipping Plane drop-down list is used to select the plane (1-6) to be defined.

The Position drop-down list and data entry fields are used to set the position of the selected
plane.

The Direction field is used to set the direction.

Clicking the Pick button enables a clipping plane to be aligned, for example, on a Ship item
such as a panel or beam, which is picked from the 3D View. The system will then
automatically fill in the Position and Direction fields based on the position and orientation of
the picked item.

The Reverse direction button is useful where a deck plate is picked and the view must be
above or below it.

Once the plane position and direction have been obtained from the picked item, the plane
can be enabled, using the Enabled plane button.

The clipped volume can then be finely adjusted if necessary by using the gadgets at the
bottom of the form to slide the selected plane in or out.
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Planes can be automatically defined based on the clipping box, e.g. following clip CE, then
adjusted individually. Planes can also be defined by selecting grid lines from a grid system.
In this case, select Derive 6 planes from grid lines from the Tools menu on the Clip - 3D
View form:

ctip- 30 view (1) 2 ][0

Detive 6 planes from orid lines...
Detive & planes from dip box...
Clear all clip planss...

The Clip From Grid form is displayed:

Clip from Grid M=0E9

Display

Grid Systems

rrvacd Loy Sricd
nes—plart-grd

Az

Shig
Ship_Reference Grid

Filmmd mavisd varbls P

Limits Frorm To

|FR—3 v| ooo || | |Fresz vl |n.|:u:| |
|LF‘-1EI v| oo || |[p1s vl |n.|:uj |
|DE|:I<III v| oo || ||peckz vl |n.|:u:| |

The Grid Systems list shows the available grid systems for the project. When one of these
is selected, the lower half of the form will change to reflect the grid system selected.

Individual grid lines to delimit the clipped volume can be selected from the Limits From and
To drop-down option lists, or the nearest grid lines to two picked positions can be
automatically selected using the two Pick buttons. Positive or negative offsets (in mm)
relative to the grid lines can be entered into the +/- boxes.

After selecting/picking the grids, the defined volume will be marked graphically:
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Clipping limits from [Snap] Snap

+@ex Gy &

e e E ]

The positions of the clipping planes will be automatically entered into the form in terms of
grid lines and offsets:

Limits Fram - ) To-
+- +i-

|FRI85 v [11.00 FRIS |v| | 26000 |
[Lp7 v [211.00 T
|Deckn v | (52400 Deci2 v | | 411600 |

When the Apply button is pressed, the clipping planes are applied to the view:
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Clip Plane 1

To assist in selecting the appropriate grid lines for clipping, any position can be picked to
display it in World and Grid Coordinates. Select Picked position in grid coords... from the
Display menu on the Clip From Grid form: the Display Grid Coords form is displayed.

Display Grid Coords B|I__I|@
I iarled - 1 —In Ship_Reference_Grid -
E 1 56550mm FRASE - 250mm
fd 41 7S LPE - 225mim
Il &7 G Deck2 -1116mm
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Undo and Redo

Edit
v Model Editar

Unda
Redo
Re-3elect

Move Selection  »
Rotate Selection  »

Move Handle b
Fotate Handle »

Delete Selection

The ease with which you can manipulate the model using the graphical techniques provided
in Outfitting Design makes the provision of an ‘undo’ facility a natural requirement.

There are three types of activity that are recognised while you are in Model Editor mode.
For each of these, the current state is saved before the change in order that it may be
restored by a subsequent Undo.

Changes to the database as a result of manipulating the Graphical Selection either by direct
graphical manipulation or from the context sensitive menus can be undone. (The selection
set and the position/orientation of the Locator Handle are also restored.)

There are two ways you may undo an activity:

e Using the standard Undo and Redo icons ( ﬂil ) in the main toolbar.

e Using the Undo and Redo options on the Edit pull-down menu.

You may step back through undo states one at a time. Following an undo, you can then
choose to redo the sequence, stepping forward one state at a time until the sequence of
changes that were undone are restored. If you do one or more "undos" and then save a
new state, the redo option is no longer available and the corresponding icons/menu options
become inactive.

Switching between applications in Outfitting Design causes the Modify mode button to be
switched off and the undo/redo states to be re-initialised.

Note: Undo/Redo operations can also take place outside of Model Editor Mode. If the Undo
operation involves moving into or out of Model Editing mode, then the switch into that
mode happens automatically, and the Model Editor button and menu option will
reflect the change. The selection set and handle appropriate to the editing operation
that was being used are also restored.

Other ‘undoables’ (operations or sequences of operations that can be undone) can
be defined as a PML ‘undoable object’ - see the Software Customisation Guide.

Delete Selection

Delete Selection on the Edit menu deletes from the database all items in the Graphical
Selection. This operation is only available while a Graphical Selection exists.

4:40 12.0



AV=VA

4.8

Graphical Model Manipulation Guide

Model Editor Operations

Note: You will be asked to confirm the deletion.

Selectable Items

The following table lists element types that can be selected and modified using the Model
Editor. Note that some types of element can be modified if they belong to an administrative
element such as a ZONE or FRMW, but they cannot be individually modified if they belong
to a Ship Item. For example, A SCTN element can be selected and moved if it belongs to a
FRMW or SBFR element, but not if it belongs to a TMPL element.

Ship Iltem

Selectable Elements

EQUIPMENT

SITE>ZONE>EQUI

PIPE (and CABLE TRAY)

PIPE/CABLE TRAY

SITE>ZONE>PIPE using the Select Owners operation

BRANCH

SITE>ZONE>PIPE>BRAN
operation

using Select Owners

Pipe component

SITE>ZONE>PIPE>BRAN>(any component)

HVAC

HVAC SITE>ZONE>HVAC using Select Owners operation

BRANCH SITE>ZONE>HVAC>BRAN using Select Owners
operation

HVAC component

SITE>ZONE>HVAC>BRAN>(any component)

HANGERS

RESTRAINT ...PIPE>REST & ...HVAC>REST using Select Owners
operation

HANGER ...PIPE>REST>HANG & ...HVAC>REST>HANG

PIPE TRACK SITE>ZONE>PTRA

ROUTING PLANE

SITE>ZONE>RPLA or SITE>ZONE>STRU>RPLA

RPLA also exists under EQUI, PTRA, SUBE, SUBS -
RPLA is NOT a significant element in these situations

PENALTY VOLUME SITE>ZONE>PVOL or SITE> ZONE>STRU>PVOL
Note: PVOL also exists under EQUI, PTRA, SUBE,
SUBS - PVOL is not a significant Model Editor
element in these situations
STRUCTURES

Primitive owned directly by
STRU

SITE>ZONE>STRU>(Primitive)

SUBSTRUCTURE

SITE>ZONE>STRU>SUBS

FRAMEWORK

...STRU>FRMW using Select Owners operation
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Selectable Elements

SUBFRAMEWORK

...STRU>FRMW>SBFR using Select Owners operation

Collection of FLOOR

...STRU>FRMW>CFLOOR using Select Owners
operation

Collection of WALL

...STRU>FRMW>CWALL using Select Owners
operation

Collection of SCREED

...STRU>FRMW>CSCREED using Select Owners
operation

Note: The following elements may be owned by FRMW, SBFR, CFLOOR, CWALL or

CSCREED

GENSEC GENSEC

WALL WALL

PANEL PANE

FLOOR FLOOR

GWALL GWALL

SCREED SCREED

PNODE PNOD

SCTN SCTN

STWALL STWALL

PALJ PALJ

DRAW SITE>DRAW or SITE>ZONE>DRAW

Note: DRAW also exists under EQUI, PTRA, SUBE,

SUBS - DRAW is NOT a significant element in
these situations. See selection rules for those
element types

BOUNDARY SITE>BOUN or SITE>ZONE>BOUN

GROUND MODEL SITE>GRDM

DATUM SITE>ZONE>DATU

Note: The Model Editor does not work with Design Template elements in the Template
World. It is not possible to selected elements owned by a TPWL>TMAR>TMPL

hierarchy.
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5 Graphical Equipment Modification

5.1 Introducing Graphical Equipment Modification

Entering Model Edit mode, clicking on an Equipment Item and selecting Edit Equipment
from the shortcut menu enables the Graphical Equipment Modification (GEM) facilities.

Edit Equipment .

De-Select Al
De-3elect Current

Hide
Femave From Draw Lisk

Zoam To
walk To

Cancel

GEM gives menu options which facilitate the graphical modification of an Equipment item
and its ‘offspring’, down to primitive level.
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5.2 Equipment Modification Characteristics and
Facilities

5.2.1 Display Characteristics

Selecting an Equipment item and enabling GEM makes non-Equipment items in the display
translucent. For example:

Clicking on a primitive which itself contains primitives causes the other Equipment primitives
to become translucent. Negative primitives are drawn in wireline.
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522 Modification Facilities

Elements below the hierarchical level of a selected primitive can be accessed using the Edit
<primitive> shortcut menu selection (for example Edit BOX).

Elements below the hierarchical level of a selected primitive can now be selected and
manipulated using the standard facilities, see Model Editor Operations.

To exit GEM, select Exit Equipment Editor from the shortcut menu.
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6 Graphical Component Modification

6.1 Introducing Graphical Component Modification

Graphical Component Modification (GCM) enables you to use the mouse to move and
rotate a Component or a selection of contiguous Components within the constraints of a
pipe route.

GCM is entered automatically when you click on a piping Component while in Model Editor
mode. You do not have to be in the Design Pipework application to be able to use this
facility, which enables you to move interactively a Component along the legs of a pipe route
and to rotate a Component about the tube centreline.

The Movement Handle in this case appears as show below:

The following facilities and constraints are available:
» rotation about the tube centre line
« constrained positioning along the path of the pipe route:
e increment snapping
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« feature highlighting

« Components can only be repositioned where there is sufficient space to fit them in the
route

e automatic reorder of the elements within the hierarchy to suit the new position within
the pipe route

« the ability to reposition the handle within the constraints of the Component selection set
(along the centreline of the pipe)

< the initial orientation of a selection should be maintained where possible

¢ undo/redo changes.
The system does not try and resolve any inconsistencies that may occur from the
repositioning of a Component. For example if a Reducer is moved into another leg of a

Branch, the Components and tube between the Reducer’s original position and its new
position in the Branch remain the same.

Note: in the above case, if a Component is moved across a Reducer, the Component is
not automatically reselected from the Specification; this must be done ‘manually’.

GCM is enabled automatically by first entering Model Edit mode and then selecting of a
Piping Component or a sequential set of Components which are within the same leg of a
Pipe Branch, and provided the selection set has certain characteristics.

GCM is exited either by leaving Model Edit mode or by selecting another element that
breaks the rules for displaying the Component Modification handle.

Selection Set for GCM

(See Selection for general information about Selection.) The movement handle is only
shown when the selection set contains:

* A single Piping Component which does not cause the Branch to change direction, i.e.
the Component has a parallel Arrive and Leave direction:

=

Selected Component F

« A sequential set of Piping Components which lie within the same leg of a Branch, i.e.
there is no change in direction or a bad alignment exists in the leg:

Selected Components

« In the following example the Component Modification Handle is not displayed.
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Selected Components

|5£:Iet:led Components

M-
— 3
—— i

-

* In this example the Component Modification Handle is displayed

|Selected Components |

6.2.1 Component Modification Handle

The Component Modification Handle only appears where the selected Component(s)
conform to the rules as defined above.

Selected
Companent

Crigin of Component
and Handle

By default the origin of the initial Component identified to define a selection is used to
position the handle.

Picking a Component already within the selection set moves the handle to the origin of the
identified element:
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6.3

6.4

Selectad
Component

Oingin of
Component and

However, selecting an item in the selection with the primary mouse button does not change
the position of the handle; it only shows the appropriate selection for the identified item.

Operations in GCM

The Component Modification Handle has two parts:
« the Movement Handle - this is used to move the selected Components along the path
of the pipe route
« the Rotation Handle - used to rotate the selected Components about the centreline of
the primary Component

Fotation Handle

hMowvernent Handle

Movement Handle

This handle is used to move the selected Components within the constraints of the of the
Pipe route that the selected Components exist in.
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6.4.2
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Dragging

The handle can be dragged by using either using primary or secondary mouse buttons. The
legs that the selection can be dragged into are highlighted with a turquoise line (see above
figure). By default, the handle moves in multiples of the currently defined linear increments
- see Element Selection in the Model Editor.

When dragging using the secondary mouse button, you are presented with a context-
sensitive menu on button up. The menu displays the available options which relate to the
drag and when in a special action mode (e.g. feature highlighting, see Feature Highlighting),
the target, if applicable. If no special actions are active, you are given the option to accept
the new position or cancel the operation and the handle and selection return to their original
position.

Move

Cancel

Feature Highlighting

With Feature Highlighting ‘on’, dragging with the primary mouse button held down causes
features such as p-points or p-lines to be highlighted when the pointer moves across them.
Highlighted features can then be ‘snapped' to. Feature highlighting can be activated either
from the F ‘hotkey’ or from Selection>Feature Highlighting on the main menu bar.

As the alignment with a feature invariably relates to the leg the Components are in, when
feature highlighting is active the drag movement is constrained to lie along the leg the
selected Component is currently in, not the whole pipe route. This prevents the inadvertent
repositioning of Components into a different leg when trying to align with a feature.

When no feature is found initially, the handle moves using the default movement increments
until a feature is identified. Selected Components cannot moved past either end of the pipe
leg they are within.

Where a derived position is not within the bounds of the leg or cannot physically fit within a
segment of a leg, the selected Components are positioned at the nearest extent of the leg
closest to the derived position. Feedback is given to indicate that the positions of the items
are not in alignment with the identified feature.

Q | __-J Derived Position |
_\-EI ="

D
= Identified Feature |

Where there is more than one position solution, the system has default behaviour to derive
the initial position (see Feature Highlighting for further details). However, it is possible to
cycle through the possible positions and choose the desired one. The P hotkey is used for
this.
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Subsequent feature identification within the same drag uses the last solution type to derive
the position, where possible. If there is no position solution to the feature selection, the
system reverts to its default behaviour.

Pointer symbaol

ﬁ\ Horizontal Solution

| MMovement Constraint |

L S
N' '“'-“:;?__ -
. Closest Point

Solution

Vertical Solution

Nudging the Handle

Once a drag has been started using the primary or secondary mouse button, you can finely
adjust the positioning of the selected Components using hotkeys. You can ‘nudge’ the
manipulation handle when dragging in a linear direction, using the numeric keypad + and -
keys. This moves the handle by + or - the current linear increment.

In a similar way to nudging a Component you may nudge the position of the handle both by
the default linear increment for major positioning, and by a fine value for accurate
positioning (e.g. clearance from surfaces). To facilitate this a ‘fine nudge’ setting is available,
where the granularity of the movement is less than that of the current linear increments.

Linear increments are controlled from the Set Increments form, see the Outfitting Design
online help for details.

Similar to the nudging using the + and - hotkeys, the fine adjustment uses the arrow keys on
the numeric keypad (or the numeric keypad 2 and 8 keys when Num Lock is ‘off’.

Once a nudge has been performed, then dragging has no effect, but the mouse key must be
kept held down. Nudging restricts the movement within bounds of the leg or segment of leg
that the selected Components are within. Nudging does not take the selected Components
past an inline Component or change in direction.
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6.5.1
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Mudge Direction

Elbow Component —
nudge will not go beyond
this

Inline Component

Rotation Handle

The Rotation Handle allows you to rotate interactively the selected Components about the
centreline of the Pipe that the handle is positioned on.

Dragging

The Rotation Handle (and the graphical selection it is attached to) can be dragged by either
the primary or secondary mouse buttons, and allows a full 360° rotation about the centreline
of the pipe. The legs that the selection can be dragged into are highlighted with a turquoise
line (see above figure).

Dragging the handle with the secondary mouse button is the same as using the primary
mouse button, but presents you with a context-sensitive menu which relates to the direction
and rotation of the handle, see Popup Menus on the Component Modification Handle.
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6.5.4
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Feature Highlighting

Use of Feature Highlighting with the Rotation Handle is similar to using Feature Highlighting
with the Movement Handle, see Feature Highlighting.

When performing a free rotate, if feature highlighting is active but no feature is identified, the
rotation uses the currently defined angular increment value. When a feature is identified, the
handle is aligned in the appropriate manner, dependent on the feature identified. See Popup
Menus on the Component Modification Handle and Hotkeys for details of shortcut menu and
hotkey options available when manipulating the rotation handle.

Nudging the Handle

Once a drag has been started using the primary or secondary mouse button, you can adjust
the derived angular offset using the + and - hotkeys for the rotation handle.

As with moving, if a direction is derived from an alignment with a feature, using the nudge
increments the rotation from the derived direction.

The Rotation Handle can be ‘nudged’ in the same way as the Linear Handle, see Nudging
the Handle.

Repositioning the Handle

The default position of the Rotation Handle is at the origin of the Component initially
selected when defining the selection. Identifying another Component in the selection
repositions the handle to the origin of the identified item.

In some instances you may wish to reposition the handle at a position which does not
correspond to the origin of a Component. You can reposition the handle to the extremities of
the selected Components via a pop-up menu on the movement handle:

Enter Walue. .,

Orienk To Paink. ..
Align with Direction, .

Align with, .

Move Handle Arrive of Selection

Leave of Selection

Cancel
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(Arrive of Selection)

(Leave of Selection)

6.6 Movement and Rotation Characteristics

6.6.1 Movement Handle

You can reposition the selected Components freely along the route of the pipe Branch into
any segment where the Components can fit. All selection and handle movements can be
undone and redone using the Undo/Redo buttons.

The following rules are for where the selected Components can be positioned within a route:

1. There must be enough implied tube for the selected Components to be positioned in.

Length of
selection

i
1

Section of tube
available for
positianing in

Where there is tube adjacent to the selected Components, then the length of the
selected Components and the adjacent tube is taken to be a continuous segment.

2. The tube between two adjacent Components must parallel to the Arrive and Leave
directions of the adjacent Components.
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As the repositioning of Components does not reselect the adjacent Components or
elements, this allows for the instances where the selected Components are included into a
segment of pipe which has a different bore, but which still allows the Components to be

moved.
Yalid section
of route
“alid section Inwalid section
of route of route

By default where there are no obstructions or changes of directions within a line, the
Components being moved will move using the currently defined linear increments.

When an extremity of the selection of Components is coincident with or passes the
approach side of an obstruction or change in direction (i.e. a Bend or Elbow), the leading
extremity of the selection snaps to the approach of the obstruction.

Directign of

Movement Ohstruction

Mot divisible by
linear incremen

Where a selection is snapped to a Component, feedback is given to inform you that this has
taken place.

Where the selection has snapped to an obstruction or change in direction, the movement
will stop until the pointer passes over a valid segment of tube, at which point the selection
moves to the new segment of pipe, or until the pointer movement implies that you want to
drag the selection past the obstruction or change in direction.

The selection will only move past the obstruction or change in direction, where there is
sufficient tube to move the Components and when the mapped position of the pointer is at
least the distance from the origin of the handle to the opposite extremity of the selection.
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Direction pf ' :
Movernent
[y Handle distance

from selection end

Note: in this case the position of the pointer mapped onto the centreline of the tube is the
position of the origin of the handle. When the selection is first dragged, the mapped
position of the pointer is with respect to the handle.

L L

Initial Orag After Snap

Where the selection is moved past the obstruction or change in direction by identifying a
segment of tube, the selection will be moved so that the handle is at the mapped position of
the pointer.
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Initial pointer
position relative to
handle

Handle and paointer
coincident

If the distance between the pointer and the handle is less than the distance from the handle
to the extremity of the selection, the selection is snapped to the exit of the obstruction or
change in direction passed. The pointer retains its relative offset from the handle position.

Direction gf == o
Moverment
Driginal pointer Handle wrt to
position wrt to handle handle pointer
nosition

Where a selection’s movement is impeded by a change in direction, the selection only
moves around the bend when the pointer crosses the tube of the next leg, as illustrated or
where the pointer movement is changed so that it follows the next leg of the pipe.

Pointer movement parallel to the leg the selection is in does not move the selection around
a change in direction.
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ninter
Mowement

. Offsetting the Selection

You can offset the Component selection set along the segment of Pipe it is currently in. You
access the offset options from the popup menu available on the handle, see Popup Menus
on the Component Modification Handle.

Each option presents you with a form which allows you to enter a positive or negative value.
You can also ‘preview’ the specified move before committing the change.

The side of the movement handle at which the pop-up is displayed determines the effect of
a positive or negative offset:

Positive offset is LIP
when requested

from this side of the
handle

Positive offset is
DOV wehen
requested fram this
side of the handle

Offsetting is not allowed where it moves either extremity of the selected Components out of
the current segment of pipe. An appropriate error message is displayed:
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Fermissible extents of offset
adjacent to the selected components

Error E|

The move offset you hawe enteredis
imvalid, The selection waould clash with
pipe compaonents or be placed outside the
pipe.

Feature Highlighting

Feature highlighting allows you to position the handle using other elements within the
model. Feature highlighting is accessed using popup menus or hotkeys, see Popup Menus
on the Component Modification Handle and Hotkeys.

Positions to be snapped to are derived by the intersection of the constrained direction of
movement and planes acting through the identified features. When Feature Highlighting is
active, the movement of the selected Components is constrained to be in the leg the
selection.

The behaviour of Feature Highlighting in GCM is identical to Feature Highlighting in Quick
Pipe Routing.

Rotation Handle

You can rotate the selection using the Rotation Handle about the centreline of the pipe the
handle is positioned on. Rotation Handle manipulation options are available from Rotation
Handle popup menu, see section Popup Menus on the Component Modification Handle.

By default, dragging the handle rotates the handle and selection by the currently defined
angular increments.
Feature Highlighting

Where feature highlighting is active, the derived direction is the same as when using the
Point option (see below) to change the pointer to identify features.
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6.7.1
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Where no feature is identified, the rotation reverts to using the standard rotation using the
currently defined angular increments.

Align with Direction

The rotation handle can be positioned so that it is aligned with an identified linear feature by
using a popup menu option - see section Popup Menus on the Component Modification
Handle.

It is possible to toggle between the initial derived direction of the identified feature and its
opposite derived direction. It is not possible T to select a direction which is parallel to the leg
of the pipe the handle is in.

Orient to Point

It is possible to orientate the Rotation Handle with an identified feature, using the Orient to
Point popup menu option, see section Popup Menus on the Component Modification
Handle.

Explicit Direction

You can set the direction of the rotation handle explicitly. As the handle is constrained in its
rotation about the centreline of the pipe, the given direction may not be possible, therefore
the system tries to resolve the direction so that it is as close to the given direction as
possible.

This option is via an option on the menu available on the handle, see section Popup Menus
on the Component Modification Handle.

A form is displayed which allows you to specify the explicit direction with respect to the
current frame of reference (the World). It is not possible to specify a direction which is
parallel to the leg of the Pipe the handle is in.

Feedback

Movement Handle

There are three types of dimensional feedback that are given when moving a selection
along a pipe route:

1. Distance from handle to origin of both up- and downstream Components.
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Crigin of Campaonent

Crigin of Component

2. Distance from handle to Leave of upstream Component and handle to Arrive of
downstream Component.

8 700.00 from Leave

Toggling between the two feedback options is by use of the D hotkey. By default option
(1) is used.

3. Distance from Branch Head/Tail

% 450.00 from Branch Tail

i

(A drag in the opposite direction would give “from Branch Head” feedback. From

Direction Change feedback is also available if the nearest Elbow/Bend is closer than
the Branch Head/Tail.)
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6.7.2 Rotation Handle

On selection of the Rotation Handle, the current direction of the handle is displayed:

6.8 Popup Menus on the Component Modification
Handle

6.8.1 Movement Handle

. Before A Drag

The following options are available on the Movement Handle before a drag:

Enter Offset, .,
Enter Distance From ®

Align with Feature. ..

Move Handle r
Distance Feedback

Cancel
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Option

Description

Enter Offset...

Displays the Constrained Move form which allows you to
enter an offset from the current handle’s position along the
segment of route the handle is within.

Enter Distance From>

Displays forms allowing you to choose a distance to move
the handle relative to a (context-dependent) point along
the route. See the Outfitting Design online help for further
details.

Align with Feature...

Allows you to use the pointer to identify features with
which to align the selected Component with, along the leg
of the route.

Move Handle

Arrive  of
Selection

Repositions the handle to the start of the selected
Components.

Leave of
Selection

Repositions the handle to the end of the selected
Components.

Distance Feedback

Displays sub-menus allowing you to choose the feedback
given relative to a (context-dependent) point selectable
from a submenu when the selection is moved. See the
Outfitting Design online help for further details.

Cancel

Returns the handle and selection to its original state
before the drag

On Completion of a Drag

The following options are available on the Extend Handle on completion of a drag, when the
secondary mouse button has been used to drag the handle.

Mawve
Cancel
Option Description
Move Leaves the selection and handle at the shown position
Cancel Returns the handle and selection to its original state before the drag

Rotation Handle

Before Drag

The following options are available on the Rotate Handle before a drag:

6:18 12.0



AV=VA

Graphical Model Manipulation Guide

Enter Walue. .,

Orient To Paoint...
Align wikh Direckion, .

Graphical Component Modification

Align with, ..
Move Handle
Cancel
Option Description
Enter Value... Gives a form which allows you to specify an angle through

which to rotate the Rotation Handle.

Orient To Point,,,

Allows you to pick a p-line through a point with which to orient
the Rotation Handle.

Align with Direction...

Allows you to identify features with which the handle is to be
aligned.

Align with...

Displays a form which allows you to align the handle with a
specified direction, or as close as possible to the given
direction, about the axis of the pipe.

Move Handle>

Allows you to move the Rotation Handle origin to the Arrive or
Leave of the current selection,

Cancel

Returns the handle back to its original state before the drag

. On Completion of a Drag

The following options are available on the Rotation Handle on completion of a drag.

Rotake
Zancel
Option Description
Rotate Leaves the extend handle at the shown direction.
Cancel Returns the handle back to its original state before the drag.
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6.9 Hotkeys
The following ‘hotkey’ options are available for Movement Handle manipulation options:
Hotkey Handle Description
Esc All Aborts the current operation in the correct manner.
@ All Cycles through derived directional alignments.
F All and when in Model | Toggle switch for feature highlighting.
Edit mode i'
P Movement Cycles through derived positions when aligning
with feature highlighting.
+ All Increment linear offset or angular rotation by
default increment setting.
- All Decrement linear offset or angular rotation by
default increment setting.
T Movement Increment linear offset from current position by
“fine linear increment” value.
Movement Decrement linear offset from current position by
l “fine linear increment” value.
D All Toggles between the available dimensional

feedback options.
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