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管道建模（Pipework Modelling） 

管道布置通常是任何一个大型项目中最费时的工作，也是产生问题最多的部分。管道

建模在 PDMS 中一直是系统中最强大的功能之一，它最大可能地避免了设计错误的产

生。 
Pipe routing is probably the activity that consumes most time on any large 
project and it is also one, which causes the most problems. Pipe routing in 
PDMS has always been one of the major strengths of the system, as you will 
discover in this module.  

数据库层次(database hierarchy) 

每个管道（PIPE）可以有多个分支（BRANCH），在分支下面才是具体的管件，分支

与管道的不同在于分支只有两个端点，而管道可以有多个端点，这要看它有几个分

支。 
Branch 1

Branch 2

Tee

● ●

●
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分支（Branches） 

分支有两个用途： 
1．定义管道的起点和终点，在 PDMS 中称为 Head 和 Tail。 
2．用分支管理管道上的所有管件。 
当你定义分支的头和尾时，它会在两点之间出现一个虚线。 

Head

Tail

在分支下面的管件位置和顺序决定了管道的铺设。在 PDMS 中，不用添加管道，只须

考虑管件，因为管道是根据管件的等级在两个相邻管件中自动生成的。 

分支的头和尾（ Heads and Tails） 

所有的分支必须有起点和终点，它可以是空间的一点，嘴子的法兰面，三通或者设计

中的其它点。分支的头尾顺序必须是管道的流向。而分支中的管件顺序同样重要，它

决定了管道的准确性。 

●

●

●
●

Nozzle 1

Gasket 1
Flange 1

Elbow 2

Nozzle 2

Flange 2

Gasket 2

Head is at start position of Gasket 1
Tail is at end of Gasket 2

流向

Elbow 1

 

管件的生成 

生成管件都要完成下面的步骤： 
1．从管道等级中选择管件。 
2．定义管件位置。 
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3．指定出口方向。 

等级(Specification) 

管道元件库非常庞大，而一类管道只用到其中一小部分，将这一小部分管件总结出来

就是等级。不同项目的同一等级也不一定相同，这要看材料的采购条件及业主的特殊

要求。 
等级有几个作用： 
1． 控制材料的选用，避免浪费。 
2． 减小管件选择范围。 
3． 减少管件选用的错误。 
在PDMS中用到的元件必须在元件库中定义并且放在等级中。 

练习中用到的管道等级 

A=A1A-TRA=ANSI CLASS 150 CARBON STEEL       用于 150 磅普通碳

钢管道 
B=A3B-TRA=ANSI CLASS 300 CARBON STEEL      用于 300 磅普通碳

钢管道 
C=F1C-TRA=ANSI CLASS 150 STAINLESS STEEL          用于 150 磅不锈钢

管道 

练习中用到的保温等级 

PDMS 提供的保温等级有三种：K(保冷，-200~0 度)， E(保温，20~200 度，固定厚度

30mm), W(保温，19~399 度)。 
W 等级中的内容如下表，温度范围指的是操作温度： 
  TEMP          PBOR0         CATREF   
19.00,99.00    15.00,1000.00  /INS30   
99.00,199.00   15.00,150.00   /INS50   
99.00,199.00   200.00,1000.00 /INS100  
199.00,249.00  15.00,100.00   /INS50   
199.00,249.00  125.00,500.00  /INS100  
199.00,249.00  600.00,1000.00 /INS150  
249.00,299.00  15.00,50.00    /INS50   
249.00,299.00  65.00,300.00   /INS100  
249.00,299.00  350.00,1000.00 /INS150  
299.00,349.00  15.00,40.00    /INS50   
299.00,349.00  50.00,200.00   /INS100  
299.00,349.00  250.00,1000.00 /INS150  
349.00,399.00  15.00,40.00    /INS50   
349.00,399.00  50.00,150.00   /INS100  
349.00,399.00  200.00,1000.00 /INS150 
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练习一：生成 80-B-7 

1． 进入管道设计模块 Design>Pipework。缺省等级选择 A3B-TRA。 
2． 生成管道。Creat>Pipe,输入管道名称 80-B-7,选择管道等级 A3B-TRA 及保温

等级 W。设置管道操作温度与压力。 

 
 

 
3． Apply 后自动生成分支 80-B-7/B1，Branch 会自动继承 Pipe 的等级属性，头和

尾设置为连接模式（Connect）。 
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4． OK 后，开始定义分支的头和尾。头连接到管嘴 E1302A-N2。Apply 后，提示选择

管嘴，用鼠标选择管嘴 E1302A-N2。 

5． 将上面窗口中的 Head 改为 Tail。Apply 后，用鼠标选择管嘴 D1201-N1。完成后

Dismiss 关闭窗口 
6． 生成管件。Creat>Component。 
设置管道铺设方向：Forward 
选择自动连接：Auto Conn 

头,尾连

接模式 
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６．在管件列表中选择 Assemblies。Create 生成组件。 

 
７．选择 Gasket Flange to Head, Apply。选择 Flange Gasket to Tail, Apply。 

显示元件描述 

可以将管件选择窗口中的提示信息显示完整。Setting>Choose Options…，将

Selection Criteria 设置为 All，缺省是 Basic。 
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显示保温 

Settings->Graphics->Representation 

 
 
 

管件的入出口点（Arrive and Leave Points） 

与设备中的基本体相似，管件也有 P-point，它有两个作用： 
1． 定义连接点。 
2． 决定管道介质流过管件的方向，通过管件的两个属性显示，Arrive 和 Leave。 
以下图为例：大小头大的一端是 P1 点，小端是 P2 点。如果管道要增大直径，流向将

从 P2 点 P1 点，这时，管件的 Arrive 属性是 2，Leave 属性是 1。缺省是 Arrive 1，
Leave 2。 
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P1

Z P2

P3Y

X

 

显示管件的入出口点 

Settings->Graphics->Aid CE arrow 

 
 

管道生成原则 

1． 两个管件的出入口方向相对。 
2． 两个管件的出入口在同一轴上。 
3． 管件直径(bore)相等。 
4． 管件连接面相匹配。 
 

数据一致性检查（Data Consistency） 

对应管道的生成原则，数据一致性检查用于检查设计中可能出现的下列错误： 

PL is E

PA is W30N
N

 
 

offset axes N
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Leave Bore

50

Arrive Bore

100  
 

Flange

connection
Screwed

connection
 

 
Utilities->Data Consistency->Check CE 用来检查当前管道，一般来说，通过检查的管

道肯定能正常输出 ISO 图。相关的错误及警告信息见《数据一致性检查》培训文档。

在本次课程中每完成一根管道都应该做一次数据一致性检查，用于练习处理模型错误

的能力。 
建议：在每天结束工作之前半个小时进行数据一致性检查，在确认设计中没有错误后

再保存设计。 

分支(Branch)的属性 

在定义分支头尾的时候，Branch 自动从连接件中提取相关的属性，包括直径，方向，

连接形式，位置等： 

 
H 开头的表示分支头的属性，T 开头的表示分支尾的属性。 
Hposition 基于 Zone 的头位置。 
Tposition 基于 Zone 的尾位置。 
Href 与分支头连接的 Nozzle 的名字。 
Tref 与分支尾连接的 Nozzle 的名字。同时 Branch 的名字也写到两个 Nozzle 的

Cref 属性中。 
Hstu     Branch 中从头开始的第一段管子的等级参考。 
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Branch 的隐含属性 

q tule  管道切管长度 tube length 
q cll  管道中心长度(包含元件)center line length 
 

Tube 的等级 

管子的等级信息存在前一个元件中的 Lstube 属性中。 

 

查询元件参数 

选择元件，Display->Properties，显示元件的基本参数。 
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查询 Tube 属性 

定位在前一个元件上，可以查询到后面 Tube 的属性： 
IL TUBE OF CE 
Q ATT 

练习二：生成 150-B-6 

Auto Connect 连接选项 

 
使新生成的管件在 Member 中总是自动出现在当前元件（CE）的后面，在屏幕中自动

与前一个管件连接。这也跟管道铺设的方向有关。有时在需要反方向铺设

（Backward）时更需要注意这一原则。 

距离选项 

两种区别如图所示。 
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SPOOL

DISTANCE

P0P0

 

Through 定位选项 

Through 使管件朝一个方向移动，在 Piping Component 对话框中管件移动的方向是在

Member 中在它前面的管件的出口（Leave）方向。在 Piping Component 对话框中的

Through 定位选项包括以下几种： 

 
Through ID Cursor：表示当前元件沿着前一个元件的出口方向移动，并且与鼠标指定

的元件对齐。 

管件方向 

管件特殊角度的旋转选择 Orientate>Component>leave。 
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Through 测验题 1 

A 中弯头 Through Next 将生成 B 还是 C？ 
 

 

Through 测验题 2 

A 中弯头 Through Next 将生成 B 还是 C？图中箭头表示前一个元件的出口方

向。 
  A 

     

B 

     

 C 

 
 

Through 原则 

1．方向：Member List 中在 CE 前面的管件的出口（Leave）方向。 
2．位置：通过 Through 移动的元件会定位在前一个元件与参照物的垂直交点上。 

 

A 
 
 
 
 
 

 
流向 

B 
 
 
 
 
 
 

流向 

C 
 
 
 
 
 
 
 

流向 
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练习三：生成 250-B-5 

多分支的定义 

分支的定义需要考虑管道内介质的流向。 

三通的流向 

三通的缺省流向是直通方向，修改它的流向在 Modify>Component>Route。 

元件的连接（Connect） 

元件的连接有两种：Connect to Previous，Connect to Next。Previous 表示在

Member List 导航器中当前元素的前一个，Next 表示当前元素的后一个。在元件生成

对话框（Piping Component）中的 Connect 缺省表示为 Connect to Previous。 
选择 Connect>Component 可以连接到下一个。 

 
或者使用新增的工具 Connect Next: 
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分支在三通处的连接 

避免出现一个三通连两个分支的情况，三通只有一个 Cref 属性，只能连接一个分支。 

管道中的分支 

一个 PIPE 下的所有 BRANCH 都必须有连接关系，否则不能生成轴测图。Isodraft 错
误提示’Not in network’。 

修改 Pipe/Branch 等级 

Pipe：等级的修改会影响以后新生成的 Branch 的等级，Modify->Pipe Specification 可

以修改 Pipe 的等级，但不会更改已建立的 Branch 的等级。 
Branch：等级的修改会影响到 Branch 上的所有元件，Modify->Branch Specification

会提示用户在新的等级中重新选择所有的元件。 

修改 Tube 等级 

定位在前一个元件，Modify->Component->Leave Tube 

 

练习四：生成 200-B-4 

管道斜接的处理 

标准做法：将 Forward 方向需要斜接的弯头中的第一个弯头的出口方向转向下一个元

件。Orientate>Component>leave>Toward Next。再将下一个弯头进行同样

的操作。 

不改变弯头

本身的角度 
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 使用程序：使用工具中的程序自动连接 Tools->Auto Elbow。 

元件的隐含属性（Pseudo-Attribute） 

q dtxr  详细描述 detail text(或者 Dtxs,dtxt) 
q mtxx  材料描述 material text(或者 Mtxy,Mtxz) 
q abor  入口直径 arrive bore 
q lbor  出口直径 leave bore 
q abop  入口管底标高 arrive bop 
q lbop  出口管底标高 leave bop 
q atop  入口管顶标高 arrive top 
q ltop  出口管顶标高 leave top 
q aod  入口端外径 arrive OD 
q lod  出口端外径 leave OD 
q mtcl  元件后管道的中心长度 material center line length 
 

PDMS 定位方法 

 
 
元件可以通过本身的定位点和外轮廓定位，在 Pdms 中对应的选项分别是 
1．Distance：定位点沿某一方向的距离定位。Through 是 Distance 定位方法的特例，

通过参照物移动元件的定位点。 
2．Clearence：外轮廓定位。BOP/TOP 是 Clearence 外轮廓在管道建模中的特例。 
 

PDMS 相对其它设计元素的定位选项 

1. Onto,Under 与选择的参照物外轮廓的垂直上下距离。 
2. Infront,Behind 沿着指定方向与选择的参照物外轮廓的前后距离。 
3. To，Form 与选择的参照物的中心定位距离。 
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定位选项组合方法 

distance(元件中心)   to,from(参照物中心)  
   infront,behind(参照物前后外轮廓) 

clearence(元件外轮廓)  onto,under(参照物上下外轮廓) 
１． 弯头中心与柱子中心定位。  Distance + to/form 
２． 弯头中心与柱子外轮廓定位。  Distance + infront/behind/onto/under 
３． 弯头外轮廓与柱子中心定位。  Clearence + to/form 
４． 弯头外轮廓与柱子外轮廓定位。 Clearence + infront/behind/onto/under 
 

定位选项组合方法示例 

infront,behind 沿着指定方向与选择的元素外轮廓定位 

 
垂直方向的定位 
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元件管底定位 Position>Component>Bop/Top (Infront) 

/BEAM

50

picked with cursor

constrained
centreline

 
 
元件管底定位 Positioning Onto/Under another Item 

/BEAM
picked with cursor

Bottom of Pipe Clearance 50 Onto ID Cursor

Bottom of Pipe Clearance 50 Under ID Cursor

 50

 50

constrained
centreline

 
 
元件管底定位 Positioning Infront/Behind another Item 
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/BEAM
picked with

50

50

constrained
centreline

Bottom of Pipe Clearance 50 Behind ID Cursor

Bottom of Pipe Clearance 50 Infront ID Cursor

 
 
 
 
 
元件管底定位 Position>Component>Clearance (Infront) 
 

/BEAM

50

picked with cursor

constrained
centreline

 
元件外轮廓定位 Position>Component>Clearance (Behind) 
 

/BEAM

50

picked with

constrained
centreline
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元件外轮廓定位 Positioning with Clearance Onto/Under another Item 
 

/BEAM
picked with cursor

Clearance 50 Onto ID Cursor

Clearance 50 Under ID Cursor

50

50

constrained
centreline

 

 
元件外轮廓定位 Positioning with Clearance Infront/Behind another Item 
 

/BEAM
picked with cursor

Clearance 50 Infront ID Cursor

Clearance 50 Behind ID Cursor

50

50

constrained
centreline

 
 

练习五：生成 100-B-8 

法兰阀定位 

用 Assemblies 生成法兰阀门时有四个选项。 
Flanged Valve Set a Distance：需要设置阀门中心到前一个管件中心的距离。 
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Flanged Valve Set To Fitting：阀门的第一个法兰与前一个管件直接连接，没有直管

段。 
Flanged Valve to Head：阀门直接连接到 Branch Head 连接的设备管嘴上。 
Flanged Valve Set To Fitting：阀门直接连接到 Branch Tail 连接的设备管嘴上。 

 
 

Drag 
1．使用 Drag 时必须确认管件在移动方向的前后都有管道(直管段)，将管道想象成为

弹簧，管件是在两端弹簧之间移动。 
2．Drag 的对象一般是： 

1) 阀门。 
2) 一段管道，这时 Drag 拖动的是一个面。 
3) 一个阀门组。 
4) 连接管道的设备管嘴。 
5) 连接管道的设备。 

3．使用技巧： 
1) 如果元件间没有可拉伸的管道，可以先断开连接，Drag 后在恢复连接。 

 

直接连接 

 

断开连接 

 

 Drag 

 

 恢复连接 

 
2) Drag 阀门到指定标高。 
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3) Drag 阀组，见下图。 

 
 

重新选择元件(Re-select) 

 
已经生成的元件可以重新选择，但如果新的元件与原有元件的结构尺寸不一致，则需

要重新进行连接，对法兰阀尤其要注意。 

重新连接 

 

练习六：生成 150-W12-2000 

架空管道 

Branch 的 Head 或 Tail 与其它元件没有连接关系，在生成 Branch 时 Head/Tail 
Setting 选择 Explicit。 
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Branch 的 Head，Tail 连接原则 

Branch 的 Head 或 Tail 可以作为管件看待，它的连接原则与管件之间的连接原则一

样： 
a.  两个管件的出入口方向相对，并且同轴。 
b.  管件直径(bore)相等。 

6) 管件连接面相匹配。 

Branch 没有元件 

管道在作数据一致性检查时会提示 Branch 没有元件，但没有数据的不一致，这种警告

信息不会影响 Iso 图的生成。 
    BRANCH /150-W12-2000/B1 

           C540 THIS BRANCH HAS NO COMPONENTS  
END  
*--* NO DATA INCONSISTENCIES *--*  

练习七：生成 100-C-13 

根据管线表的要求，操作温度超过 500 度管线应加 100mm 高的管托。 

Branch Head(Tail)的直径 

如果 Branch 的 Head 或 Tail 与管嘴或其它管件连接，它们会自动提取直径信息，如果

Head 或 Tail 是空间一点，则要指定它的直径。直径的修改选择菜单

Modify>Branch>explicit。 

弯头的管底/管顶标高定位 

弯头用管底/管顶标高定位 Position>Component>Bop/Top。 
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Branch 空间 Head(Tail)的定位方法 

b) 连接：Connect >Branch>Last Number，将 head (tail)连接到 Branch 最后管件的

出口     上。这样，head(tail)的直径与 Branch 最后管件的直径一样,方向相反。 
c) 定位： 

i. 给定精确坐标。Modify>Branch>explicit。 
ii. 在没有参照物时，直接输入距离。Position>Branch>Distance。 
iii. 在有参照物时，寻找合适的参考点。Position>Branch>Through。 

 

仪表件 

孔板作为仪表件它的孔板位号直接写到 Name 中，法兰选择孔法兰(ORIFice)，孔法兰

有可以连接分支的 P3 点。 

 
生成轴测图时在 Isodraft 的 Option 选项设置中的 Annotation Options 选项需要设置

Instrument Tag=Name 及 Bollean Size=3(半径)。 

 
生成的 Iso 图如下图： 
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材料控制 

仪表件材料一般不出现在 ISO 图中，在 Pdms 中材料可以通过元件的属性控制。对于

管件，由其 MTOC 属性控制。对于管道(Tube)，由其所属的管件的 MTOT 控制。对于

分支(Branch)中的第一段管道，则由 Branch 的 MTOH 属性控制： 
1) ON：缺省值，正常开料。 
2) OFF：在单管图 Material List 上将不显示材料，在单管图上仪表符号正常显

示（实线带尺寸标注）。 
3) DOTD：在单管图 Material List 上将不显示材料，在单管图上仪表符号显示

为虚线带尺寸标注。 
4) DOTU：在单管图 Material List 上将不显示材料，在单管图上仪表符号显示

为虚线不带尺寸标注。 

材料控制宏程序 

如果所有 INST 和 PCOM 都不需要在 ISO 图中显示材料，则可以用下面宏程序在

Design 中对所有管道进行处理： 

Var !CompColl Coll all INST PCOM 
 Do !I values !CompColl 
   $!I 
   MTOC OFF 
Enddo 

Branch 的修改方法 

1. Connect>Branch，头尾的连接。 
2. Modify>Branch>Explicity，头尾的精确定位。 
3. Position>Branch，头尾的参考定位。 
4. Modify->Hierarchy->Reverse Order，头尾的转换。 

 

Branch Head(Tail)没有参考连接 

管道在作数据一致性检查时会提示 Branch Tail 没有参考连接，这种警告信息不会影响

Iso 图的生成。 
PIPE /100-C-13 
BRANCH /100-C-13/B1 
                   B 10 TAIL  REFERENCE NOT SET  
END  
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练习八：150-B-57 

因为泵管嘴压力为 300 磅，所以管道等级需要选择 A3B-TRA。 

拷贝分支 

１． 对称的分支可以拷贝生成，但头尾需要重新连接。 
２． 拷贝的偏移距离直接获取。 

 

假三通（Set On Tee） 

管道上的开口焊在 PDMS 中使用 Set On Tee 处理，它以三通的形式出现，但是在主

管道上没有长度，在 Isodraft 材料单中也不出现。分支角度可以用 Angle 属性控制。 

排凝与放空 

如果需要在 Iso 图中表示螺纹连接放空或者排凝，将管道的 Head/Tail 的连接方式改为

SCRD，VENT 或者 DRAN，如：  
   Tconn DRAN 
出图效果如下图： 
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Branch Head(Tail) 连接形式不匹配 

排凝放空管道在作数据一致性检查时不会提示 Branch Tail 没有参考连接，但会提示最

后一个元件与 Tail(Head)连接形式不匹配，这种警告信息不会影响 Iso 图的生成。 
    BRANCH /150-B-57/B1 

VALVE 2 =15392/13900 
       E730 LEAVE CONNECTION TYPE NOT COMPATIBLE WITH TCONN  
 END  

Position 菜单选项 

Position 菜单上部分是通用的定位方法，下部分是专门针对管道的。尤其是

Component 选项中包含隐含方向，即前一个元件的出口方向。 

 
 

练习九：生成 100-C-12 

仪表调节阀 

在 Pdms 中调节阀有三种做法： 
1. 所有尺寸完整的，与一般的阀门一样。 
2. 阀门长度固定，膜头高度和膜头直径可调整的。Creat 后需要修改属性(Modify 

Attribute)才能显示出来，Height 是阀芯到执行机构的高度，Radius 是膜头的半

径。 
3. 阀门长度，膜头高度和膜头直径都是可调整的，Modify->Properties… 
在等级 F1C-TRA 中使用的是第二种。 

保温伴热等级修改 

选择 Tool->Modify Pipe->Add Insulation…可以设置 Pipe 的保温等级，伴热等级和管

道级别。 
1． 必须保证保温等级和伴热等级与管道等级在同一个 SpecWorld 下。 
2． 操作温度和操作压力写到：OpeTemp 和：OpePres 用户自定义属性中，如果没有

自定义属性，程序自动跳过。 
3． 管道级别写到 Inschedule 属性中。 
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Plane Through 

  A 

     

Through 

     

 Plane through 

 
倾斜管道的连接要用到 Plane Through 方法。通过法线确定一个平面(Plane)，移动的

元件可以以任意角度延伸到这个平面上。 
 

三通分支点的方向对齐 

这种方法不能用于有坡度的管道。 
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管道附件 Attachment 

Attachment Point 有三个主要用途，主要是针对 ISODRAFT 的： 
1. 强制分图 
2. 指明支吊架的位置和型号。 
3. 指明管道上的一个特殊点，并且可以标注或注释。 
具体的应用是通过设置 Attachment 的 ATTYPE 属性实现的： 
1. 设置 ATTY  XXXX 

在 ISODRAFT 中将管道在该点强制分成两张图。 
2. 设置 ATTY CCCC 

在 ISODRAFT 中加入注释信息，该点被标注。注释写在 Stext 属性中。 
3. 设置 ATTY CCNN  

在 ISODRAFT 中加入注释信息，该点不标注。注释写在 Stext 属性中。 
4. 设置 ATTY FLOW  

在 ISODRAFT 中生成流向箭头，这种方法很少使用，一般用自动流向箭头。 

 
5. Skey 是 FLOR 或者 PENI 的 Attachment 在 ISODRAFT 中显示穿墙符号。 
6. 设置 ATTY HANG 或者 SUPP。 

穿平台／墙符号 

管道专业生成 Attachment(Skey 是 FLOR)，与平台对齐(Through)。结构专业进入

ASL 模块，Creat->Floor Penetration 生成平台穿孔，但只能针对 ASL 模块生成的平

台。 

 
 

逻辑支吊架 

生成 Attachment，设置 ATTY HANG 或者 SUPP，支吊架型号写在 Stext 属性中。在

ISODRAFT 中标出管道支架型号，需要设置 Option 文件。  

 

右键弹出
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坡管 Slope  

自动坡管 

在管道铺设完成后再进行自动坡管，Modify->Slope。设置坡度，然后根据提示选择从

分支的 head 逐个弯头设置坡度。 

手动设置管道坡度 

1. 选择弯头设置坡度，Orientate>Component>Slope。 

 
2. 选择下一个弯头，Position>Component>Plane through 沿着坡度方向重新定位。 

 
３．修改当前弯头的入口角度，Orientate>Component>Leave。 

 

Plane 法
线方向 
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分段坡管 

 

煨弯管 Bend 

煨弯管 

插入 bend，修改 radius 属性，然后重新 Connect。 

零长度弯管 Zero-length Bend 

零长度弯管主要用于填充有坡度管道上的三通与分支管道连接处的缝隙。在生成 Iso
图前应修改 Isodraft 选项中的 Dimension Option，关掉(off)zero length skews on 
falling lines。 

 
 

 

 
  

参考标注 Reference Dimensions 

如果在 Design 中设置了参考标注，在 Isodraft 中可以显示出来。定义参考标注

需要两个步骤： 
1. 选择参照物(reference datum)。 
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2. 设置管道上需要标注的点。 

选择参照物(reference datum) 

作为参照物的实体必须有Origin(原点)和SKEY 属性,或者上一级有SKEY属性。  
可以作参照物的实体有： 
1. Datums; 
2. Equipment; 
3. Equipment中的基本体; 
4. Sections; 
5. Piping components; 
6. Point elements, if they have a parent with an SKEY attribute. 
 
不同的参照物（SKEY Type） 在Isodraft中会出现不同的标注信息 
SKEY           参照物                                    ATEXT       标注信息 
HST*                 Horizontal steelwork element           460            BEAM $? 
VST*                 Vertical steelworkelement                461            COLUMN $? 
BLD*                Building                                             462            ? $BUILDING CL 
EQU*                Equipment item                                 463            CL EQUIPMENT $? 
PIP*                  Piping component                              464            CL PIPELINE $? 
FLR*                Floor level                                          465            ? $FLOOR LEVEL 
WAL*              Wall                                                    466            ? $WALL 
GRD*              Grid line                                              467            GRID LINE $? 
XXX*              Miscellaneous                                     468            ? 
*可以是任意一个字符，标注信息中的？表示元件名字。 

设置参考标注 

1．对于管道元件(Piping Components)和ATTAs 
DMTY NORT EAST 
DMFA /F-6 /F-6 

 
DMTYPE 用于确认参考标注的方向，它可以是下面中的一个或两个： 
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1) EAST 
2) NORT 
3) ELEV  
4) POS for a 3D dimension 
DMFARRAY 是一个数组类型的属性，设置参照物的名字。 
注意：强制分图和流向箭头的ATTA不能用于参考标注。 
2．Branch Heads 和Tails 
使用的属性是：HDMTYPE 和HDMFARRAY  

显示参考标注 

在生成 Iso 图前应修改 Isodraft 选项中的 Dimension Option，选中 Reference 
dimension。 

 

Inter-DB Macro 

在不同的数据库中进行连接会生成交叉数据库宏。如下图，管道连接到管嘴时有两个

过程： 
1. PIPEN 中的管道起点连在 PIPES 中的设备管嘴上，会获得管嘴的直径和连接形

式，并且将管嘴的名字写在 Cref 属性中。 
2. 同时，PDMS 也要在设备管嘴中的 CREF 属性中写入管道信息。 
 

 
3．但 PIPEN 对 PIPES 的设计数据库没有写的权利，这时会自动生成交叉数据库宏，

把向 CREF 赋值的过程写到宏文件中，让 PIPES 用户自己执行宏程序，写入相关属

性。 

AutoRun Inter-DB Macro 
Tools->InterDB Macro 程序只显示当前用户所需要运行的所有交叉数据库宏。 
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按 AutoRun Macro 后，在 Command Line 会有提示，如果有错误将不执行相应语句。

例如：没有找到名字，位置已经改变，头尾连接错误等。 

 

Delete Inter-DB macro 
运行所有 InterDB Macro 后，进入 Monitor，选择 Project->Inter-db Macros… 
删除所有执行过的 Inter-DB Macro。 

 
注意：禁止在操作系统中直接删除 Inter-db Macro。 
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跳等级(Spec break) 

Spec break 有两级(level)： 
1. 基于 Branch，只显示 Branch 之间的等级变化。 
2. 基于 Component，显示 Branch 之间和 Component 之间的等级变化。 
见 Isodraft 选项中的 Sheet layout Option 

 
 
练习八：生成 100-B-1 
练习九：生成 80-B-14 
练习十：生成 80-A-11 
练习十一：生成 100-B-2 
练习十二：生成 150-A-3 
练习十三：生成 50-B-9 
练习十四：生成 40-B-10 
 
 


