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1 Introduction

This document is intended for System Administrators responsible for setting up defaults and
the Libraries used by the Outfitting Draft application.

It is assumed that you are already familiar with using Outfitting Draft to produce annotated
drawings, and that you have attended an Outfitting Draft Administration Training course. For
information about training courses, see AVEVA’s worldwide sales and support offices, see
the Customer Support pages on our website at http://www.aveva.com/.

For more information about using Outfitting Draft, see the Outfitting Draft User Guide and
Drawing Production User Guide.

You must be a member of the Outfitting Draft ADMIN team in order to see the Administration
options on the Outfitting Draft menus. See Setting Up Administrative Access Rights.

1.1 How the Guide is Organised
The remainder of this guide is made up of the following:

• Some General Principles explains some principles which you need to understand
before you try to use the Outfitting Draft Administrator functions.

• Setting the Outfitting Draft Defaults explains how to control the default settings which
affect the way Outfitting Draft’s applications appear to other users.

• Selecting the Working Library tells you how to select the library you wish to work on.
• Sheet Library Administration tells you how to configure a Sheet Library, giving users

access to standard backing sheets and/or overlay sheets.
• Symbol Library Administration tells you how to configure a Symbol Library, from which

users can choose 2D symbols to add to their drawings.
• 2D Symbolic Representation Administration explains how to set up 2D symbolic

representation.
• ISODRAFT Symbol Library Administration tells you how to configure an ISODRAFT

Symbol Library, where you can create symbols for use in ISODRAFT.
• Label Library Administration tells you how to configure a Label Library, from which

users can choose symbolic and general labels.
• Style Library Administration tells you how to configure a Style Library (within the

Representation Library), which controls the appearance of various aspects of the
drawing (such as which parts of the model are drawn, and which pens are used for
which types of line).

• Representation Library Administration explains how to define Representation Rule
Sets (within the Representation Library), which reference particular Styles. These can
be used to link drawing styles to specific types of element within the Outfitting Design
DB if required.
12.01:1
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• Drawlist Library Administration tells you how to configure a Drawlist Library, which
holds ID lists to control which elements are drawn.

• Tag Rule Library Administration explains how to set up the rules for automatic tagging
of items in drawings

• ADP Administration tells you how to set up defaults for Automatic Drawing Production.
• AutoDRAFT Administration tells you how to edit symbols and sheet frames for use

within AutoDRAFT.
• Loading Data Files tells you how to use data files to create new projects.
• Updating the Database describes a special item on the Graphics menu which allows

you to update parts of the Outfitting Draft DB explicitly, to correct inconsistencies which
may arise due to operations in other modules such as reconfiguration.

• Administrator Menus shows, in a quick-reference format, the administration parts of the
Outfitting Draft menu hierarchy.

• Database Hierarchy shows that part of the Outfitting Draft (PADD) database hierarchy
which is most relevant to the Outfitting Draft administrator, namely the LIBY and its
members. The full hierarchy is shown in the Outfitting Draft User Guide.

• Libraries shows the Library Hierarchy supplied with Outfitting Draft.
12.01:2
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2 Some General Principles

This chapter explains some general principles, which you need to understand before you try
to carry out any administrative functions in Outfitting Draft. It explains:

• Which aspects of Outfitting Draft are under the control of the administrator.
• What access rights you must have in the Project in order to be able to act as an

Outfitting Draft administrator, and how to set these up.

2.1 Role of the Outfitting Draft Administrator
The Outfitting Draft Administrator applications enable you to configure the Outfitting Draft
environment to suit specific company and/or project requirements in the following areas.

Default Settings

The Outfitting Draft defaults system allows you to define the following:
• Library pointers
• Layer settings
• Sheet sizes
• Naming conventions
• User-definable styles and colours
• Name string delimiters

The ways in which you set these up are explained in Setting the Outfitting Draft Defaults.

Libraries

As Outfitting Draft administrator, you are responsible for setting up the standard libraries that
other users will reference during drawing production. You can create new libraries, or edit
the content of existing libraries, so that the standard data available to individual Outfitting
Draft users complies with the company requirements for their particular drafting functions.
The following types of library are controlled in this way:

• Sheet libraries
• Symbol libraries
• ISODRAFT Symbol libraries
• Label libraries
• Style libraries
• Representation rules libraries
• Drawlist libraries
• Auto Tagging rule libraries
12.02:1
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The ways in which you set these up are explained in subsequent chapters.

Automatic Drawing Production

The Outfitting Draft Administration options allow you to set up defaults and define rules that
control how drawings are automatically produced and annotated. These functions are
explained in ADP Administration.

AutoDRAFT Symbols and Sheet Frames

The Outfitting Draft Administration options allow you to edit symbols and sheet frames for
use with AutoDRAFT. You can also import symbols and sheet frames from AutoCAD work
directories and macros. These functions are explained in AutoDRAFT Administration

Creating Projects

The Settings > Load data file option allows you to create new project areas using existing
data files. This is explained fully in Loading Data Files.

Database Updating

Occasionally all or part of the Outfitting Draft (PADD) database (DB) may need to be
updated to allow for changes made outside the normal Outfitting Draft operations; typically
when a project has been reconfigured or the Outfitting Design DB has been rebuilt from
macros. Updating the Outfitting Draft database is explained in Updating the Database.

2.2 Setting Up Administrative Access Rights
In order to use the Administrator options on the Outfitting Draft menus, you must enter
Marine as a User who is a member of the Outfitting Draft ADMIN team, and you must have
Read/Write access to the Outfitting Draft database that holds the libraries. The System
Administrator should ensure that projects are set up in this way.

2.3 Supplied Libraries
The Sample Project supplied with the product contains two Departments, Master_Libraries
and Project_Libraries. These Departments contain Libraries that contain sample sheets,
symbols, and rulesets for tagging, representation etc. The contents of the sample Libraries
are summarised in Libraries.

2.4 Searching Libraries
When an Outfitting Draft application user attempts to create a new element, for example, a
symbolic label, the application searches for relevant Libraries in a specific sequence. It
looks at each LIBY in the DEPT in the listed order until it finds one that contains appropriate
type of Library. It then adds this LIBY and all subsequent LIBYs to the scrollable list on the
Library form until it finds a LIBY which does not contain a relevant LALB. No further
searching is carried out.

This principle allows you, as the Administrator, to hide LIBYs from the user by adding them
to the end of the DEPT’s members list. (You could, alternatively, store all reference LIBYs in
a separate DEPT, but this would add extra DEPTs to the user’s Members List.)
12.02:2
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It is important to note that, due to this method of searching for the LIBYs, different types of
Libraries must be grouped together under the same Department if they are all to be
available to the user. 

2.5 Outfitting Draft Default Files
The following is a summary of the default files supplied with the product. The files
themselves contain additional information. The files are stored in the PDMSDFLTS folder.

General Default Files

Name Description

DRA-GEN-SYSTEM System defaults file

DRA-GEN-SYSTEM.IMP System defaults file with imperial settings

DRA-GEN-SYSTEM.bak System defaults file back-up copy

DRA-SETUP User configurable setup file

DRA-GEN-FONTS Font names file: four font names can be defined

DRA-GEN-TEXT Sample intelligent texts displayed to user from dynamic text
forms

DRA-GEN-CLASHTEMP Clash plotting macro template

DRA-GEN-DEFLAY Layer setup macro: standard default

DRA-GEN-DIMLAY Layer setup macro: dimension layers

DRA-GEN-HLDLAY Layer setup macro: Hangers & Supports layers

DRA-GEN-LABLAY Layer setup macro: label layers

DRA-GEN-MATLAY Layer setup macro: matchline layers

DRA-GEN-NLLLAY Layer setup macro: label layers with no leader lines

DRA-GEN-NOTLAY Layer setup macro: note layers

DRA-GEN-PLTEXT Projection-line text options

DRA-GEN-RADLAY Layer setup macro: radial dimension layers

DRA-GEN-SYMLAY Layer setup macro: symbol layers (2D SYMB)

DRA-GEN-TAGLAY Layer setup macro: tagging layers (layers with reserved
purpose TAG)
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ADP Default Files

Hangers & Support Default Files

Name Description

DRA-GENADP-
EQUILOCN

General ADP defaults file for equipment location plans

DRA-GENADP-PIPING General ADP defaults file for piping plan and elevation GAs

DRA-GENADP-
PLOTPLAN

General ADP defaults file for plot plans

DRA-GENADP-
SUPPORTS

General ADP defaults file for H&S drawings

DRA-ADP-BRANINLAY Layer setup macro for ADP branch labels

DRA-ADP-DIM1LAY Layer setup macro for ADP Type 1 dimensions

DRA-ADP-DIM2LAY Layer setup macro for ADP Type 2 dimensions

DRA-ADP-DIM3LAY Layer setup macro for ADP Type 3 dimensions

DRA-ADP-EQUICLLAY Layer setup macro for ADP equipment centrelines

DRA-ADP-PESYMBLAY Layer setup macro for ADP pipe end symbols

DRA-ADP-SCHEDLAY Layer setup macro for ADP schedules

DRA-ADP-SCHEDSUPP Layer setup macro for ADP Hanger and Support schedules

DRA-ADP-TAGLAY Layer setup macro for ADP Tagging

DRA-ADP-
DIM3LEFTATTS

Dimension setup macro for ADP TYPE 3 dimensions LEFT
side of view

DRA-ADP-DIM3UPATTS Dimension setup macro for ADP TYPE 3 dimensions UP
side of view

DRA-SDADP-MACRO Macro file for setting defaults for Steelwork Detailing ADP.

Name Description

DRA-SUPP Main H&S defaults

DRA-SUPP-HADLAY Layer setup macro for hanger dimension layers

DRA-SUPP-HSMLAY Layer setup macro for hanger material list layers

DRA-SUPP-SIBLAY Layer setup macro for supported item BOM layers

DRA-SUPP-STBLAY Layer setup macro for steelwork BOM layers
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Detail View Default Files

Radial Dimension Default Files

Miscellaneous Default Files

Name Description

DRA-LOC-LAYER Detail layer setup macro for master view

DRA-LOC-NOTE Default detail view note intelligent text for master view

DRA-LOC-NOTE-
EXAMPLES

Examples of alternative detail view note intelligent texts for
master view

DRA-DET-LAYER Detail layer setup macro for new detail view

DRA-DET-NOTE Default detail view note intelligent text for new detail view

DRA-DET-NOTE-
EXAMPLES

Examples of alternative detail view note intelligent texts for
new detail view

Name Description

DRA-DIM-PDIM PDIM setup macro, this macro is executed each time a PDIM
is created

DRA-DIM-RDIM RDIM setup macro, this macro is executed each time a RDIM
is created

Name Description

DRA-AUTONAME File required for successful appware loading (for future use)
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3 Setting the Outfitting Draft Defaults

This chapter tells you how to define the default settings that will be used in the Outfitting
Draft applications.

When you enter Outfitting Draft and load the forms and menus interface, the macro
%PDMSUI%/DRA/ADMIN/START calls the user-defined setup macro %PDMSDFLTS%/
DRA-SETUP DRAFT which, among other actions, points to the location of the main
Outfitting Draft defaults file, DRA-GEN-SYSTEM. The environment variable PDMSDFLTS
is set to the folder where the defaults file is stored. Remember, if you wish to change the
start up operation, that you should only modify DRA-SETUP, not the AVEVA-defined START
or VARS files.

As an Outfitting Draft administrator, you can change the settings in the defaults files, if
necessary creating a different defaults file for each of the company’s drafting requirements.
The defaults file accessed by an individual user is determined by the setting of the user's
PDMSDFLTS environment variable. 

Defaults can be set for the following:
• Definitions of layers for use with views; defined in terms of their purpose and

associated attribute groups.
• Definitions of name delimiters; that is, the characters used to separate the component

parts of an element’s name.
• Pointers to the libraries from which the different aspects of Outfitting Draft’s drawing

functions obtain their standard data, for example:
• 2D symbols and labels
• Backing sheets and overlay sheets
• Global representation rules and local styles
• Circulation lists
• Drawlists
• Tag rules and tag templates
• DRWG and SHEE templates

3.1 Setting the System Defaults
The Outfitting Draft System Defaults form will be displayed when you select Settings >
System Defaults from any of the Outfitting Draft Administration main menus. To access the
administration functions, select Draft > Administration.
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The File gadget at the top of the body of the form shows the current defaults file. 

The Master Project Defaults and Local Project Defaults sections of the form show the
default settings of the pointers to the Outfitting Draft Libraries. If you want to change any of
these, either type the new element name into the text box, or navigate to the element
required and press the appropriate CE button. The text to the right of the CE button shows
the type of element required for each Library.

Note: The library reference defaults are also shown on a User Defaults form that is
accessed by selecting Options > Defaults from the main application menu. The
User Defaults form is initialised with the settings from the Draft Defaults form after the
defaults have been loaded from file. Subsequent changes made on the User
Defaults form override (but do not change) the settings on the Draft Defaults form,
allowing a user some flexibility in the use of available libraries during drawing
production.
12.03:2



Outfitting Draft Administrator Application User Guide

Setting the Outfitting Draft Defaults
Name delimiters. By default, the individual parts of drawing element names are separated
by a slash delimiting character. For example:

SHEETS/SHLB1/BACK1/SN1

This option allows you to specify any other delimiter character which has been used for
Style names, Label Library names and Drawlist Library names.

The Further Defaults options are as follows:
• Layer Purpose Definitions.
• Layer Creation Definitions.
• Layer Purpose Filtering.
• Sheet Size Defaults.
• Defining Element Naming Conventions

The options under File on the menu at the top of the form are described in Saving and
Loading Default Values.

3.2 Saving and Loading Default Values
Saving Default Files

As supplied, the Outfitting Draft applications reference a defaults file named DRA-GEN-
SYSTEM that is set up to reference the AVEVA library database. 

When you have modified the defaults forms to suit your own requirements, you can save the
updated settings to a file in the usual way; that is, either by updating the current file or by
specifying a new file name. To do so, use the File > Save or File > Save As option,
respectively, from the menu on the Draft System Defaults form.

Loading Default Files

You can load default settings from a file, which may be either the current Outfitting Draft
defaults file or a different named file. To do so, use the File > Load or File > Load From
option, respectively, from the menu on the Draft System Defaults form.

In each case, you can perform either a Full load or a Partial load by selecting the relevant
option from the submenu. The difference is as follows:

• Full loading of defaults:
• Clears all existing default values from the forms before loading the new ones.
• Checks that the minimum number of default values are loaded to allow the

application to run correctly. This involves checking that all layer purposes are
defined, that naming conventions are specified, and that sheet sizes are set. If any
of these settings are not loaded from the specified file, the standard AVEVA values
are loaded so that the application can still function.

• Partial loading of defaults:
• Does not clear existing form settings, allowing you to overwrite a subset of the total

defaults available (which speeds up the process if only a few values are to be
updated).
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• Does not check the overall consistency of the loaded defaults (so a little care is
needed to avoid problems).

Both full and partial loading modes keep a log of any errors that occur during loading and
display these when loading has been completed. Each error message shows the load file
line number at which the error occurred and a brief description of the error. To list the stored
loading errors at any time, select File > Display Errors from the menu on the Draft System
Defaults form.

Restoring Defaults from a Backup File

Each time you save an updated defaults file the current defaults settings are saved in a
backup file named DRA-GEN-SYSTEM.bak. To reload the previous default settings from the
backup file, select File > Restore Backup from the menu on the Draft System Defaults
form.

3.3 Layer Purpose Definitions
The Layer Purpose Definitions form is displayed when you select the Layer Purpose
Definitions button on the Draft System Defaults form.

The scrollable list shows all currently defined layer defaults. The highlighted layer is the one
that will be updated by any new settings that you enter.

All layers have a PURP attribute which is set to a four character keyword which identifies the
purpose for which that layer is intended to be used. Layer purposes cannot be duplicated
under any one owning View. The Layer Purpose box on the form allows you to specify the
purpose as a three-character string (the fourth character is added automatically when
setting PURP so that multiple layers of a given type can be created under a single View).
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For example, if you have defined a layer with its purpose defined as DIM and a user decides
to have three dimension layers in each View for, say, steelwork (STLDIM), equipment
(EQUDIM) and piping (PIPDIM), then the View contents might be as follows:

where the fourth character of the PURP (A, B or C) distinguishes the individual DIM layers.

Note: The purpose keyword TAG is reserved for autotagging layers. This is a requirement
of the application (see Chapter 14) and must always be defined in the layer defaults.
If it is omitted, a TAG layer purpose definition will be appended automatically during
default initialisation. The TAG layer purpose definition cannot be deleted.

The Setup File box is used to specify the macro file that will be executed to set the layer
attributes after a layer has been created. Default macro files are supplied with the product.
For example, DRA-GEN-DEFLAY defines the default attribute values for layers. This
ensures that all users create layer annotation to a common standard. 

You can copy and modify these macro files to meet your company and/or project standards.
You can also create new files for other purpose types of your own definition.

The Attribute Group check boxes (Dim, Note, Text, Lab and Symb) allow you to specify
which attribute types will be displayed on the Layer Attributes form. The combination which
applies to each of the currently defined layers is shown by the + (selected) and -
(unselected) codes in the scrollable list. To change these, turn the attributes on and off as
required and then click the Apply button.

3.4 Layer Creation Definitions
The Layer Creation Definitions form is displayed when you select the Layer Creation
Definitions button on the Draft System Defaults form. This form allows you to define what
layers are created, and how they are named, when a View is created. 

Element Type Name PURP

VIEW XYZ0001/S1/V1   n/a

LAYE XYZ0001/S1/V1/STLDIM DIMA

LAYE XYZ0001/S1/V1/EQUDIM DIMB

LAYE XYZ0001/S1/V1/PIPDIM DIMC
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Select the Purpose from the scrolling list, and change the Purpose and suffix as required.

Note that you can create many layers with the same Purpose.

3.5 Layer Purpose Filtering
The Layer Purpose Filtering form is displayed when you select the Layer Purpose Filtering
button on the Draft System Defaults form.

This form defines what Layers are visible in the Layer Note drop-down list on the
appropriate application menu bar.

3.6 Sheet Size Defaults
The Sheet Defaults form is displayed when you select the Sheet Sizes button on the Draft
System Defaults form.

This form allows you to define the dimensions and a reference description for up to 15
standard sheet sizes:
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3.7 Defining Element Naming Conventions
The Name Convention form is displayed when you select the Naming Conventions button
on the Draft System Defaults form.
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The form is divided into two parts: 
• MANDATORY NAMES, that is names for the elements which must be named in order

for the application to function correctly: DEPT, REGI, DRWG, SHEE and VIEW. For
example, drawing numbers typically have a common project related prefix, which you
should enter, in the Prefix box for the Drawing element.

• OPTIONAL NAMES for the elements which do not need to be named for the
application to function: VNOT, NOTE, RRUL and VSEC. For these elements, use the
Named check box button to specify whether or not automatic naming is required.

3.8 Setting Plotting Options
Outfitting Draft allows you to plot files in a variety of formats. As an Administrator you can
enter or select operating system command strings that enable users to plot their files in a
variety of formats. 

To select or enter output formats, select Settings > Plotting Defaults from the main
Outfitting Draft Administration menu. The Plotting Options form will appear.

This form contains predefined command strings for PostScript and HPGL format conversion
and printing. For PostScript and HPGL options, make sure that you provide a proper
Windows network path to the chosen printer

The System command string has several components to it. 

Example: plotcadc FILE ps \printserver\psprint01 

plotcadc This is the name of the batch file PLOTCADC.BAT and uses the
parameters supplied in the rest of the system command string to
specify the printing or other actions to be performed. This batch
file uses the Plot Utility Program to perform the plot file
conversions and the Windows print command to send them to a
printer. This batch file is run when either of the Plot + File or Plot
options are applied in the form shown after using the Utilities >
Plot CE command.
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Please note that the Plot Viewer program does not print at a true 100% scale, and therefore
your print will be slightly smaller. 

An example of the modified form showing the PlotViewer entry is shown below. 

Also available under the Windows O/S, it is possible to plot to any printer using the Screen
pre-viewer:

plotcadc FILE screen -0 

Here, the Plot program is executed with the Screen argument. A pre-viewer form is shown
which enable you to zoom in and out of the plot file. To send the plot file to a printer, press

FILE A plot file is created when a drawing sheet is to be output. When
the system command string is executed, the location of this file
plot file replaces the word ‘FILE’. 

ps This results in a conversion from the Outfitting plot file format to a
form compatible with a postscript plotter. This file type for the
plotter corresponds to a Plot Utility Program driver name; see the
PLOT User Guide for more details. Typical examples are: ps and
hpgl.

\printserver\psprint01 This is an example Windows network name of the destination
printer. 

Under the Windows O/S it is possible to set the System command string to direct the plot
file directly to the default printer. This is made possible by utilising the AVEVA product
called ‘Plot Viewer’:

PlotViewer /p FILE Here, instead of the Plot program, the Plot Viewer program is
executed with the following arguments:

/p runs Plot Viewer in plot-only mode and hence sends the
plot file directly to the default printer. 

FILE this word will be replaced by the plot file name 
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the button sequence Cntrl-P and the standard Windows print form will be displayed,
allowing you to choose any printer as the destination. 

For more information on the subject of the Plot executable see the manual PLOT User
Guide. 

Once you have set all of the plotting options, select the one you require to be set as the
default by clicking on the appropriate option button at the left of the form then press OK. 

The Save button will save the settings, which can be recalled by clicking the Load button.
The Load Defaults button will load the predefined plotting settings. 

The Reset button cancels any changes made to the form since it was opened.

PRINT Option

This option instructs the system to use the standard Windows printing dialog for printing the
selected sheet, as shown below:

This would send the picture directly to the printer without creating an intermediate plot file.

Other Documents

This option instructs the system to create a graphical file or a PDF file representing the
given picture instead of printing it. The available output formats are shown below:
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The plotting options form supports previewing the output instead of printing. Clicking the
Configure viewers button displays a form where a command string can be entered for each
file type that will launch an appropriate viewer.

Other Plotting Options

To set the minimum line width to be used when plotting, enter a value (in mm) in the
Minimum pen line width text box.

The output colour can be controlled by selecting one of the Colour correction mode options:

Click on the Save button to save the changes.

Standard retains the colours as defined in the database

Black & White changes all colours to black or white to contrast with the
background colour

Grayscale converts all colours to an equivalent shade of grey

Colour Plus converts all shades of grey to black or white to contrast with the
background colour
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The viewing of the PDF files is handled internally by launching the Acrobat Reader
application, which must be installed on the workstation. There are no configuration options
for the PDF files.

For all other supported file types it is possible to specify the command to be executed in
order to view a particular file. If you leave the command field empty, or containing the text
'Not specified – default Windows action used', the handling of the particular file type will be
determined by Windows operating system. The action taken will be exactly the same as if
you double clicked on the file in Windows Explorer.

If a non-default action is required, the proper command line must be provided, using the
word FILE to represent the full file path of the file to be shown.

For example in order to view BMP files in Microsoft Paint, the following command should be
entered in the BMP files (*.bmp) field:

mspaint "FILE"

To view the JPG files in Irfanview (provided that it is installed in C:\Program Files\Irfanview),
the following command should be entered in the JPG files (*.jpg) field:

"C:\Program Files\Irfanview\iview32.exe" "FILE" /fs 

Note: After changing the viewers' configuration remember to save the plotting options in
the main form, as the viewers' settings are stored together with the plotting options.

3.9 ADP Administration
You set the defaults for Automatic Drawing Production from within the Auto Drawing
Application. However, the Backing Sheets used for ADP Drawings must be created by the
Outfitting Draft Administrator. See ADP Administration for details.
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4 Selecting the Working Library

When you enter one of the Outfitting Draft Administration applications, you will be prompted
to select a working library.

Select Draft > Select Working Library. You will see the Library Selection form.

The Type list allows you to select the type of library you wish to select (Sheet, Symbol,
ISODRAFT Symbol or Label). After you have selected a Type, you can scroll through the
Main Library list until you find the main LIBY that holds the library you want to work with.

After you have chosen a Main Library, all the libraries of the selected type held in the library
will be displayed in the Type list on the right of the form. You can select the library you want
from this window.

Once you have selected your library, any related backing sheets or overlays are displayed in
the bottom window of the form. You can select one of these if required.

4.1 Changing your Working Library
The icons at the top of your Outfitting Draft display tell you:

• The type and name of the library you have currently selected to work on, for example:

• The library you have currently selected. For example:

All the libraries you have selected as working libraries in the current work session are
shown in the option list. Clicking on any of the libraries in the list will automatically
select that library and make it the current working library. 
Clicking the + button to the right of the list of working libraries adds the current element
to the list, if it is a suitable type.

• The option gadget on the right allows you to switch the display of elements on and off.
For example: 

You can add existing Libraries to the list of Working Libraries by selecting Draft > Select
Working Library. The Library Selection form will be displayed.
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5 Sheet Library Administration

This chapter tells you how to set up Sheet Libraries (SHLB) containing the Backing Sheets
(BACK) and Overlay Sheets (OVER) that users can reference for use with their drawing
sheets.

The relevant hierarchy is shown in Database Hierarchy.

Note: The DEPT Project_Libraries, supplied as part of the standard product, contains
REGIs named /DRA/PRJ/TMP/discipline, where discipline is Piping, Equipment, etc.
Each of these REGIs contains DRWGs, which own sample sheets with associated
LIBYs.
 
The DEPT Project_Libraries also contains a LIBY named DRA/PRJ/OVERS, which
holds sample overlay sheets.
 
The DEPT Master_Libraries contains a LIBY named DRA/MAS/BACKS, which holds
sample backing-sheets.

5.1 Entering the Sheet Library Administration 
Application
From one of the Outfitting Draft Administration menus, select Draft > Sheet Libraries. The
main menu will change to the Outfitting Draft Sheet Library Administration menu. The
menu hierarchy is illustrated in Administrator Menus. All menu selections specified in the
remainder of this chapter refer to this Sheet Library menu unless otherwise stated.

5.2 Creating a Sheet Library
To create a new SHLB, proceed as follows:

1. Navigate to the appropriate LIBY level in the existing hierarchy or, if necessary, use
Create > Library to add a new LIBY.

2. Select Create > Sheet Library. It is recommended that you give the new SHLB a name
that will make its content obvious to users.

3. The SHLB is effectively a drawing sheet template that aligns with the BACKs and
OVERs that it owns, so you must specify its dimensions (either explicitly in the Width
and Height boxes, or by selecting a standard sheet size from the drop-down list). This
size will be cascaded down to BACK and OVER level.

4. If you wish to define attributes at SHLB level, such that they will be cascaded down to
BACK or OVER level, click on the Attributes button and change the settings on the
Sheet Library form. (You can modify these attributes for individual BACKs or OVERs
later if you wish.)
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5.3 Creating a Backing Sheet and its Content
To create and display a new BACK, proceed as follows:

1. Navigate to the appropriate SHLB level.
2. Select Create > Backing Sheet. It is recommended that you give the new BACK a

name that will make its content obvious to users.
3. The BACK is a drawing sheet on which you will position one or more NOTEs, each of

which may comprise any combination of 2D primitives, text primitives (TEXP) and
existing symbol instances (SYMB).
Hint: You will find it easier to position and align individual NOTE components (i.e.
primitives, text and/or symbol instances) if you display a working grid with a fairly small
spacing (say 10 mm) and set the snap function to on.

4. For each NOTE in turn, select Create > Note > Back.
5. Depending on the detailed design required, create one or more features of the Backing

Sheet Note using the Create > 2D Primitives, Create > 2D Symbol and Create > Text
options. As you create each feature, use the cursor to position it and, for a primitive, to
define its size. If the grid snap function prevents you setting the precise position or size
that you want, either turn snapping off temporarily or modify the attributes of the
primitive later.

Restricting the Usable Area of a Sheet

You can define the usable area of a sheet, so that the area in which a user can create views
does not overlap any of the backing sheet annotation, by creating a special NOTE with the
name backing_sheet_name/LIMITS. This NOTE should contain just a single RECT primitive
that corresponds to the sheet area available to a user. When the user selects the option
Create > View > Pre-defined Frame, Outfitting Draft searches the sheet for this special
note and, if found, the VIEW dimensions will be set automatically to fit into the RECT
defining the available area.

During creation of any Views the limits are used to set the initial position and size of the
View, as shown:
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5.4 Creating an Overlay Sheet and its Content
To create and display a new OVER, proceed as follows:

1. Navigate to the appropriate SHLB level.
2. Select Create > Overlay Sheet. It is recommended that you give the new OVER a

name to make its content obvious to users. This is important; as each drawing sheet is
likely to reference several overlay sheets simultaneously. The function of the Ruleset
Reference drop-down list will be explained in Step 4.

3. In its simplest form, the OVER is a drawing sheet on which you can position NOTEs, for
which the procedure is exactly the same as for a BACK (see Creating a Backing Sheet
and its Content). However, an OVER can also own VIEWs, (typically used to display
keyplan views of all or part of the Design DB), each of which can own one or more
LAYERs, each of which can, in turn, own VNOTEs (View Notes). It is the VIEWs, and
their members, which we will consider further (see Database Hierarchy).
Hint: You will find it easier to position and align individual VIEWs and their members if
you display a working grid with a fairly small spacing (say 10 mm) and set the snap
function to on.

4. To create a VIEW in an OVER, select Create > View > Limits Defined or Create >
View > User Defined and set the VIEW attributes. Each VIEW can reference a
Ruleset which defines the way in which its Design graphics are to be drawn: you can
set the Ruleset Reference either at individual VIEW level, or at OVER level (see Step
2), or at SHLB level (Creating a Sheet Library).

Note: When you create a VIEW, a set of LAYERs is created automatically, their function
and content being determined by the default settings, as explained in Layer Purpose
Definitions. (This is exactly the same as for the creation of VIEWs during the normal
use of Outfitting Draft.)

5. To create a VNOTE, navigate to the appropriate LAYER level and select Create > Note
> Over.

Limits box

x

y

x/2

y/2

View

Sheet
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6. Depending on the detailed design required, create one or more features of the View
Note using the Draw options on the main menu. As you create each feature, use the
cursor to position it and, for a primitive, to define its size. If the grid-snap function
prevents you setting the precise position or size that you want, either turn snapping off
temporarily or modify the attributes of the primitive later.
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6 Symbol Library Administration

This chapter tells you how to set up Symbol Libraries (SYLB) containing the Symbol
Templates (SYTM) from which users can select 2D symbols to add to their drawings. Each
SYTM may comprise any combination of 2D primitives, text primitives (TEXP) and existing
symbol instances (SYMB).

The relevant hierarchy is shown in Database Hierarchy.

Note: The DEPT Master_Libraries, supplied as part of the standard product, contains a
REGI named DRA/MAS/SYMBOLS, which holds contains two LIBYs holding general
symbols and electrical symbols, which you can adapt as required.

6.1 Entering Symbol Library Administration Mode
From one of the Outfitting Draft Administration menus, select Draft > Symbol Libraries.
The main menu will change to the Outfitting Draft Symbol Library Administration menu.
The menu hierarchy illustrated in Symbol Library Administration. All menu selections
specified in the remainder of this chapter refer to the Symbol Library menu unless otherwise
stated.

6.2 Creating a Symbol Library
To create a new SYLB, proceed as follows:

1. Navigate to the appropriate LIBY level in the existing hierarchy or, if necessary, use
Create > Library to add a new LIBY.

2. Select Create > Symbol Library. It is recommended that you give the new SYLB a
name that will make its content obvious to users.

3. The SYLB is effectively a drawing sheet on which you will position the SYTMs, so you
must specify its dimensions (either explicitly in the Width and Height boxes, or by
selecting a standard sheet size from the drop-down list).

4. If you wish to define attributes at SYLB level, such that they will be cascaded down to
SYTM level, click on the Attributes... button and change the relevant settings on the
resulting form. (You can modify these attributes for individual SYTMs later if you wish.)
12.06:1



Outfitting Draft Administrator Application User Guide

Symbol Library Administration
6.3 Creating Symbol Templates
The SYTMs define the appearance of the 2D symbols which users can select and add to
their drawings (as symbol instances).

Hint: You will find it easier to position and align the individual parts of each SYTM (i.e. the
primitives, text, and/or instances of other symbols) if you display a working grid with a fairly
small spacing (say 10 mm) and set the snap function on.

Create each SYTM as follows:

1. Select Create > Symbol Template and give the symbol a meaningful name.
2. Use the cursor to position the origin of the SYTM at a convenient grid point.
3. Depending on the detailed design required, create one or more components of the

SYTM in turn from the Draw options on the main menu bar. As you create each
component, use the cursor to position it and, for a primitive, to define its size. If the
grid-snap function prevents you setting the precise position or size that you want, either
turn snapping off temporarily or modify the attributes of the primitive later. (Remember,
when positioning the component parts of the SYTM, where you placed its origin in Step
2.)

6.4 Adding Annotation via a Backing Sheet
When you create each SYTM, you define its origin with respect to its component outlines. It
is helpful if users can see where this origin is, but you may not want to make an origin
marker part of the selectable symbol instance. Similarly, you may wish to add a descriptive
name to the SYTM, as displayed on the SYLB sheet, in such a way that the name is not
selected for display on the drawing sheet. The solution is to position the origin marker and
descriptive name on a backing sheet that is displayed with, but does not form part of, the
SYLB sheet. To do so, proceed as follows:

1. Examine the displayed SYLB sheet and make a note of the coordinates of all locations
at which you wish to position supplementary details. (You may be able to use the grid
as a measuring scale if you have chosen a convenient spacing and have positioned
SYTM components at grid intersection points.)
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2. Change to Sheet Library Administration mode (see Sheet Library Administration).
Create a backing sheet (BACK) with the same dimensions as the SYLB sheet and
display it in a 2D View.

3. For each required group of annotations on the SYLB, create a NOTE and position it at
the appropriate point on the BACK (using the notes which you made in Step 1 as a
reminder); or create all of the annotations within a single NOTE if you prefer.

4. Change back to Symbol Library Administration mode. Select Modify > Symbol
Library > Definition and set the Backing Sheet Reference option to the name of the
corresponding BACK that you have just created.

Now, when the SYLB is displayed, the annotation for each SYTM will be shown for the
user’s guidance but will not be selected for adding to a drawing.
12.06:3



Outfitting Draft Administrator Application User Guide

Symbol Library Administration
12.06:4



Outfitting Draft Administrator Application User Guide

2D Symbolic Representation Administration
7 2D Symbolic Representation Administration

Symbolic representation is cross-disciplinary functionality which allows design items to be
represented symbolically in a 2D View in Outfitting Draft when the Update Design process is
executed. This depends on creating appropriate symbol and/or text templates in the
Outfitting Draft database and setting up appropriate data structures and references in
Catalogue databases before this functionality is used.

If the Outfitting Draft administrator does not have the appropriate permissions in the
Catalogue, then effective co-operation between the Outfitting Draft and Catalogue
administrators will be critical for the symbolic representation functionality.

To support this functionality, additional elements (DRSSET and DRSYLK) have been added
to the Catalogue database.

7.1 Project Structure and Distribution
When symbolic representation is used in a drawing, the same design symbol should be
used under the same conditions across an organisation irrespective of its size.

Design symbols will usually be held in an Outfitting Draft (i.e. PADD) database in one of the
Multiple Databases (MDB) in the master project (MAS) in addition to the master discipline
catalogues that already reside there. This Outfitting Draft database will contain the
templates for 2D design symbols that are referenced by the Catalogue. Thus, Outfitting
Draft design symbols will be made available in user projects by including a foreign reference
to the MDB in the master project.

As the Outfitting Draft design symbol libraries will be stored within a foreign project
database, then it will be the responsibility of the system/project administrator for the foreign
project to distribute them globally. The Global application only distributes databases for a
given project. Thus if master project is required at another location, then the system/project
administrator must either make that a Global project or otherwise arrange for its distribution.

Note: Use of backing sheets (BACK) should be avoided within the design symbol database
since these will complicate distribution of the design symbol libraries.

7.2 Catalogue Items
The following element types have been added to the Catalogue (CATA) DDL:

DRSYLK (Drafting Symbol Link)

DRSSET (Drafting Symbol Link)

DRSSET have been added as a list member of CATE, STCA, SECT and STSE.
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Elements SCOM, SPRE, JOIN and SFIT include a reference to a Draft Symbol Set: dynamic
ftable %DRSSRE (%DRSSET).

The Catalogue and Specifications Reference Manual (PARAGON Section) describes how to
create DRSSET and DRSYLK elements in the catalogue.

7.3 Assumptions on how Design Symbols will be Used
Each Catalogue item references a parameterised template and provides a set of values for
these parameters. Consequently, there could, for example, be Catalogue items for OFFICE-
TABLE/1200x1000, OFFICE-TABLE/1800X750 and OFFICE-TABLE/2000X800. 

To use symbolic representation with a fixed size symbol for occurrences of these Catalogue
items in an Outfitting Draft View, a single Design Symbol Set (DRSSET) will be created and
referenced by the GPART for each of these items. 

However, if a scaled design symbol is used, a DRSSET would be created for each of these
items in the Catalogue, for example DRSSET-OFFICE-TABLE/1200x1000, DRSSET-
OFFICE-TABLE/1800X750 and DRSSET-OFFICE-TABLE/2000X800. As there is a one-to-
one correspondence between GPART and DRSSET, this may require the creation of
additional GPARTs.

7.4 Non-uniformly Scaled Design Symbols
Setting the x and y scaling factors in the %XYSC attribute independently on the Design
Symbol Link (DRSYLK) element will enable the non-uniform scaling of Design Symbols
(DESSYMs). This will enable the DESSYM to be scaled to the correct size for the design
element that it is intended to replace in the Outfitting Draft View regardless of the aspect
ratio of that design element.

7.5 Orientating Design Symbols
The Outfitting Draft administrator or the symbol designer must associate the symbol
template (SYTM) or text template (TXTM) with orientation of the component in the
Catalogue that the design symbol (DESSYM) will represent. This is achieved either by
selecting an existing P-point on the Catalogue Component or by creating a new P-point.
Then the value of PPDI attribute on the SYTM or TXTM must be set to the value of P-point
Number (%NUM) attribute on the Catalogue Component. This will enable the 2D Symbology
functionality to use the direction of the P-point, which is determined by the P-point direction
(PTCD) attribute on the P-point element, for aligning the x-axis of the SYTM or TXTM.
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8 ISODRAFT Symbol Library Administration

This chapter tells you how to set up ISODRAFT Symbol Libraries (ISOLB), containing
ISODRAFT Symbol Templates (ISOTM). This allows you create and modify ISODRAFT
Symbol Keys.

8.1 Entering ISODRAFT Symbol Library Administration 
Mode
From one of the Outfitting Draft Administration Applications main menus, select Draft >
ISODRAFT Symbol Libraries.

The main menu will change to the ISODRAFT Symbol Library Administration menu. The
menu hierarchy is illustrated in Database Hierarchy. All menu selections specified in the
remainder of this chapter refer to the ISODRAFT Symbol Library menu unless otherwise
stated.

8.2 Creating an ISODRAFT Symbol Library
To create a new ISODRAFT Symbol Library (ISOLB):

1. Navigate to the appropriate LIBY level in the existing hierarchy or, if necessary, use
Create > Library to add a new LIBY.

2. Select Create > ISODRAFT Symbol Library. It is recommended that you give the new
ISOLB a name that will make its content obvious to users.

3. The ISOLB is a drawing sheet on which you will position the ISOTMs, so you must
specify its dimensions (either explicitly in the Width and Height boxes, or by selecting
a standard sheet size from the drop-down list).

4. If you wish to define attributes at ISOLB level, such that they will be cascaded down to
ISOTM level, click on the Attributes... button and change the relevant settings on the
resulting form. (You can modify these attributes for individual ISOTMs later if you wish.)

8.3 Creating ISODRAFT Symbol Templates
The ISODRAFT Symbol Templates allow ISODRAFT users to produce user-defined
symbols using the Outfitting Draft interface. The symbol definition is made up of two
components - straights and markers.

Straights can be solid for normal lines, dashed for insulation lines and chained for tracing
lines.

Markers can be defined for symbol arrive and leave points, tee points and spindle points.

Create each ISOTM as follows:
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1. Select Create > ISODRAFT Symbol Template and give the symbol a name. The
Symbol Template form will be displayed. 

2. Define the symbol geometry using the pending on the detailed design required, create
one or more components of the ISOTM in turn from the Draw, Construct, and Edit
options, which are used in the same way as in the 2D Drafting Application. 

You can add annotation to an ISODRAFT Symbol Template in the same way as for Symbol
Templates.
3. Export the ISODRAFT Symbol by selecting Utilities > Export ISODRAFT Symbol.

See the online help for more information.

8.4 Importing ISODRAFT Symbols
The Import ISODRAFT Symbols form is displayed when you select Utilities > Import
ISODRAFT Symbols from the ISODRAFT Symbol Library Administration menu. The form
allows you to import ISODRAFT symbol macro files into Outfitting Draft symbol libraries. 

You specify the filename of the file containing ISODRAFT symbol macros, and give the
name of symbol library. 

The Apply button imports the given symbol macro file into the Outfitting Draft symbol library.
The first symbol is positioned at the bottom left hand corner of the Sheet. Subsequent
symbols are tabulated across and up the page. When there is no space left on the Sheet, a
new ISOLB is created.

For more information, see the on-line help for the Import ISODRAFT Symbols form.
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9 Label Library Administration

This chapter tells you how to set up Label Libraries (LALB) containing the Symbol
Templates (SYTM) and Text Templates (TXTM) from which users can create symbolic
(SLAB) or general (GLAB) labels, respectively. Each SYTM may comprise any combination
of 2D primitives, text primitives (TEXP) and existing symbol instances (SYMB). Each TXTM
holds specific or intelligent (i.e. #-coded) text in its BTEX attribute.

The relevant hierarchy is shown in Database Hierarchy.

Note: The DEPT Master_Libraries, supplied as part of the standard product, contains a
REGI named DRA/MAS/LABELS, which holds contains LIBYs holding different types
of label templates, which you can adapt as required.

9.1 Entering Label Library Administration Mode
From one of the Outfitting Draft Administration Application main menus, select Draft > Label
Libraries.

The main menu will change to the Label Library Administration menu, which gives you
access to the menu hierarchy illustrated in Label Library Administration. All menu selections
specified in the remainder of this chapter refer to this Label Library menu unless otherwise
stated.

9.2 Creating a Label Library
To create a new LALB, proceed as follows:

1. Navigate to the appropriate LIBY level in the existing hierarchy or, if necessary, use
Create > Library to add a new LIBY.

2. Select Create > Label Library. It is recommended that you give the new LALB a name
that will make its content obvious to users.

3. The LALB is effectively a drawing sheet on which you will position the SYTMs and
TXTMs, so you must specify its dimensions (either explicitly in the Width and Height
boxes, or by selecting a standard sheet size from the drop-down list).

4. If you wish to define attributes at LALB level, such that they will be cascaded down to
SYTM and TXTM level, click on the Attributes... button and change the relevant
settings on the resulting form. (You can modify these attributes for individual SYTMs or
TXTMs later if you wish.)
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9.3 Creating Symbol Templates
The SYTMs define the appearance of the 2D symbols that users can refer to when creating
SLABs to add to their drawings.

Hint: You will find it easier to position and align the individual parts of each SYTM (i.e. the
primitives, text, and/or instances of other symbols) if you display a working grid with a fairly
small spacing (say 10 mm) and set the snap function on.

Create each SYTM as follows:

1. Select Create > Symbol Template and give the symbol a meaningful name.
2. Use the cursor to position the origin of the SYTM at a convenient grid point.
3. Depending on the detailed design required, create one or more components of the

SYTM in turn from the Draw, Edit and Construct options. As you create each
component, use the cursor to position it and, for a primitive, to define its size. If the
grid-snap function prevents you setting the precise position or size that you want, either
turn snapping off temporarily or modify the attributes of the primitive later. (Remember,
when positioning the component parts of the SYTM, where you placed its origin in Step
2.)

Adding Annotation via a Backing Sheet

When you create each SYTM, you effectively define its origin with respect to its component
outlines. It is helpful if users can see where this origin is, but you may not want to make an
origin marker part of the selectable symbol instance. Similarly, you may wish to add a
descriptive name to the SYTM, as displayed on the LALB sheet, in such a way that the
name does not form part of the selectable symbol instance. The solution is to position the
origin marker and descriptive name on a backing sheet that is displayed with, but does not
form part of, the LALB sheet. To do so, proceed as follows:

1. Examine the displayed LALB sheet and make a note of the coordinates of all locations
at which you wish to position supplementary details. (You may be able to use the grid
as a measuring scale if you have chosen a convenient spacing and have positioned
SYTM components at grid intersection points.)
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2. Change to Sheet Library Administration mode (see Sheet Library Administration).
Create a backing sheet (BACK) with the same dimensions as the LALB sheet and
display it in a 2D View.

3. For each required item of annotation on the LALB, create a NOTE and position at the
appropriate point on the BACK (using the notes which you made in Step 1 as a
reminder).

4. Change back to Label Library Administration mode. Select Modify > Label Library >
Definition and set the Backing Sheet Reference option to the name of the
corresponding BACK that you have just created.

Now, when the LALB is displayed, the annotation for each SYTM will be shown for the
user’s guidance without confusing the selection of a symbol instance for adding to a
drawing.

9.4 Creating Text Templates
Unlike SYTMs, TXTMs have no members. Instead, they hold text strings (in their BTEX
attributes) to which users can refer when creating GLABs to add to their drawings. These
text strings can include #-coded intelligent text, which is replaced by the corresponding
attribute settings from the Design DB when the labels are displayed on the drawing sheets.

Each TXTM automatically includes a Label Frame, although this can be switched off if it is
not required.

In order to see the effects of adding individual TXTMs as you build up the LALB contents,
open a 2D View window and add the LALB to the display. You may find it easier to position
and align TXTMs if you display a working grid with a fairly small spacing (say 10 mm) and
set the snap function on; or you may prefer just to position them by eye.

Create each TXTM as follows:

1. Select Create > Text Template and give the template a meaningful name.
2. Use the cursor to position the origin of the TXTM at the required point. (Nothing will

appear in the displayed view until you have set the BTEX attribute.)
You will be presented with a Modify Text form
.

3. Enter the required text using the keyboard or insert intelligent text codes, formatting
your text using the options above the text box.
Inserting Intelligent Text Codes
To incorporate a #-coded intelligent text item, call up the Intelligent Text gadget by
clicking the Intelligent Texts button. Use the Codewords menu options to select the
Design attribute whose setting is to be inserted when the TXTM is referenced by a
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GLAB. Select the required codeword, copy it, and then paste it into the text box on the
Dynamic Text form. The Codewords menu includes, in a categorised hierarchy, short
descriptions of all attributes whose settings are most likely to be needed; if you want to
incorporate any attribute not covered by the listed options, type its name, preceded by
the # character, into the text box.
Copying Text from an Existing TXTM 
To save unnecessary typing, you can copy text from an existing TXTM into the TXTM
that you are currently defining. To do so, first ensure that the TXTM that you wish to
copy is visible in a 2D View and then click the Insert Text button. When prompted, use
the cursor to identify the TXTM whose BTEX is to be copied; the text will be inserted
after the highlighted line in the edit window.

4. When the required text is displayed in the text box, click Apply to copy the string to the
BTEX attribute of the TXTM. The text and label frame (if switched on) will appear in the
displayed LALB at the position you defined in Step 2.
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10 Style Library Administration

This chapter tells you how to set up Styles (STYL), which define how different elements are
drawn, and Hatching Styles, which define which elements are hatched, and the appearance
of the hatching. Styles and hatching Styles are stored in Representation Libraries (RPLB).

This chapter also tells you how to set up Design Change Styles (DCSTYL), which define
how different design elements (including hatching) that have changed are drawn, and
Annotation Change Styles (ACSTYL), which define how annotation elements that have
changed are drawn. Design Change Styles and Annotation Change Styles are stored in
Representation Libraries (RPLB).

From one of the Outfitting Draft Administration application main menus, select Draft > Style
Libraries.

The main menu will change to the Representation Style Administration menu. The menu
hierarchy is shown in Style Library Administration. 

10.1 Creating a Style Library
Note: Style Libraries are actually Representation Libraries (RPLB) in terms of Outfitting

Database elements. Note that the STYLs that you can reference from an RRUL must
be owned by the same LIBY.

To create a new Style Library:

1. Navigate to an existing LIBY or use Create > Library to add a new LIBY.
2. Select Create > Style Library, and you will see the Create RPLB form on which you

can give the Style Library a name. It is recommended that you give the new RPLB a
name that makes it obvious that it is a Style Library.

3. When you press OK on the Create RPLB form, you will see the Style Library form. This
form allows you to define the STYLs to be stored in the library.
The Style Library form will be considered in two stages:
• The upper part of the form is concerned with the creation and deletion of STYL

elements within the RPLB. It contains a list of all STYLs in the current Style Library.
This part of the form is explained in Creating and Deleting Styles.

• The lower part of the form allows you to set attribute values for the current STYL;
that is, for the STYL which is highlighted in the list. This part of the form is explained
in Setting Style Attributes.

10.1.1 Creating and Deleting Styles
The upper part of the Style Library form shows the name of the current RPLB that is being
used as a Style Library, and a list of all STYLs within it (or None if you have just created the
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RPLB). You can change the current element by selecting the library you want in the emboss
list and clicking CE.

Creating a Style

To create a new STYL, click the Create Style button and give the new STYL a name. The
name will be added to the displayed list and will be highlighted as the current selection. The
attributes of the new STYL will have the default settings shown by the gadgets in the lower
part of the form. Change these, if required, as explained in Setting Style Attributes.

Deleting a Style

To delete a STYL from the current library, highlight it in the list and click the Delete Style
button.

Listing Some of the Attributes

The amount of information shown in the Styles list about each STYL is controlled by the
option selected from the Display drop-down list:

Name
shows only the STYL name and drawing level.

Gen
shows the drawing level and any linestyle and colour settings applicable to general
drawings.
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Pipe
shows the drawing level and any linestyle and colour settings applicable to pipework
drawings.

Steel
shows the drawing level and any linestyle and colour settings applicable to steelwork
drawings.

Set an appropriate Display mode to make it easier to find the STYL whose attributes you
want to modify, without having to recognise its name.

10.1.2 Setting Style Attributes
The lower part of the Style Library form consists of three sets of gadgets that allow you to
modify the attribute settings for the currently highlighted STYL.

To modify any of the attribute settings for the current STYL, change the settings of the
corresponding gadgets (as explained in the following paragraphs) and click the Apply
button.

Setting Drawing Levels

The Draw Level text box shows the Drawing Level (DLEV) setting. This attribute will restrict
the elements displayed using this Style to just those that include this number in their drawing
level range, as set in Outfitting Design.

Note: Every primitive in the design model has an associated drawing level range attribute.
If the drawing level given here lies within this range, the 3D object will be drawn when
it is added to the Draw List.

Assigning Colours and Styles

The Styles and Colours section of the form shows the assignment of linestyles and colours
to the six line types (i.e. Frontface, Backface, etc).
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For each line type you can assign a colour and either a Standard linestyle (which may be
‘Off’) or a User-defined linestyle. 

Colours can either be selected from a drop-down list (initially populated with the basic 16
system-defined colours) or picked from a colour-palette shown when the Pick button is
clicked. The colour selector gadgets will be greyed out if the linestyle is ‘Off’.

Standard linestyles are selected from two drop-down list gadgets: the first allowing ‘Off’ or
one of the 10 standard system-defined line-patterns to be selected, and the second allowing
one of the three standard system-defined line-widths to be selected.

If a User-defined linestyle is required click Select. This will cause the two Standard
linestyle gadgets to be greyed out and the User-defined Linear Styles selection form to be
displayed as shown below. The left-hand side of this form lists all the Linestyle Tables found
in the MDB. Selecting one of these causes the right-hand side to be populated with the
Table’s Linestyles from which a selection can be made. Once a User-defined style is
selected, the checkbox is used to toggle between the standard style and the User-defined
style.

Setting Drawing Flags On or Off

The Representation Flags section of the form shows the current On/Off settings for the
TUBE, PSYM, OBST, INSU, PRFG and PLFG flags:

• Tube: If switched off this will suppress the display of all pipes.
• Piping Symbols: If switched off this will suppress the display of all piping symbols.
• Obstructions: If switched off this will suppress the display of all obstructions.
• Insulation: If switched off this will suppress the display of any insulation.
• Profile: This is used for steelwork & if off then the profiles of the steelwork will be

suppressed. 
• P-Lines: This is used for steelwork and if on will show the steelwork stick build

representation

10.2 Creating a Hatching Style Library
Note: Hatching Style Libraries are actually Representation Libraries (RPLB) in terms of

Outfitting Database elements. Note that the HSTYLs that you can reference from a
HRUL must be owned by the same LIBY.

To create a new Hatching Style Library:
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1. Navigate to an existing LIBY or use Create > Library to add a new LIBY.
2. Select Create > Hatching Library, and you will see the Create RPLB form on which

you can give the Hatching Style Library a name. It is recommended that you give the
new RPLB a name that makes it obvious that it is a Hatching Style Library.

When you press OK on the Create RPLB form, you will see the Hatching Styles form that
allows you to define the HSTYLs to be stored in the library.

The Hatching Styles form will be considered in two stages:
• The upper part of the form allows you to create and delete HSTYLs. It contains a list of

all HSTYLs in the current RPLB. This part of the form is explained in Creating and
Deleting Hatching Styles.

• The lower part of the form allows you to set attribute values for the current HSTYL; that
is, for the HSTYL which is highlighted in the list. This part of the form is explained in
Setting Hatching Style Attributes.

10.2.1 Creating and Deleting Hatching Styles
The name of the current RPLB is shown at the top of the form. You can change the current
element by selecting the Library you want in the Members List and clicking CE.

Creating a Hatching Style

To create a new HSTYL, click the Create Style button and give the new HSTYL a name.
The name will be added to the Hatching Styles list and will be highlighted as the current
selection. The attributes of the new HSTYL will have the default settings shown in the lower
part of the form. Change these, if required, as explained in Setting Hatching Style Attributes.
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Deleting a Hatching Style

To delete a HSTYL from the current library, highlight it in the list and click the Delete Style
button.

10.2.2 Setting Hatching Style Attributes
There are three sets of gadgets in the lower part of the form which allow you to modify the
attribute settings for the current HSTYL.

Hatching Pattern Colour and Style

For the Hatch Pattern you can assign a colour and either a Standard fillstyle (which may
be ‘Off’) or a User-defined fillstyle.

The Colour can either be selected from a drop-down list (initially populated with the basic
16 system-defined colours) or picked from a colour-palette shown when the Pick button is
clicked. The colour selector gadgets will be greyed out if the fillstyle is ‘Off’.

The Standard fillstyle is selected from the drop-down list gadget. A total of 18 standard
system-defined fillstyles are provided as well as ‘Off’ and ‘Solid Fill’.

If a User-defined fillstyle is required click Select. This will cause the Standard style gadget
to be greyed out and the User-defined Fill Styles selection form to be displayed as shown
below. The left-hand side of the form lists all the Fillstyle Tables found in the MDB. Selecting
one of these causes the right-hand side to be populated with the Table’s Fillstyles from
which a selection can be made. Once a User-defined style is selected, the checkbox can be
used to toggle between the standard style and the User-defined style.
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Outline Colour and Style

For this line type you can assign a colour and either a Standard linestyle (which may be
‘Off’) or a User-defined linestyle. Refer to Setting Style Attributes for an explanation of the
gadgets.

If an Outline is used, then each surface hatched will be outlined in the specific style.

Pipe Symbols 

The choices are ON or OFF. Choosing ON will hatch the cross-section of a pipe or HVAC
duct with a piping end symbol or ducting end symbol. OFF will hatch the full cross-section of
the pipe or duct. 

10.3 Creating Change Style Libraries
To create a new Change Design Library:

1. Navigate to an existing LIBY or use Create > Change Design Library to add a new
LIBY.

2. Select Create > Change Design Library, and you will see the Create RPLB form on
which you can give the Change Design Library a name. It is recommended that you
give the new RPLB a name that makes it obvious that it is a Change Design Library.

3. When you click OK on the Create RPLB form, you will see the Change Design Library
form. This form allows you to define the DCSTYLs that will be stored in the library.

A similar procedure should be followed in order to create a new Annotation Design Library
except that you would use Create > Change Annotation Library and the Change
Annotation Library form.

The Change Design Library form and the Change Annotation Library form are similar,
having identical upper parts, but different lower parts.

• The upper part of these forms is explained in Creating and Deleting Change Styles.
• The lower part of the Change Design Library form allows you to set attribute values for

the current DCSTYL; that is, for the DCSTYL that is highlighted in the list. This part of
this form is explained in Setting Change Design Style Attributes.

• The lower part of the Change Annotation Library form allows you to set attribute values
for the current ACSTYL; that is, for the ACSTYL that is highlighted in the list. This part
of this form is explained in Setting Change Annotation Style Attributes.
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10.3.1 Creating and Deleting Change Styles
The upper part of the Change Design Library and Change Annotation Library forms shows
the name of the current RPLB that is being used as a Change Style Library, and a list of all
Styles (either DCSTYLs or ACSTYLs) within it (or None if you have just created the RPLB).

Creating a Change Style

To create a new Design (DCSTYL) or Annotation (ACSTYL) Change Style click the Create
Style button. You will be prompted for a name for the new Change Style which will be added
to the displayed list and will be highlighted as the current selection. The attributes of the new
Change Style will have the default settings shown by the gadgets in the lower part of the
form. Change these, if required, as explained in Setting Change Design Style Attributes or
Setting Change Annotation Style Attributes.

Deleting a Change Style

To delete a Change Style from the current library highlight it in the Styles list and click the
Delete Style button.

Listing Some of the Attributes

The amount of information shown in the Styles list about each Change Style is controlled by
the option selected from the Display drop-down list:

Set an appropriate Display mode to make it easier to find the Change Style whose
attributes you want to modify without having to recognise its name.

Name Shows only the Change Style name

Gen Shows the linestyle and colour settings applicable to
changes in general drawings.

Pipe 
(Design Change Styles only)

Shows the linestyle and colour settings applicable to
changes in pipework drawings.

Steel 
(Design Change Styles only)

Shows the linestyle and colour settings applicable to
changes in steelwork drawings.

Hatch Shows the style and colour settings applicable to
changed areas of hatching 

Style 
(Annotation Change Styles only)

Shows the font and other changes made to mark
changes in text strings.
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10.3.2 Setting Change Style Attributes
This Section describes the use of the lower parts of the Change Design Library and Change
Annotation Library forms to modify the attribute settings for the currently highlighted
DCSTYL or ACSTYL.

Setting Change Design Style Attributes

The lower part of the Change Design Library form consists of sets of gadgets that allow you
to modify the attribute settings for the currently highlighted DCSTYL.

To modify any of the attribute settings for the current DCSTYL, change the settings of the
corresponding gadgets (as explained in the following paragraphs) and click the Apply
button.

The lower part of the form allows the assignment of styles and colours to the six line types
(i.e. Frontface, Backface, etc) equivalent to those of a Representation Style (STYL), and to
the single line type (i.e. Outline) and single Hatch pattern equivalent to those of a Hatching
Style (HSTYL).

For all eight of these line types you can assign a colour and either a Standard style or a
User-defined style. A colour may also be set to ‘Unchanged’ and a style to ‘Unchanged’ or
‘Off’.

Colours can either be selected from a drop-down list (initially populated with the basic 16
system-defined colours and the ‘Unchanged’ option) or picked from a colour-palette shown
when the Pick button is clicked. The colour selector gadgets will be greyed out if the Style is
‘Off’.

Standard linestyles are selected from two drop-down list gadgets: the first allowing
‘Unchanged’ or ‘Off’ or one of the 10 standard system-defined line-patterns to be selected,
and the second allowing one of the three standard system-defined line-widths to be
selected.

The Standard fillstyle is selected from the drop-down list gadget. A total of 18 standard
system-defined fillstyles are provided as well as ‘Unchanged’, ‘Off’, and ‘Solid Fill’.

If a User-defined Style is required click Select. This will cause the Standard Style gadgets
to be greyed out and the User-defined Linear (or Fill) Styles selection form to be displayed.
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The left-hand side of this form lists all the Linestyle (or Fillstyle) Tables found in the MDB.
Selecting one of these causes the right-hand side to be populated with the Table’s Styles
from which a selection can be made. Once a User-defined style is selected, the checkbox
can be used to toggle between the standard style and the User-defined style.

Setting Change Annotation Style Attributes

The lower part of the Change Annotation Library form consists of sets of gadgets that allow
you to modify the attribute settings of the currently highlighted ACSTYL. These attributes
control the appearance of changed annotation graphics (lines and hatching) and text
strings.

To modify any of these settings for the selected ACSTYL, change the settings of the
corresponding gadgets (as explained in the following paragraphs) and click the Apply
button.

• Annotation Graphics
• Colours can either be selected from a drop-down list (initially populated with the

basic 16 system-defined colours and the ‘Unchanged’ option) or picked from a
colour-palette shown when the ‘Pick’ button is clicked.

• Standard linestyles are selected from 2 drop-down list gadgets: the first allowing
‘Unchanged’ or one of the 10 standard system-defined line-patterns to be selected,
and the second allowing one of the three standard system-defined line-widths to be
selected.

• The Standard fillstyle is selected from the drop-down list gadget. A total of 18
standard system-defined fillstyles are provided as well as ‘Unchanged’ and ‘Solid
Fill’.

• If a User-defined Style is required click Select. This will cause the Standard Style
gadgets to be greyed out and the User-defined Linear (or Fill) Styles selection form
to be displayed. The left-hand side of this form lists all the Linestyle (or Fillstyle)
Tables found in the MDB. Selecting one of these causes the right-hand side to be
populated with the Table’s Styles from which a selection can be made. Once a
User-defined style is selected, the checkbox can be used to toggle between the
standard style and the User-defined style.

• Annotation Text
For the text of a changed annotation element there are separate gadgets that allow you
to specify the colour and font; either of these may be set to ‘Unchanged’.
The Representation Flags section contains two additional gadgets for defining how
changed text is presented:
• The Underline check box allows you to underline all changed annotation text;
• The Brackets selector allows you (optionally) to enclose changed annotation text

within brackets of various types.
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11 Representation Library Administration

This chapter tells you how to set up:
• Representation Rule Sets (RRST) and Representation Rules (RRUL). These define the

appearance of the drawing of the Design Model.
• Hatching Rule Sets (HRST) and Hatching Rules (HRUL). These define how model

faces created by section planes, and surfaces of Specified Design primitives, are
hatched.

These Rules Sets are created within Representation Libraries (RPLB). When accessed
during normal Outfitting Draft drawing operations, each RRUL references a STYL or HSTYL
(Hatching Style) that is to be applied to the View from which the owning RRST has been
called.

Note: The DEPT Project_Libraries, supplied as part of the standard product, contains a
LIBY named DRA/PRJ/REPR, which holds sample representation rule libraries.

This chapter also tells you how to set up:
• Change Rule Sets (CRST), Design Change Rules (DCRULE) and Annotation Change

Rules (ACRULE). These define the appearance of changed design elements and
changed annotations on the drawing of the Design Model.

Change Rule Sets are created within Representation Libraries (RPLB). When accessed
during normal Outfitting Draft drawing operations, each DCRULE references a DCSTYL and
each ACRULE references an ACSTYL, which is to be applied to the View from which the
owning CRST has been called.

From one of the Outfitting Draft Administration application main menus, select Draft >
Representation Rules. The main menu will change to the Representation Style
Administration menu. The menu hierarchy is shown in Administrator Menus.

11.1 Creating a Representation Library
Representation or Hatching Library

To create a new RPLB, proceed as follows:

1. Navigate to an existing LIBY or use Create > Library to add a new LIBY.
2. Select Create > Representation Library or Create > Hatching Library. You should

give the new RPLB a name to make it obvious whether it is a Representation Rule
Library or a Hatching Library.

Note: The STYLs or HSTYLs which you can reference from a RRUL or an HRUL must be
owned by the same LIBY.
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Local Rules

Views can also own local HRULs and RRULs. The View HRSF attribute should be set to
point to a HRST, and the HSTYF attribute of the HRULs owned by the View should be set to
point to HSTYLs, in the same way as HRULs owned directly by HRST 

The database hierarchy is shown in the following diagram.

Note: You can store HSTYLs in a separate RPLB if you wish, and that you can store
HRSTs, RRSTs and Styles in the same RPLB.

Change Library

To create a new RPLB, proceed as follows:

1. Navigate to an existing LIBY or use Create > Library to add a new LIBY.
2. Select Create > Change Library. You should give the new RPLB a name to make it

obvious that it is a Change Rule Library.

Local Rules

Unlike Representation Rules, Views cannot own DCRULEs or ACRULEs. All Change Rules
applicable to a View are owned by a Change Ruleset (CRST) which is referenced by the
View's Change Ruleset Reference attribute.

The database hierarchy is shown in the following diagram.

HSTYF

HSTYF

HRSF

LIBY

RPLB
Representation Library

HRST STYL

RRUL

RPLB
Style Library

STYLRRST

RRUL

RPLB
Hatching  Library

VIEW RRSTHRST HSTYL HSTYL

HRUL HRUL HRUL RRUL

User Defined Administrator Defined
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11.2 Creating Representation Rule Sets
When a Representation Library is created, a Representation Rule Set (RRST) is
automatically created below it. To create additional RRSTs below the current RPLB, select
Create > Ruleset. The Create RRST form will be displayed, and you can give the RRST a
name. 

When you press OK on the Create RRST form, you will see the Representation Rule Set
form that allows you to define individual RRULs and to set up a reference from each of
these to an existing STYL. (Remember that each RRUL can only reference a STYL in the
same LIBY).

The Representation Rule Set form will be considered in two stages:
• The upper part of the form is concerned with the creation and deletion of RRULs within

a RRST. It also allows you to restrict the application of a RRUL to a specified class of
elements. This part of the form is explained in Creating and Deleting Representation
Rules.

• The lower part of the form displays a list of all currently defined STYLs and allows you
to select any one of these to be referenced by the current RRUL. This part of the form
is explained in Associating Representation Rules with Styles.

11.3 Creating and Deleting Representation Rules
The upper part of the Representation Rules form shows the name of the current RPLB. You
can switch to another RPLB by selecting it in the Members List and pressing the CE button.

DCSTYF

VIEW

RPLB

CRST

 ACRULE   DCRULE

RPLB

 DCSTYL
CRSF

ACSTYF

 ACSTYL
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The Rule Sets drop-down list allows you to switch to any RRST owned by the current
RPLB.

The Rules list shows all RRULs in the current RRST.

Specifying the Owning Rule Set

Select the RRST whose member RRULs you wish to modify from the Rule Set drop-down
list. The RRULs owned by the current RRST will be shown in the Rule list (or None if you
have just created the RRST).

Creating a Rule

To create a new RRUL, click the Create button and give the new RRUL a name. The name
will be added to the list and will be highlighted as the current selection.

Deleting a Rule

To delete a RRUL from the current RRST, highlight it in the Rules list and click the Delete
button.

Specifying the Elements to which Rules Apply

You can specify the type of element or a list of named elements, as follows:

To specify the type of element to which the current RRUL is to be applied, click the For
option button and select the type from the drop-down list. 

To specify named elements to which the current RRUL is to be applied, press the Modify
button, and the Names form will be displayed. On this form, select individual elements from
the Members list for copying to the Names list in the usual way. When you press OK, the
names will be shown in the text pane on the Representation Rules form.
12.011:4



Outfitting Draft Administrator Application User Guide

Representation Library Administration
Criteria for Rule Application

To apply qualifying restrictions to the elements specified by the For option, type an
expression in the With text box. For example, if the For gadget specifies Branches, you
might use the With qualifier to enter

’(HBOR GT 100) AND (TBOR GT 80)’ 

meaning ‘Branches with HBOR greater than 100 mm and TBOR greater than 80 mm’.

The Symbology box is available to be checked.

The Style box halfway down the form, shows the name of the STYL (if set) that is
referenced by the current RRUL. The way in which you set this is explained in Associating
Representation Rules with Styles.

11.4 Associating Representation Rules with Styles
The lower part of the Representation Rule Set form allows you to list the contents of any
Style Library in the same LIBY as the current Representation Library.

To associate a RRUL with a STYL, proceed as follows:

1. Use the Styles drop-down list to select the RPLB that holds the required STYL.
All STYLs in the selected Style Library will be shown in the list.

2. If necessary, use the Display drop down list to change the amount of information
shown in the list. The display options are identical to those that you used when you
created the Style Library, as described in Creating a Style Library.

3. Make sure that the required RRUL is highlighted in the Rule list and select the
corresponding STYL from the Style list; then click the Apply button to create the
association.

11.5 Creating Hatching Rule Sets
When a Hatching Library is created, a Hatching Rule Set (HRST) is automatically created
below it. To create additional HRSTs below the current RPLB, select Create > Hatching
Ruleset. The Create HRST form will be displayed, and you can give the HRST a name. 

When you press OK on the Create HRST form, you will see the Hatching Rule Set form to
allow you to define individual HRULs and to set up a reference from each of these to an
existing HSTYL. (Remember that each HRUL can only reference an HSTYL in the same
LIBY).
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The Hatching Rule Set form will be considered in two stages:
• The upper part of the form is concerned with the creation and deletion of HRULs within

a HRST. It also allows you to restrict the application of a HRUL to a specified class of
elements. This part of the form is explained in Creating and Deleting Hatching Rules.

• The lower part of the form displays a list of all currently defined HSTYLs and allows you
to select any one of these to be referenced by the current HRUL. This part of the form
is explained in Associating Hatching Rules with Styles.

11.6 Creating and Deleting Hatching Rules
The upper part of the Hatching Rules form shows the name of the current RPLB. You can
switch to another RPLB by selecting it in the Members List and pressing the CE button.

The Rule Sets drop-down list allows you to switch to any HRST owned by the current
RPLB.

The Rules list shows all HRULs in the current HRST.

Specifying the Owning Rule Set

Select the HRST whose member HRULs you wish to modify from the Rule Set drop-down
list. The HRULs owned by the current HRST will be shown in the Rule list (or None if you
have just created the HRST).

Creating a Rule

To create a new HRUL, click the Create button and give the new HRUL a name. The name
will be added to the list and will be highlighted as the current selection.

Deleting a Rule

To delete an HRUL from the current HRST, highlight it in the Rules List and click the Delete
button.
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Specifying the Elements to which Rules Apply

You can specify the type of element or a list of named elements, as follows:

To specify the type of element to which the current HRUL is to be applied, select the For
option button and select the type from the drop-down list. 

To specify named elements to which the current HRUL is to be applied, press the Modify
button, and the Names form will be displayed. On this form, select individual elements from
the Members list for copying to the Names list in the usual way. When you press OK, the
names will be shown in the text pane on the Hatching Rules form.

Criteria for Rule Application

To apply qualifying restrictions to the elements specified by the For option, type an
expression in the With text box. For example, if the For gadget specifies Branches, you
might use the With qualifier to enter
 ‘(HBOR GT 100) AND (TBOR GT 80)’ 
 meaning ‘Branches with HBOR greater than 100 mm and TBOR greater than 80 mm’.

The Style box, halfway down the form, shows the name of the HSTYL (if set) that is
referenced by the current HRUL. The way in which you set this is explained in Associating
Hatching Rules with Styles.

11.7 Associating Hatching Rules with Styles
The lower part of the Hatching Representation Rules form allows you to list the contents of
any Style Library in the same LIBY as the current Hatching Library.

The Style drop-down list displays the current Hatching Style of the selected Hatching Rule.

To associate an HRUL with an HSTYL:

1. Select the RPLB owning the required HSTYL from the Styles drop-down list. All
HSTYLs in the selected Hatching Library will be shown in the Display list.

Note: In the Administration application, this is all the Hatching Libraries in the MDB, but for
the user defined local hatching, only the library from the User Defaults Local Styles is
available. 

2. Make sure that the required HRUL is highlighted in the Rules list and select the
corresponding HSTYL from the Styles drop-down list; then click the Apply button to
create the association.
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11.8 Hatching Rule Attributes
The Hatching Rule attributes give you more control over which surfaces of an element are
hatched. The Hatching Rules Attributes form is displayed when you press the Attributes
button on the Hatching Representation Rules form.

• Pressing the Plot button on the Hatching Rule Attributes form will display the Hatching
Rule Attributes Plot form which illustrates the Hatching Rule Attributes. 

Hatching rules can Consider:
• Only Sectioned Surfaces, which means only surfaces cut by a section plane
• All Primitive Surfaces, which means that the element need not be cut by a section

plane to be hatched. 

The Rule can be further refined by the Hatching options:
• All Surfaces in All Directions means all surfaces meeting the initial criteria. 
• Only Surfaces Perpendicular to the View Direction - example, if the view direction is

north then the south face of the element will be hatched, assuming it meets the initial
criteria. 

• Only Surfaces Facing in a Specified Direction means that the user can specify a
direction normal to the surface to be hatched, instead of using the view direction. An
example of this is a box shown in an isometric view with the top surface cross-hatched.
If six surfaces of a box were required to have different hatching styles then this option
would be used on six Hatching Rules.

The Direction and Derived gadgets are active when Only Surfaces Facing in a Specified
Direction is chosen. If you press Derived, you will be prompted to pick a Design element.
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11.9 Creating Change Rule Sets
When a Change Library is created, a Change Rule Set (CRST) is not automatically created.
To create a CRST below a Change Library, navigate to the RPLB, select Create > Change
Ruleset. The Create CRST form will be displayed, and you can give the CRST a name.

When you click OK on the Create CRST form, you will see the Change Representation
Rules form to allow you to define individual DCRULEs and ACRULEs and to make
references from these to existing DCSTYLs and ACSTYLs.

The Change Representation Rules form will be considered in two stages:
• The upper part of the form is concerned with the creation and deletion of DCRULEs

and ACRULEs within a CRST. If creating a DCRULE it allows you to restrict the
application of a DCRULE to a specified changed element. If creating an ACRULE it
allows you to restrict the application of an ACRULE to a specified changed annotation
type. This part of the form is explained in Creating and Deleting Change Rules.

• The lower part of the form displays a list of all currently defined DCSTYLs or ACSTYLs,
depending on the selection made in the upper part of the form, and allows you to select
any one of these to be referenced by the current DCRULE or ACRULE. This part of the
form is explained in Associating Change Rules with Styles.
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11.10 Creating and Deleting Change Rules
The upper part of the Change Representation Rules form shows the name of the current
RPLB. You can switch to another RPLB by selecting it in the Members List and clicking the
CE button.

The Rule Sets drop-down list allows you to switch to any CRST owned by the current
RPLB.

The Rules list shows all DCRULEs and ACRULEs in the current CRST.

Specifying the Owning Rule Set

Select the CRST whose member DCRULEs or ACRULEs you wish to modify from the Rule
Sets drop-down list. The DCRULEs and ACRULEs owned by the current CRST will be
shown in the Rules list (or None if you have just created the CRST).

Creating a Rule

To create a new Rule, first select the type of Change Rule that you wish to create, Design
(DCRULE) or Annotation (ACRULE), from the Create drop-down list, then click the Create
button and give the new Rule a name. The name will be added to the Rules list and will be
highlighted as the current selection.

Deleting a Rule

To delete a Rule from the current CRST, highlight it in the Rules list and click the Delete
button.

Specifying the Changed Elements to which Rules Apply

You can specify the type of change or create a list of types of change, as follows:

To specify the type of changed element to which the current DCRULE or ACRULE is to be
applied, select the type from the For drop-down list. Use the right-hand drop-down list for
Annotation Changes and the left-hand drop-down list for Design Changes. The drop-down
list available depends on the type of Change Rule selected.
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To create a list of changed design elements that a DCRULE is to be applied to, select an
option in the For drop-down list, then click the Add button. Select another option from the
For drop-down list and again click the Add button. Clicking the Add button adds the option
selected to the list. Individual options can be deleted from the list by selecting them and
clicking the Remove button. A complete options list can be deleted by clicking the Clear
button.

Criteria for Rule Application

To apply qualifying restrictions to the elements specified by the For option, type an
expression in the With text box. For example, if the For gadget specifies Branches, you
might use the With qualifier to enter

’(HBOR GT 100) AND (TBOR GT 80)’ 

meaning ‘Branches with HBOR greater than 100 mm and TBOR greater than 80 mm’.

The Style line below the With text box shows the name of the Change Style which is
referenced by the current Change Rule. The way in which you set this is explained in
Associating Change Rules with Styles.

11.11 Associating Change Rules with Styles
The lower part of the Change Representation Rules form allows you to list the contents of
any Change Style Library in the same LIBY as the current Change Style Library.

The Style gadget displays the current Change Style of the selected Change Rule.

To associate a Change Rule with a Change Style:

Select the RPLB owning the required Change Style from the Styles drop-down list. All
Change Styles of the relevant type in the selected RPLB will be shown in the Display list.

Ensure that the required Change Rule is highlighted in the Rules list and select the
corresponding Change Style from the Styles list, then click the Apply button to create the
association.
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12 Drawlist Library Administration

This chapter tells you how to set up Drawlist Libraries (DLLB), each containing a group of
Drawlists (IDLI; also known as ID Lists) which allow users to create lists of design elements
to be drawn or sectioned. You can allocate DLLBs and IDLIs to design items according to
design disciples, project areas, or any other classifications appropriate to your company’s
working practices.

Each IDLI comprises a list of Design elements, in the usual format of an Add List and a
Remove List, which can all be displayed in an area view simply by reference to the IDLI
name.

Note: The DEPT Project_Libraries, supplied as part of the standard product, contains a
LIBY named DRA/PRJ/DRAWLISTS, which holds sample drawlist libraries.

12.1 Entering Drawlist Library Administration Mode
From one of the Outfitting Draft Administration menus, select Draft > Drawlist Libraries.
The main menu will change to the Outfitting Draft Drawlist Library Administration menu. The
menu hierarchy is illustrated in Administrator Menus. All menu selections specified in the
remainder of this chapter refer to the Drawlist Library menu unless otherwise stated.

12.2 Creating a Drawlist Library
To create a new DLLB, proceed as follows:

1. Navigate to the appropriate LIBY level in the existing hierarchy or, if necessary, use
Create > Library to add a new LIBY.

2. Select Create > Drawlist Library. It is recommended that you give the new DLLB a
name to make its use as a Drawlist Library obvious to users and indicate the IDLI
classifications that it is to contain.

12.3 Creating Drawlists
To create the first IDLI in a new DLLB, select Create > Drawlist and give the new IDLI a
meaningful name.

To add another Drawlist to a DLLB that already has member IDLIs, select Modify >
Drawlist Library. (You can, of course, do this even if the DLLB is empty, as an alternative to
the method given in the preceding paragraph.)

In either case, you will be presented with a Drawlist Management form. This form is the
same as that used to define local Drawlists. For more information, see the online help. The
only difference is that as Outfitting Draft Administrator you are creating Drawlists at Library
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level rather than at local user level. Only the basic principles of using the form will be
repeated here, as a reminder.

The Drawlist Management form will be considered in two stages:
• The upper part of the form is concerned with the creation and deletion of IDLI elements

within a DLLB. This part of the form is explained in the remainder of this section.
• The lower part of the form allows you to select elements from the Design DB for

inclusion in the Add and Remove lists (ADDE and REME) of a specified IDLI. This part
of the form is explained in Creating and Setting Up Tag Rules. The upper part of the
Drawlist Management form appears like this:

Selecting a Drawlist Library

To specify the Drawlist Library whose member IDLIs you wish to modify, use the Drawlist
Library option button. The list that is presented to you includes both DLLBs you have
defined and standard DLLBs that were supplied as part of the product (as determined by the
Drawlists Library Reference on the Draft Defaults form; see Setting the System Defaults).

Creating a Drawlist

To create a new (empty) IDLI, click the Create button and give the IDLI a name.

Creating a Copy of an Existing Drawlist

To create a new IDLI that has the same Add and Remove lists as an existing IDLI, click the
Create Copy button, give the new IDLI a name, and use the displayed Copy Drawlist form
to select the IDLI to be copied.

Deleting a Drawlist

To delete an IDLI from the current DLLB, highlight it in the displayed list and click the Delete
button.

12.4 Defining Drawlist Members
The lower part of the Drawlist Management form contains the gadgets that you use to build
up the Add and Remove lists owned by each Drawlist.
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The usual principles apply; that is, you select items from the Reference List Members list
and copy them into the Drawlist Members list by using the Add, Remove or Volume
Defined buttons.

The Drawlist Members list shows all elements in both the Add List and the Remove list, the
element names being qualified by ‘Add’ or ‘Remove’ to show their status.

Identifying Design Elements

The Reference List Members list can show either the Design DB elements or other existing
Drawlists. The former allows you to pick design elements explicitly; the latter allows you to
identify design elements by their presence in other Drawlists. Use the Design Members/
Drawlists drop-down list to choose which list is to be displayed.

Specifying Design Elements within a 3D Limits Box

To add elements within a given design volume to the Drawlist, click the Volume Defined
button. All significant elements positioned partly or wholly within the current limits box will
be added to the Drawlist. If no limits box is currently defined, you will be presented with a
Drawlist Limits form on which you can enter coordinates of two opposing corners of the
required volume.

Deleting an Entry from the Drawlist Members List

To delete an entry from the Drawlist, highlight the relevant line in the Drawlist Members list
and click the Delete Entry button. The selected line may be either an Add entry or a
Remove entry.
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13 Tag Rule Library Administration

This chapter explains how you set up Tag Rule Sets (TRST) and Tag Rules (TAGR), within
Tag Rule Libraries (TRLB). When accessed during normal Outfitting Draft drawing
operations, each TAGR references a Tagging Template (which may be either a SYTM or a
TXTM; see Chapter 8). Tag rules determine which items will be tagged in the View graphics.

Note: The DEPT Project_Libraries, supplied as part of the standard product, contains a
LIBY named DRA/PRJ/AUTOTAG, which holds sample tag rule libraries for various
disciplines.

13.1 Entering Auto Tagging Administration Mode
From one of the Outfitting Draft Administration menus, select Draft > Tagging Rules. The
main menu will change to the Outfitting Draft Tagging Rules Administration menu. The
menu hierarchy illustrated in Administrator Menus. All menu selections specified in the
remainder of this chapter refer to the Auto Tagging menu unless otherwise stated.

13.2 Creating a Tag Rule Library
To create a new TRLB, proceed as follows:

1. Navigate to the appropriate LIBY level in the existing hierarchy or, if necessary, use
Create > Library to add a new LIBY.

2. Select Create > Tagrule Library. It is recommended that you give the new TRLB a
name to make its use as a Tag Rule Library obvious to users.

You will be presented automatically with a Tagging Library form that allows you to define
TRSTs and their member TAGRs.

The Tagging Library form will be considered in two stages:
• The upper part of the form is concerned with the creation and deletion of TRSTs within

a TRLB. This part of the form is explained in Creating and Deleting Tag Rule Sets.
• The lower part of the form enables you to create TAGRs, to define the types of element

to which they are to be applied, and to set references to the templates which control the
format of the associated tags. This part of the form is explained in Creating and Setting
Up Tag Rules.

13.3 Creating and Deleting Tag Rule Sets
The upper part of the Tagging Library form shows the name of the current LIBY and has a
drop-down list which allows you to switch to any TRLB owned by that LIBY. It also
incorporates a list of TRSTs within the current TRLB.
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Specifying the Owning Tag Rule Library

To specify the TRLB whose member TRSTs you wish to modify, use the Tag Rules Library
drop-down list to select from those available in the current LIBY. The TRSTs owned by the
current TRLB will be shown in the Tag Ruleset list (or None if you have just created the
TRLB).

Creating a Tag Rule Set

To create a new TRST, click the Create Ruleset button and give the new TRST a name.
The name will be added to the displayed list and will be highlighted as the current selection.

Deleting a Tag Rule Set

To delete a TRST from the current TRLB, highlight it in the Tag Ruleset List and click the
Delete Ruleset button.

13.4 Creating and Setting Up Tag Rules
The lower part of the Tagging Library form contains all of the gadgets necessary to create
TAGRs, to define the types of element to which they are to be applied, and to set references
to the templates which control the format of the associated tags.
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Viewing Tag Rules

The Rule drop-down list displays a list of all TAGRs in the current TRST (i.e. the TRST
highlighted in the Tag Ruleset list). It is also used to change the current TAGR if you wish to
modify its attribute settings.

Creating a Tag Rule

Note: Tag Rules are always named automatically when they are created. You cannot
change the name.
 
 The attribute values for the newly created TAGR are defined by the current settings
of the other gadgets on the form (Tag, With, Template Reference, etc.), so set these
as explained in the following paragraphs before you create the TAGR.

To create a new TAGR, click the Create Rule button. The TAGR will be named
automatically and its name will be added to the Rule option button list as the current
selection.

Deleting a Tag Rule

To delete a TAGR from the current TRST, make the TAGR current (by using the Rule drop-
down list) and click the Delete Rule button.

Specifying the Elements to which Rules Apply

You can specify the type of element or a list of named elements, as follows:

To specify the type of element to which the current TAGR is to be applied, select a design
element class from the Tag drop-down list.

Criteria for Tag Rule Application

To apply restrictions to the elements specified by the Tag option, type an Outfitting
expression into the With text box. For example, if the Tag gadget specifies Branches, you
might use the With qualifier to enter ‘(HBOR GT 100) AND (TBOR GT 80)’ to compile the
overall specification ‘Branches with HBOR greater than 100 mm and TBOR greater than 80
mm’.

Associating a Label Template with a Tag Rule

To select a label template that will define the appearance of tags generated by the current
TAGR, use the Template Reference Select button. You will be presented with a Select
Template for Auto Tagging form. On this form, select the Label Library required and, from
the displayed templates, pick the one which is to be associated with the current TAGR.
Apply this to the current TAGR.

Associating a Drawlist with a Tag Rule

To specify a drawlist which is to be associated with the current TAGR (such that only items
in the drawlist will be tagged), click the Drawlist Reference button. You will be presented
with a Drawlist Reference form. On this form, select the Drawlist Library required and, from
the displayed list, pick the Drawlist which is to be associated with the current TAGR. Apply
this to the current TAGR.

To modify the content of the drawlist associated with the current TAGR, click the Drawlist
button. You will be presented with a Drawlist Management form. On this form, select the
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Drawlist whose member list is to be modified and add or remove design elements. Apply
this to the current TAGR in the usual way. Apply the changes to the current TAGR.
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14 ADP Administration

This chapter explains what the Outfitting Draft Administrator must do to set up a project to
allow Automatic Drawing Production (ADP) for Pipework and Steelwork.

Outfitting Draft provides for three types of Automatic Drawing Production (ADP):
• General ADP for Equipment and Piping
• Steelwork Detailing ADP.
• Hanger and Support ADP. The Administrator's role is setting up suitable backing

Sheets, as described in Hangers and Supports ADP. The User information for Hangers
and Supports ADP is given in Pipe Support Design User Guide.

Note: ADP administration is accessed through the Automatic Drawing Production
Application, and not through the Administration Application. The forms and menu
options are only available if you are a member of the DRAFTADMIN team. 

14.1 General ADP
The General ADP options create drawings from specified parts of the Design model in the
usual way, and then add annotation according to defaults set up by the System
Administrator.  

The defaults are stored in files, and there are different defaults suitable for different types of
drawings. The user must load a suitable file for the drawing being produced. 

The ADP application can add dimensions, labels, and schedules to a drawing. It can also
add graphical information such as equipment centrelines and pipe end symbols. 

The ADP application recognises different Types of dimensions:
• Type 1 dimensions are used for pipework.
• Type 2 dimensions are used for equipment centres.
• Type 3 dimensions are used for gridlines.

You can control the way in which each type of dimension is displayed. You can specify the
order in which types of dimensions are generated. For each type, you can set up Rules
using PML expressions to define how different drawing element types are dimensioned.

14.1.1 Setting the ADP Defaults
The ADP Defaults are set on the ADP Defaults File Editor form, which is displayed when
you select Settings > General ADP Defaults from the Main ADP Menu.

There are several defaults files supplied with the product, stored in the directory
%PDMSDFLTS%. The file names are of the form DRA-GENADP -*. These files can be
modified, and you can create your own new files as well.
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You can load a defaults file in the following ways:
• Select File > Load From from the menu at the top of the form. A File Browser will be

displayed, showing the files in the given directory. Select the file you want.
• Press the Browse button on the body of the form. A File Browser will be displayed.
• If you already have an ADP Drawing displayed, you can select From View and pick

any item in the View. The Defaults file used to create the View will be loaded.

When a defaults file is loaded, the ADP Defaults File Editor form will be filled in with details
from the file. You can change the defaults as described in the following sections.

The File Header text box shows a description of the type of defaults. 

The text boxes labelled Type 1, Type 2 and Type 3 show the type of dimensions controlled
by the given types. As supplied, Type 1 is Piping, Type 2 is Equipment and Type 3 is
Gridline. Not all types are used in all default files: when a type is not used in the current
default file it is shown on the form as Unused. To change a type of dimension, click on the
appropriate Type button, and a Type n Defaults form will be displayed.

For information about the options on the Type n Defaults forms, see the online help.

The General, Schedules and Tagging buttons allow you to set defaults as described in the
following sections.

The General ADP Defaults Form

The General ADP Defaults form is displayed when you press General on the ADP Defaults
File Editor form. This form allows you to:

• Restrict USER Access. If this button is switched off, users will be able to access the
Modify User Defaults form and so change the defaults. If this button is switched on,
users will not be able to modify the defaults files from the user forms. The only way to
change them will be from this form, which is only accessible to users who are members
of the DRAFTADMIN team. The Modify button on the Modify User Defaults form and
the Edit button on the View Function form will not be active. 

• Set the Annotation Processing Order. In the text box, enter the order in which
different types of annotation are to be processed. As supplied, the order is 3, 2, 1. Each
Type n Defaults form has an option where you can define how inherited dimension
points are handled, by specifying which Type they are copied from: the processing
order must ensure that the dimension points to be copied already exist. 

• Create any Representation Rulesets needed. If the standard Representation
Rulesets are required, this text box should contain the text Standard.

• Create any rules needed to control which elements are ADDed or REMOVEd from
Drawlists defined by volume. As supplied, all elements within the Volume will be added,
but elements of type PIPE that are owned by a Zone with Function set to Heating or
Electrical will be removed. 
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The ADP Defaults - Schedules and ADP Defaults - Tagging Forms

The ADP Defaults - Schedules form is displayed when you press Schedules on the ADP
Defaults File Editor form. 

The ADP Defaults - Tagging form is displayed when you press Tagging on the ADP
Defaults File Editor form.

14.1.2 Creating a Tagging Library
The tagging facilities used in ADP are based on the standard Outfitting Draft automatic
tagging functionality. You need to be familiar with this before reading any further.

The ADP PGA defaults file contains an entry to allow the administrator to define what tag
rule set element will be available to the user during use of the ADP system. The supplied
system refers to a TRLB called 

DRA/PRJ/ADP/TAGGS/PGA

that contains the TRST’s that the user accesses on the tagging creation form. Each TRST is
represented by toggle gadgets on the user’s form.

In order to create your own TRLB for tagging you simply create the TRSTs and their TAGR
elements with tag rules and tagging templates as required. The only important consideration
for the ADP system is that the last part of the TRSTs name is used on the user’s form, and
so this should describes the tagging available to the user.

For example, if the TRST is named /MYTAG/Instruments, then Instruments will appear on
the user’s tagging creation form.

Some example tagging templates are provided in the label libraries 

DRA/PRJ/ADP/TAGGS/PGA/TXTM

and

DRA/PRJ/ADP/TAGGS/PGA/SYTM

but you are free to define or use any symbol or text template as required.

14.1.3 Creating a Schedule Library
The schedule facilities used in ADP are based on the standard Outfitting Draft automatic
tagging functionality, and you should be familiar with this before reading any further.

The ADP PGA defaults file contains an entry to allow the administrator to define what tag
rule set element will be available to the user during use of the ADP system. The supplied
system refers to a TRLB called

DRA/PRJ/ADP/SCHE/PGA

that contains the TRSTs that the user accesses on the schedule creation form. Each TRST
is represented by a toggle and modify button gadget group on the user’s form.

In order to create your own TRLB for schedules and any number of TRSTs below this, each
of which represents an available schedule for use by the user. The TRSTs and their
constituent TAGRs have to be built with the following naming conventions:
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TAGR /LOCAL can reference any STYM or TXTM as required. This tag rule is responsible
for generating the tags local to the design graphics.

TAGR /ENTRY has to reference a special SYTM which in turn has references to other
SYTMs and is responsible for generating the tabular format entries generated as part of the
schedule. In order to generate a matching set of local and table tags it is important that both
TAGRs have the same criteria.

The SYTM referenced by the TAGR /ENTRY has an associated set of SYTMs as shown
below, where prefix can be any prefix name for the SYTMs, but the same prefix is used to
identify all three SYTMs required to construct the schedules table.

Example

The following example is based on the Project Libraries supplied in the Sample Project,
under DRA/PRJ/ADP/SCHED:

/MySchedules/NozzlesTRST

TAGR /ENTRYowner-name /LOCALowner-name

TMRFTRST
/NOZZLES-1

TAGR
/NOZZLES/LOC

TAGR
/NOZZLES/ENTRY

Reference by name
from prefix  /ENTRY

Schedule

View

TXTM
BTEX 'X0 Y-10'

Defines offset
between entries

Defines label
in View

TMRF
TXTM

SYTM
prefix  /OFFSET

Reference by name
from prefix  /ENTRY

N1

Nozzle Schedule

N1
Nozzle Size North East Elevation

200 +1100 +200 +3100

SYTM
prefix  /ENTRY

SYTM
prefix  /HEADER
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Each of the functions of the three schedule table SYTMs is explained below:

The SYTM prefix/OFFSET contains a single TEXP whose BTEX determines how each table
entry is positioned with respect to the previous. The BTEX simple states the OFFSET for
each table entry in the standard X and Y format. For example:

This means that each table entry is offset by -10 in the Y direction, therefore producing a
vertical table that grows down the sheet from the origin position.

The origin and extent positions for any schedules created are initially taken from a special
note created in the BACK by the administrator. See the next section for details of how to
implement this.

14.1.4 Backing Sheet Controls
The backing sheet referenced by an ADP sheet can contain two sets of information to allow
the ADP annotation and view creation to be more automated. The following sections
describe the types of additional information that can be generated under a BACK for use by
the ADP system.

The general ADP application makes use of special information stored on the backing sheet
in the form of Notes, which specify where certain types of annotation generated by ADP will
be located on the sheet. If this information is not present on the backing sheet the
application will either prompt the user for input or not allow the user access to the
associated automatic annotation options. 

All the Notes have visibility set to false.

Reference Drawings

This is the area on the Sheet that is available for the user to insert a list of Reference
Drawings. It is defined under a Note named back_sheet_name/REFDRWGS. The Note
contains TEXPs that are used to represent reference drawings associated with a sheet.
Each TEXP should be positioned and have attributes set as required. The TEXP is copied
from the backing sheet onto the user’s sheet during reference drawing definition. 

The Note should also contain a rectangle whose area represents the available area taken by
the reference drawing texts, which is used during zoom operations. 

Sheet Limits

This is the area available on the backing sheet where the View will be created. It is defined
under a Note named back_sheet_name/LIMITS. The Note should contain just one RECT
element whose limits correspond to the available free space on the BACK. This LVIS of the

prefix/ENTRY The SYTM used to construct the table entries

prefix/HEADER The SYTM used to construct the table header

prefix/OFFSET The SYTM used to determine how each of the table entries
is positioned, during construction of the table

Example:

BTEX = ’X 0 Y -10’
12.014:5



Outfitting Draft Administrator Application User Guide

ADP Administration
NOTE should be set to FALSE in order to inhibit the display of the rectangle on the user’s
sheet.

Schedules

This is the area on the Sheet that will be used to display Schedules. The origin of the
schedule table and its maximum extent is defined on the backing sheet. Only one origin and
extent definition can be added to a BACK and this is initially used by ALL schedules that are
created by the user. The user always has the option to re-define the two attributes for any
schedule created. The ORIGIN and EXTENT information gives the application a starting
point for any schedules.

To create the ORIGIN and EXTENT positions on the backing sheet create a NOTE under
the required BACK with the name

back_sheet_name/SCHEDULE.

This note should own two MRKP elements named:

back_sheet_name/SCHEDULE/ORIGIN 

and

back_sheet_name/SCHEDULE/EXTENT

SCHEDULE/ORIGIN should be positioned where the origin of the schedule will be
positioned and from where the schedule will be built.

SCHEDULE/EXTENT should be positioned at a point past which the schedule should not be
built. All subsequent schedule entries that would exceed this extent position are hidden and
the user is warned of the schedule overflow.

Keyplan

This is the area on the Sheet that will be used to display a Keyplan. It is defined under a
Note named back_sheet_name/KEYPLAN. This note should contain one MRKP element to
determine the position for the Sheet’s keyplan OLAY. The MRKP must be named: 

back_sheet_name/KEYPLAN/ORIGIN.

The Note should also contain a rectangle whose area represents the available area taken by
the reference drawing texts, which is used during zoom operations. 

Title

This is the area on the Sheet that will be used to display the title block of the backing sheet.
It is defined under a Note named back_sheet_name/TITLE. The Note can contain 2D
primitives to define the geometry of the Title Block. It should have a Rectangle (the first
primitive in the list, or first Rectangle in the list) with NLSTYLE set to OFF, whose area will
define the area occupied by the title block. This is used during zoom operations.

Summary

The following table summarises the special Notes that can exist on the backing sheets, and
more details are given below. 

Name Use Action if not present

/REFDRWGS Reference Drawing Information GUI gadgets inactivated

/LIMITS Defines available sheet area Whole sheet area assumed
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You can refer to the standard A0 backing sheet, /DRA/MAS/BACKS/METRIC/A0, in the
Department Draft_Libraries, as an example.

14.2 Steelwork Detailing ADP
This Section describes the administration tasks which you will need to carry out for
Steelwork Detailing Automatic Drawing Production (SDA), which allows the Outfitting Draft
User to produce dimensioned and annotated drawings of the most commonly used
structural elements (straight Beams and Columns, and flat Plates) automatically. 

The requirements for SDA are:
• A Sheet Library containing suitable backing sheets
• A Symbol Library containing suitable annotation symbols
• A Style Library containing suitable styles 
• A Representation Rules Library containing rules defining which Styles are used for

displaying the profiles.
• One or more SDAOPT elements, which set the SDA defaults that the SDA User will

initially see displayed on the SDAOPT form.  

The backing sheets and SDAOPT elements supplied with the product are in the Department
Master_Libraries. The backing sheets in the Library DRA/MAS/BACKS can be used for
SDA. The Library DRA/MAS/SDADP contains Libraries of Styles, Symbols and
Representation Rules for SDA. It also contains two SDAOPT elements:

SDA-Default 

SDA-Main-Views

The only difference is that the SDA-Main-Views file will not output detail views.

Note: Occasionally fabrication drawings produced by SDADP will be under-dimensioned,
although it will always be at least 70% of that required for fabrication of the
component. If a dimension is missing, it may be due to the way the catalogue
component is defined.

14.2.1 SDA Options
The attributes of the SDAOPT element define the options that will be used. You can change
the attributes of an SDAOPT element or create a new one using the Steelwork Detailing
Options form, described in Drawing Production User Guide. 

The UPDCB attribute of the SDAOPT element controls which customisation macro is run: it
is set to:

%PDMSDFLTS%/DRA-SDADP-MACRO

See the next section for information about the macro.

/SCHEDULE Defines schedule position info User prompted for positions

/KEYPLAN Position for keyplan OLAY Positioned at X0 Y0

/TITLE Area for zooming on TITLE BLOCK GUI gadgets inactivated

Name Use Action if not present
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If you create your own SDAOPT element, it will be created in the current LIBY, if there is
one. If your current element is the World, a new LIBY will be created to store the options in.
You will have to give this LIBY a suitable name, if required, after the SDAOPT element has
been created.

14.2.2 SDA Customisation Macros
The two SDA customisation macros supplied in the PDMSDFLTS directory (SDA-Default
and SDA-Main-Views) control the naming conventions for the Sheets generated by SDA,
the pens and the positions of text on the Sheets

You can edit these macros, or write your own, if you are familiar with PML, the AVEVA
Programming Macro Language. See the AVEVA Software Customisation Guide and the
AVEVA Software Customisation Reference Manual for more information. A customisation
macro is called once for each major item created by SDA. This means that you can define
the parameters used to draw each type of element.

Note that the supplied macros do not name the DEPTs REGIs and DRWGs created by SDA.
You will have to give them suitable names, if required, after an SDA run.

14.3 Hangers and Supports ADP
This section describes how the backing sheets supplied for Hanger and Supports ADP are
set up. The Sheets are supplied in the Library

Each Backing Sheet contains twelve member notes. Each Note owns TEXPs to help define
the specific area of the sheet. Some TEXPs are not used at this release, and some Notes
contain 2D primitives that are not used at this release.

The TEXPs must be kept as members of certain Notes for the Outfitting Draft GUI to work
correctly. The values in the BTEXT of the TEXP elements can be whole numbers, decimals
or fractions.

The standard backing sheet has the following members. Those marked with an asterisk are
required, the other are optional.

* NOTE 1 /DRA/MAS/H&S_A2/HS_Matl_List

* NOTE 2 /DRA/MAS/H&S_A2/Frame

* NOTE 3 /DRA/MAS/H&S_A2/Supported_Items

* NOTE 4 /DRA/MAS/H&S_A2/Support_Steel

NOTE 5 /DRA/MAS/H&S_A2/TitleBlock

NOTE 6 /DRA/MAS/H&S_A2/TitleBlockData

NOTE 7 /DRA/MAS/H&S_A2/DrawingNotes

NOTE 8 /DRA/MAS/H&S_A2/Address

NOTE 9 /DRA/MAS/H&S_A2/SmallPrint

NOTE 10 /DRA/MAS/H&S_A2/ModBlock

NOTE 11 /DRA/MAS/H&S_A2/HashTexts

* NOTE 12 /DRA/MAS/H&S_A2/LIMITS
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Note: 1: /DRA/MAS/H&S_A2/HS_Matl_List

This Note contains TEXPs that define settings for the Hanger Bill of Materials. The Members
of this Note do not have to be named.

TEXP 1 BTEX attribute set to 
H&S_MATL_LIST:value1, value2
where value1 and value2 specify the starting point of the Bill of Material.
This position is based on the lower left-hand corner of the owning BACK
size.

TEXP 2 BTEX attribute set to 
REF_X:value
where value sets the horizontal (X) placement of the part number hanger
element in the BOM, The position is a specified distance from the left-
hand edge of the BOM area defined by TEXP 1.

TEXP 3 BTEX attribute set to 
DESC_X:value
where value sets the horizontal (X) starting position of the hanger
element in the BOM. The position is a specified distance from the left-
hand edge of the BOM area defined by TEXP 1.

TEXP 4 BTEX attribute set to 
DESC_MAX_CHAR_X:value
where value specifies the number of characters allowed in each line of
the material description. Additional characters will wrap onto the next
line.

TEXP 5 BTEX attribute set to 
DIAM_X:value
where value specifies the distance from the left edge of the BOM area
when the diameter setting of the hanger element is to be placed

TEXP 6 BTEX attribute set to 
LENGTH_X:value
where value specifies the distance from the left-hand edge of the BOM
area where the length text of the hanger element is to be placed.

TEXP 7 BTEX attribute set to 
QTY_X:value
where value specifies the distance from the left-hand edge of the BOM
where the quantity of the hanger parts is to be placed.

TEXP 8 BTEX attribute set to 
LINE_SPACE:value
where value specified the distance between each line in the description
part of the BOM.

TEXP 9 BTEX attribute set to 
ITEM_SPACE:value
where value specifies the distance between each part number
description down the BOM listing.
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Note: 2  /DRA/MAS/H&S_A2/Frame

This Note contains the 2D drafting primitives that define the main backing Sheet border,
similar to the backing sheets for standard drawing sheets.

Note: 3  /DRA/MAS/H&S_A2/Supported_Items 

This Note displays a table that lists the pipes that are being supported.

TEXP 10 BTEX attribute set to 
UNBOLT_PACK_EXCLUDE:word, word
Not used at this release

TEXP 11 BTEX attribute set to 
LAYE_PURP:word
where word specified distance from the left-hand edge of the BOM area
defined by TEXP 1.

TEXT 12 BTEX set to
SLAB_SORF:name
The name specified is that of the TAGR to be referenced for the support
labels

TEXP 1 BTEX set to 
BOM:SIB
Not used at this release

TEXP 2 BTEX set to
HEADER_POS:value1,value2
where value1 and value2 define the position of a SLAB that references
the supported item table symbol template (SYTM). The origin of the
SYTM is the upper left corner of the table.

TEXP 3 BTEX set to
LABEL_POS:value1,value2
where value1 and value2 define the position of the first SLAB in the
support item table. The position is a distance from the lower left corner of
the owning BACK.

TEXP 4 BTEX set to
TILE_X:value
where value is the horizontal distance between the reference SLABs in
the support item table. 

TEXP 5 BTEX set to
TILE_Y:value
where value is the vertical distance between the reference SLABs in the
support item table.  

TEXP 6 BTEX set to
TILE_MAX:value
Not used at this release
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Note: 4  /DRA/MAS/H&S_A2/Support_Steel

This table displays the list of member parts, listing the size of each member and its required
length. 

TEXP 7 BTEX set to
TAGGING:name
The LABEL TAGR defines criteria for the Support Table BOM and
references that specific label template.

TEXP 8 BTEX set to
TITLE:text
where text is used in the log file to mark the start of messages relating to
symbolic labels in the supported item layer owned by the View.

TEXP 1 BTEXT
set to BOMST:STB
Not used at this release

TEXP 2 BTEX set to
HEADER_POS:value1,value2
Value1 and value2 define the upper left corner position of the steel BOM
table. The table template (SYTM) is referenced by a SYMB that is
created under a VNOT in the Steel BOM layer of the first View when the
support drawing is generated.

TEXP 3 BTEX set to
LABEL_POS:value1,value2 
where value1 and value2 define the position of the first SLAB in the steel
BOM list. This position is the distance from the lower left corner of the
owning BACK.

TEXP 4 BTEX set to
TILE_X:value
where value specifies the horizontal distance between SLABs in the
support material list.

TEXP 5 BTEX set to 
ILE_MAX:value
Not used at this release

TEXP 6 BTEX set to
TILE_Y:value
where value specifies the vertical distance between SLABs in the
support material list.

TEXP 7 BTEX set to
TAGGING:name
where name specifies the name of the TRST that owns the TAGRs to be
used for the support items listing.
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Note: 5  /DRA/MAS/H&S_A2/TitleBlock

This Note contains TEXPs that define the title block layout such as, date, checked,
approved etc. These TEXPs have the BTEX attribute set to fixed information. They are not
set to extract data through hash codes.

Two TEXPs in this Note are named DRA/MAS/H&S_A2/Scale and DRA/MAS/H&S_2/Proj.
Both TEXPs are at specified positions on the sheet but the BTEX attribute is not set in either
case. These two TEXPs are used for placement of the view scale and angle projection
specified from the overall default settings. The creation of the drawing is not abandoned if
the Note or the two named TEXPs do not exist. 

Note: 6  /DRA/MAS/H&S_A2/TitleBlockData

The TEXPs in this Note are similar to those stored in the Titleblock Note. By default, the
visibility of this Note is turned off. When the H&S drawing is generated Outfitting looks for a
note in the backing sheet ending in TitleBlockData. To avoid an error message in the batch
log file this note should exist.

Note: 7  /DRA/MAS/H&S_A2/DrawingNotes

This Note contains one TEXP. The BTEX is set to 

NOTE_WIDTH:30 

Not used at this release.

Note: 8  /DRA/MAS/H&S_A2/Address

This Note contains one symbol. It could be used to reference a company logo symbol
template and be positioned were required. 

Note: 9  /DRA/MAS/H&S_A2/SmallPrint

This Note does not contain any members.

Note: 10 /DRA/MAS/H&S_A2/ModBlock

This Note contains TEXPs that define the revision area block layout of the AVEVA backing
sheet. These TEXPs have the BTEX attribute set to fixed information. They are not set to
extract data through hash codes.

TEXP 8 BTEX set to 
TAGGING:name
where name specifies the name of the TRST that owns the TAGRs to be
used for the structural support steel list BOM. The TRST has two
member TAGRs, LOCAL and LABEL. These TAGRs are copied into the
appropriate layer and the member SLABs that are generated reference
them. The LOCAL TAGR defines criteria for locating the Part Number
SLAB in the Views. The LABEL TAGR defines criteria for the Support
Material Table and references that specific label template.

TEXP 9 BTEX set to
TITLE:text
where text is used in the log file to indicate the start of messages relating
to symbolic labels in the support steel layer owned by the View.
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Note: 11 /DRA/MAS/H&S_A2/HashTexts

The TEXPs in this Note define the intelligent text hash codes extracting the AUTHOR, DATE
and NAME from the owning DRWG and their placement on the backing. A fourth TEXP
extracts the title attribute from the hanger or support drawing sheet.

The Drawing and Sheet titles attributes are preset and filled in from the file
PDMSUI>DRA>SUPP>UDRWGMAK. Lines 63 and 64 of this file set the drawing title
attribute and lines 108 and 109 set the sheet title attribute.

Note: 12 /DRA/MAS/H&S_A2/LIMITS

This note contains one rectangle. The rectangle defines the area on the hanger and support
drawing where the Views will be created. It should be noted that placement and sizing of this
rectangle should be kept clear of the Supported Item and Support Steel BOM lists to
maintain clarity. 
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15 AutoDRAFT Administration

The AutoDRAFT option of the Administration menu allows you to access the AutoDRAFT
Symbol Editor (allowing you to convert symbols created in AutoCAD into a form usable by
Outfitting Draft) and the Frame Editor (allowing you to take drawing frames created in
AutoCAD and convert them into an Outfitting Draft usable format). 

You can also import symbols and sheet frames created in AutoCAD to be used in Outfitting
Draft.

15.1 Accessing AutoDRAFT Administration
To display the AutoDRAFT Administration menu bar, select Draft > AutoDRAFT. The menu
hierarchy is shown in Administrator Menus.

15.2 Starting the Symbol Editor
The Symbol Editor enables symbols created in AutoCAD to be converted into an Outfitting
Draft command macro that can then be used to create the equivalent symbols as Outfitting
Draft Symbol Template (SYTM) elements.

If any of the SYTMs thus defined already exist in the current Outfitting Draft Symbol Library
then the old 2D primitives are deleted and replaced by the new definition.

1. Select Draft > AutoDRAFT to bring up the AutoDRAFT Administration menus.
2. Select Edit > Symbols from the menu bar. This displays the AutoDRAFT Symbol

Editor form.
3. Make the Symbol Library (SYLB) that you wish to contain the returning Symbol Editor

generated symbols the current element.
4. Click on one of the option buttons as required:

Create a New Drawing creates a new, empty AutoCAD drawing for use by the Symbol
Editor. (If an AutoCAD drawing of the same name already exists then you are asked if
you wish to continue (i.e. update it, as below), the alternative being to return to
DRAFT.)
Open an existing Drawing opens an existing Symbol Editor drawing.

5. Use the Browse button to select a folder for a new drawing (if Create a New Drawing
option is selected), or a folder and a DWG file name (if Open an existing Drawing
option is selected). Alternatively, edit manually the text boxes AutoCAD Work
Directory and AutoCAD Symbol Drawing Name to define the name and location of
the AutoCAD drawing.

6. If you wish all symbols drawn in AutoCAD that have the same name as existing DRAFT
symbol templates in the selected Symbol Library to overwrite the DRAFT symbol
templates when they are imported from the Symbol Editor, tick the Replace All
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Symbols check box. (If this option is not set, you will still be given the option, at the
import stage, to overwrite symbols individually.)

7. Specify the AutoCAD drawing units to be used by selecting from the Units drop-down
list.

8. If you wish the Symbol Library (SYLB) that you wish to contain the returning Symbol
Editor-generated symbols to be other than the shown current element (as selected at
step 6), backspace in the Symbol Library Name text entry box until it is clear, then
type in the required name.

9. Click on OK. After a short pause, the AutoCAD text window and graphics window (with
the specified drawing displayed within it) will appear.

15.3 Starting the Frame Editor
The Frame Editor enables drawing frames created in AutoCAD to be converted into a
command macro that can then be used to create the equivalent frames as Backing or
Overlay Sheet elements within a specified Sheet Library.

If the specified Backing/Overlay Sheet already exists in the specified Sheet Library then the
old 2D primitives are deleted and replaced by the new definition.

1. Select Draft > Administration > AutoDRAFT to display the AutoDRAFT
Administration menus.

2. Make the Sheet Library (SHLB) that you wish to contain the returning Frame
Editor-generated symbols the current element.

3. Select Edit > Sheet Frame from the menu bar. This displays the AutoDRAFT Frame
Editor form.
12.015:2



Outfitting Draft Administrator Application User Guide

AutoDRAFT Administration
4. Click on one of the option buttons as required:
Create a New Drawing creates a new, empty AutoCAD drawing for use by the Frame
Editor. (If an AutoCAD drawing of the same name already exists then you are asked if
you wish to continue (i.e. update it, as below), the alternative being to return to
DRAFT.)
Open an Existing Drawing opens an existing Frame Editor drawing.

5. Use the Browse button to select a folder for a new drawing (if Create a New Drawing
option is selected), or a folder and a DWG file name (if Open an Existing Drawing
option is selected). Alternatively, edit manually the text boxes AutoCAD Work
Directory and AutoCAD Drawing Name to define the name and location of the
AutoCAD drawing.

6. Specify the AutoCAD drawing units to be used by selecting from the Units drop-down
list.

7. If necessary, you may select a different Sheet Library (SHLB) to contain the sheet to be
generated by Frame Editor by selecting it in the explorer and using the 'Select DB
element' button. If you select a SHLB element, only the sheet library will be set. If you
select a BACK or OVER element, both the sheet name and its owning library will be
set.

8. Select from the drop-down list at the bottom-left of the form whether you wish the
imported symbols to create a Backing Sheet or an Overlay Sheet.

9. Enter the name that you wish to give the derived Sheet into the Name text box.
10. Click on OK. After a short pause, the AutoCAD text window and graphics window (with

the specified drawing displayed within it) will appear.

15.4 Importing Symbols and Backing/Overlay Sheets
Note: The file import facilities described in this section need only be used if the AVEVA

software and AutoDRAFT are on different hardware platforms. Furthermore, the use
of these facilities is optional; provided you first navigate to the correct position in the
database hierarchy, the macro file exported from AutoDRAFT can be run into the
Outfitting Draft database using the $M/ command.
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Note: If the AVEVA software and AutoCAD are on the same hardware platform, the Symbol
or Sheet elements created using AutoCAD can be created in the database directly
from AutoDRAFT. See the AutoDRAFT User Guide for details.

Having created entities in AutoCAD (using the AutoDRAFT Symbol Editor) which can be
used as Symbols in Outfitting Draft, they can be imported to Outfitting Draft and Symbol
Template (SYTM) elements automatically created. 

1. Select Draft > AutoDRAFT to bring up the AutoDRAFT Administration menus.
2. Select Import > Symbols from the menu bar. This displays the Load AutoDRAFT

Symbols form.

3. If the directory to contain the Symbol creation macro file is not the local one, backspace
in the AutoCAD Work Directory text box until it is clear, then type in the required
directory name.

4. If the macro file to be used does not have the supplied default name symbols.mac then
backspace in the AutoCAD Symbol Macro text box until it is clear, then type in the
new file name.

5. Press OK, and a Backing or Overlay Sheet will be automatically created.
6. If you wish all symbols drawn in AutoCAD that have the same name as existing

Outfitting Draft Symbol Templates in the selected Symbol Library to overwrite the
Outfitting Draft Symbol Templates when they are imported from the Symbol Editor, tick
the Replace All Symbols check box. (If this option is not set, you will still be given the
option, at the import stage, to overwrite symbols individually.)  

The Symbol Library (SYLB) to which the Symbol Templates are to be added is as specified
on entry to the Symbol Editor, see Starting the Symbol Editor.

Note: The ways in which AutoCAD entities and attributes are mapped to Outfitting Draft
elements and attributes are described in the AutoDRAFT User Guide.

Having created a drawing entity in AutoCAD (using the AutoDRAFT Frame Editor) that can
be used as a Backing or Overlay Sheet in Outfitting Draft, it can be imported to Outfitting
Draft and a Backing or Overlay Sheet element (as required) automatically created. 

1. Select Draft > AutoDRAFT to bring up the AutoDRAFT Administration menus.
2. Select Import > Sheet Frame from the menu bar. This displays the Load AutoDRAFT

Sheet Frame form.
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3. If the directory to contain the Sheet-creation macro file is not the ‘local’ one, backspace
in the AutoCAD Work Directory text box until it is clear, then type in the required
directory name. If the macro file to be used does not have the supplied default name
pdmsback.mac then backspace in the AutoCAD Sheet Macro text box until it is clear,
then type in the new file name.

4. When you press OK, a Backing or Overlay Sheet will be automatically created.

The type of Sheet to be created, and the Sheet Library (SHLB) to which the Sheet is to be
added are both as specified on entry to the Frame Editor.

If the specified Backing/Overlay Sheet already exists in the specified Sheet Library then the
old 2D primitives are deleted and replaced by the new definition. 
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16 Loading Data Files

The Administration option of Outfitting Draft contains a feature that allows you to
automatically load data files to create new projects. By using the Load Data File option you
can load new project data for Main Libraries, Template Drawings and Application
Department. 

16.1 Accessing Load Data Files
To load the data files, select Draft > Settings > Load data file from the Outfitting Draft main
menu.

You can then select the data files you wish to load (Main Libraries, Template Drawings or
Application Department).
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17 Updating the Database

There are occasions when the database needs to be updated specifically, as opposed to the
routine updating that occurs from time to time in normal use. This chapter explains when
and how you should do this.

17.1 Updating Picture Files
This operation should be carried out to recover from a corrupt picture file, such as may
result from a RECONFIGURER operation, or if an attempt has been made to display a
VIEW created using a previous version of Outfitting Draft.

Annotation graphics will always be restored but Design graphics may not be. In all such
cases, a message alert will be displayed instructing you to carry out the update operation,
and this is the only time that the operation should be carried out. 

Select Graphics > System Update > Picture from the Administration menu. 

17.2 Updating Template Instancing
This option (valid at SHEE, BACK, OVER, SYLB or LALB level, or above) scans the
database hierarchy and updates all those parts of picture files that use the graphics
‘instancing’ mechanism. For example, a SYMB is an ‘instance’ of a SYTM. OLAY and BACK
elements are in the same category.

This update should be used to generate the correct graphics after the LIBNO NEW option
has been used in RECONFIGURER.

Select Graphics > System Update > Instances from the Administration menu. 

17.3 Updating Cross-DB Reference Attributes
This option updates all Draft element attributes that refer to elements in the Design
database. The settings of such attributes exist as database reference numbers. 

The updating function operates on the current element. It should only be used if the Design
database has been deleted and rebuilt from macros. See Chapter 2 of the Outfitting Draft
User Guide for further details.

Select Graphics > System Update > Refs from the Administration menu. 
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17.4 Updating Cross-DB Name Attributes
Draft elements with attributes that refer to elements in the Design database (the settings of
which exist as database reference numbers) also have (hidden) text attributes set to the
names of the referenced elements. This option updates the latter attributes, using the
settings of the associated reference attributes.

The updating function operates on the current element. It should only be used if the Design
database has been deleted and rebuilt from macros. See Chapter 2 of the Outfitting Draft
User Guide for further details.

Select Graphics > System Update > Names from the Administration menu. 
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A Administrator Menus

A.1 General Administrative Menu
Note: The Administrative menu options that are different from the User Applications are

shown in bold. Options that are common to all the Administrative Applications are
only shown on the General Administration menu.

This Section shows the part of the menu hierarchy that is common to all Applications.

A.2 Sheet Library Administration
Note: The Draw, Construct and Edit options are the same as in the 2D Drafting

Application.
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A.3 Symbol Library Administration
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Note: The Draw, Construct and Edit options are the same as in the 2D Drafting
Application.

A.4 ISODRAFT Symbol Library Administration

Note: The Construct and Edit options are the same as in the 2D Drafting Application.
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A.5 Label Library Administration

A.6 AutoDRAFT Administration
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A.7 Style Library Administration

A.8 Representation Rule Administration

A.9 Drawlist Library Administration
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A.10 Tagging Administration
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B Database Hierarchy

Note: Automatically created ‘system' elements are not shown.

WORLD

STYLWL LIBY DEPT

REGI

LIBY

REPOOLINES

LINEST

LSTYTB

DRWGHPATTE

FILLST

FSTYTB

TEXT

REVI

TEXT

NOTE VIEW

LAYE RRUL VSEC

ADIM LDIM VNOT GLAB SLAB

(see overleaf)

(see overleaf)

(see overleaf)

(see overleaf)

REVIOLAY

TAGRPDIM RDIM

HRUL

GLYTB

GLYPH

SHEE
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Note: Automatically created system elements are not shown.
12.0B:2



Outfitting Draft Administrator Application User Guide

Libraries
C Libraries

The Outfitting Draft Libraries supplied with the product are stored in two Departments:
• Master_Libraries can be referenced from any project.
• Project_Libraries contain rules that are Project-specific.

This appendix summarises the contents of the two Departments.
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Master_Libraries
DEPT

continued

DRA/MAS/LABELS
REGI

SYTMs
templates  containing

LIBY
DRA/MAS/LABELS/GEN

LALB
DRA/MAS/LABELS/GEN/USERDEF

ATEXTS

SYTMs
for

LALB
DRA/MAS/LABELS/GEN/EL-GEO

geodetic labels
datums
top of steel
steelwork positions
column labels
equipment tables
pipe end symbolsDRA/MAS/SYMBOLS

REGI

LIBY
DRA/MAS/SYMBOLS/GEN

SYLBs
DRA/MAS/SYMBOLS/GEN/GRATINGS

SYTMs
for
Gratings, slopes,

LIBY
DRA/MAS/SYMBOLS/ELE

etc
welds, pipe breaks,
sections markers,
direction arrows

SYLBs
DRA/MAS/SYMBOLS/GEN/GRATINGS

SYTMs
for
Intercoms,etc
receptacles
pushbuttons
fire alarms
switches, etc

LIBY
DRA/MAS/SYM-LAB-BACKS

SHLB
DRA/MAS/SYM-LAB-BACKS/AUTOTAG

SHLB
DRA/MAS/SYM-LAB-BACKS/LABELS

SHLB
DRA/MAS/SYM-LAB-BACKS/SYMBOLS

BACKS
 for autotagging

BACKS
 for label libraries

BACKS
 for symbol libraries
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C.1 Project Libraries

Project_Libraries

DRA/PRJ/TMP/ADP-PGA

DEPT

REGI
For automatic drawing production of Piping GAs

Each of the following REGIs contains Drawings, Sheets and Libraries for 
different standard sheet sizes for appropriate discipline

REGI For Piping drawings

DRA/PRJ/TMP/EQUI
REGI For Equipment drawings

DRA/PRJ/TMP/ELEC
REGI For Electrical drawings

DRA/PRJ/TMP/CLASH
REGI For Clash Plotting

DRA/PRJ/TMP/ADP
REGI For automatic drawing production

DRA/PRJ/TMP/PIPING

Each of the following LIBYs contains standard libraries of suitable elements

DRA/PRJ/REPR
LIBY Contains RPLBs which own RRSTs and RRUL

DRA/PRJ/STYL
LIBY Contains RPLBs which owns RRST and STYLs

DRA/PRJ/OVERS
LIBY

DRA/PRJ/AUTOTAG
LIBY

DRA/PRJ/DRAWLISTS
LIBY

DRA/PRJ/CIRCULATION
LIBY

Contains a SHLB which owns Overlay Sheets

Contains TRLB which own TRSTs for Piping,

Contains a DLLB which owns IDLIs for the 

Contains a CLLB which owns example CIRLs

for various uses

for various uses

defining ADP keyplans (metric and imperial)

structural and Equipment applications

Stabilizer Site
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