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2.2. R PFE(Multiple user access)
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3.3. ITE&%EMN

3.3.1. FmEIER % (Standard)
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3.3.2. #=HIT B4 (Controls)

N U ~wNE

@4 (Open new drawing)

FT 4745 3L+ (Open an old drawing)
A7 24 BT X4 (Save current drawing)
F1E1 2475 3214 (Print current drawing)
SN =458 (Input model)

BEH = 4E57 (Exchange model)
R £ B (Model information)

I (Verify)
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3.3.3.

JU{a & T B 4% (Geometry)
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Hfi 5 (Operation complete)
B (Quit)
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3.3.4. #=FET E% (Number)

Mumber E
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ARG RS e T RSO, P A DLEE A (Crrl+3iy) Bl i 4y
TRFEHA.

3.3.5. #H#MT A% (Transformation)
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1. bt (Scale) 11. LU #8285 1% (Mirror in U axis)
2. W5 (Move delta) 12. 47 (Parallel)

3. #£3)) (Move two positions) 13. (Move four positions)

4. Jig#% (Rotate delta) 14. 5#H[F (Same as)

5. Jig%: (Rotate two positions) 15. (Along curve)

6. el 45 ¥ (Rotate 45 degrees) 16. (Snap)

7. Jig% 90 & (Rotate 90 degrees) 17. BiE U i (Lock U)

8. Jigh: 180 J¥ (Rotate 180 degrees) 18. #i7E V % (Lock V)

9. Jig¥:-90 J¥ (Rotate -90 degrees) 19. (Centre)

10. PA V B 26515 (Mirror in V axis) 20. (Form detection)

3.3.6. M4t IHIR T A4 (2D point mode)
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1. fE= s (Cursor position) 9. [&0 A (Arc centre)

2. i s (Node) 10. Hal B 5K _E 4 (Arc by angle)
3. WAU.V J:ﬁ(Key in) 11. (Distance along)

4, IR i i S (Event) 12. E.0» A3 (Centre of gravity)

5. H A (Mid) 13. #F*5 /& (Symbol connection)
6. 225 (Intersection) 14. 477 SWF (Offset current)
7. Hix &1 (Nearest) 15. (Automatic)
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3.3.7. Z=HAET A% (3D requset)
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1. (Keyin) 11. (Lock XZ)
2. (Event) 12. (Lock YZ)
3. (Offset current) 13. (Lock XY)
4. (Lock U) 14. (Lock event line)
5. (Lock V) 15. (Lock any line)
6. (Lock view) 16. (Unlock)
7. (Lock X) 17. (Set current)
8. (LockY) 18. (Add offset)
9. (Lock2) 19. (Verify)
10. (Lock event plane)
3.3.8. R~T#r:xT B4 (Dimension)
Dimension ]
= Do FaFHs|EE R Ve = R
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17
1. KR R~FhRvE (Linear Dimension)
2. FryEE4E (Radius Dimension)
3. tRVEHE4 (Diameter Dimension)
4. FER R ARV (Angle Dimension)
5. FryF £k K E (Curved Dimension)
6. FryEME A (Area Dimension)
7. VRS E 4 PE S (Distance Dimension)
8. (3D Linear Dimension)
9. (3D Axis-parallel Dimension)
10. =4 552k k#1E (3D Coordinate Dimension)
11, AR AL K FRvE (3D Curve length Dimension)
12. #E & H.ObpvAF (WCOG Dimension)
13. (Shell Profile Mounting Angle Dimension)
14. By =ZER PR R (3D Ruler Dimension)
15. 7% (Note)
16. &R~} 4573 (Modify Dimension)
17. (Move Reference)
S
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3.3.9. BT E% (Shading)
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1% (Select)
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3.3.10. FEI A% (Subpicture)

Subpicture B 4 i & (Current Subpicture)
X E O #4518 (Transform Subpicture)

#£ 11 (Copy Subpicture)
Ml (Delete Subpicture)
P75+ K (Split Subpicture)
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3.4. fIHEEEXH

I

e Mg File>0pen i3 bzt TR % (Standard) %4, FT0T OAFAE
IIBELE

Open Drawing
Databank: I:4TriboniMi“Frojects Y04 dbippidb mother databﬂ

Object i
Object IDrawing LI
Envelope
’7(:' Hone " Initi {~ Permanent I™ Expand drawing referenc

fE4 \HE Object Name == (¥R A&, Ak List 424, xHiEAE 51 i #cdi 12 PPIDB o iy ity

SCAE

Open Drawing
Databank: D:\TribonM1 \FrojectshTDhdbhppi db qother databﬂ

-
308PE-J03

308PS-T04
308PS-T05
308PS-JOT
306F5-T08
308FS-T09
308PS-T10
308P5-TL1
308PS-T12
308F5-T13
308PS-T14
308FS-MODEL
309P5-T04
309PS-T05
309FE-TOB |

Objeat |I List |
Object I]]rawing LI Canecel |

Envelope
’75' Hone " Initi " Permanen t I™ Expand drawing referene

it Ky 22 PPIDB o (¥ SR8 (g, P 7 A 34K AR SO IR v e ol i 74 S B ied i

fizhig. TRIBON o i@mcsran .

* VEHCAE & 5 B 74 £
% VLHCAE & B 4

I
o
champion. -12-



champion Tribon M1 Hull Drafting
e

2445, EHIEHTIT 48 310PS-MODEL [ 5cfF, S| T,

weE ke File>0pen, 7E4i A4z Object i\ 310PS-M*.

Open Drawing
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Open Drawing
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3.5. BIEHCH

3 sz File>New 53 dibrvi: 1T H 4 (Standard) + D T, TR SO
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3.6. RTEFMMBESCH
et sz File>Save sl fadibr T

H.%(Standard)+ 1AL, PRAF B S
Un R 2 SO AR B R PRAF LI SO,

Data bank: I A\Tribon'Mi‘Frojectsi¥D'db'ppidb

Save Drawing As x}iGHE, F /7 72 AAE Name

of drawing form i N\ SciF4, s OK 424

Hame of drawing

=l

TRAFSCAE, RGERIARI R4 UNTITLED.
[ ok | omtions |  ceneel | guit |

SRR AR, BT S A BT o M b
FEFER . IR L2 R S HE, RS @ Drawing with Ehis name already exists on DE!
B A M R E BA, SEmeiid, RakiR

[a] Save Drawing As xHiGHE, JH 7 E A4 .

F Pl sk File->Save as 4w BB U TE 73— AN SCF s

v F4se s File->Databank->Delete in, %
Guo th an A7 U RS

d  lrawings Options |

## 1 Drawings, #%is i Delete Drawings

Hested Frofiles

2 Standards | Cancel |
] 3  Subpictures | Huit |
SHEHE, 7E4m AAE Name of drawing form i A\ 2 4 In book |
WA SO0 4 e OK 42260, SCPH45 M ¥4 % PPIDB : :'_ﬂ“’";; — !
=] 1pe etches
EFIﬂﬂ'IJIZ%O T Other |
. |
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3.7. B4R

TRIBON i@ id ¥ T E 4 (Controls) = x40 #2 (4 el I hfg . I LR 4% 41 H 7\ BA
TR B HE N TR RN B E .

425t .75 (Zoom auto) o FECRALE (Zoom in)

= ‘ 4

45 /ML (Zoom out)
3.8. BEIRKIKE

3.8.1. ¥1RYJLATEAZSE (New geometry preference)

*

PR AL (Pan)

g, &%, EEULEAREENSH s EEK X Format S25 5.

R T HARET, REK SRR — AN HMIETUE RIER. o UBN A R E, kK
SR E RTINS A

MR E, RGESPONRIER—NRE, XK, ATRESHBLETE, JFHSER AT
LT RGEx 28 Pk B 1 JLART 22 B — N AH LRI IER S
3.8.2. & (Defaults)

BE /AR g, mTeLEd L A Format-> Defaults.

RN R — NI A A R E R

Current default settings

TEXT_FOHT

TEXT_TEANSL_FOHT

TEXT_(ORIG_FORT o0
TEXT_STD_HEIGHT 1 2. 500E+00
TEXT_STD_ROT 0. 000E+00
INT_LIN_SFACE 1. 500E+00
TEXT_AUT_LIHE o1
TEXT_STD_DIST 1. S00E+00
TEXT_AUT_LIST 3. 000E+00
TEXT_AUT_AHG 4. 500E+01
TEXT_AUT_SYME Y
TEXT_STM_DIST 1. 000E+01
TEXT_MIEROE_MOLE .0
TEXT_VECTOE_FOHT o1
SYME_FONT cEl
SYME_MENU_HEOW © 3
SYME_MENU_HCOL DES
SYME_STD_HEIGHT 1. 000E+01
SYME_STD_ROT 0. 000E+00
SYME AUT LIHE o1 j

Eey in default assignment:

OE I Option=z Cancel Gt |
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FHrb s B AT AR R g, (B DOR S BT SR R
N E, A RSB SIRE SR E . XRS5 Y N R SE R 75T

3.8.3. EZELH(Drawing scale)

SR AN TR AL R EE B PT BE FEAN —FE . Bildn, AR . I E L K T AL
FItEflE 1: 50, T ArERM LRI aER 1: 580 1: 10,

7£ Tribon v, @RERUG, SRBIREEH &ARLE . = 4R R #E th R 4 H 3
11 75 22 AR 2], AL I B AME R AR 10 5 AL I LR AT 22 K5, ] DA AN x
EHATBN.

ohifd, iR A Drafting 24— /MBI, Blings]—AT Sl BATELHIZ 6, @t
B M p R RAA U E

#:F tools-> Subpicture> Current =i /i 7 & T A 4 (Subpicture) 1 i
G ) — N B B 3 HoB R B8k B LR

SRR ER LT R R ], &% Current Subpicture xfiGHE.

Current Subpicture
d Bwisting ptions |
Hew, swystem choice Cancel |

Hew drawing scale

2
3
4
2

Hew, uszerz choice | Quit |

Automatic

%+ 4 New drawing scale L1, RG0K 4 BRI T I AAE:

Eew in absolute scale:

pm |

k| or | options | cameer | guit |

R G H A LB BoRERNAE S, B HBSCN TR ZER G, 285 s OK #4100
S
.
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AN 1: 100 PIFAm AR 2T

Fa¥ 2 EH o Gurrent Subpicture xiEHE, Jf (5 RS BoR g BRG], i
il BT 14 LA R AE 50U (1 EL A3

R T BAE— AN OAFE AR P i LA AA, D6 00K 200 B 5 B R il 1 L. BTl L
AT (A PR L A5 5 2 A1 1 0 B — B8

KL E S E 4R, Akl Gurrent Subpicture xiiEHE - 1EXisting, @i+
FobARE PR s TR, EEE—R TR FRIINE SCRIE LS MR i,

3.8.4. #FREF=(Title block)

ST TS, ARdER I E EAE R G R 2 TRIBON Rgei s o —iE 2 TE. B
L SE R, T s BAE EHE bR A LIRS A AR, Bl 5. HIL B4R pl=E.

il Rz File—>Properties my LLscilix —1hfE.

e Tz File>Properties, #4044 SRl T AHEHE.

eeeeeeeeeee

AR I A ARG oty OK 82, SO EEURE (AR REAZ B IR P9 25 B B 3T
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23—

a) EEFLY| TFE YD 37T Drafting 2+
b) BIEH CHHiEFES A1 KEIHE.
c) KrEFREAL (Title Block)H:25k =] 15 F AR E4E 5 (Zoom) FI &2 3 (Pan) T g

d) ERBAERIE TG BB R.

Drawing no: 123-45
Title: Block TRAINI1
Drawn by: <Your name>
Dep: Hull

Date: dd—mmm
Scale: 1:100

Tot. sheet. no: 1

Check: AA

Appr: BB

e) LA TRAINT-HULL [543 AR TE
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FNE EAKJL{a (Basic geometry)

fEh—% TRIBON [OMSRBEEH /1, 2 TR R OB RS REAY . SR A (1 48R0 51
PLE I B A A 25 B J 7, 2R X B TAEC 2R D /M, AR
SR LT, @ AR B IRA T = > il 7 TRIBON B G 5 A LA 4.
4.1. BRI

4.1.1. g (Points)

7E TRIBON v, DA—A/N T oRB R SEA U R —— R SERRE IR v 75 2 ] i BRAE 4T B
I R m TS BUAR D, R EATTR A 15

SR AE B BE AL T LT AR IR s T3 SR 0 2 R, — SRR RS R 10 s m el A 4 i 4 R
FMOEFE, RGURAE BV BOE AL LRI I B2 I e o

3 Cursor: 83 BUbR s o 72 2 BT F B A0 B A 2 A

N Node: 7t — ™Sk 1Bl o rL AL B 1

Key in: %\ U, VARKR{E GRS,

&) Event: = 4EMEMY (1) Feifm 4 pi

\\ Mid point: 2.

pod Intersection: %7 /5.

"'i" Nearest: #ixri.

"x, Existing: C777E 5.

(=) Arc center: 5.0 5.

& Arc by angle: &7 [E5K b 4.

= Distance along curve: i /5 i 25 (1 25 25 61 4 A .

Iﬂ Centre of gravity: =0 15,

[k Symbol connection: 75 1AL O & 5.

=t Offset current: AIXt 487 AL B AME (U, V) BAIEL.
s Automatic: 75 S [93 25, H A EAZ ATAR B

o Add off set: AHXF 47T fifr BRI AWMEE (U, V) ERIE A, I NTT A

s
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ygiiba k- gz

T he s Insert> Point 53 5 Uik T B 44 (Geometry) F s, B A

i I 4 A T B 2% (2D point mode) ik ik,
T TR R AL s 4 T

VA KEY IN | CURSOR | NODE
I |
d I il ANY CURSOR POSITION I NOUE: POINTS
: KEY IN' 100,150 = (Y
160 |/"_— I -] l
: | . |
‘E 111 | # I
& = g| Es-—- ==
0,0
EXIST OFFSET CURRENT CENTRE OF GRAVITY

(COG)

| I

| |
" + EXISTING POINTS | CURRENT POINT | coe
i ; [ 2 |

| I

| |

| I

B 5 e e v
o
= gu it
"7 TARC AT ANGLE |, ARC CENTRE St 3t INTERSECTION
EY [N 30 | I
/ﬂ_— | ARC CENTRE |
55 | | __ INTERSECTION POINT
| |
| |
| [
——————————— -T-_______ﬁ__—t-______—_'___-
MIDPOINT | DISTANCE ALONG | NEAR
I |
MIDPOINT OF SEGMENT A POINT A DISTANCE p
OR CONTOUR | ALgNe A CONTOUR | /9—
| I
| 150 I \“_NEAREST POINT ON A LINE
| i |
| |
___________ fm—m e — e — — — — —— — -
SYMBAL | EVENT (2D POINT) | ADD QOFFSET
SYMBOL CONNECTION POINT | |
}’(///’ | | NODE POINT
| I NODE + OFFSET
-<"__S I | KEY IN: 100,-50
™\ SYMBOL : : e
___________ 4 SN S R Ty S, sy
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Ik kA

4.1.2. %&(Lines)

P IR Insert>Line =i s o LAl 4 T 2 4% (Geometry) / T, ALk
PRI 2 21 7 1

l.”

|-

XA

2N

3

Line between 2 point: & SR 4R RIS BRI H 2R B

Line through point at angle to existing line: &l 5. B 5 EHL R AAIEL,

E——

Horizontal line: & X K4

Vertical line: © 3 3 H 4B

100 -
Parallel Line: “F17m#%, 40T~ AW & . ” | —I

Perpendicular Line through point: 32 SCid i &5 FIAH 3 B 1) B 28 B .

Line at tangent to arc and through point: & SGE i S AFE Y] K

Line at tangent to arc and parallel to line: & SCHHF-4T HI £k FAH VI R 5K

Line at tangent to arc and perpendicular to line: & SCAHE B (128 A1 AH ) [ 5K o

Line at tangent to 2 arcs: & X F/MHDIE N

champion.
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Ik kA

4.1.3. [EIK (Arcs)

T hize e Insert>Are 5 Sy LAk T A 4 (Geometry)

L A R

A [ I 7 2

g B @ 3 3 e 2

Arc through 3 points: & X 3 A [H K.

. iy N AY A2 T ||1I:”:I| b ‘
Centre and radius: & SC[5].Co A4 ) [H] o —I

: : . . |[rool -] ‘
2 Points and amplitude: & X 2 SF15% 5.

|1nn| ;| ‘

2 Points and radius: & X 2 SA1ER. |

Centre point and point on arc: 5 3 5 SR ATE T 25,

[0 =l

Two tangents and radius: & X 2 MJZLFI4%

3 tangents: & X 3 MIZ i [H

4.1.4. %X £ (Polylines)

2 R ESH HLBMBA B A G L. — B, Prf B2BO R INBRA v 2

% LR AL RS 5 T AN Sy LA A . e T hse s Insert>Polyline 503 i L& T A

el

% (Geometry) e, AlEE L.
BAIRE T, Sl LR

champion.
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e

o 1 x
P g, L T R4 (Geometry) gl < € P 7

E'\
r:(/ ,J(/ /
&
i
A I E

# [ B
| |
. )

///
[
ﬂ//|/|mex?|

| ﬂ s
1Zl7e o Br|/[Cmnn| 37| /[Ca

4.1.5. &%k (Splines)

%L, Al ik

-
</'
N |

AT

P

T h sz Insert> Spline =% o J LT 4 T 245 (Geometry) Fel, B EERE SR
ik .

fE LT TR et Spline #dl, R4pnm Momas
%ﬁﬂﬁ@ﬁ"ﬂﬁiﬁﬂio [ptions |
2 Change | Cancel |
Bui t |

siifi 1 Create. R Ronins EIHXGHAE.
Tangent
lptions |

End point (5] | Cancel |

None: ARG A B s R IE D) A

End Point: I/ ZORIRMG A T s IED)
o RS EHAITA LV

All Point:  Ji o9 fRAERE SR IR HORS B2, SR NPT K IE DA

W EEIEFRIUP A, RS BRI TE RS IR R 3R 1, 2R

IR 2 B 3, AR GU oK H B A AH B A 57 15
R FTHREN R )G R 06 324, KRG Rk i 21045 ROF inl 25 . a0 Rk

i
2
a3

A1]1 points | Quit |

bl YES 4241,
S
L
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e 2

RGHEP RIS R, VPRI — MBI % th 2k BB AR O RE SR I 2, Al
QUIT #4578 418

WARAEAEIRE S i 2:, ] Insert>Spline =ie )L 14 T H. 2% ] Spline %41 .

#P 2 CHANGE. RS R B RE A 2G5 05 . FR VB R m REAR IR 1 0, e AR 4%
2. RGHEH—ANREREXAT AL EEEA S LE— %R Mai e M. R

WS, REESWIMIERREIEM, e L YES 4kasuk.

R 58 SR A B R AE.

New Tangent: 45 e L —ANEHIIEYI A . e e

Move Point. SNy J‘Z’i S-aute )f_:T\ bﬂjé/\j}‘ ; \;‘Eo 2  Mowe point | Cancel |
RGBT A I NE DA =

B —A R B IED M2 f5, FH YES #4718
SXAMER, ARE Rl 00 #4, RGiox TR U SR 2R

4.1.6. F{TBHZE (Parallel Curves)

Y

£ F s Insert> Parallel Curve i 5o ) L[4 T 2. 45 (Geometry) i
B PAT 2R .
SRR PR ASCER . EXHEAE B NAREL R AL B, F5 I AR I i 2R AR A B —id .

v

ARG R AL, 5T R UIHAMAT i, AWAE A TR E L, Sl
AR H

4.1.7. FEF (Rectangles)

T hize s Insert> Rectangle =i 5 7 Uik T B 45 (Geometry) T, ) g
5
F -+ 6 b @ SR T P 6 A B AT 61 @46 7 o

champion. -26 -



champion Tribon M1 Hull Drafting
e 2

4.1.8. IEF (Squares)

N R Insert> Square =i Ay L4 1T H 4 (Geometry) + u fedl, Ak
T

FI7olehm g SCIETT TIPS A BRI G IR T7 o IR D7 T I A IR e bm pirfir HE 1K
2.

4.1.9. ZXrph%k (Conics)

T hse i Insert> Gonic =i 4 i J L[4 1. A % (Geometry) + Fdl, Bl Ik
k. SFh2EAY g — Rk i 24250 2 nAE J Ul T 2461050 .

|EZ!'
Circumscribed rectangle. fi7i&5iE X —M4MIHTE
£
Major and minor axis. & S K45 4.
& _ S [too] =]
Focal points and major axis. & SCEE s Mo N Kb K
b
Focal points and point. & S £ K2k E— .
Segment data. & Y —PBrihiZl: & RGNS R S, % E AP A
i

End points, slope and point. & SGE 45 s fIEE o1 5, AR dB s SRR A Al — o
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DZIE 2 BT

%3

50°

"I‘-"‘" "'M?I'
3 / >
| S b=
| L 1
I:ﬂ'\. |
' i
!
Lo hE ]
et —-—hl-ul
SR =
e - \‘4 —:’ b
s ¥ ¥
e L e e e e = - -i —————— [ ]
L) L;‘} {
- =) -,
[ S— I:__-Jl
O ol )
R L’ﬁ { d-l

R2S
Ned
Lo
-
RN
RZS

i
L

oy

[REP | DATE | ZOME RET| INITIA.G | DEGGAAFTICK Eo
[TITLE sk
| v . ]
TEIBONT e :
Tontnrig Raristoeit ol x e GHEEEED 0ErT.,
Bl Ii:’l:--nﬂnhnr— TR - NANE WATE T
| EXERCIZER REEET SCALE

PR DPE R EL ] 1:1, B m DI M B 28 L VR 1:5 e, APRiERAT
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gk 3k za

ZES] T eeccetceciitiiiiitiiiiitiittietittietietitetetiettttetcttattttettttttnes 30
4,2 FBBUJUAIJR  cecereesereececsicntatniiiiirictesatiiieciiesrestsecsaitcsttccescns 31
4.9.1 %)ﬁ\@‘ [(07e] 1171 R T TECTITTPPTPRLY: 31
4.9.9 gjzgg (Line type) ........................................................................... 31
-1 » ] R T TR T I 32
4.3.1 YR K BT (Trim by Iength) ......................................................... 32

4.3.2 i@ Gap ThAEFT T L& (Remove part of a geometry, Trim by Gap) «««-xexe+++ 34

4.3.53 L Fillet IhReME R A e8] A (Trim by Fillgt)eeseeeeeeeeeceneneecceaneannnanee. 34

4,4 JE TP eevvevvceerectececcettittcticetiectiiicticettettotittttectiotssticettettsttsecceces 35
4,5 FHER JUAA]4AR ceeeceeeccrecsecoseceriacrsectcesccrsencostsssasasnocscscestsessasscannes 37

4' 5' 1 ﬂﬂ»”lgé:t/l\/leg (Deleting an individual geometry) .......................................... 37

4' 5' 2 1&*&@%}{%”5@ (Deleting area Of geometry) .......................................... 37

4.6 g@&%mnﬁﬁg .................................................................. 38
4.6.1 %Zijj (MOVIng geometry) ............................................................... 38

4.6.2 %Tﬁ%jﬁﬁ (WayS to transform) ......................................................... 38

4.6.3 ?%Jl_\l (Copylng geometry) ............................................................... 41

ZH D] eeceeetcteteniittiiitiitetitiitettitacetiitititttettcettitcttttttttetttctsttans 49
5 &%}E‘ERTJ‘ (DlmenSIOnlng) ......................................................... 43
5‘ 1. 1 &Eﬂﬁﬁ‘*ﬁ:?}z (Linear dlmensions) ------------------------------------------------ 43

5.1.2  KERRSHRERZ 0K E (Linear Dimension Parameters) «+=+ssssseeseeeseeee: 44

5' 1' 3 *ﬂ—-\‘?jziiﬁ,/fé (HOW to make a radius dlmension) .......................................... 45

5' 1' 4 *ﬂ—??fﬁﬁé (Dlameter measure) --------------------------------------------------------- 45

5.1.5 %Eﬂﬁﬂ‘*ﬁiii (Angle measure) ...................................................... 46

5.1.6  FriEHIZE K FE (DImension along CUIVE) «+eeeeeseeeseesreeernemieiniieneieienn, A7

5.1.7 *i:iiﬁ‘ﬁ:{ (DlmenS|on Area) ............................................................ 48
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DZIE 2 BT

%3

50°

"I‘-"‘" "'M?I'
3 / >
| S b=
| L 1
I:ﬂ'\. |
' i
!
Lo hE ]
et —-—hl-ul
SR =
e - \‘4 —:’ b
s ¥ ¥
e L e e e e = - -i —————— [ ]
L) L;‘} {
- =) -,
[ S— I:__-Jl
O ol )
R L’ﬁ { d-l

R2S
Ned
Lo
-
RN
RZS

i
L

oy

[REP | DATE | ZOME RET| INITIA.G | DEGGAAFTICK Eo
[TITLE sk
| v . ]
TEIBONT e :
Tontnrig Raristoeit ol x e GHEEEED 0ErT.,
Bl Ii:’l:--nﬂnhnr— TR - NANE WATE T
| EXERCIZER REEET SCALE

PR DPE R EL ] 1:1, B m DI M B 28 L VR 1:5 e, APRiERAT
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e

4.2. Rl

4.2.1. Bifa (Colour)

e Fhze s Modify—> Colour, = 4:5# itk #5329,

R - |
0K I Options I Cancel | Ozt |

R, sdr OK 4240 . 15 B4248r Indicate any geometry, i+ i 245 i (. 1)
JUATAR B H B

v >

i P Pl R B B, iy TR H .
4.2.2. £3 (Line type)

e T 32y Modify—> Line type, #4i5 h AR Rk g o,

Choose option

Thiokn.

i@t Thickn ek &2k v:, 34 Thin, Wide, X-Wide =#hzk vtk fe. Wwirirk s,
R¥E T EiE B4R . (5 2 4232r Indicate any geometry.

sl T BB UK, RGUR SR 2 5E AT 2 7Y

v 4

s AR P R i, FHARH .
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MR EFT
4.3. Y]
## Fhizz e Modify—> Trim > To Entity, 55U L1k,

T ]

|m|:|dif-:.- Molume PFipe Sketch  Help
e b GRS
Copy ' —_—
Transform k
Stretch... By Length
Zhain Gap
Dechain Cubout

Eill=t

Properties 3

5 Autocad A~JF)f2, TRIBON w83 U RE (45 8T V) Th e O R K IhRE . 4 N s

PEK: .
\ \ 1
R 3 print g0 it AP AR CIE N K.

\ \ \

-

prik = IR ER prink = AR iUk Lol
4.3.1. RI\BKEBIYI (Trim by length)

ISP A B R BOE K BT ) 348 10K 2, TRIBON 324t =rpig I, wbHE Fhisgs

o
Modify—> Trim > By length, #&3EK T8 LTk. . .

m
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Dzf 2 E AT
New length: - #5 e Hiit& .
enterstring
Eev in mew length:
f4500 [~

T B Dptions Cancel guit |

4500 o
|

Delta length: A figesbmmrKzE.
Entersting

Eev in mew length:

|1cu:u:|| ﬂ

T B Dptions Cancel guit |

SB00 | 0

Central angle: x5 B LI# A .
Central angle
Options |

2 Add delta | cencer |
3 Giwve new end angle | Quit |
b 907 270"
r‘—‘—-u.\-‘\\\ f..l"d—t-'_—T—‘_-:,:"".
P N j/an
i i o : \
AR ¢ B
\u ]Il L :
\:: i
!
New angle Add delta angle Key in end angle

O
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e

4.3.2. Eid Gap DhgEFTHIJLf{F (Remove part of a geometry, Trim by Gap)

R R h e Modify> Trim > Gap, B oiBIZk4T Wi L. BB BRI T
N

Maodify  Wolume  Pipe Sketch  Help

1. SEBRESTW 0 LA (1) o

. Mowve Fx .:? e [
2. HFEYIEIZ(2). g N S
" Transfarm »
\ . EEC oy
3. ﬂj%tﬂ%ug%(3)° ! Stretch. .. By Length
chan
4. RGEHAHANT WG, 2 Dechain ST

Fillet:

Properties L4

0K to lkeep?

Ho | [ptions | Cancel | Quit

et Yes 453

F No 45 E

4.3.3. @iT Fillet ThEEMEREI BT EIA (Trim by Fillet)

RN hse s Modify—> Trim > Fillet, WyDEIZ4T W LTk . RGUHH 0/ T FiRiE I

HE -
Choose option _

Modify Volume  Pipe Sketch  Help

NN\ e b GG aC
. Lopy f S—
| —

Transfarm

champion.

T oo
Stretch. .. By Lenagth
Chain Gap
Dechain Cukout

.

Propetties 4
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Dzf 2 E AT
WEPFAB R f BB BT e RGUH A T A
Entersting
Kev in radius:
f500 I~

ok | o | optiens | Canea guit |

BB AR B TOhRIE RS LRI A

4.4. HFE
P hisE o Insert> Hateh, s — 3 P i X AT s 7 1
e — B I HI R R PR A ER ) 55— B PRI RC R 4R
" —_IT
&7» / e /
/ P s
b / i
N |
\‘\“‘g y
3 s l'f
CUTEE—— PR
0K \\‘.\‘ NS fﬂ
Ho | Options | Cancel | Huit | \.\'""-_ A ..‘.‘I;

riils Yes 4240, e AT B 70 1 X 45
|
B
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v

s 7l s R A MR .

ygiiba k- gz

i Rz % Format> Hatch pattern, [ 7 a7 s 358 78 i1 R ANE 78 ROR BT B E

Default Hatch Pattern
Font
A\

Select hatch pattern type

[ptions Cancel Bt

iR e, BB IS N SCER) & (Island) BCR
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e

4.5. HHBRJL{AT 4

4.5.1. MHERAMAE (Deleting an individual geometry)

% # F s Edit—-> Delete—> Geometry, &) L4

= B2 Indicate any geometry.

FIF 5 ebmide M BR 1) S LA, 3 J5 T LT AR 5 2o

JUARSEE S, B P =R

1. i Jﬁ?%ﬂ, M T 1) JUART A AR B o

2. F+Febmig s HABZERIBR 0 TUT AR, R GURE B I Hh I LART e 5 /s B b — 2
e ) LART A

X

3. sk AR M TR
4.5.2. {&HEEIRMIER (Deleting area of geometry)

e T iz Edit—> Delete—>By area, 4/ i AR 4 J LA 44

= B A2#27% Indicate subpicture or ALL (Update Display ON) .

iiii
gl W, B A D AR
e 1, BRI LT R 2 —
SRR 2, B IRLL P i L AT R 3 ) oot | o |
FEFEIS, R A A A, —

BeAR 1, IR UOE K, KR

Resztricting area
it L N
)ﬂ@ﬂiﬂéﬁ%iﬂﬂ:ﬁ, ﬁﬁ Eﬁ%l‘ﬁ‘ltﬂﬁ%o 2 (General area | Cancel |
Ghai
B 2, 5 O T LA P e SO A 0 o |

HEATHRAE
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4.6. BENBIEDLEE

4.6.1. F3Bh(Moving geometry)

£ N usE s Modify—> Transform—> Geometry 750 — > s J LA 4k .
B — AR TR, KRG TR TUTE. ERT SR, U ERE
b feE ARBER S BN E, USSR E . IR R AMIE, S A
EEANMIE, mALH.
WA BIX AL B A Pk
1. A a4 i 38 SR AT B
2. fEEH SE—K, JUA S IR ESREr 1o R B ER I BIAE, L
(ERLN: w2 DA

4.6.2. FH#FGFI (Ways to transform)

i 4 T A 4% (Transformation) FH /= 7] DURE 7% 22652 ) LR SO0 B . BahitiE

B VR S . 7R e T 2 % (Transformation) m, RSB =5 B2 R HRRIE R

=
AAN R sfhaviald sirmoan s s

El Scale: XEMERELE. Hlan, EEMELFN 1 1, EWAESTHA L 181,
T,
Move delta: X EEMERREE (U, V), S/KHEMEBEHE.

7

Move two positions: 7SRz, BIESERUT:
1 & LRI R 3) 2 1 .
2. BGPTSR EEIENE.
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e i

1. NODE

POINT | |
| 2. MID |
POINT ! RESULT
e A ey wEw =

Y

Rotate delta: #i A\ Fx} 5 2600 B e ss /A 12
&of

Rotate delta: DUIwy4&idjigss bt S B 2SRk @ ) LA ie i 5 A B

Rotate predefined angle: 45, 90, 180 71-90 /g,

Ab =

TR Mlirror: vk s e B %
/;’/ Parallel: ## )| iRfd H—i P47 T 5 —EHE& I HAH LR R N 8 E Ml . BRE bR
R

1. IEPESE LR T —id .
2. EHFE—HZ.
3. BB LR —i 5 BRI IR R

Transform 4 positions: [U/5a55). /DB IT:

1 & 1a. 1b, DA S T Uik R ) 2 IR
2. &P 2a. 2b, DAXT s E LRI S S IR S AL E, JF H 1a #3)

|
B
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M) E AT
JE AL B AT 2a 55,
I
2b. Nearest B
1&M$Wt
| L , \: Intersection \ﬁ
RESULT
£
\\'\-.::-s:‘!
|
Same as: ikt R —TRIEMEME, ek,
& |a
Lock U/Lock V: #ise U Asbr/Bi5E V A8hR.
E) Change center of rotation(symmetry): o2 U ieis thoo AL B . AE S BT

1. %&£ F iz Modify—> Transform—> Geometry, it Lk,

©

2. mili 1785 IR (1K Nk SRR = A i i U = £ P AR

v

3. Ay T2
4, SR JUAIRTERE ERE . DU, JUMAR TR b0 S R B UE AL B .

[

Toggle form detection: &% 3 fl i fom 1%, FEIHE(drawing form) L ffdesk 2

s
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[
ANBERIE R, A R R SR AR B R R . I {2 AL AT DA S T R D 4

e
FEN, AR LA, S8 {2 A T LA IR Sh /R A e S 4 A A1 K D) 8t

4.6.3. ¥D1(Copying geometry)

e hize s Modify—> Copy—> Geometry # Ul L{AT 4.
15 BN
Indicate any geometry (ALONG CURVE in Transformation toolbar available)

WP ELPE DU LA, K58 g AHE
Prompt

Ho of copies:
E K
| 0K I [ptions Cancel Bt |

SONELRE DR, oS OK 24l
= B2 Choose transformation or pick item to drag.
B, #4 T % (Transformation) - pra izhaeat 2T Y, o al Lok TR %

(Transformation) =i BUArK#2 DA BAE GG E . R NHERT 1, KGRI
— /N DL R RO P2 DL LARTAA BRI AR O B B Sl o HeAth 4% DR A7 B
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DZIE 2 BT
REY | DATE | ZONE WEF| INITIALS | DESCRIPTIDA
TITLE §TD- No- DRAKN by
T T DATE ey 2l
EXERCIEES SHEET SCALE
MR B RIS 125, JFHREE LS 1:10, AbRERN .
I
I
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FHE #RFR~T (Dimensioning)
Fhizgy dimension iR ~FRE T % (Dimension) St R~ RRE R ThAE . R SERRAE RS
AR EE, PR B AR KBRS RE, RERINPRAN mm. REFE

A4 Pi4EkrvE(2D Dimensioning) .

5.1.1. KBBR<T#sF (Linear dimensions)

4+—F
e Fhskee Dimension > Linear i fish R <Fxik T H 4 (Dimension) L %
B, BN OHEE, G REERAR AR T 2
x|

Direction Tolerance

f+ Horizonta i H-:-rmal |7F Home ¢ £ 4 /-

" Vertica {~ Chain

{~ Paralle {" Staircas p Reference Line
[T Prefi:f@

|L3_.|_5 .>|£L.|L_L£|_,I_L£| Advenced |

& Advanced %41, 7 Dimension Parameter Settings xii%#E.

Status
Options |

Cancel |

guit |

Text height

Frefiz/Suffix

Tolerances

Fit

2
3
4
5
B
7

Text position

R L EPTASIEHE R S HOR . H A DR B ROHARE R . B3 HERIEN &
NZHS. .2 B3R AR AR A I AT fbsi 4 25 ul Advanced 24,
X EZ R ERE: Y Drafting #27 0CHn, ROHREMSER EAR R . EHT AT
INEIEPSERS NN o
L
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5.1.2. KBER-THETINSHEIZE (Linear Dimension Parameters)

DIMENSION MENU ON THE SCREEN

HORIZ | NORM
OFF |.E..| YES PARAM
DIR TYPE TOLERANCE DIAM PRES REFERENCE
HORIZONTAL :
N XX |
PARALLEL +300¢
— XX
AN \
gl [
STAIR QFF YES | &
[l [ ] -
PARAM: 1=DEC 2=ARROW 3=TEXT HEIGHT 4=PREFIX/SUFFIX
B=TOLERANCES 6=F1T 7=TEXT POSITION
|=NO OF DECIMALES 15 29
(DEFAULT*+ NO DECIMALES) + { ;
DTS AnoE FEXT-LINE
B - H
:
EF EXCESS:
b AN S e MEASURE CHAIN GAP: l
ARROW S1ZE: STAIRCASE FACTOR:® 29

3=TEXT HEIGHT
(DEFAULT® 2.5 MM)

4=PREFIX/SUFFIX

e

, xlfz?v%__l

I

6=FIT
WHEN LIMITED SPACE:
I=SHRINK 2=ROTATE 3=NO ADJUST

TEXT POS,

7=TEXT POSITION
TEXT POS. NORMAL:®

CHAINED®

1=ABOVE 2=SPLITTING 3=ROTATED

I=CENTERED 2=AT ARROW
3=AT ARROW ROTATED 4=AT REFERENCE LINE ROTATED

champion.
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5.1.3. Fr3E%4E (How to make a radius dimension)

o
#F k5 Dimension > Radius =i fid: T hrid T2 % (Dimension) -+ Q A,
ST REE, AR AR R
x|

L FR PR EARE MR IR, KRB B S I

,/// \"'},\ R
N\ RS
[/ ’i
\ /
\,
‘\‘-»‘ - N R2

5.1.4. ¥REHE4R (Diameter measure)

## Tk Dimension > Diameter = i )X FriE T H % (Dimension)

B, 58 AR NS HE .
x|
~ [ = Crme x4y

leas] sl | [luze] L as Advanced

W AR PRER A, W TR S EARE R BN, K BUE R E A S E AL
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5.1.5. AERRTHRFE (Angle measure)

#F N h ks Dimension > Angle =i it R ~Fhrid T 2% (Dimension) -+

SR A0 X TEAE
x
Unit Toleramee —————————
& Degrees Glimg C £ O S
i~ Grades |V
™ Radians

|7 Tnit onfod ‘{j hdvanced

3

2,

TRIBON 24t =7l B sefn, AP, IR, BREE. & FERARAORRIE T 2URI&0E I HAE
LSRR R B AR A L R 25 582k, 4R BT RN 1T 5 i € i [ e

I RAD

450 \30 ORA

R BRBRTBCEE Pl ZERRIE (1 A L v 1]
BRGE T IRERIAE

champion.
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5.1.6. Fr;ERIZRICE (Dimension along Curve)

by

#wFE TRy Dimension > Curved i 5 )R ~FhwiE T H % (Dimension) i
B, 9 T RS HE

Dimensioning : Curyed El

—Iype Tolerance

i+ Hormal o Home =  + 7 -
i~ Chain
i Staireas [+ Beference Line

[T Text fdjus
o ol || en|  avancea
A BEARMARE A, iR R ERE ML, E BRI P R & e KiE 2

IR A DA CIR N

T

v X Mool ARQQGB @D

ndicate contour to measure
irst point on curve (OC to measure whole curwvel

ndicate interszection point

ijl ocate dimension lime (OC to skip)

1

L[] 2 B Al baERh e, RBAUE R EA GG E .
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AL A P A i 2 A A 2R B i AN S A AR (BT B AL, bRy h 2 EiX
PR TR L, R BB E AR A I AL .

5.1.7. #REMEER (Dimension Area)

EF T h 22 Dimension > Area mlis it NS bRik TH % (Dimension) T,
I BT 3% v P AR T A

AR T AR A B TR ZE, ARUGE T AN EE, KRG H N EE, 9% Yes R

)
I

o
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