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1 Introduction

This guide explains how to install and set up AVEVA Marine (hereafter referred to as
Marine) on a workstation running the Microsoft Windows XP operating system (hereafter
referred to jointly as 'Windows'). Local Administrator rights are required to perform the
installation.

This guide assumes you are familiar with the concepts of folder/file hierarchies for storing
data on disks and with basic Windows terminology and commands. If you are not, you may
also need to refer to your operating system documentation while you carry out the
installation.

The guide also assumes that you have already gained access to the Marine installation files
via a DVD, from the AVEVA Web site, or by some other route.

1.1 Contents of this Guide
Hardware and software requirements are described in: Hardware and Software
Requirements. For completely up-to-date information, please see the AVEVA Website at
http://www.aveva.com/support and refer to the Customer Support Hardware pages. The
Web pages also give hints on ways of setting up and running Marine on different computers
in order to achieve the most efficient performance.

Installing the Software Suite, describes how to install and license the software.

Setting Up the Windows Environment, explains how to configure the Windows operating
system before you run Marine.

Running Marine Under Windows, gives some advice on using Marine in a Windows
environment.

Troubleshooting describes solutions for some of the errors that you could encounter when
running Marine. 

1.2 Associated Products
There are various AVEVA products that may be used in conjunction with Marine. You may
wish to consider installing these at the same time.  Those closely associated with Marine
include the following DESIGN products:

• Global - for synchronisation of Marine projects between world-wide sites
• Model Management - for change & status control of engineering objects (e.g. pipes,

welds, …) from system DESIGN through detailing and into deliverable production
• SQL Direct 
• MDS
• ABA ADP
12.01:1© 2007 AVEVA Solutions Ltd
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For details of the installation of these ‘add-on’ products, please refer to the relevant
installation guide.  If they are required, it may be advisable to read these before installing
Marine. 
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2 Hardware and Software Requirements

2.1 Windows Workstation
AVEVA Marine is normally installed on workstations and projects are normally stored on a
Network Server.

Minimum System Requirements:

2.1.1 Workstation Notes
OS: Windows XP Service Pack 2 has been successfully tested with AVEVA Marine and will
be supported with previous software versions in line with their respective support status
ratings.

AVEVA Marine is not supported on Windows Vista. Software testing is being carried out, but
no commitment regarding AVEVA Marine / Vista can be made at this time.

Although a full software installation requires approximately 4 GB of drive space, extra
capacity is required if you store project files and databases on the workstation. Please
contact your local AVEVA Support Office if you require more information.

OS Windows XP Pro SP2, plus .NET 2.0

CPU 2 GHz Intel Pentium

RAM 1 GB DDR RAM (2GB Recommended)

HDD 4 GB free disk space

Display 1024 x 768 dpi (1280 x 1024 Dual display recommended)

Graphics see Graphics in Workstation Notes below

File System NTFS

Network 100 Mb/sec LAN (Gigabit recommended)

Firewall Microsoft ICF disabled (see Workstation Notes below)

Other Scroll mouse

DVD drive

MS VISIO Standard (for Marine Diagrams)

Adobe SVG Viewer (for AVEVA P&ID 3D Integrator) Download
from:http://www.adobe.com
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Graphics: See Verified Graphics Cards Reports or go to: http;//www.aveva.com/support.

Firewall: If Microsoft’s Internet Connection Firewall (ICF) is left enabled (default), it must be
configured to enable access to the database server and the licence server.

2.2 Windows Server
AVEVA Marine is designed to perform most of its work on the workstation, so the Server’s
main function is to provide rapid and secure access to the Project files and databases.

Minimum System Requirements, based on 50 clients:

2.2.1 Server Notes
OS: .NET version 3.0 has not been tested, although it is expected that it will perform
satisfactorily.

CPU: Multiple core processors will increase the performance for multiple workstations.

RAM: High performance, high capacity RAM will increase the performance for multiple
workstations.

Network: The network should provide a minimum of 100 Mb/sec for each workstation. Two
or more network cards are recommended for increased performance and redundancy.

2.3 Licence File
To operate, AVEVA software must be able to access the correct Flexman 3.1 licence file,
which should be installed on either the Server, on your workstation, or on a networked
workstation.

OS Windows 2000 Server or Windows 2003 Server, plus .NET 2.0

CPU 2 GHz Intel Pentium (Dual core or dual processors recommended)

RAM 2 GB DDR-2 RAM

HDD 4 GB free disk space (RAID 0+1, using high performance hard drives
recommended)

File System NTFS

Network Gigabit PCle LAN
12.02:2© 2007 AVEVA Solutions Ltd
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3 Installing the Software Suite

3.1 Basic Installation
Local Administrator rights are required to:

1. To install from DVD - Insert the DVD into your DVD-ROM drive. If you have AutoRun
enabled for the drive, the installation starts automatically.  Otherwise, run Start.htm on
the DVD.
If you are installing from the network - Click Start>Run on the Windows taskbar and
type the path to the Start.htm file on your network.

2. Click check DVD CONTENTS and select the product which you want to install (in this
case AVEVA Marine ), then click INSTALL. Click OK on any confirmation forms which
appear.

3. On the File Download form, select Run this program from its current location (IE 5.0) or
Open (IE 5.5 or later) to install the program files directly from their current location onto
your hard disk. Select Yes on the Security Warning Query about an Authenticode
signature.

4. This starts the InstallShield® Wizard, which will lead you through the rest of the
installation process.

It is recommended that you use the default settings for folder paths etc. unless you have
good reasons for doing otherwise. 

Important: You must not use embedded spaces in folder path names.

When the process is complete, shortcuts to AVEVA Marine applications can be found on the
start menu Start>Programs/AVEVA Marine 12.0.

3.1.1 NET Framework Installation
The software requires that Microsoft’s .NET Framework 2.0 be installed. The .NET
Framework is supplied on the installation DVD, and is installed automatically if it is not
already installed.

3.2 Uninstalling and Reinstalling
If InstallShield detects an existing installation, it will display the options for modifying/
repairing/removing the files rather than simply offering the standard installation options. 

To remove installed components from your hard disk, or to add additional components to an
existing installation, select Start>Settings>Control Panel and use the Add/Remove
Programs tool.
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As an alternative procedure, repeat Steps 1 to 4 of the installation sequence detailed above.
The InstallShield® Wizard will detect your existing installation and will give you the following
options:

• Modify
Displays the same list of options as the Custom installation. Select new components to
be added and/or deselect any currently installed components to be removed.

• Repair
Reinstalls all currently installed components (to correct any corrupted files etc.).

• Remove
Removes all currently installed components.

Note: Uninstalling AVEVA Marine will not uninstall Microsoft’s .NET Framework: this must
be removed separately if required.

3.3 Flexman License Manager
You must install and set up the Flexman license system before launching the installed
software. This will usually be done only on the server.  Please see the Flexman Installation
Guide.  News and update information is also available for Flexman on the AVEVA support
web-site.

3.4 Silent Installation of Marine 12

3.4.1 Introduction and Purpose
This guide will instruct the user on how to perform a silent installation of Marine12.

The following assumptions are made within the manual:
• That the user defined path names do not contain spaces.
• That the network share that is being used is shared and that the users performing the

installations have access rights to the necessary folder. You can access these
commands either from a UNC path or a network drive. A network drive is used in this
manual.

• That the folder names in this manual are variable and the user can specify their
personal choices.

• The number of files demonstrated within the screen shots may vary depending on what
version is being implemented.

1. Copy the contents of the DVD to a network share.
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2. Create a Windows installer response file from a workstation.
3. On a workstation create an InstallShield Response File.   

Please see the following screenshot to create the setup.iss file:

4. Follow the instructions in the Marine installation wizard to complete the creation of the
InstallShield Response File.

5. To deploy the software silently on other computers use the /s /w switches in conjunction
with setup.exe. It is also optional to create a log file of the installation using the f2
switch (an example being setup.exe /s /w /f2"%TMP%\setup.log")   This can be
illustrated as follows:
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3.4.2 Deployment Across a Network
There are numerous methods for such a deployment. However here are three commonly
used methods of deploying the software across a network. These can be depicted in the
following section of the manual. This is not a step-by-step approach as the installation will
depend on the environment the user has installed.

• Deployment Using SMS
Please use the standard procedures for deploying with SMS and use the setup.exe /w /s at
the command line.

Below is an example of such a dialogue box:
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• Deployment Using Logon Script
In your logonscript check if Marine is installed. If not, then install it.

Logonscript example:
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• Deployment Using GPO
Create a Software Installation Settings file (Zap)

Example zap file:

Reference here: http://technet2.microsoft.com/windowsserver/en/library/3512b600-5bb4-
4dae-8b2c-7b71ef9951a01033.mspx?pf=true 

[Application]

FriendlyName = "AVEVA Marine 12"

SetupCommand = "\\Server\Install\\Path2InstallScript\\Deploy.bat"

DisplayVersion = 12.0

Publisher = AVEVA

Example of deploy.bat:
:InstallMARINE12
:: Install AVEVA MARINE 12.0 Silently
echo Installing AVEVA MARINE 12.0
if exist "%TEMP%\MARINE12Inst.log" del /Q /F "%TEMP%\MARINE12Inst.log"
call "%~dp0setup.exe" /w /s /f2"%TEMP%\MARINE12Inst.log"
:: Check if installation is okay
findstr /I /C:"resultcode=0" "%temp%\MARINE12inst.log" 1>nul 2>&1
IF "%ERRORLEVEL%" EQU "0" (

echo Installation succeeded

exit /b 0

ELSE (

echo Installation failed

exit /b 1

)

12.03:6© 2007 AVEVA Solutions Ltd
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4 Setting Up the Windows Environment

This chapter describes how to configure the Windows operating system before you run
AVEVA Marine. Following installation of AVEVA Marine, you should perform the following
steps:

• Check the settings for your graphics card: See Graphics Card Settings.
• Ensure the Flexman License Manager daemon is running, and set environment

variables relating to Flexman: See Setting the License File Location.
• Configure Windows parameters for Marine: see Marine Environment Variables.
• You can then run Marine by clicking on the Marine shortcut or icon, which will set up the

remaining environment variables required.

Note: In the following instructions it is assumed that AVEVA Marine has been installed in
folder C:\AVEVA. If it has been installed elsewhere, substitute C:\AVEVA with the
name of the installation folder.

4.1 Graphics Card Settings
You should set your display to a resolution of at least 1024 x 768 and the colour depth to
True colour or 16.7 million colours.

Due to the rapidly changing list of hardware accelerated OpenGL graphics cards
commercially available, an up-to-date list of supported graphics cards, graphics device
drivers and recommended device driver configuration cannot be included in this document.
However, the AVEVA Support Web pages http://www.aveva.com/support contain a current
list of both tested and supported graphics cards, along with advice on configuration of
graphics device drivers.

4.2 Setting the License File Location
Before you can use Marine, you must set up the Flexman license system and connect to the
Flexman License Manager daemon (see the Flexman Installation Guide). A licence file
should be requested from AVEVA Customer Services.

4.3 Marine Environment Variables
AVEVA Marine uses Windows Environment variables to locate folders containing Marine
system files and users project data. This allows you to locate these folders anywhere on the
file system. The location for Marine system files is C:\AVEVA\Marine\OH12.0, unless the
default location was changed during the installation. 
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Marine is supplied with a file evars.bat in the Marine executables folder which sets default
values for the environment variables so that they point to the folder structure as installed. It
also sets the PATH variable to include the PDMSEXE folder containing Marine executables. 

You may need to modify this file to reflect the folder structure of your own installation. The
following is a list of the variables you may need to reset, with a brief description of each one
and the default setting.

Note: That all environment variables must be UPPERCASE.

• Search Paths of Folders Containing Spaces 
Search paths of folders can contain spaces, by using a semicolon as the separator between
folders, for example:

set PDMSUI=C:\Local Marine\Appware;M:\Project Marine\Appware;
a:\Company Marine\Appware

Note: That in order to define an environment variable that contains just one item including
spaces, it must explicitly include a final semicolon. For example:

set PDMSUI=C:\Local Marine\Appware;

• Length of Search Path Environment Variable
The lengths of Marine search path environment variables can be up to a maximum of 5120
characters.

• Recursive Expansion of Environment Variables
An environment variable defining a search path can itself contain references to other
environment variables.  For example:

set MPATH=%ROOT%\Standard Version;%ROOT%\Update Version

set ROOT=C:\Program Files\AVEVA; (note final semicolon)

Then on PDMS:

*$m%MYPATH%\mac

Will check in turn for:

C:\Program Files\AVEVA\Standard Version\mac

C:\Program Files\AVEVA\Update Version\mac

System Environment Variables 

The following environment variables refer to the location of Marine system files.

PDMSEXE Executable folder

C:\AVEVA\Marine\OH12.0\

PDMSEXEMAIN Copy of MarineEXE, but can be a search path
C:\AVEVA\Marine\OH12.0\

PDMSUI Application User Interface folder (PML 1)
C:\AVEVA\Marine\OH12.0\pdmsui
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User Environment Variables 

The following environment variables refer to the location of users Marine folders. Users
must have write permission to these folders.

Project Environment Variables

For each Marine project, ten more environment variables must be set. For example, for a
project ABC:

PMLLIB Application User Interface folder (PML 2)
C:\AVEVA\Marine\OH12.0\pmllib

PDMSDFLTS Applications defaults folder
C:\AVEVA\Marine\OH12.0\pdmseui\dflts

PDMSPLOTS Applications PLOTS folder
C:\AVEVA\Marine\OH12.0\pdmsui\plots

PLOTCADC Pointer to the PLOT executable.
C:\AVEVA\Marine\OH12.0\plot\plot.exe

PDMSHELPDIR Online help data files.
C:\AVEVA\Marine\OH12.0\onlinehelp

PDMSHELPDIR Online help data files.
C:\AVEVA\Marine\OH12.0\onlinehelp

PDMSWK Temporary Marine work file folder
C:\temp

PDMSUSER Application Users save/restore setup area (or the users
'home' folder)

C:\AVEVA\Marine\OH12.0\pdmsuser

PDMSREPDIR Marine Applicationware Report Input and Output folder.
C:\AVEVA\Marine\OH12.0\pdmsui\reports

PDMSDFLTS Applications defaults folder. Note that individual users may
not have permission to change Marine System defaults in
C:\AVEVA\Marine\OH12.0\pdmsui\dflts, but they should
have their own local defaults area. This is achieved by
setting a MarineDFLTS search path, e.g. ‘C:\USERDFLTS
C:\AVEVA\Marine\OH12.0\pdmsui\dflts’.

ABC000 Project database folder

ABCISO Project ISODRAFT options folder

ABCMAC Project Inter-DB connection macro folder

ABCPIC Project DRAFT picture file folder 

ABCDRG Hull drawings

ABCDWG Outfitting drawings
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Marine is installed with sample project data. Marine Project Environment variables for these
projects are set in evars.bat.

4.4 Running Marine from a Command Prompt Window
You can run Marine from a Command Prompt window rather than using the Start/Programs
menu. To do this you must set your PATH variable to include the folder where Marine is
installed.

Windows XP
• Open the Control Panel. 
• Select System, and pick the Advanced tab.
• Click on the Environment Variables button.
• Edit the system variable Path to add the Marine folder (for example,

C:\AVEVA\Marine\OH12.0) to the list of folders in the Path variable.

Once the Path variable includes the Marine folder, you can run Marine by typing marine at a
command prompt.

ABCMAR Project Hull database folder

ABCDIG Diagrams

ABCSTE Stencils

ABCTPL Templates
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5 Running Marine Under Windows

5.1 Spaces in Windows pathnames
To run macros with spaces in the filenames, you must enclose the filename in quotes,
without a leading slash. For example:

$m'c:\Program Files\Macros\space.mac' arg1 arg2

Due to the way in which Marine parses its command lines this format is also recommended
for use with filenames containing Asian characters.

5.2 Linking to Microsoft Excel
You can make your reports load directly into a Microsoft Excel spreadsheet, as comma-
separated files:

• Select Utilities>Reports>Modify from the Marine main menu bar.
• Pick a report template.
• Click on OK: the Modify Template form is displayed.
• Select Options>Other Formats... from the Modify Template form menu bar. This

displays the Report Format form. From this form:
• Choose the CSV option from the Format drop-down list.
• Click on OK: this returns you to the Modify Template form.

• Select the Overwrite radio button.
• For the filename enter %PDMSUSER%/fname.csv (the .csv extension is important).
• In the System command text box enter.
• 'cmd/c “C:\<excel folder>\excel.exe”  %PDMSUSER%\fname.csv'.

where C:\<excel folder> is the location of Excel on your system. Note that it is
necessary to enclose Windows command arguments in double quotation marks if the
argument contains embedded spaces. :\<excel folder>\.

5.3 Windows Parameters
The following setting can be used to improve performance when repositioning forms in
Marine. These are optional Windows Parameter settings.

Windows XP
• Open the Control Panel. Select Display, then select the Appearance tab and click on

the Effects… button. On the form, uncheck Show Window Contents While Dragging
and Show shadows under menus.
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6 Troubleshooting

Here are some suggestions about solving some problems you may encounter when using
Marine under Windows.

6.1 General

6.2 License Manager Errors

Error: The dynamic link library DFORMD.dll could not be found in the
specified path.

Explanation: This is supplied with Marine. Perhaps you have not set your PATH
variable. The PATH setting must include ‘C:\AVEVA\Marine\OH12.0’

Error: STOP.  The application failed to initialise properly (0xc0000135). Click
on OK to terminate the application.

Explanation: This occurs after a number of other errors. The most likely reason is a
problem with the PATH variable.

Error: When you start up lmgrd it says <time> (lmgrd) Can't make folder
C:\FLEXlm, errno: 2 No such file or folder, etc.

Solution: There is no C: drive for the license manager to write to. As the System
Administrator or a Power User, you need to make a shared disk called
C:. This can be done on a networked or non-networked computer.

Within the Windows Explorer’s File menu, create a new folder (e.g.
D:\C_drive) and make it current. Select File>Properties and select
the Share tab. Click on the Shared As: option button and then click
OK.

Then from the Tools menu select Map Network Drive. Select C: from
the Drive: drop-down list in the displayed form and type:
\\hostname\C_drive in the Path box. Then click on OK. (C:)
should now appear in the list of available drives in Explorer

Error: <time> (lmgrd) "<host>": Not a valid server hostname, exiting.
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6.3 Entering Marine

Explanation: The hostname used by AVEVA to create the license file does not
correspond with the computer on which you are running Marine. The
hostname comes from the variable COMPUTERNAME, which you
can obtain by typing 'env|findstr COMPUTERNAME' in a Command
Prompt window. Compare this with the license file contents, and
resubmit if necessary.

Pop-up Mess.: FLEXlm: checkout failed: Cannot connect to license server (-15,
10:10061) WinSock error code.

Explanation: lmgrd has not been started up - see above for details.

Pop-up Mess.: FlexLM: checkout failed: Cannot find license file (-1,73:2) No such file
or folder.

Explanation: lmgrd has not been started up - see above for details.

Pop-up Mess.: FlexLM: checkout failed: Licensed number of users already reached (-
4,132).

Explanation: You have exceeded the permitted number of users specified in your
license file.

Error: (43,9)  Environment Variable not defined for project name.

Explanation: You have not set the environment variable for the project, 
e.g. XYZ000.

Error: (43,1)  Project <xxx> not available!

Error 7 allocating system database.

Explanation: The environment variable for the project does not point to the correct
location. Either the disk and/or folder do not exist or are not readable.

Error: <username> not found. Invalid username or password.

or

Bad Password

Explanation: You are trying to enter Marine without a valid Marine username and/or
password.

Error: PDMSWK environment variable not set.

Solution: Set PDMSWK to c:\temp or some other folder where Marine can
create temporary files.

Error: Error 34 opening variables file.

Explanation: You cannot create a file in the location pointed to by environment
variable PDMSWK.
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6.4 Problems with Graphics

6.5 Troubleshooting the .NET Installation

6.5.1 Version Error

Error: Project <xxx> is pre version 8.

Explanation: This can happen if you have transferred the project from UNIX using
FTP in ASCII rather than Binary format.

Error: Cannot pick certain items in DESIGN 3D shaded views.

Solution: There is probably a problem with the display driver for the graphics
board that you are using. Make sure you have the version of the
display driver recommended on our supported display drivers Web
page.

Error: Incorrect colours.

Solution: Check the setting of your Display. The colour resolution should be set
to ‘True Colour’ or 16.7 million colours.

Error: Graphics speed (for example in 3D views) is poor.

Solution: Check the setting of your Display.

Error: System.IO.FileLoadException: The located assembly's manifest definition
with name 'MarineResources' does not match the assembly reference.

Solution: All .Net assemblies must be the same version. Check
File>Properties>Version Assembly Version on all assemblies is 12.0.0.0
or whatever the current version is.
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6.5.2 Wrappers or a Dependency Missing

6.5.3 No Add-ins

Error: An exception ‘System.IO.FileNotFoundException’ has occurred in
mon.exe. 

Additional information: File or assembly name Wrappers, or one of its
dependencies, was not found.

Solution: All the .NET assemblies are Private assemblies and are installed under
%PDMSEXE% (Assembly Base directory) or a subdirectory below. .NET
loads private assemblies from the base directory of the application. If it
can’t find the private assembly here, it uses the application’s configuration
file called <module>.exe.config to see whether it contains any path hints.
Path hints are stored in the <probing> element. So, for example,
marhdes.exe.config has the following probing path <probing
privatePath="Design" />. This means that Wrappers.dll is loaded from the
subdirectory DESIGN below the application directory. Each Wrappers.dll
depends on the given modules Win32 DLL e.g. DESIGN’s Wrappers.dll
found in the Design subdirectory depends on des.dll. Win32 DLL loading
rules apply here. These are:

• The directory from which the importing component loaded. (i.e. the
DESIGN subdirectory where Wrappers.dll is loaded in the case of
DESIGN)

• The (application's) current directory (where it’s run from)
• The Windows directory (default: C:\Windows) (we don’t install

anything here)
• The directories that are listed in the PATH environment variable

Since the module DLL does not live in the same directory as the
Wrappers.dll then unless Marine is running from %PDMSEXE% the
%PATH% will be used to locate the module DLL. (The Wrappers.dll
subdirectory is effectively is the directory which is first looked in for all the
Win32 DLL’s which Wrappers depends on i.e. <module>.dll, sglNet.dll,
udDNet.dll, º)

Make sure that both %PDMSEXE% and %PATH% point to the root
directory in which Marine is installed.

Problem: Add-ins missing from module

Solution: Add-ins loaded by each module are defined in xml files, as example
below:

<application>addins.xml

If Add-ins are missing, check that these files exist in %PDMSEXE%
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6.5.4 Window Layout

6.5.5 Serialization
Serialization is the process used to store the data - e.g. history stacks, toolbar state - for the
GUI in a .NET environment.

Problem: Window layout is not restored e.g. Add-ins position and/or docked state,
…

Solution: The file <module><version>WindowLayout.xml in the %PDMSUSER%
directory stores this information for the each GUI module. If this file is
deleted then the window layout will return to its default.

Problem: Information is stored per project and per module in the following files in
the %PDMSUSER% directory:

<project><version>Settings.bin 

<module><version>Settings.bin.

Solution: These files may be deleted or transferred between users working on the
same project.
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