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MARS2000 User’s guide Booklet 3 
CALCULATION OF A SECTION 
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个人总结最重要理解： 
           一、概念 
          净规格：扣除了腐蚀要求值 
          总规格：按定义的舱环境增加了腐蚀要求值 
          重算规格：往往要求值变小，不考虑总强度影响，不考虑腐蚀要求值。 
          船舶状态：Project(设计)，As Build（建造），Survey（年检）。 
          关于载荷工况： 

规范的含义是： 
船舶迎浪状态（载荷工况a和b）；船舶横浪状态（载荷工况c和d） 

           二、工作步骤 
                 -BSD船的基本数据（65米下不算总纵强度，即静水波浪弯矩，船体梁等不考虑） 
                          默认：材料ST235（A级钢）用于尾、中、首。 
                 -选本船典型横剖面：分类两个舱壁和剖面（有局部舱壁的可分建剖面和舱壁）。 
                 -总程序中建立剖面和舱壁 
                 -编辑剖面和舱壁：建立命名不同的板架PANEL:龙骨，底部，舷侧,顶，甲板边
板，甲板板。 

-按循序按板架建立节点（并给出类型）。 
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-按板架给定列板strake厚. （注意组概念） 
-按板架按节点(或构件)给定横向型材范围和规格，端部（注意组概念） 
-按板架按节点(或构件)给定纵向型材范围和规格，端部（注意组概念） 
-给出整个剖面所在舱的区间，类型（便于软件强度计算和腐蚀计算）。 
-可以按板架给出压力载荷类型和具体值。 
提示：板架方向指引和构件方向指引。 
没有错误提示（右下脚红色）。即可结束。 

然后就可回到主程序进行RULE计算，了解一些符号的含义。 
 
Chapter 1 : GENERAL COMMENTS 综述 

1.1     MAIN FEATURES主要特色 
The MARSRULE module allows to check a section according to Bureau Veritas Rules for Classification of 

Steel Ships. It checks:按BV钢船规则检查剖面 
•   the strength characteristics of the hull girder,船体梁强度 
•   the scantling of the continuous longitudinal members – strakes and longitudinal ordinary stiffeners,

连续纵向型材（及船底板）规格检查 
•   the scantling of the transverse ordinary stiffeners.横向普通构件规格 

MARSRULE is able to perform calculations in any section all along the ship length. The sections are to be 
defined as described in the booklet ‘Definition of a section’.可以计算任意已定义的剖面 

The module allowing to perform the calculations for a given section is organized around the following 
application: 

 
Figure 1: MARSRULE 

Warning Box: displays warning message when MARSRULE detects incoherence in the Section definition. 
Section View: displays a view of the section. 
1.2     COMPUTE SECTION剖面计算 

When you launch MARSRULE module or you click on the Compute section  button or on Compute 
section on the File menu (Figure 18), the Compute section window is displayed: 
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Figure 2: COMPUTE SECTION WINDOW 

This window allows selecting one or several types of calculation from the following list:各计算分类 
•  Geometric properties.几何属性 
•  Hull girder loads; check of section modulus and inertia.船体梁负荷，剖面模数和惯性矩 
•  Yielding check.屈服强度 
•  Ultimate strength check.极限强度 
•  Plating and longitudinal ordinary stiffeners.板和纵向普通型材 
•  Transverse ordinary stiffeners. 横向普通型材 
•  Structural details (fatigue)结构细节（疲劳） 
•  Replacement thickness.更换厚度 
•  Shear (gross scantling).剪切（整个截面） 

Warning: Rule calculations for dredgers have not yet been implemented.还不能对泥船计算 
Rule options tab规范选择表 

SHEAR FORCE:剪力 
As required by the Rules, the shear stress is taken into account in criteria applied to strakes and 

longitudinal ordinary stiffeners (ships greater than 90 m in length). Consequently, exhaustive rule 
verification assumes that the user has defined a value of design still water shear force. 

If this value is not entered, Mars uses a default shear stress as defined in Rules (ships greater than 90 m 
in length). 

Clicking on Shear Force check box the calculation takes into account the input value of design still water 
shear force. If this value has not been defined (it means, equal to rezo), there is a warning. 

TORQUE:扭矩 
Clicking on Torque check box the calculation takes into account stresses due to torque moment. To do 

that, a torsion model, for which the calculations have been performed and saved into the database, has to be 
selected. 

Load cases (a, b, c, d)载荷状况 
This list allows carrying out the hull scantling calculations for all the load cases (normal rule scantling) or 

only for a particular one, it means: 
•   load case a, 
•   load case b, 
•   load case c, 

船体梁强度 

屈服强度 

规范 

载况对结构 

扭矩 

剪力 

其他 

构件规格 

自选参数 极限强度 

船体梁强度 

横向型材 

结构疲劳 

剪力总规格 

更换厚度 

板和纵向型材 

几何特性 

船舶状态 

船体梁剖面检查 
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•   load case d, 
•   dynamic pressure (resonance due to Roll),横摇共振动压 
•   dynamic pressure (resonance due to Sway).摇摆共振动压 
Ultimate options tab极限选项表 
Choosing the Ultimate strength check calculation it is possible to require calculations based on different 

assumptions. 
The rule calculation is based on: 
•   the net scantling for the section,剖面净规格 
•   the Standard control for “Solution” item,标准控制用于相应的材料特性 
•   the “Fixed horizontal/vertical curvatures ratio” for “Moment” item, with a ratio value equal to zero. 

Following parameters may be tested:采用水平和垂向曲度控制对应弯矩 
•  Solution材料特性 

Elastic ideally plastic behaviour 
Standard control 
Plate failure mode 
Beam-column failure mode 
Flexural-torsional failure mode 
Local (web) failure mode 

•  Moment弯矩 
Fixed vertical bending moment 
Fixed horizontal bending moment 
Fixed horizontal/vertical bending moments ratio 
Fixed vertical/horizontal bending moments ratio 
Fixed horizontal/vertical curvatures ratio 
Fixed vertical/horizontal curvatures ratio 

•  Ratio value比例系数值 
•  Gross scantling calculation check整个构件计算检查 

 

Miscellaneous options tab其他选项表（用户定义指标值检查） 
Clicking on User defined value option button launchs the calculation with the user defined vertical wave 

bending moment, in case of the user has entered correspondinge values in the Main Section data. 
In that case, the section is not evaluated according to the Rules. 

1.3     CONCEPTS概念 
The following section gives some guidance about two concepts widely used in MARS, the net scantling 

and the Elementary Plate Panel. 
1.3.1        Net Scantling净规格 

Depending on the rule criteria, the calculations have to be performed with the gross or with the net 
scantling of the section.按规范标准计算剖面的净规格和总规格 

Gross scantling: hull girder strength criteria (bottom and deck moduli; yielding check) 
总规格计算是按船体梁计算强度标准（船底和甲板剖面模数） 
Net scantling: verification of the scantling of the strakes and ordinary stiffeners, including fatigue 

calculation for structural details; ultimate strength check of the hull girder. 
净规格计算是按列板和普通型材的规格，包括疲劳计算，船体梁的极限强度检查。 
In MARS, Actual Net Scantling refers to a scantling automatically deduced by the program from the 

Actual Gross Scantling.This evaluation, for every stake and every stiffener, is based on the location of the 
considered element in the section and on the attribute “Main destination” of the compartments surrounding 
the element. 

实际规格计算是程序自动从实际总规格计算估算规格进行减少，方法是对每一个列板和每一个型材按相应

位置按主要舱的环境数据进行的。 
The “Main destination” defines the corrosion margin to be applied to the element.定义腐蚀量 

1.3.2        Elementary Plate Panel – EPP单元板架（重要） 
The rule criteria apply to every strake and every stiffener.确定每个列板和型材 
But, even is the approval process has to be performed at the stake level, the calculations are performed 

at a more elementary level, the Elementary Plate Panel which is a unit of plating stiffened on its four sides. 
So, local calculations for plating are always performed E.P.P by E.P.P. The syntheses of calculations are 

made at the strake level.将列板分为不同的列 
We may distinguish two cases: 
PLATING LONGITUDINALLY STIFFENED板纵向型材 
An elementary plate panel (E.P.P.) is the unit of plating bordered by two longitudinal ordinary stiffeners 

and limited by the primary transverse structure.在横向结构里由两个纵向的型材限制的板单元 
To check the strake S2, MARSRULE checks the EPP’s 1,2, 3 and 4. The EPP 1 and 4 are assumed to 



MarsRule 剖面规则计算.doc 

5 / 22 

have the thickness of strake S2. 
But, when checking the strake S3, MARSRULE reuses, as first EPP of the strake S3, EPP 4 with an 

assumed thickness equal to S3 thickness. 
PLATING TRANSVERSALLY STIFFENED板横向型材 
An elementary plate panel (E.P.P.) is the unit of plating bordered by two transverse ordinary stiffeners 

and limited by the primary longitudinal structure. 在纵向结构里由两个横向的型材限制的板单元 
To check strake S2, MARSRULE calculates the large EPP 1 assumed to have an homogeneous 

thickness equal to the thickness of strake S2. 
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Chapter 2 : GEOMETRIC PROPERTIES 几何特性 

Clicking on the Geometric properties button   or on Geometric properties on the View menu (Figure 
19), The user enter the Geometric properties result window: 

  
Figure 3: GEOMETRIC PROPERTIES RESULT WINDOW Figure 4: GEOMETRIC PROPERTIES RESULT WINDOW (HALF) 

The program provides results for Gross scantling and Net scantling.总规格和净规格 
All results except gross area are effective values: it means that, compared to the calculation of gross 

area, the program takes into account mechanical properties as: 总规格为有效 
•   Young modulus: the calculation, is provided assuming an homogeneous material with Young modulus 

equal to: 假设均质材料的杨氏模量等于： 
206.000 N/mm2, for a ship built in steel常用造船钢材材料强度 
70.000 N/mm2, for a ship built in aluminium alloy常用造船铝材材料强度 
Ship built in steel: 
The program corrects the areas by multiplying by the hereunder ratio which takes into account the actual 
Young modulus and c coefficient of the material of the considered plating. 
Actual Young modulus / (206.000 * c) 
Ship built in aluminium alloy: 
The program corrects the areas by multiplying by the hereunder ratio which takes into account the actual 
Young modulus of the material of the considered plating. 
Actual Young modulus / 70.000 
•   Bending efficiency: when strakes and longitudinal stiffeners are defined with a bending efficiency 

different from 100%%, it means that they do not have a full contribution to the overall strength. To take their 
effective contribution into account, the area of these elements is multiplied by the actual value of the bending 
efficiency coefficient. 

Full section tab完整剖面表 
•   Gross area of cross-section : pure geometric calculation 
•   Effective area of cross-section: different from gross area when strakes and longitudinal stiffeners are 

defined with a bending efficiency different from 100. 
Section moduli are calculated:剖面模数计算 
•   at deck (Wp)对甲板 
•   at bottom (Wf)对船底部 
•   at distance Vt from neutral axis中和轴 
A modulus is calculated at a distance Vt from neutral axis in case where there are continuous trunks and 

longitudinal hatch coamings contributing to the longitudinal strength. This Vt value is evaluated in a point 
defined by its coordinates b (Y coordinate) and V1 (distance to neutral axis). This point is the one that leads 
to the maximum value of Vt. 

Half section tab半剖面表 
The results displayed are relevant to the half section only (Fig. 14). 
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Moreover the program prints for the whole section a list of the different types of stiffeners existing in the 
section and a list of thickness with their corresponding length in the section. 
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Chapter 3 : GLOBAL STRENGTH CRITERIA 国际强度标准 

Clicking on the Global strength criteria button or on Global strength criteria on the View menu 
(Figure 19), you enter the Global strength criteria result window 

3.1     HULL GIRDER LOADS船体梁载荷 

 
Figure 5: GLOBAL STRENGTH CRITERIA RESULT  

WINDOW (1) Still water bending moment窗口1为静水弯矩 
The value of the design still water bending moments used to calculate the section are evaluated as 

follows:按以下方法： 
•  Equal+ to local still water moments (builder’s proposal) entered in the module ‘Definition of a section’ 

for the current section, if they have been defined.按定义值加上局部值（用户定） 
•  Otherwise, equal to the values calculated at the longitudinal location of the section according to the 

rule distribution law. The maximum value of this distribution is equal to the still water moments (builder’s 
proposal) entered in the module ‘Basic ship data’ if they have been defined. Otherwise, the program uses the 
rule permissible still water bending moments.按规则计算的总纵强度。都可自定义。 

Wave bending moment波浪弯矩 
Design vertical wave bending moments are basically rule value.按规则 
However if the user has defined values in input process and if he has explicitly required non-rule 

calculation, these value are used and printed out.当然可按自己要求输入。 
3.2     SECTION MODULI剖面模数 

 
Figure 6: GLOBAL STRENGTH CRITERIA RESULT WINDOW (2) 

The global characteristics of a section subject to rule criteria are: 
•  The moduli at bottom, at deck at side and at a distance Vt. 
•  Only for midship section, the moment of inertia of the section about the neutral axis. 
The rule values of modulus at bottom, at deck at side and at a distance Vt are based on design bending 

moments.（按规范计算） 
The program displays a summary allowing comparing the rule values of moduli to the actual values. The 
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red color means that the actual value does not comply with the rule one. 
Even in the case of non-compliance with rules, the actual values are used for the calculations of the local 

rule scantlings. 
3.3     ULTIMATE STRENGTH极限强度 

 
Figure 7: GLOBAL STRENGTH CRITERIA RESULT WINDOW (3) 

3.4     NET/GROSS MODULI净/总模型 

 
Figure 8: GLOBAL STRENGTH CRITERIA RESULT WINDOW (4) 

Local stress calculations are based on the actual net scantling. But, if one of the actual net moduli is 90% 
less then its corresponding actual gross moduli, local stress calculations are based on 90% of the actual 
gross scantling.  

局部应力的计算是基于实际净规格。但是，如果实际净规格模数90％小于相应的实际总

规格值的弹性模量，局部应力计算将基于90％的实际总规格值。 
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Chapter 4 : STRAKES 列板 

Clicking on the Strakes button  or on Strakes on the View menu (Figure 19), you enter the Strakes 
result window: 

 
Figure 9: STRAKES RESULT WINDOW 

4.1     SCANTLING CALCULATION构件计算 
The purpose of this calculation is to check in a given section the actual scantling of strakes contributing 

to the longitudinal strength of the ship.按船的纵向强度检查给定剖面的列板规格 
The window display the results at strake level or in more detailed way for each elementary plate panel 

forming the strake. To highlight the strake anomalies if the actual value of considered result is lower then rule 
value this latter become red. 

4.2     SYMBOLS符号 
Gross frame总构件 

 Actual实际 Rule规则 
Thickness 
厚度 

Gross thickness of the strake. Maximum of Rule thick. Load and Rule Thick. Mini 
added with the corrosion margin of the strake. 

Sig Nor 
常规弯曲 

Normal stress induced by vertical bending 
moments. 

Rule normal stress induced by vertical bending 
moments. 

Tau Nor 
弯曲剪力 

Shear stress induced by vertical bending 
moments. 

Rule shear stress induced by vertical bending 
moments. 

Sig Comb 
组合弯曲 

Normal stress induced by torque and bending 
moments. 

Rule normal stress induced by torque and bending 
moments. 

Tau Comb     Shear stress induced by torque and bending moments. 组合剪应力引起的扭矩和弯矩。 
Rule shear stress induced by torque and bending moments. 

Net frame净构件 
 Actual实际 Rule规则 
Thick. Load 
列板厚度 

Net thickness of the strake. Thickness based on external or internal design 
pressure and on a stress factor depending on the 
overall bending stress. 
It is calculated on each E.P.P. considered by the 
program. The output value of Thick. Load is the 

  Thick. Mini 
最小厚度 

Net thickness of the strake. Minimum rule thickness. Maximum of the values 
calculated on each E.P.P. 

Sigma Buck. 
屈曲应力 

In plane hull girder 
compression normal stress. 
The output value is the one 
obtained on the E.P.P. where 
the ratio Rule/Actual is the 

 

Critical buckling stress based on Euler stress. 
The output value is the one obtained on the E.P.P. 
where the ratio Rule/Actual is the harshest. 
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Tau Buck. 
屈曲剪应力 

In plane hull girder shear 
stress. The output value is the 
one obtained on the E.P.P. 
where the ratio Rule/Actual is 

  

Critical buckling shear stress based on Euler stress. 
The output value is the one obtained on the E.P.P. 
where the ratio Rule/Actual is the harshest. 

Yielding tab塑性强度表 
This tab gives details of the Thick. Load result on the E.P.P. where it is maximized. 

Thick 
厚度 

Thickness based on external or internal design pressure and on a stress 
factor depending on the overall bending stress. 

Load reference 
载荷类型 

Code indicating the corresponding type of loading 
and load case. The possible items of loading are 

  Ps静水压力 Still water pressure.静水压力 
Pw波浪压力 Wave pressure.波浪压力 
SigX1应力 In-plane hull girder normal stress. 平面船体梁压缩正应力 
Tau1剪力 In-plane hull girder shear stress. 平面船体梁剪力 

Load references载况参考 
SEA海水压力 Sea pressure 
LIQ i液体压力 Liquid pressure 
BULK i散装压力 Bulk pressure 
SEALIQ I由于海水和内部液体货物的差压 Differential pressure due to sea and internal liquid cargo 
SEABULK I由于海水和内部的散装货物的差压力 Differential pressure due to sea and internal bulk cargo 
FLOOD I在水浸条件下的压力 Pressure in flooding condition 
Slosh I晃动压力 Sloshing pressure 
Impact i冲击压力 Impact pressure 
Wheel轮压力 Wheel load 
UniCarg均匀干货压力 Dry uniform cargo pressure 
AccDeck居住甲板 Accomodation 

For the code described hereabove the figure i mean: number of the compartment, the data of which are 
used in the calculation of pressure. 
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Chapter 5 : STIFFENERS 纵向型材 

Clicking on the Longitudinal stiffeners button  or on Stiffeners on the View menu (Figure 19), you 
enter the Longitudinal stiffeners result window: 

 
Figure 10: LONGITUDINAL STIFFENERS RESULT WINDOW 

5.1     SCANTLING CALCULATION构件计算 
The purpose of this calculation is to check in a given section the actual scantling of longitudinal 

stiffeners contributing to the longitudinal strength of the ship.纵向型材检查 
To highlight the stiffener anomalies if the actual value of considered result is lower then rule value this 

latter become red.低于规范要求的会显示红色 
5.2     SYMBOLS符号 
Gross frame总构件 

 Actual Rule规则 
Modulus 
剖面模数 

Modulus of the stiffener based on its gross 
scantling. 

 

Sig Nor 
正常应力 

Normal stress induced by vertical bending 
moments. 正常应力引起的垂向弯矩。 

Rule normal stress induced by vertical 
bending moments. 

Tau Nor 
剪应力 

Shear stress induced by vertical bending 
moments. 

Rule shear stress induced by vertical 
bending moments. 

Sig Comb 
组合应力 

Normal stress induced by torque and bending 
moments. 

Rule normal stress induced by torque and 
bending moments. 

Tau Comb 
组合剪应力 

Shear stress induced by torque and bending 
moments. 

Rule shear stress induced by torque and 
bending moments. 

Net frame净构件 
 Actual Rule 
Modulus 
型材模数 

Modulus of the stiffener based on 
its net scantling. 

Modulus based on external or internal design pressure 
and on a stress factor depending on the overall 
bending stress. 

Shear Area 
剪力面积 

Shear area of the stiffener based 
on its net scantling. 

Shear area based on external or internal design 
pressure and on a stress factor depending on the 
overall bending stress. 

Thick. Mini最小厚 Net thickness of the stiffener web. Minimum rule thickness. 
Sigma Buck. 
船体梁正应力压缩最大比值 

In plane hull girder compression 
normal stress.The output value is 
the one obtained for maximal ratio 
Rule/Actual. 
在平面船体梁正应力压缩最大比值规则/实际 

Critical buckling stress based on Euler stress. 
The output value is the one obtained for maximal ratio 
Rule/Actual. 
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Ult. Strength 
极限强度 
船体梁正应力压缩

最大比值规则/实际 

In plane hull girder compression 
normal stress. 
The output value is the one 
obtained for maximal ratio 
Rule/Actual. 

Ultimate strength stress. 
The output value is the obtained for maximal ratio 
Rule/Actual. 

Fat Modulus 
疲劳净模数 

Modulus of the stiffener based on 
its net scantling 

Modulus based on external or internal design pressure 
range and on the overall bending stress range. 

Fat Life疲劳   
Modulus tab计算模数表 
This tab gives details of the net modulus result. 

W 
剖面模数 

Modulus based on external or internal design pressure and on a stress factor depending 
on the overall bending stress. 

Load reference 
载荷类型 

Code indicating the corresponding type of loading and load case. The possible items of 
loading are described hereafter. 

Ps静水压力 Still water pressure. 
Pw波浪压力 Wave pressure. 
SigX1船体梁正应力 In-plane hull girder normal stress. 平面船体梁正应力。 
Spac间距 Spacing of the stiffener. 
Span跨距 Span of the stiffener. 

Shear A. tab剪力表 
This tab gives details of the shear area result. 

S Area 
剪力面积 

Shear area based on external or internal design pressure and on a stress factor 
depending on the overall bending stress. 

Load reference 
载荷类型 

Code indicating the corresponding type of loading and load 
case. The possible items of loading are described hereafter. 

Ps静水压力 Still water pressure. 
Pw波浪压力 Wave pressure. 
Spac间距 Spacing of the stiffener. 
Span跨距 Span of the stiffener. 

Ult. Str. Tab极限强度表 
This tab gives details of the Ult. Strangth result. 

SigU 
极限强度的压力 

Ultimate strength stress. 极限强度的压力 
The output value is the obtained for maximal ratio Rule/Actual. 规则/实际输出值最大比 

Load reference 
载荷类型 

Code indicating the corresponding type of loading and 
load case. The possible items of loading are described 

 Ps静水压力 Still water pressure. 
Pw波浪压力 Wave pressure. 
SigX1船体梁正应力 In plane hull girder compression normal stress. 平面船体梁压缩正应力 
Spac间距 Spacing of the stiffener. 
Span跨距 Span of the stiffener. 

Load references参考载荷 
SEA海水压力 Sea pressure 
LIQ i液体压力 Liquid pressure 
BULK i散装压力 Bulk pressure 
SEALIQ I由于海水和内部液体货物的差压 Differential pressure due to sea and internal liquid 

 SEABULK I由于海水和内部的散装货物的差压力 Differential pressure due to sea and internal bulk 
 FLOOD I在水浸条件下的压力 Pressure in flooding condition 

Slosh I晃动压力 Sloshing pressure 
Impact i冲击压力 Impact pressure 
Wheel轮压力 Wheel load 
UniCarg均匀干货压力 Dry uniform cargo pressure 
AccDeck居住甲板 Accomodation 

For the code described hereabove the figure i mean: number of the compartment, the data of which are 
used in the calculation of pressure. 
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Chapter 6 :  TRANSVERSE STIFFENERS 横向型材 

Clicking on the Transverse stiffeners button  or on Transverse stiffeners on the View menu (Figure 
19), you enter the Transverse stiffeners result window: 

   
Figure 11: TRANSVERSE 

STIFFENERS RESULT WINDOW(1) 
Figure 12: TRANSVERSE 

STIFFENERS RESULT WINDOW(2) 
Figure 13: TRANSVERSE 

STIFFENERS RESULT WINDOW(3) 

6.1     SYMBOLS符号 
Gross frame总构架 

 Actual 
Modulus模数 Modulus of the stiffener based on its gross scantling. 

Net frame净构架 
 Actual Rule 
Modulus 
模数 

Modulus of the stiffener based 
on its net scantling. 

Modulus based on external or internal design pressure and 
on a stress factor depending on the overall bending stress. 

Shear Area 
剪力面积 

Shear area of the stiffener 
based on its net scantling. 

Shear area based on external or internal design pressure and 
on a stress factor depending on the overall bending stress. 

Thick. Mini 
最小厚度 

Net thickness of the stiffener 
web. 

Minimum rule thickness. 

Modulus tab计算模型表 
This tab gives details of the net modulus result. 

W 
剖面模数 

Modulus based on external or internal design pressure and on a stress factor 
depending on the overall bending stress. 

Load reference 
载荷类型 

Code indicating the corresponding type of loading and load case. The possible 
items of loading are described hereafter. 

Ps静水压力 Still water pressure. 
Pw波浪压力 Wave pressure. 
Max 
最大 

Code indicating the position along the stiffener where the ratio Rule/Actual is 
maximal. The possible items of position are described hereafter. 

Spac型材间距 Spacing of the stiffener. 
Span型材跨距 Span of the stiffener. 

Shear A. tab剪切表 
This tab gives details of the shear area result. 

S Area 
剪力面积 

Shear area based on external or internal design pressure and on a stress factor depending 
on the overall bending stress. 

Load reference 
载荷类型 

Code indicating the corresponding type of loading and load case. The possible items of 
loading are described hereafter. 

Max 
最大 

Code indicating the position along the stiffener where the ratio Rule/Actual is maximal. The 
possible items of position are described hereafter. 

Ps静水压力 Still water pressure. 
Pw波浪压力 Wave pressure. 
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Spac型材间距 Spacing of the stiffener. 
Span型材跨距 Span of the stiffener. 

Load references参考载况 
SEA海水压力 Sea pressure 
LIQ i液体压力 Liquid pressure 
BULK i散装压力 Bulk pressure 
SEALIQ I由于海水和内部液体货物的差压 Differential pressure due to sea and internal liquid cargo 
SEABULK I由于海水和内部的散装货物的差压力 Differential pressure due to sea and internal bulk cargo 
FLOOD I在水浸条件下的压力 Pressure in flooding condition 
Slosh I晃动压力 Sloshing pressure 
Impact i冲击压力 Impact pressure 
Wheel轮压力 Wheel load 
UniCarg均匀干货压力 Dry uniform cargo pressure 
AccDeck居住甲板 Accomodation 

For the code described hereabove the figure i mean: number of the compartment, the data of which are 
used in the calculation of pressure. 

Position references参考位置 
Start Start of the stiffener (panel direction) 
End End of the stiffener (panel direction) 
Between Point where the moment is maximal. 
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Chapter 7 : RENEWAL 补充，重查 

7.1     STRAKES列板 

 
Figure 14 : STRAKE RENEWAL RESULT WINDOW 

Thickness frame构件厚度 
Actual Gross thickness of the strake. 
Renewal Maximum of tRi. 
Thickness detailed frame构件详细厚度 

 ti tRi重算 
Minimum最小 Minimum net thickness. Minimum renewal thickness. 
Yielding 
塑性 

Thickness based on external or internal design pressure and 
on a stress factor depending on the overall bending stress. 
外部/内部设计压力和应力因素取决于整体弯曲应力的厚度。 

Renewal thickness of plating 
subjected to lateral pressure 
and wheel loads. 

Buck. Comp. 
压缩屈曲 

Compression buckling net thickness. 
压缩屈曲净厚度 

Compression buckling renewal 
thickness. 

Buck. Shear 
屈曲剪力 

Shear buckling net thickness. 屈曲剪力净厚度 Shear buckling renewal 
thickness. 

7.2     LONGITUDINAL STIFFENERS纵向型材 

 
Figure 15 : STIFFENER RENEWAL RESULT  
WINDOW Thickness frame框架厚度 
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 Actual Renew 
Web thick Actual web thickness Renewal web thickness. 
Flange thick Actual flange thickness Renewal flange thickness. 

Thick Dat tab厚度数据表 
 Web Flange 
%   
Buck   
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Chapter 8 : STRESSES 压力 

Clicking on the Stresses button  or on Stresses on the View menu (Figure 19), you enter the Stresses 
result window: 

 

 
Figure 16 : STRESSES RESULT 

WINDOW 
The distribution of stresses is calculated for unitary internal forces using the geometry of the section. The 

actual stresses are obtained by multiplying the unit stresses by the value of the internal forces stored for each 
loading conditions. 

The stress display are induced by: 
•  Vertical Shear Force;垂向剪力 
•  Horizontal Shear Force; 水平剪力 
•  Saint Venant torque; 圣文南扭矩 
•  Warping torque;扭曲扭力 
•  Warping moment.扭曲弯具 

When you click in the section view the window shows the value for the selected segment in Start and End 
fields. 
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Chapter 9 : RATIO 比例系数 

Clicking on the Ratio button  or on Ratio on the View menu (Figure 19), you enter the 
Ratio result window :可以输入你的选择 

 
Figure 17 : RATIO RESULT WINDOW 

This window allows to select one or several types of ratio from the following list : 
•  Hull girder strength.船体梁强度 
•  Local strength – Strakes.局部强度-列板 
•  Local strength – Stiffeners. 局部强度-型材 
•  Local strength – Transverse stiffeners. 局部强度-横向型材 
•  Corrosion.腐蚀 
Here after the different type of ratio available for each item.每个条款可以给出不同的比率系数 

Hull girder strength桁材强度 
•  All 
•  Sigma西格玛希腊字母表的第十八字母(∑,σ) 

Local strength – Strakes载荷强度船底板 
•  All 
•  Thickness Load载荷厚度 
•  Thickness Mini最小厚度 
•  Buckling – Normal stress屈曲应力 
•  Buckling – Shear stress屈曲剪应力 

Local strength – Stiffeners载荷强度-型材 
•  All 
•  Thickness Load 
•  Net modulus 
•  Net shear area 
•  Buckling – Normal stress屈曲强度 
•  Ultimate strength极限强度 
•  Thickness Mini最小厚度 
•  Fatigue疲劳 

Local strength – Transverse stiffeners载荷强度-横向型材 
•  All 
•  Net modulus净模数 

•  Net shear area静剪力 
•  Thickness Mini最小厚度 

Corrosion防腐 
•  Corrosion addition腐蚀增量 
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Chapter 10 :   MAIN FEATURES 主要特色 

10.1   MENU菜单 
File Menu文件 

It allows to launch the calculation, to print and to quit MARSRULE. 
Figure 18 : FILE MENU 

Item Use Shortcut 
Compute section allows to set calculation options (see 1.3).  
Print Results… prints the calculation results (see 1.4.1). Ctrl + P 
Print Drawing… Prints a drawing of a section (see 1.4.2).  
Export…   
Quit Quits MARSRULE to return to MARSHELL. Ctrl + Q 
View menu视图 

It gathers the results from calculation. 

 
Figure 19 : VIEW MENU 

Item Use Shortcut 
Geometric properties displays the geometric properties results window (see 2).  
Global strength criteria displays the Hull girder strength criteria results window (see 3).  
Strakes displays the Strake results window (see 4).  
Stiffeners displays the Stiffener results window (see 5).  
Transverse stiffeners displays the Transverse stiffener results window (see 6).  
Stresses displays the Stresses results window (see 7).  
Ratio displays the Ratio results window (see 8).  
Plot hull girder ultimate strength displays the Hull girder ultimate strength results window (see 9).  

 
Figure 20 : CHECK MENU 
Item Use Shortcut 
Materials displays the strakes and stiffeners with a different color for each material.  
Bending Efficiencies displays the strakes and stiffeners with a different color for each bending 

efficiency. 
 

Span (see Figure 21)  
Thickness displays the strakes with a different color for each thickness.  
Longitudinal stiffeners (see Figure 22)  
Positions Codes displays the segments with a different color for each position code.  
Transverse stiffeners (see Figure 23)  
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Figure 21 : SPAN SUB-MENU 
Item Use Shortcut 
Spacing of primary 
transverse structures 

displays the strakes with a different color for each span.  

Effective Span displays the strakes and stiffeners with a different color for each span.  

 
Figure 22 : LONGITUDINAL STIFFENERS SUB-MENU 

Item Use Shortcut 
Stiffeners scantling displays the stiffeners with a different color for each stiffener scantling.  
Bracket scantling displays the brackets with a different color for each bracket scantling.  
Bracket length displays the brackets length.  
Span reduction displays the span reduction.  

 
Figure 23 : TRANSVERSE STIFFENERS SUB-MENU 

Item Use Shortcut 
Stiffeners scantling displays the transverse stiffening zones with a different color for each scantling 

of those transverse. 
 

Stiffeners spacing displays the transverse stiffening zones with a different color for each spacing 
of those transverse. 

 

Tools menu :工具菜单 

 
Figure 24 : TOOLS MENU 
Item Use Shortcut 
Display always… allows to set drawing preferences.  
Preferences… displays a set up window for the drawing preferences on the screen or a 

printer. 
 

Zoom allows to zoom in (see 10.3).  
Refresh section refreshes the screen in case of display anomalies. F9 
Previous panel changes the current panel to the previous one. F5 
Next panel changes the current panel to the next one. F6 
Copy to clipboard Allows to paste the section drawing in any other application Ctrl + C 
Debug Occurs on panel displays occurrence attributes for one panel in the section.  
View File EPP displays yielding values for all the Elementary Plate 

Panel in the section. 
 

View File Stiff displays modulus values for all the stiffeners in the section.  
View Ultimate Strength displays Ultimate strength values for all the stiffeners in the section.  
Debug EPP on panel displays Elementary Plate Panel attributes for one panel in the section.  

10.2   MENUS PRINTING打印菜单 
10.2.1      Printing data打印数据 

Clicking on  or on Print Results… on the File menu (Figure 18) or pressing Ctrl + P, you enter the 
Print Results management window : 
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Figure 25 : PRINT RESULTS MANAGEMENT WINDOW 

This window allows you to select what you want to print. The All (None) button selects (deselects) all the 
items of the list. 

Front page produces the cover page of a report. 
10.2.2      Printing drawing打印图 

Clicking on Print Drawing… on the File menu (Figure 18), you enter the Print Drawing management 
window : 

 
Figure 26 : PRINT DRAWING MANAGEMENT WINDOW 

This window allows you to select which item will be printed on the item. 
The Normalized scale check box will make the drawing printed with a regular scale (e.g. 1/50, 1/100,…). 

10.3   ZOOM视窗 
It is possible to Zoom in on or out of the Section view thanks to the Zoom Toolbar: 

 
Figure 27 : ZOOM TOOLBAR 

A first click on the Zoom button (Figure 27) or on Zoom on the Tools menu (Figure 24) changes the cursor 

in  and allows you to zoom in the section view by simple click on it. 
A second click on the Zoom button (Figure 27) or on Zoom on the Tools menu (Figure 24) changes back 

the cursor in  and allows you to work on your zoomed section view. 
To zoom out of the section view, you can : 
•  click on the No Zoom (1:1) button (Figure 27) to bring back the view to the initial size. 
•  right-click on the section view when the Zoom button is down. 
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