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CALCULATION OF A BULKHEAD ARRANGEMENT
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Chapter 1 : GENERAL COMMENTS £gid
1.1 CONCEPTSH&

BhaRule is able to perform calculations in any bulkhead all along the ship length. The bulkheads are to be
defined as described in the booklet “Definition of a bulkhead arrangement”.

Local calculations are based on the net scantling of the section. This net scantling is evaluated from the
main destination of each compartment.

An elementary plate panel (E.P.P.) is a subdivision of plate bordered by primary stiffeners, ordinary
stiffeners and bulkhead bounds.

Local calculations for plating are always performed by E.P.P. As strakes can be divided in E.P.P.,
syntheses of calculations are made to the strake level.

When a welding joint is located between two stiffeners, the E.P.P. belongs to both jouxting strakes. But it is
calculated twice, each time with the thickness of one of the two strakes.

1.2  MAIN FEATURES:E 4

The BhaRule module performs, for plates and ordinary stiffeners located on a transverse bulkhead, rule
calculations according to Jap Rules and Regulations for classification of Steel Ships.

All the calculations carried out by this module which is explained in this booklet, are relative to the
bulkhead arrangement which has been selected in MarsShell.

The module allowing to perform the calculation for a given bulkhead arrangement is organized around the
following application:

& BhaRule - Bulkhead from Midship STIF/bulk full:DB void MEE

WEMUS —Fle Bulkhead Arangement Check Took Options Help

) Display always
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@ [~ Secondary stifeners
| [™ Strakes
@ [" Camugation
i
T -
BULKHEAD ARRANGEMENT VIEW WARKING BOX

Figure 1 : BHARULE
Warning Box : displays warning message when BhaRule detects incoherence in the Bulkhead
arrangement definition.

Bulkhead Arrangement view : displays a view of the bulkhead arrangement.
1.3 COMPUTE BULKHEAD ARRANGEMENTIEBEEME

When you launch BhaRule module or you click on the Compute bulkhead arrangement button —’I or
on Compute bulkhead arrangement on the File menu (Figure 2), the following window is displayed:
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Compute Bulkhead Arrangement

— Compute
Az built section |
B Rules Ed:
Fehruar, 2000
Compute : — Options
—HULL SCAMTLING ————— Load cases (a.b.c.d) for hull scantling :
All cases -
V¥ Plate J
¥ Ordinary stiffeners Select bulkhead to calculate
1-BaLLAST TAMNK CENTE
2-DEBE BALLAST TAMNEK Al
—MISCELLAMEDS —— — v 3 - CARGO HOLD
¥ Beplacementthickness Hone |
Ok Cancel |

Figure 2 : COMPUTE BULKHEAD ARRANGEMENT WINDOW

This window allows carrying out the hull scantling calculation. It is possible to require calculations for only

plates or only stiffeners (by default both of them).
OptionsiEIn

It is possible to require calculations for all the load cases (default value) or for only one of these (e.g. case
a, case b,...).

Moreover, it is possible to select all the Bulkhead : |1 -tank =l
bulkheads of the bulkhead arrangement (default )

 E.P.F.
or only some of them. The. All (None) bytton - Suile Case
selects (deselects) all the items of the list. _ Gross
Thickness (mmj} 20.50 17 96 I
Chapter 2 : STRAKE RESULTS fRJEHR
(BB SR Net
i 19.50 16.96 [b
Clicking on Strakes button ﬁl or on Thick. Load (mm)
Strakes on Bulkhead Arrangement menu (Figure | Thick. kdini {rarm} 13.50 5.37
3), you enter the Strake results window:
Figure 3: STRAKE RESULT WINDOW
2.1 SCANTLING CALCULATION#IA% it
A _ o _ wielding | Data
The purpose of this calculation is to check in
a given bulkhead the actual scantling of strakes. —_——
Thick. 1696 frm) LI bk

The window display the results at strake
level or in more detailed way for each ps 14867 pwr 23.04 (KM
elementary plate panel forming the strake. To
highlight the strake anomalies if the actual value
of considered result is lower then rule value this
latter become red.

2.2 SYMBOLSH5 < I Strake M- 1 - |
Gross frame R EE
Actual Rule

Thickness | Gross thickness of the strake.| Maximum of Rule thick. Load and Rule Thick. Mini added with
the corrosion margin of the strake.

Net frame 5%

Actual Rule

Thick. Load |Net thickness of the strake. [Thickness based on internal design pressure.

It is calculated on each E.P.P. considered by the program. The
output value of Thick. Load is the maximum one.
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Thick. Mini |Net thickness of the strake. |[Minimum rule thickness. Maximum of the values calculated on
each E.P.P

Yielding tab J& IR3E 2

This tab gives details of the Thick. Load result on the E.P.P. where it is maximized.

Thick Thickness based on internal design pressure.

Load reference | Code indicating the corresponding type of loading and load
case. The possible items of loading are described hereafter.

Ps Still water pressure.
Pw Wave pressure.
Load references# &%
LIQi Liquid pressure
BULK i Bulk pressure
Slosh | Sloshing pressure
Impact i Impact pressure

For the code described hereabove the figure i means: number of the compartment, the data of which are
used in the calculation of pressure.

Chapter 3 : STIFFENER RESULTS &iff 455

Clicking on Stiffeners button ﬂl or on Stiffeners on Bulkhead Arrangement menu (Figure 3), you enter
the Stiffener results window:

BEBulkkhead : |1 - tank --|
A ctald Ful= Case
— [Eross
Fodulus I 1.85 E4I I
— Mlet
FAccdulus 1.71 E4A| s91312 Ib
Shear Srea. 435 .85 5911 Ib

FAodulus I Shear.ﬂnreal Datal

oy BEEEERE Lic 1 b
o= EEEEE [ [ 16.37| (R
P = —

Spac W Span Iw )

< I I St P
Figure 4 : STIFFENER RESULT WINDOW
3.1 SCANTLING CALCULATION#M &
The purpose of this calculation is to check in a given bulkhead the actual scantling of Stiffeners.
To highlight the stiffener anomalies if the actual value of considered result is lower then rule value this
latter become red.
3.2 SYMBOLSf%

Gross frame @ #ik
Actual Rule
Modulus Modulus of the stiffener based on its gross scantling.
Net frame i
Actual Rule
Modulus Modulus of the stiffener based on its net scantling. |[Modulus based on internal design pressure.
Shear Area [Shear area of the stiffener based on its net Shear area based on internal design pressure.
scantling.

Modulus tab®R fiff &
This tab gives details of the net modulus result.
w Modulus based on internal design pressure.
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Load reference | Code indicating the corresponding type of loading and load case.
The possible items of loading are described hereafter.

Ps Still water pressure.

Pw Wave pressure.

Max Code indicating the position along the stiffener where the ratio Rule/Actual is maximal.
The possible items of position are described hereafter.

Spac Spacing of the stiffener.

Span Span of the stiffener.

Shear A. tabE] Jy

This tab gives details of the shear area result.

S Area

Shear area based on internal design pressure.

Load reference

Code indicating the corresponding type of loading and load case.
The possible items of loading are described hereafter.

Max Code indicating the position along the stiffener where the ratio Rule/Actual is maximal.
The possible items of position are described hereafter.

Ps Still water pressure.

Pw Wave pressure.

Spac Spacing of the stiffener.

Span Span of the stiffener.

Load references %84

LIQi Liquid pressure — Ratio —
BULK Bulk pressure ILc\caI strength - Strakes j

Slosh | Sloshing pressure & 1
lmpaCt ! ImpaCt pressure " Thickness Load 0.975

For the code described hereabove the figure i mean: number of the
compartment, the data of which are used in the calculation of pressure.

i Thickness Mini

Position references %A1 B

Start Lower position on the span.
End Upper position on the span.
Between Point where the moment is maximal.

Chapter 4 : RATIO RESULTS e &%

Clicking on Ratio button ﬁl you enter the Ratio results window:

Figure 5: RATIO RESULT WINDOW

The window allows to select one or several types of ratio from the

following list:

* Local strength - Strakes.

* Local strength - Secondary.

* Hereafter the different type of
ratio available for each item:

Local strength — Strakes & 5 -
REJEAR (BB

e Al

® Thickness Load

* Thickness Mini

Local strength - Stiffeners# &
Ji-gith)

e Al

* Net modulus

* Net shear area

Chapter 5 : RENEWAL
RESULTS EH &R

Clicking on Renewal E button
you enter the Renewal results
window.

51 STRAKESHMER (Fitk)

BOEL I NEE

Bulkhead :

T Stiffenar

— T hickness

Acctual () 20.50
Feaenewal (rmrm) 14.37
— T hickness cdetailed
ti T
FAirnirmurm (rmmd 5.37 5.09
~ielding () 16 .96 14.37
Crat= I
Corrosion RMargin (il 1.00
Thick. et Crmimd 19.50

< | |

Stralke -7 1
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Figure 6 : RATIO RESULT WINDOW (1)

Thickness frameE &

Actual Gross thickness of the strake.

Renewal Maximum of tRi.

Thickness detailed frame 4155
ti tRi

Minimum Minimum net thickness. Minimum renewal thickness.

Yielding Thickness based on internal Renewal thickness of plating subjected to lateral pressure.
design pressure.

5.2 LONGITUDINAL STIFFENERS [a] B4

BEulkhead : |1 —tank

T Strake

Thickness
Actual Fenaew
e b thick (rmrad 19.68 o.0a
Flange thick (rmm) 17.00 a.oo
Data | Thick Det|
[ =

Corrosion RMargin Crmrmd

F==0 0 e A |

< |

WINDOW (2) Thickness frame
Actual

Actual web thickness
Actual flange thickness

Figure 7 : RATIO RESULT

Renew

Renewal web thickness.
Renewal flange thickness.

Web thick
Flange thick

Thick Dat tab

Web | Flange
% Opet.. Cirl+0
Buck Compute Bulkhead Arrangement
Print Data... Clrl+FP
Chapter 6 : GENERAL FEATURES &N Print Drawing...
6.1 MENUS3H® Quit Chl+3
File Menu

It allows to manage the sections (save, open), to print and to quit MARSIN.
Figure 8 : FILE MENU

ltem Use Shortcut

Open.. opens an existing bulkhead. Ctrl+ O

Compute Bulkhead allows to set calculation options (see 1.3).

Arrangement

Print Data... prints the data of the bulkhead (see 1.4.1). Ctrl + P or

Print Drawing... prints a drawing of a bulkhead (see 1.4.2).

Quit Quits BHARULE to return to MARSHELL. Ctrl+ Qor

Edit Menu Bulkhead Arrangement

It gathers the results from calculation.

Stakes
Ordinary Stiffeners

Figure 9 : BULKHEAD ARRANGEMENT MENU
Ratio

Benewal

| Shortcut

| Item | Use
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Strakes

displays the Strake results window.

Stiffeners

displays the Stiffeners results window.

Check menu

It includes checking tools.

Strakes
Figure 10 : CHECK MENU Thickness _ Stifteners
Secaondary Stiff. szantling
em Use Shortcut
Materials - Strakes displays the strakes with a different color for each
material.
Materials - Stiffeners displays the stiffeners with a different color for each
material.
Thickness displays the strakes with a different color for each
thickness.
Secondary Stiff. scantling | displays the secondary stiffeners with a different color
for each stiffener scantling.
Tools menu :
Tools
£00m
Prewiouz bulkhead Fh
Hest bulkhead F&
Wiew File EPP
Wiew File Sff
Figure 11 : TOOLS MENU
Item Use Shortcut
Zoom allows to zoom in (see 6.3).
Previous bulkhead changes the current bulkhead to the previous one. F5
Next bulkhead changes the current bulkhead to the next one. F6
View File EPP displays yielding values for all the Elementary Plate Panel
in the bulkhead.
View File Stiff displays modulus values for all the stiffeners in the
bulkhead.
Options menu
Preferences...
Refrezh drawing F3
Figure 12 : OPTIONS MENU
ltem Use Shortcut
Preferences... displays a set up window for the drawing preferences
on the screen or a printer.
Refresh drawing refreshes the screen in case of display anomalies. F9

o2, TRINTING
621 nn ata
Printing data Erint : &ll | ﬂDﬂel Options | Miscellaneous |
Clicking on %l or WEFront page _
on Print Data... on ] Shrakes Brirter : IHF' Lazenlet 5/50 j
the File menu | | Stiffeners
(Figure 8) or Start page I1
pressing Ctrl + P, Margins
you enter the Print
Data management Left [cm): |2-B —
window : e recectd
Eoattom [cm]: |1 2 | Eromaete
F I_:_Page 1
Foot [cm) : II:I_B EF —
Fant: [4ial =l o
Ok Presview LCancel |

6/7



BhaRule fiBEA & o 5

Figure 13 : PRINT DATA MANAGEMENT WINDOW
This window allows you to select what you want to print. The All (None) button selects (deselects) all the
items of the list.
Front page produces the cover page of a report.
6.2.2 Printing drawing

Clicking on Print Drawing... on the File menu (Figure 8), you enter the Print Drawing management window :

|Ordinary Stiffener

i i v
Frinter Mormalized scale W

[HP 5/5M =

—Plot:

V¥ Az

¥ Stools " Secondary stiffeners

I Modes [~ Strakes

[~ Mode numbers I™ Corrugation

™ Primary stiffeners

|BhﬁRuIe viD |SINAN ATASOY |39135
|1 8702700 |Elu|khead fram 39136 |>< =42.28m

Caneel | [~ Preview

Figure 14 : PRINT DRAWING MANAGEMENT WINDOW
This window allows you to select which item will be printed on the item.
The Normalized scale check box will make the drawing printed with a regular scale (e.g. 1/50, 1/100, ...).

6.3 ZOOM
It is possible to Zoom in on or out of the Section view thanks to the Zoom Toolbar :

ZO0OM —0
Bh—NO ZOooM(1:1)

Figure 15 : ZOOM TOOLBAR
A first click on the Zoom button (Figure 9) or on Zoom on the Tools menu (Figure 5) changes the cursor in

and allows you to zoom in the section view by simple click on it. A second click on the Zoom button
(Figure 9) or on Zoom on the Tools menu (Figure 5) changes back the cursor in % and allows you to work
on your zoomed section view. To zoom out of the section view, you can :
* click on the No Zoom (1:1) button (Figure 9) to bring back the view to the initial size.
* right-click on the section view when the Zoom button is down.
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