
结构建模 

 
结构建模 
 
程序组成 
结构建模分为四部分程序： 

１．Beams & Columns 

２．Panels & Plates 

３．ASL Modeller(Access,Stairs and Ladders) 

４．Walls & Floors 

 
型钢及型钢等级 

 
PDMS内置了国外很多国家的型钢标准库，称为型钢等级 Profile Specification。 

 

以型钢的中心对齐 

定位线，出图时画成虚线

与其他梁中心连接 
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型钢的连接 

两个型钢的连接会产生一个 SJOI (Secondary joint)，而 SJOI从属于 SNOD 
（Secondary Nodes）。 

 
练习一：生成项目管理层 
1． Creat>Site，命名为 STABILIZER。Position>Explicitly修改 SITE的标高为 UP 

100000mm。 

2． Creat>Zone,生成以下四个层次，注意它们是同一层次。 

ZONE /EQUIP.ZONE 

ZONE /PIPE.ZONE 

ZONE /STEEL.ZONE 

ZONE /CIVIL.ZONE 

 

结构模型的层次及层次设置 

 
练习中的用到的层次设置： 

ZONE STEEL.ZONE 

STRU  EQUIPRACK     设备框架 

FRMW   EQUIPRACK/MAIN   主框架 

SBFR EQUIPRACK/MAIN/COLUMNS 

SBFR EQUIPRACK/MAIN/BEAMS 

 

SBFR EQUIPRACK/ACCESS/BEAMS 挑梁 
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STRU PIPEWORK      管廊 

FRMW   PIPEWORK/MAIN 

SBFR PIPEWORK/MAIN/COLUMNS 

SBFR PIPEWORK/MAIN/BEAMS 

 

FRMW   BRACING-NORTH   斜撑 

SBFR BRACING-N 

FRMW   BRACING-SOUTH 

SBFR BRACING-S 

ZONE EQUIPRACK/ACCESS     设备框架附件 

STRU EQRACK/7M-STAIR    上层斜梯 

STRU EQRACK/5M-STAIR    下层斜梯 

STRU EQRACK/7M-FLOOR    上层平台 

STRU EQRACK/5M-FLOOR    下层平台 

 
练习二：生成设备框架 
框架的数据和型钢的大小请参考图集。 
1． 选择梁柱模块 Design>Structure>Beams & column。 

2． 确认在结构分区 STEEL.ZONE下面。 

3． Creat>Structure⋯命名为 EQUIPRACK。 

4． Creat>Framework⋯命名为 EQUIPRACK/MAIN。是设备主框架。 

5． Creat>SubFrame命名为 EQUIPRACK/MAIN/COLUMNS。用于存放主框架的柱子。 

6． Creat>SubFrame命名为 EQUIPRACK/MAIN/BEAMS。存放主框架的横梁。 

7． Creat>Section>Specials在 Secion Creation列表中选择 2.Regular Structure。 

8．在弹出的对话框中首先要确定柱子（COLUMN）的存放位置。在 Member List中定位

在 SBFR  EQUIPRACK/MAIN/COLUMN，在对话框的 Storage area栏中键入 CE，表示在

MemberList中的当前元素。回车后，出现全称。

 

回车后，

出现全称

９．点取 Profile按钮，选择柱子使用的型材。 
10．设置框架梁的存放位置及使用的型材。注意：梁的对齐方式为顶对齐 TOS。 
11．框架的西南角起点坐标为W314200 N292990 U0。 
12．填入东（EAST）方向的起点坐标和跨距。 
13．填入北（NORTH）方向的起点坐标和跨距。 
14．填入两层框架的绝对标高。 
15．选择 Trim sections to plines。修剪两柱的连接处 
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SITE的标高
为 100000米

框架的西南角起点坐

标为W314200 
N292990 U0 

其余的输

入跨距 

16．填完的对话框如图。Preview预览没问题后 Apply，生成框架。Limits>drawlist可
以看到全部。 
 
平台 
平台包括以下几种类型 
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    Corner       Rectangular 

  
        Return Access 

     Walkway  

Floorplate 

 

Round  

护栏连接形式 
 

 

  

 

    Ball Joint (Default)         Tee Joint Cone Joint 
 
练习三：生成框架平台 
1. 选择梯子平台模块 Design>Structure>ASL Modeller…。 
2. 生成梯子平台管理层 ZONE  /EQUIPRACK/ACCESS。 
3. Creat>Platform>Rectangular>On ID section。生成 7M平台。 
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４． pply后，根据提示依次选择北，南，东，西方向的横梁。 

 
练习四：生成 5M平台 
 
练习五：生成顶部平台挑梁 
1． 返回到 Structure>Beams & column。 
2． 设置挑梁的型钢规格。选择左面的图标。 

设置挑梁的型钢规格与框架的横梁规格一致，顶对齐。完成后如下图： 

2．确认在 FRMW  EQUIPRACK/MAIN这一级。Creat>Sub frame…生成一个子集。
SBFR EQUIPRACK/ACCESS/BEAMS 
3． Creat>Section>straight…在 Section  string methor中选择 Continuous。 

4． 在 positioning control type中选择 Element。 选择框架柱子的上端，自动会捕捉到柱
子的端点，并在端点处提示 start点。 

5． 第二点采用极坐标方法生成，在 Creat Option 中选择按钮 

输入终点方向和距离，自动生成一段梁。可以连续生成。 
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练习六：生成中间回廊挑梁 
在上面的第 4步中设置捕捉交点。 

然后选择柱子和横梁，它们的交点自动成为起点。 
 
练习七：生成回廊平台 
护栏的修剪方法见《Accessways,Stairs&Ladders Application User Guide》第７节 

 
斜梯 
有两种类型的斜梯，缺省的参数设置见 Setting>Default。 

练习八：生成 5-7M斜梯 
1． 选择梯子平台模块 Design>Structure>ASL Modeller…。 
2． 确认当前元素是 ZONE  EQUIPRACK/ACCESS。 
3． Creat>stair>bottom flight>height&length。命名为 5-7M.STAIR，方向为 N。不用给
出精确坐标，通过参考点可以定位。 
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定位点(Origin)在斜梯底端。但为了定位方便，程序在斜梯顶端通过计算得到一个参考
点 Reference point，可以通过参考点定位 
4．Connect>Reference point。选择 BOX侧面的 Ppoint作为定位点。 
 
练习九：生成 0-5M斜梯 
国外的设计规范中，斜体的踏步不允许超过 18级，0-5米的斜梯时 21级台阶，所以要
修改缺省的参数设置 Setting>Default。 
 
练习十：生成直梯 
1． Creat>Ladder>FrontExit。其他类型的直梯见参考手册。 

 
练习十一：管廊 
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1． 生成管廊数据库层次。 
2．生成 3层管廊。 
 
练习十二：延伸 Extend 
1． 选择要延伸的柱子。 
2．Position>Extend>By…。选择柱子的延伸点（Start还是 End）和延伸距离。 

 
练习十三：生成及拷贝管廊挑梁 
1． 生成一个挑梁 
2． 拷贝生成。Creat>Copy>Offset。 
3． 选择菜单 Offset>From Element>To Element。自动测量出偏移的距离。 
4．重复上一步，共生成 4个挑梁。 
 
练习十四：延伸与修剪 
1． 选择要延伸的柱子。 
2．Position>Extend>Through…。 

3．Cursor>Element。选择延伸面。Plane Direction是法线方向。 
4．修剪。Connect>Trim to Section>Pick。选择需要修剪的梁，然后按 Esc键。 
 
练习十五：斜撑 Bracing 
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1． Creat>Section>Bracing configuration。选择保存区域，型钢规格及斜撑类型。 

 
分割 Splitting sections 
分割有三个选项： 

 
初始状态 
一个连续的梁穿过柱子 
 

 

 

１．修剪分割 Trimmed split sections 

这种情况下一般的选择是修剪（trimmed），梁的端点在柱子最外侧
的 p-line上。自动生成连接关系。 

 

２．点分割 Nodes split sections 

在 node点上分割横梁，自动生成连接关系。 

 

３．None 
类似于第二个选项，在 node点上分割横梁，自动生成连接关系。 
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生成报告 
Utilities>Reports>Run选择 steel_mto.tmp 

 

 

 

 

 

 

 

定位控制 Positioning Control 
 

用途 
在事件驱动图形模式下（event-driven graphics mode ）当你需要选取一个定位点的时
候，定位控制对话框会自动出现。他能帮助用户在设计中快速定位。

  
输入

坐标

 类型 输入栏选项 

 
类型： 
在光标选择时，控制那一类的元素响应光标的选择。同时被选中的元素在图形中高亮

显示，在状态行中显示详细信息。 
类型中的选项包括:  

Any  任意的元素，aid， pline或是 p-point。 
Element 元素的定位点，对于型钢来说，是 start和 end点。 
Aid 辅助线。 
Pline 型钢的 plines线。 
Ppoint P-points 或者 panel 的定位点（vertices）。 
Screen 屏幕中的任意一点，在图中得到的是二维点，纵深点
来源于当前的工作平面。 

Graphics 任意的图形元素。 
 
选项 
决定了在光标选择了元素后定位点如何确定。 

Snap   捕捉到靠近拾取点的最近点。对于型钢来说，意味着最近的
start或 end点。 
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Distance   在输入栏中输入数值，光标能拾取到距最近捕捉点给定距离的
点。负值则向相反方向。 

Mid-Point  光标拾取到中心点。 

Fraction 在输入栏中输入分割份数，光标捕捉到最近的分割点。 

 

 

 

 

Proportion   在输入栏中输入分割比例，光标捕捉到最近的分割点。例如
0.25 。  
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Intersect 两个元素的交点。 

 
 
 
 
 
 
 
 

 
 
 
 
Cursor 光标在元素上拾取的任意一点。 

 
练习十七：组 LIST 
1．点取 Creat Lists按钮，弹出 List/Collections对话框。 

 
2． Add->List，键入描述为 A。 
3． 在Member List中定位到设备框架柱子 

SBFR  EQUIPRACK/MAIN/COLUMNS。 
4．Add->CE members，完成后关闭对话框。

 
 
练习十八：修改型钢截面形式 
将设备框架柱子截面形式改成混凝土形式。 
1． Modify->Sections->Specification…,在屏幕中选择一个柱子，弹出对话框。 
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选择
LIST 

2． 选择 LIST，然后将型钢截面改成混凝土形式 Concrete Sections。 
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练习十九：板 Panel 
1． 切换模块 Design->Structures->Panels&Plates。 
2． 在导航器中定位在 SBFR   
3． Creat->Panels。 
 

 
 
P-line Rules 

Pline rules describe how two sections are to be connected together. They 
also decide which P-lines will be visible and available for positioning of 
fittings, penetrations etc. 

 

NA

RTOTOSLTO

NAL NA

BOS

LBT

LBO

LTB RTB

RBO
RBT
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The most commonly used P-line rule is: pkey eq 'NA' or CCON eq 
'ANY' The rule makes P-line ‘NA’ and all the P-lines with the CCON 
attribute set to ‘ANY’ feasible for connections and snapping. According 
to the figure above: TOS, BOS, NAL and NAR have CCON set to ‘ANY’. 
This rule is provided as a standard rule, but needs to be set. 

From the main menu: Settings>Pick Filters>Plines… Define 
Rule….Select Rule ‘Normal’ and press OK. 

 

 
 

Connection with no rule set: 
 

 

 

                                 Connection with “normal” rule: 

pkey eq 'NA' or CCON eq ANY' 
 

 

 

Cadcentre supplies a set of standard details in the catalogues, which can be used for 
detailing. It is however important that each company build their own standard details 
in the catalogues. 

Secondary Joints 

The secondary joints can have an associated geometry, which is stored in a catalogue. 
The shape of the joint geometry can be parameterised to suit more than one specific 
occurrence.   

Modify>Joints> Specification  ‘Select a connected section end’ - Will bring up 
the following menu: 
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Type of joint: e.g. Column connection 

Subtype: e.g. Column web 

 

Available joints  

 

Geometry justification. (NA for most 
Cadcentre standard joints) 

Cuts the attached section by a certain 
distance 

Rotates the geometry around the attached 
section’s z-axis. 

 

Sketch of the joint geometry 

 

 

 

 

 

 

 

Primary Joints 

The geometry of a primary joint can be selected from a specification in a similar way 
to secondary joints. Typical catalogue geometry’s for Primary Joints would be: Base 
plates, Foundations, Sealing plates etc 
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Joint Freedom 

When a connection is made between structural elements the joint can either be 
dominant or subordinate, by default it is subordinate.  If a joint is subordinate then 
this means that if the owning section is moved then in response the attached sections 
will only extend or retract when the p-line rules are re-executed, in some situations 
this results in an unrealistic geometry with section end. When the joint is dominant 
the owning section doesn’t only describe the cut-plane for the attached section with p-
line rules, it also describes the end point of the section dragging the connected end of 
the attached section to the new position of the joint on the owning section.  
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Fittings 

A Section fitting does not belong to joints or nodes and can therefore be located 
anywhere along a section. Various types of fitting are available in the standard 
catalogue, e.g. Web stiffeners, Lifting lugs, fire insulation, etc. From the main menu 
bar in the Beams & Columns application Create>Fitting…  

 

Current specification 

Selector for section type or Subtype 

Selector for Subtype  

Available fittings  

 

 

 

 

Justification line (location line) 

Distance away from section Start 

Rotation around section Z-axis 

Sketch of fitting 

Lifting lug located on TOS of HEA section 
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Structural Exercise 4- Section Fittings and Joints 

• Modify one of the Main girder to Main girder joints to look like the picture below. 

Modify>Joints>Specification… 

Identify end of section to be modified 

Select:End Preparations 

            Simple Examples 

            Flush_p_cutback_with_snipe 

            Justification: NA 

            Cutback: 0 

            Beta angle: 0 or 180  

             Apply 

            Give a Rathole radius: 30  

If an error message occurs, check if the sections are connected, if they need 
connecting select Connect>Connect and connect them. 

If the cutouts are displayed like black wireframe lines change your graphical 
representation mode: Settings>Graphics>Representation… 

 

 

 

Toggle these buttons and press 
Apply. 

 

 

 

• Copy the joint  specification to the other side of the section using: 
Modify>Joints>Joint Like>Maintain Pline   
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- Hit joint to be copied like and then joint to be modified. 

The ‘Maintain Pline’ option is used for copying joints to the same section, while  
‘Use copied Pline’ is used for adjacent sections.   

 

• Modify the Angle to Main Girder Joints to:   

 End Preparations, Simple Examples, Angle_with_plate, Rathole 0. 

 Switch to wireline representation if it is hard to see the joint (F8) 

 

 

• Modify the tubular joints to: Tube Connections,  Bracing Tube, 
TUBE/TUBE/CONNECT 

 

 

 

 

 

 

• Add web stiffener brackets at the location of incoming bracing. See figure next 
pageCreate>Fitting>Single… 
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Use the measuring facility to find the position of the stiffeners . 

 

 

1. Snap Pline on Column  

2. Snap Pline on Bracing 

 

 

Copy Multiple Attached 

There are often instances, as in the beginning of our example, where a section needs 

VANTAGE PDMS培训手册 22



结构建模 

to be copied several times at regular centres, this would happen for example in a floor 
deck or where a uniformly distributed load is being applied to a bay. Each copy needs 
to have connections to the same elements and the same joint preparation. (Multiple 
offset copy would produce the items but with no connectivity.) 

Copy multiple attached automatically calculates how many sections at a given centres 
will fit in a bay, after the designer has selected the number of sections required they 
are produced complete with a copy of the connection details of the original. All the 
designer has to do is select the original as CE then select Create>Sections>Multiple 
Attached…. 
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