
 

 

 

   第一章 ANSYS 的安装和配置 

   ANSYS 程序包括两张光盘：一张是 ANSYS 经典产品安装盘，另一张是 ANSYSWorkbench 产品安装盘。本章以 ANSYS10．0 为例介绍 ANSYS

的安装、配置、启动及 ANSYS 的相关知识。 

   第一节 ANSYS 的安装 

   一、安装 ANSYS 对系统的要求 

   安装 ANSYS 对计算机系统的要求如下。 

   1．硬件要求 

   ①内存至少 256M； 

   ②采用显存不少于 32M 的显卡，分辨率至少为 1024x768，色彩为真彩色 32 位： 

   ③硬盘剩余空间至少 2G； 

   ④安装网卡，设置好 TCP／IP 协议，并且 TCP／IP 协议绑定到此网卡上。注意在 TCP／1P 协议中要设定计算机的 hostname。 

   2．软件系统要求 

   操作系统为 Windows2000 或 WindowsXP 以上。 

   二、安装 ANSYS 前的准备工作 

   1．拷贝文件 

   先将安装光盘中 MAGNITUDE 文件夹拷入计算机中，如 D：LMAGNITUDE，用 Windows 的记事本打开 D：~IAGNITUDE 文件夹中的

ansys．dat 文件，该文件的第一行内容为"SERVERhostOOOOO(30000001055”，把 host 改为你的计算机名，如 1wm 是我的主机名，则 host

改为 Ivan。执行命令所有程序>附件，命令提示符进入 DOS 状态，键入 1PCONFIG／ALL 回车，所显示的 physicaladdress 即为网卡号，本例中

计算机网卡的 physicaladdress 为 000c6e10c8531055，则 ansys．dat 文件的第一行内容修改为“SERVERlwm000c6e10c8531055”，以原

文件名存盘退出。 

   2．生成许可文件 

   运行 D：\MAGNITUDE 文件夹中的 keygen．bat 文件，生成 license．dat，该文件就是 ANSYS 的许可文件，将它存放在指定目录下永久

保存，本例中存放在 D：LMAGNITUDE 文件夹中。 

   三、安装 ANSYS 

   ①将 ANSYS 的安装光盘放入光驱中，出现如图 1-1 的画面，选择 Install ANSYS 10．0 开始安装 AHSYS10．0。 

   ②开始运行 ANSYS 安装程序，出现 ANSYS 安装欢迎界面如图 1-2 的所示，选择 Next 按钮进行下一步安装。 
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  第二章 实体建模 

   第一节基本知识 

   建模在 ANSYS 系统中包括广义与狭义两层含义，广义模型包括实体模型和在载荷与边界条件下的有限元模型，狭义则仅仅指建立的实体模型

与有限元模型。建模的最终目的是获得正确的有限元网格模型，保证网格具有合理的单元形状，单元大小密度分布合理，以便施加边界条件和载荷，

保证变形后仍具有合理的单元形状，场量分布描述清晰等。 

   一、实体造型简介 

   1．建立实体模型的两种途径 

   ①利用 ANSYS 自带的实体建模功能创建实体建模： 

   ②利用 ANSYS 与其他软件接口导入其他二维或三维软件所建立的实体模型。 

   2．实体建模的三种方式 

   (1)自底向上的实体建模 

   由建立最低图元对象的点到最高图元对象的体，即先定义实体各顶点的关键点，再通过关键点连成线，然后由线组合成面，最后由面组合成体。

   (2)自顶向下的实体建模 

   直接建立最高图元对象，其对应的较低图元面、线和关键点同时被创建。 

   (3)混合法自底向上和自顶向下的实体建模 

   可根据个人习惯采用混合法建模，但应该考虑要获得什么样的有限元模型，即在网格划分时采用自由网格划分或映射网格划分。自由网格划分

时，实体模型的建立比较 1e 单，只要所有的面或体能接合成一体就可以：映射网格划分时，平面结构一定要四边形或三边形的面相接而成。 

   二、ANSYS 的坐标系 

   ANSYS 为用户提供了以下几种坐标系，每种都有其特定的用途。 

   ①全局坐标系与局部坐标系：用于定位几何对象(如节点、关键点等)的空间位置。 

   ②显示坐标系：定义了列出或显示几何对象的系统。 

   ③节点坐标系：定义每个节点的自由度方向和节点结果数据的方向。 

   ④单元坐标系：确定材料特性主轴和单元结果数据的方向。 

   1．全局坐标系 

   全局坐标系和局部坐标系是用来定位几何体。在默认状态下，建模操作时使用的坐标系是全局坐标系即笛卡尔坐标系。总体坐标系是一个绝对

的参考系。ANSYS 提供了 4 种全局坐标系：笛卡尔坐标系、柱坐标系、球坐标系、Y-柱坐标系。4 种全局坐标系有相同的原点，且遵循右手定则，

它们的坐标系识别号分别为：0 是笛卡尔坐标系(cartesian)，1 是柱坐标系 
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(Cyliadrical)，2 是球坐标系(Spherical)，5 是 Y-柱坐标系(Y-aylindrical)，如图 2-1 所示。 

 

   ANSYS 引用坐标系 x 轴、Y 轴、z 轴代表不同的意义，笛卡尔坐标系的 X 轴、Y 轴、Z 轴分别代表其原始意义；柱坐标系的 x 轴、Y 轴、z 轴

分别代表径向 R、轴向 O 和轴向 Z；球坐标系的 X 轴、Y 轴、z 轴分别代表 R、O、p。 

   注意：4 种全局坐标系有共同的原点． 

   2．局部坐标系 

   局部坐标系是用户为了方便建模及分析的需要自定义的坐标系，可以和全局坐标系有不同的原点、角度、方向。 

   (1)建立局部坐标系 

   1)通过当前激活的工作平面的原点为中心来建立局部坐标系 

   ①Command 方式： 

   CSWPLA，KCN，KCS，pARl，PAll2 

   a．KCN：坐标系编号。KCN 是大于 10 的任何一个编号。 

   b．KCS：局部坐标系的属性。KCS=O 时为笛卡尔式坐标系；KCS=1 时为柱坐标系；KCS=2 时为球坐标系：KCS-3 时为环坐标系：KCS-4



时为工作平面坐标系：KCS=5 时为柱坐标系。 

   c．PAR1：应用于椭圆、球或螺旋坐标系。当 KCS=1 或 2 时，PAR1 是椭圆长短半径(Y／X)的比值，默认为 1(圆)：当 KCS=3 时，PARI

是环形的主半径。  ． 

   d．PAR2：应用于球坐标系，当 KCS=2 时，PAR2 是椭球 Z 轴半径与 x 轴半径的比值，默认为 1(圆)。 

   ②GUI 方式： 

   WorRPlane>Local Coordinate Systems>Create Local CS>At WP Origin 

   2)通过已定义的关键点来建立局部坐标系 

   ①Command 方式： 

   CSKP,KCN，KCS，PORlG，PXAXS，PXYPL，PARl，pAR2 

   a．KCN：坐标系编号。KCN 是大于 10 的任何一个编号。 

   b．KCS：局部坐标系的属性。KCS=0 时为笛卡尔式坐标系；KCS=1 时为柱坐标系；KCS=2 时为球坐标系：KCS=3 时为环坐标系；KCS=4

时为工作平面坐标系；KCS=5 时为柱坐标系。 

   c．PORlG：以该关键点为新建坐标系原点，若该值为 P，则可进行 GUI 选取关键点操作。 

   d．pXAXS，定义 x 轴的方向，原点指向该点方向为 x 轴正向， 

   e．PXYPL：定义 Y 轴的方向，若该点在 x 轴的右侧，则 Y 轴在 x 轴的右侧，反之在左侧。 

  第三章划分网格 

   第一节基本知识 

   几何实体模型并不参与有限元分析，所有施加在有限元边界上的载荷或约束，必须最终传递到有限元模型上(节点和单元)进行求解。因此，在

完成实体建模之后，要进行有限元分析，需对模型进行网格划分——将实体模型转化为能够直接计算的网格，生成节点和单元。 

   一、有限元网格概述 

   1．网格类型 

   总的来说，ANSYS 的网格划分有两种： 自由网格划分(Free meshing)和映射网格划分(Mapped meshing)，如图 3—1 所示。 

   自由网格划分主要用于划分边界形状不规则的区域，它所生成的网格相互之间是呈不规则排列的。对于复杂形状的边界常常选择自由网格划分。

自由网格对于单元形状没有限制，也没有特别的应用模式。缺点是分析精度往往不够高。 

   与自由网格划分相比较，映射网格划分对于单元形状有限制，并要符合一定的网格模式。映射面网格只包含四边形或三角形单元，映射体网格

只包含六面体单元。映射网格的特点是具有规则的形状，肆元明显地成行排列。 

 

   一般来说映射网格往往比自由网格划分得到的结果要更加精确，而且在求解时对 CPL 和内存的需求也相对要低些。如果用户希望用映射网格划

分模型，创建模型的几何结构必须由一系列规则的体或面组成，这样才能应用于映射网格划分。因此，如果确定选择映射网格，需要从建立几何模型

开始就对模型进行比较详尽的规划，以使生成的模型满足生成映射网格的规则要求。ANSYS 支持的单元形状与网格类型见表 3-1。 

 

   2．划分网格的过程 

   在 ANSYS 程序当中，有限元的网格是由程序自己来完成的，用户所要做的就是通过给出一些参数和命令来对程序实行“宏观调控”。网格划分过

程的 3 个步骤如下： 

   ①定义单元属性 定义单元属性的操作主要包括定义单元类型、定义实常数和定义材 
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料参数等。 



   ②定义网格划分控制 ANSYS 程序提供了大量的网格生成控制，用户可以根据模型的形状和单元特点选用。 

   ③生成网格 其中第②步的设置有时是不需要的，因为默认网格控制对许多模型都是适用的。可定义单元属性对于网格划分来说是必不可少的，

它不仅影响到网格划分，而且对求解的精度也有很大影响。 

   二、定义单元属性 

   在生成节点和单元网格之前，必须定义合适的单元属性。 

   1．定义单元类型 

   在有限元分析过程中，对于不同的问题，需要应用不同特性的单元，单元选择不当，直接影响到计算能否进行和结果的精度。ANSYS 的单元库

中提供了 200 多种单元类型，每个单元都有唯一的编号，如 LINK1、pLANE2、BEAM3 和 SOLID45 等，几乎能解决大部分常见问题。 

 

   下面用 GUI 的方式介绍定义单元类型的常用操作步骤。 

   ①选择 MainMenu>Preprocessor>Element Type>Add／Fxlit／Delete 命令，弹出如图 3-2 所示的 Element Type 对话框(初次定义时，

列表框中显示“NONE DEFINED”，表示没有任何单元被定义)。 

   ②单击 Add…按钮，弹出 Library of Element Types 对话框，如图 3-3 所示。可以看到，列表框中列出了单元库中的所有单元类型。左侧列

表框中显示的是单元的分类，右侧列表框为单元的特性和编号，选择单元时应该先明确自己要定义的单元类型，如 LINK、PLANE、BEAM 和 SOLID

等，然后从右边列表框中选择合适的单元。 

   ③在左侧列表框中选择 Solid，则右侧列表框中将显示所有的 Solid 单元，如 Brick 8node45 即为 Solid45 单元。选中此单元，并在 Element 

type reference number 文本框中输入参考号，默认为“1”，单击 OK 按钮即可，如图 3—3 所示。 

   ④此时，单击 Apply 按钮，可继续添加别的单元类型，同时 Element type reference number 文本框中的数值将自动变为“1”．用户可以模

仿前面介绍的方法，定义一个 BEAM3 单元，单击 OK 按钮后，返回单元类型对话框，如图 3-4 所示。 

 

第四章 逻辑选择 

   第一节基本知识 

   若用户只对模型的某一部分进行操作处理，如加载、有选择性地观察结果等，则可利用选择功能。选择功能可以选择节点、单元、关键点、线、

面、体等子集，以便能够在该部分实体上进行操作。 

   所有的 ANSYS 数据都在数据库内，利用选择功能，用户可以方便地只选择数据的某部分进行操作。例如：显示第一象限内的点、删除所有半

径在 0．5 与 1．0 之间的弧段、只观察材料是钢的单元的计算结果等。 

   利用选择功能的典型例子包括施加载荷、列出子集结果、或者是绘制所选实体等。选择功能的另一个有用特征是能够选择实体的子集并给这个

子集命名。例如：可以选择组成水泵叶片部分的所有单元，并把它命名为子集 blade。像这样命名的子集叫做元件，几个元件组成一个部件。 

   进入 ANSYS 选择 Select 菜单，操作命令为 GUI：Utility Menu>Select。 

   一、选择实体 

   1．实体类型 

   运行选择实体的操作命令 GUI：Utility Menu>Select>Entities，弹出实体选择对话框，如图 4-1 所示。实体类型包括 Nodes、Elements、



Volumes、Areas、Lines、Keypoints。 

   2．选择准则 

   选择准则与实体类型有关，不同的实体类型对应不同的选择准则。如选择节点的准则有： 

①ByNum／Pick 项，通过实体号或通过拾取操作进行选择。 

②Attached to 项，通过实体的隶属关系进行选择。 

③By Locafion 项，根据 X，Y，Z 坐标位置选择。 

④By Attributes 项，根据材料号、实常数号等进行选择，不同的实体所用的属性不相同。 

⑤Exterior 项，选择模型外边界的实体。 

⑥By Results 项，根据结果数据选择。 

3．选择方式 

选择实体的方式有七种，如图 4-2 所示。各项的含义为： 

①From Full 项，从整个实体集中选择一个子集，阴影部分表示活动子集。 

②Reselect 项，从选中的子集中再选择一个子集，逐步缩小子集的选择范围。 

③Also Select 项，在当前子集中添加另外一个不同的子集。 

④Unselect 项，从当前子集中去掉一部分，与 Reselect 的选择刚好相反。 

⑤Select All 项，恢复选择整个全集。 

⑥Select None 项，选择空集。 

⑦Invert 项，选择当前子集的补集。 
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   二、Comp／Assembly 功能 

   此项为构件和部件的创建和选择功能菜单。用户可以将一些常用实体组合构造成一个构件 Component，并给这个构件赋予一个构件名。也可

以将多个构件组合构造成一个部件集合 Assembly，部件也有自己的名字。在选择实体模型时，用户可以随时通过该项对应的名称来访问构成这些构

件和部件的实体。 

   操作命令有 GUI：Utility Menu>Select>Comp／Assembly。 

   下面对 Comp／Assembly 子菜单中各功能选项进行介绍。 

   1．CreateComponent 生成构件 

   GUI：Utility Menu>Select>Comp／Assembly>Create Component。 

   在执行上述操作之前，必须先选择实体类型如节点、单元等。当选择组成元件的实体，执行该命令后，会弹出 Create Component 的对话框，

输入创建的构件名，单击 OK 键结命令。 

   2．Create Assembly 生成部件 

   GUI：Utility Menu>Select>Com／Assembly>Create Assembly。 

   选定要构成部件的所有构件，运行上述菜单，弹出生成部件对话框，在此窗口输入所要创建部件的名字，即可创建由这些构件构成的部件。 

   3．Edit Assembly 编辑部件 



   GUI：Utility Menu>Select>Comp／Assembly>Edit Assembly。 

   运行上述菜单，弹出 EditAssembly 对话框可以对部件进行编辑。选定要编辑的部件，可以对其中的构件进行删除操作，也可以向部件中添加

构件。 

   4．SelectComp／Assembly 选择构件／部件 

   GU：UtilityMenu>Select>Comp／Assembly>Select Comp/Assembly。 

   运行上述菜单，弹出 Select Component Assembly 窗口，可以对先前定义的构件或者部件进行选取。 

   5．ListComp／Assembly 列出构件／部件 

   GUI：Utility Menu>Select>Comp／Assembly>ListComp／Assembly。 

第五章加载与求解 

   施加载荷是有限元分析中关键的一步，可以对网格划分之后的有限元模型施加载荷，也可以直接对实体模型施加载荷。当对模型进行了划分网

格和施加载荷之后，就可以选择适当的求解器对问题进行求解。 

   第一节基础知识 

   一、载荷的分类 

   ANSYS 中载荷(Loads)包括边界条件和模型内部或外部的作用力。在不同的学科中，载荷的定义如下。 

   ①结构分析：位移、力、压力、弯矩、温度和重力。 

   ②热分析：温度、热流率、对流、内部热生成、无限远面。 

   ③磁场分析：磁势、磁流通、磁电流段、源电密度、无限远面。 

   ④电场分析；电势(电压)、电流、电荷、电荷密度、无限远面。 

   ⑤流场分析：速度、压力。 

   在 ANSYS 中，载荷主要分为六大类：DOF 约束(自由度约束)、力(集中载荷)、表面载荷、体载荷、惯性力及耦合场载荷，它们的含义为如下。

   ①DOF 约束(DOF constraint)：用户指定某个自由度为已知值。在结构分析中约束是位移和对称边界条件：在热力学分析中约束是温度和热流

量等。 

   ②力(集中载荷)(Fome)：施加于模型节点的集中载荷。如结构分析中的力和力矩，热分析中的热流率。 

   ③⑧表面载荷(SurfaceLoad)：作用在某个表面上的分布载荷。如结构分析中的压力，热分析中的对流和热流量。 

   ④体载荷(Body loads)：作用在体积或场域内。如结构分析中的温度和重力，热分析中的热生成率。 

   ⑤惯性载荷(Inertia loads)：结构质量或惯性引起的载荷。如重力加速度、角速度和角加速度，主要在结构分析中使用。 

   ⑥耦合场载荷(Coupled-field loads)：它是一种特殊的情况，从一种分析中得到的结果用作另一种分析的载荷；如热分析中得到的节点温度可

作为结构分析中的体载荷施加到每一个节点。 

   二、载荷步、子步和平衡迭代 

   1．载荷步 

   载荷步是指分步施加的载荷，在线性静态或稳态分析中，可以使用不同的载荷步施加不 
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同的载荷组合。如图 5—1 所示，第一个载荷步用于线性载荷，第二个载荷步用于常数载荷部分，第二个载荷步用于卸载。 

   2．子步 

 

   子步是指在一个特定的载荷步中每一次增加的步长，也称为时间步，代表一段时间。对于不同的分析类型，子步的作用不同： 

   ①在非线性静态分析或稳态分析中，使用子步逐渐施加载荷以便能获得精确解。 

   ②在线性或非线性瞬态分析或稳态分析中，使用于步满足瞬态时间积分法则(为获得精确解，通常规定一个最小的时间步长)。 

   ③在谐波分析中，使用于步可获得谐波频率范围内多个频率处的解。 

   3．阶跃载荷和坡度载荷 

   在一个载荷步中，有两个或者两个以上的载荷步子步时，就必须选择所施加的载荷应该为阶跃载荷还是为坡度载荷。所谓阶跃载荷，就是指在

第一个子步全部施加上去了，载荷在以后的每个子步中保持不变。坡度载荷就是指在每一个载荷步子步，载荷值都是递增的，直到最后一个载荷步子

步，全部的载荷才施加上去。 

   4．平衡迭代 

   平衡迭代是指在给定子步下为了收敛而计算的附加解。平衡迭代仅应用于收敛起着很重要作用的非线性分析(静态或瞬态)中的迭代修正。 



   三、通用选项 

   通用选项包括瞬态或者静态分析当中载荷步结束的时间、子步步数或者说时间步大小、阶跃载荷、热应力当中的参考温度。选择 Main 

Menu>Solution>Load Step Opts 命令展开载荷步选项菜单。选择 Main Menu>Solution>Load Step Opts>Time／Frequent>Time-Time 

Step 命令，弹出如图 5-2 所示的对话框。 

   注意：如果展开的载荷步选项菜单不完全，选择 Main Menu>Solution>Unabridgad Menu 命令即可． 

   TIME 命令在与速率有关的问题当中是指实际的时间，要求指定一个时间值；在与速率无关的问题里面，时间是一个用作跟踪载荷的参数。显然，

无论哪一种情况，都不能将时间设置为 0。 

   DELTIM 命令是给 ANSYS 程序分析指定时间步的大小，在通用选项的另外一个窗口 Time and Substep Options 当中，ANSYS 程序是要通

过 NSUBST 命令来指定分析过程当中的子步的大小。 

 
   KBC 命令是指定载荷的施加是采用阶跃式还是采用坡度式(线性方式)。 
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第六章 后处理 

   第一节基本知识 

   对模型进行有限元分析后，通常需要对求解结果进行查看、分析和操作。检查并分析求解的结果的相关操作称为后处理。 

   用 ANSY$软件处理有限元问题时，建立有限元模型并求解后，并不能直观地显示求解结果，必须用后处理器才能显示和输出结果。检查分析结

果可使用两个后处理器：通用后处理器 POSTl 和时间历程后处理器 POST26。输出形式可以有图形显示和数据列表两种。 

   一、通用后处理器 POST1 

   这个模块用来查看整个模型或者部分选定模型在某一个时刻(或频率)的结果。对前面的分析结果能以图形、文本形式或者动画显示和输出，如

各种应力场、应变场等的等值线图形显示、变形形状显示以及检查和解释分析的结果列表。另外还提供了很多其他功能，如误差估计、载荷工况组合、

结果数据计算和路径操作等。 

   进入通用后处理器的路径为 GUI：Main Menu>General Postproc。 

   1．将数据结果读入数据库 

   要想查看数据，首先要把计算结果读入到数据库中。这样，数据库中首先要有模型数据(节点和单元等)。若数据库中没有数据，需要用户单击

工具栏上的“KESUM DB”按钮(或输 XRESUME 命令，或 GUI 菜单路径：Utility Menu>File>Resume Jobname．db)读取数据文件

Jobname.db．数据库包含的模型数据应与计算模型相同，否则可能会无法进行后处理。 

   默认情况下，ANSYS 会在当前工作目录下寻找以当前工作文件命名的结果文件，若从其他结果文件中读入结果数据，可通过如下步骤选定结果

文件。 

   运行 Main Menu>General Postproc>Data & File Opts 命令，弹出 DataandFileOptions(数据和文件选项)对话框，如图 6—1 所示。在

此对话框中选择后处理中将要显示或列表的数据，如节点／单元应力、应变。此外，还要选择包含此结果的数据文件，对于结构分析模型，选择*rst

文件，单击 OK 按钮则所选择的文件读入到数据库。对话框中各参数的意义如下。 

   (1)Data to be read 项，选择要分析的结果。一般采用默认值 All items 或 Basic items。 

   (2)Results file to be read 项，在文本框中输入将要读入的结果文件名，或单击文本框右侧的[…]按钮选择将要读入的结果文件。 



 

   一旦模型数据已经存在于数据库中，执行 GUI：Main Menu>General Postproc>Read Results 命令，可将结果文件读入数据库。 
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   2．图像显示结果数据 

   POSTl 具有强大的图形显示能力，所需结果存入数据库后，可以将读取的结果数据通过不同的形式用图形直观地显示出来。 

   (1)等值线显示 等值线显示表现了结果项(如应力、变形等)在模型上的变化，它用不同的颜色表示结果的大小，具有相同数值的区域用相向的

颜色表示。因此通过等值线显示，可以非常直观地得到模型某结果项的分布情况。 

   (2)变形后的形状显示 在结构分析中可用它观察在施加载荷后的结构变形情况，显示变形的方式有三种选项： 

   ①Def Shape only 项，仅显示变形后的形状。 

   ②Def+undeformed 项，显示变形前后的形状。 

   ⑧Def+underedge 项，显示变形后的形状及未变形的边界。 

   (3)矢量显示 矢量显示可用箭头显示模型牛某个矢量大小和方向的变化。鲒构分析中的位移、转动、主应力等都是矢量。 

   (4)路径显示 路径图是显示某个变量(例如位移、应力、温度等)沿模型上指定路径的变化图。沿路径还可以进行各种数学运算，得到一些非常

有用的计算结果。但是仅能在包含实体单元(二维或三维)或板壳单元的模型中定义路径，对仅包含一维单元的模型，路径功能不可用。 

   以图形方式观察结果沿路径的变化或者沿路径进行数学运算需要遵从以下步骤： 

   ①定义路径属性。 

   ②定义路径点。 

   ③沿路径插值(映射)结果数据。 

   ④显示结果。一旦把结果影射到路径上，可用图像显示或列表显示方式观察结果沿定义的路径变化情况，也可以执行算术运算。 

   要查看某项结果沿路径的变化情况，首先要定义路径(Path)。ANSYS 提供了 3 种定义路径的方法：通过节点定义路径、在工作平面上定义路

径和通过路径定义点来定义路径。通过节点定义路径的 GUI 操作步骤为：运行 Main Menu>General Postproc>Path Operations>Define 

Path>By Nodes 命令，弹出节点选择对话框，选择足够多的节点以定义路径。 

   节点选择完毕后单击 OK 按钮，弹出如图 6-2 所示的对话框。在 Define Path Name 文本框中输入路径名；在 Number of datasets(数据项

的个数)文本框中输入可以映射到所定义的路径上的结果项数目的最大值，此项最小值 4，默认值为 30；在 Number of divisions(分割个 
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第七章 桁架和梁的有限元分析 

   第一节基本知识 

   一、桁架和粱的有限元分析概要 

   1．桁架杆系的有限元分析概要 

   桁架杆系系统的有限元分析问题是工程中晕常见的结构形式之一，常用在建筑的屋顶、机械的机架及各类空间网架结构等多种场合。 



   桁架结构的特点是，所有杆件仅承受轴向力，所有载荷集中作用于节点上。由于桁架结构具有自然离散的特点，因此可以将其每一根杆件视为

一个单元，各杆件之间的交点视为一个节点。 

   2．梁的有限元分析概要 

   梁的有限元分析问题也是是工程中最常见的结构形式之一，常用在建筑、机械、汽车、工程机械、冶金等多种场合。 

   梁结构的特点是，梁的横截面均一致，可承受轴向、切向、弯矩等载荷。根据梁的特点，等截面的梁在进行有限元分析时，需要定义梁的截面

形状和尺寸，用创建的直线代替梁，在划分网格结束后，可以显示其实际形状。 

   二、桁架和梁的常用单元 

   桁架和梁常用的单元类型和用途见表 7-1。 

 
   通过对桁架和粱进行有限元分析，可得到其在各个方向的位移、应力并可得到应力、位移动画等结果。 
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   第二节桁架的有限元分析实例案例 1--2D 桁架的有限元分析 

 
   问题 

   人字形屋架的几何尺寸如图 7—1 所示。杆件截面尺寸为 0．01m^2，试进行静力分析，对人字形屋架进行静力分析，给出变形图和各点的位

移及轴向力、轴力图。 

   条件 

   人字形屋架两端固定，弹性模量为 2．0x10^11N/m^2，泊松比为 0．3。 

   解题过程 

   制定分析方案。材料为弹性材料，结构静力分析，属 21)桁架的静力分析问题，选用 Link1 单元。建立坐标系及各节点定义如图 7-1 所示，边

界条件为 1 点和 5 点固定，6、7、8 点各受 1000N 的力作用。 

   1．ANSYS 分析开始准备工作 

   (1)清空数据库并开始一个新的分析 选取 Utility Menu>File>Clear&Start New，弹出 Clears database and Start New 对话框，单击 OK

按钮，弹出 Verify 对话框，单击 OK 按钮完成清空数据库。 

   (2)指定新的工作文件名 指定工作文件名。选取 Utility Menu>File>Change Jobname，弹出 Change Jobname 对话框，在 Enter New 

Jobname 项输入工作文件名，本例中输入的工作文件名为“2D-spar”，单击 OK 按钮完成工作文件名的定义。 

   (3)指定新的标题 指定分析标题。选取 Ufility Menu>File>Change Title，弹出 ChangeTitle 对话框，在 Enter New Tifie 项输入标题名，



本例中输入“2D-spar problem'’为标题名，然后单击 OK 按钮完成分析标题的定义。 

   (4)重新刷新图形窗 9 选取 Utility Menu>Plot>Replot，定义的信息显示在图形窗口中。 

   (5)定义结构分析 运行主菜单 Main Menu>Preferences，出现偏好设置对话框，赋值分析模块为 Structure 结构分析，单击 OK 按钮完成分

析类型的定义。 

   2．定义单元类型 

   运行主菜单 Main Menu>Preprocessor>Element Type>Add／Edit／Delete 命令，弹出 Element Types 对话框，单击 Add 按钮新建单

元类型，弹出 Library of Element Types 对话框，先选择 
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   第八章 平面和壳问属的有限元分析 

   第—节基本知，识 

   严格地说，任何弹性物体都是处在三维受力状态，因而都是空间问题，但是在一定条件下，许多空间问题可以简化为平面问题，从而使计算工

作量大大减少。典型的平面问题有平面应力问题和平面应变问题。 

   板壳问题是工程实际中最常遇到的问题之一。 

   一、平面应力问题 

   平面应力问题是指受力体在 z 方向上尺寸很小(即呈平板状)，外载荷都与 x 轴垂直，且沿 z 轴方向没有变化，假设受力体在 z 方向上的尺寸为

h，平分 h 的平面成为中间平面，简称中面，则在 z=±h/2 处的外表面上不受任何载荷，如图 8—1 所示。在建立模型时，以受力体的中面尺寸建立

模型。 

   二、平面应变问题 

   平面应变问题是指受力体在 z 方向的尺寸很大，所受的载荷又平行于其横截面(垂直于 x 轴)且不沿长度方向(z 方向)变化，即物体的内在因素和

外来作用都不沿长度方向变化，如图 8-2 所示。 

 

   对于有些问题，例如挡土墙和水坝的受力问题，虽然其结构不是无限长，而且在靠近两端之处的横截面也往往是变化的，并不符合无限长柱形

体的条件，但实践证明，这些问题是很接近于平面应变问题的，对于离开两端较远之处，按平面应变问题进行分析计算，得出的结果是可以满足工程

实际要求的。 

   表 8-1 是常用的平面应力问题和平面应变问题的单元类型和用途。 

   在利用 ANSYS 进行有限元分析时，将这些单元定义为新的单元后，如平面应力问题，设置单元配置项 KEYOPT(3)为 Plane stree 或 Plane 

stress with thickness input(考虑板的厚度)；如为平面应变问题，设置单元配置项 KEYOPT(3)为 Plane strain。 
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   三、壳的问题 

   对于两个曲面所限定的物体，如果曲面之间的距离比物体的其他尺寸小很多，就称之为壳体。并且这两个曲面称为壳面。距两壳面等距的点形

成的曲面成为中间曲面，简称中面。对受力体进行有限元分析时，以中面尺寸建立模型。表 8-2 是常用的壳单元类型和用途。 



 
   第二节平面问题有限元分析实例 

案例 1——角架的静力分析 

   问题 

   如图 8-3 所示，角架材质为钢，其厚度为 0．5 m，左端孔直径 1m，并且固定，右下方有一孔直径 1m，角架圆弧部分为半径 1 m 的半四)

并且承受均变压力 100Pa～1000Pa～100h，其他尺寸如图所示，试对该角架进行静力分析。 

   条件 

   弹性模量为 3．0x10^7N／m^2，泊松比为 0．3。 

   解题过程 

   以角架左端孔圆心为坐标原点，建立直角坐标系如 
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第九章 轴对称问题的有限元分析 

   第一节基本知识 

   本节的有限元对象为轴对称问题，目的是学习将 3D 问题转化为 213 问题分析的轴对称方法，涉及如何选取轴对称单元、建模规律、载荷的施

加方法和后处理技术。 

   一、轴对称问题的定义 

   轴对称问题是指受力体的几何形状、约束状态，以及其他外在因素都对称于某一根轴(过该轴的任一平面都是对称面)。轴对称受力体的所有应

力、应变和位移均对称于这根轴。 

   二、用 ANSYS 解决 2D 轴对称问题的规定 

   用 ANSYS 解决 2D 轴对称问题时，轴对称模型必须在总体坐标系 XOY 平面的第一象限中创建，并且 Y 轴为轴旋转的对称轴。 

   求解时，施加自由约束、压力载荷、温度载荷和 Y 方向的加速度可以像其他非轴对称模型一样进行施加，但集中载荷有特殊的含义，它表示的

是力或力矩在 360 度范围内的合力，即输入的是整个圆周上的总的载荷大小。同理，在求解完毕后进行后处理时，轴对称模型输出的反作用力结果

也是整个圆周上的合力输出，即力和力矩按总载荷大小输出。 

   在 ANSYS 中，x 方向是径向，Z 方向是环向，受力体承载后的环向位移为零，环向应力和应变不为零。 



   常用的 2D 轴对称单元类型和用途见表 9—1。 

 

   在利用 ANSYS 进行有限元分析时，将这些单元定义为新的单元后，设置单元配置项 KEYOPT(3)为 Axisymmetric(Shell51 和 Shell61 单元

本身就是轴对称单元，不用设置该项)，单元将被指定按轴对称模型进行计算。 

   后处理时，可观察径向和环向应力，它对应的是 SX 与 SZ 应力分量，并且在直角坐标系下观察即可。 

   可以通过轴对称扩展设置将截面结果扩展成任意扇型区域大小的模型，以便更加真实地 
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观察总体模型的各项结果。 

   第二节 2D 轴对称问题有限元分析实例 

   案例 1——圆柱筒的静力分析 

   问题 

   如图 9．1 所示，圆柱筒材质为 A3 钢，受 1000N／m 的压力作用，其厚度为 0．1 m，直径 12m，高度为 16m，并且圆柱筒壳的下部轴线

方向固定，其他方向自由，试计算其变形、径向应力和轴向应力。 

 

   条件 

   弹性模量为 2．0x10^11N／m^2，泊松比为 0．3。 

   解题过程 

   以圆柱筒底部中心为坐标原点，建立直角坐标系如图 9—1 所示，标出主要点(1 点和 2 点)的坐标，为实体造型做好准备。 

   制定分析方案。分析类型为线弹性材料，结构静力分析，轴对称问题，由于受力题为圆柱壳，选用 Shell51 单元，筒的厚度为 0．1m 为单元

的实常数；边界条件为圆柱筒下部施加轴线方向固定支撑，2 点的受力为 1000*12 等于 37699N。 

   1．ANSYS 分析开始准备工作 

   (1)清空数据库并开始一个新的分析 选取 Utility Menu>File>Clear&Start New，弹出 Clear database and Star New 对话框，单击 OK

按钮，弹出 Veilfy 对话框，单击 OK 按钮完成清空数据库。 

   (2)指定新的工作文件名 指定工作文件名。选取 Utility Menu>File>Change Jobname，弹出 Change Jobname 对话框，在 Enter New 

Jobname 项输入工作文件名，本例中输入的工作文件名为“yuanzhutong"，单击 OK 按钮完成工作文件名的定义。 

   (3)指定新的标题 指定分析标题。选取 Utility Menu>File>Change Title，弹出 Ch 皿 gc 
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第十章 3D 实体的有限元分析 

   第一节基本知识 



   一、3D 实体建模方法 

   在实际问题中，任何一个物体严格地说都是空间物体，它承受的载荷一般都是空间的，任何简化都会带来误差，因此，在分析问题时应尽量对

受力体建立三维模型，然后进行分析。三维实体的建模方法主要有两种，一种是直接在 ANSYS 中建立三维图形，另一种是在其他三维 CAD 软件中

建立模型后导入 ANSYS 中。第一种方法的特点是直接并且没有建模信息的丢失，但如果需要建立的模型比较复杂，特别是有比较复杂的曲面时，就

必须采用第二种法了。 

   二、3D 实体的常用单元 

   常用的 3D 实体单元类型和用途见表 10—1。 

 
   通过对三维实体物体进行有限元分析，可得到其在各个方向的位移、应力并可得到应力、位移动画等结果。 

   第二节 3D 实体的有限元分析实例 

   案例——车刀的静力分析 

   问题 

   如图 10-l 所示，为一车刀的示意图。A1 面受 1000N／m2 的压力作用，该面的高度为 

第 200 页

0．005m，如面 A19、A26、A18 固定，试计算其发生的变形、产生的应力．车刀的图形存放在光盘中\import ansys file 文件夹下，文件名为

cutter．igs，在建模时的单位为 cm。 

   条件 

   弹性模量为 2．0X101lN／m^2，泊松比为 0．3。 

   解题过程 

   制定分析方案。分析类型为线弹性材料，结构静力分析，3D 实体静力分析问题，选用十节点四面体结构实体单元 Tet 10node 92 单元(Solid92)，

不需要设置实常数：边界条件为面 A19、A26、A18 固定，A1 面受 1000N／mJ 的压力作用。 

   1．ANSYS 分析开始准备工作 

   (1)清空数据库并开始一个新的分析 选取 Ufill 订 Menu>File>Clear&StartNew，弹出 Clears database and Start New 对话框，单击 OK

按钮，弹出 Veri～对话框，单击 OK 按钮完成清空数据库。 

   (2)指定新的工作文件名 指定工作文件名。选取 Utility Menu>File>ChangeJobname，弹出 Change Jobname 对话框，在 Enter New 

Jobname 项输入工作文件名，本例中输入的工作文件名为“Cutter"，单击 OK 按钮完成工作文件名的定义。 

   (3)指定新的标题 指定分析标题。选取 Utility Menu>File>Change Title，弹出 ChangeTitle 对话框，在 EnterNew0Uc 项输入标题名，本

例中输入“3Dproblem”为标题名，然后单击 OK 按钮完成分析标题的定义。 

   (4)重新刷新图形窗口 选取 UtilityMenu>Plot~Replot，定义的信息显示在图形窗口中。 

   15)定义结构分析 运行主菜单 MainMenu>Preferences，出现偏好设置对话框，赋值分析模块为 Structure 结构分析，单击 OK 按钮完成分

析类型的定义。  2．把图形导入 ANSYS 中 

   (1)选择 Nodafeaturing，输入 cutter.igs 文件 选取 Utility Menu>File>lmoort>IGES…，弹出 inputIGESFile 对话框，单击 OK 拉钮，

弹出 Import IGES File 对话框，如图 10-2 所示。在光盘的 importansysfile 文件夹中选择文件 cutter.igs，单击 OK 按钮调入车刀模型。 

   (2)改变模型的单位 由于 cutter,lgs 文件图形是以厘米为单位建立模型，为了计算方便，在 ANSYS 中统—采用国际单位，长度单位采用米。

运行 Main Menu>Preprocessor>modeling>Operate>Scale>Volumes，弹出拾取菜单，按 PickAll，弹出 Scale Volumes 对话框如 
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ANSYS 中单元类型及其选择 

2009-03-12 14:38 

ansys单元类型种类统计 

单元名称 种类 单元号 

LINK (共 12 种) 1,8,10,11,31,32,33,34,68,160,167,180 

PLANE (共 20 种)2,13,25,35,42,53,55,67,75,77,78,82,83,121,145,146,162,182,183,223 

BEAM (共 09 种)3,4,23,24,44,54,161,188,189 

SOLID (共 30

种)5,45,46,62,64,65,69,70,87,90,92,95,96,97,98,117,122,123,127,128,147,148,164,168,185,186,187,191

,226,227 

COMBIN (共 05 种)7,14,37,39,40 

INFIN (共 04 种)9,47,110,111 

CONTAC (共 05 种)12,26,48,49,52 

PIPE (共 06 种)16,17,18,20,59,60 

MASS (共 03 种)21,71,166 

MATRIX (共 02 种)27,50 

SHELL (共 19 种)28,41,43,51,57,61,63,91,93,99,131,132,143,150,157,163,181,208,209 

FLUID (共 14 种)29,30,38,79,80,81,116,129,130,136,138,139,141,142 

SOURC (共 01 种)36 

HYPER (共 06 种)56,58,74,84,86,158 

VISCO (共 05 种)88,89,106,107,108 

CIRCU (共 03 种)94,124,125 

TRANS (共 02 种)109,126 

INTER (共 05 种)115,192,193,194,195 

HF (共 03 种)118,119,120 

ROM (共 01 种)144 

SURF (共 04 种)151,152,153,154 

COMBI (共 01 种)165 

TARGE (共 02 种)169,170 

CONTA (共 06 种)171,172,173,174,175,178 

PRETS (共 01 种)179 

MPC (共 01 种)184 

MESH (共 01 种)20 

转自http://m61116.on-line-degrees.net/jx/res-p1-t148348-/ 

http://m61116.on-line-degrees.net/jx/res-p1-t148348-/
http://m61116.on-line-degrees.net/jx/res-p1-t148348-/


ANSYS分析结构静力学中常用的单元类型 

类别 形状和特性 单元类型 

杆 普通 

双线性 

LINK1,LINK8 

LINK10 

梁 普通 

截面渐变 

塑性 

考虑剪切变形 

BEAM3,BEAM4 

BEAM54,BEAM44 

BEAM23,BEAM24 

BEAM188,BEAM189 

管 普通 

浸入 

塑性 

PIPE16,PIPE17,PIPE18 

PIPE59 

PIPE20,PIPE60 

2-D 实体 四边形 

三角形 

超弹性单元 

粘弹性 

大应变 

谐单元 

P 单元 

PLANE42,PLANE82,PLANE182 

PLANE2 

HYPER84,HYPER56,HYPER74 

VISCO88 

VISO106,VISO108 

PLANE83,PPNAE25 

PLANE145,PLANE146 

3-D 实体 块 

四面体 

层 

各向异性 

超弹性单元 

粘弹性 

大应变 

P 单元 

SOLID45,SOLID95,SOLID73,SOLID185 

SOLID92,SOLID72 

SOLID46 

SOLID64,SOLID65 

HYPER86,HYPER58,HYPER158 

VISO89 

VISO107 

SOLID147,SOLID148 

壳 四边形 

轴对称 

层 

剪切板 

SHELL93,SHELL63,SHELL41,SHELL43,SHELL181 

SHELL51,SHELL61 

SHELL91,SHELL99 

SHELL28 

http://www.gogo36.cn/search.php?site=nwkey&name=%E5%88%86%E6%9E%90
http://www.gogo36.cn/search.php?site=nwkey&name=%E7%BB%93%E6%9E%84


P 单元 SHELL150  
ANSYS 单元类型选择方法 

2009-03-12 14:39 

最近在学习 ANSYS，收集到一些资料，跟大家分享一下：还有心得体会将在后面写出来跟同行们交流！ 

下面是有关 ANSYS 分析中的单元选择方法： 

一、单元类型选择概述： 

ANSYS 的单元库提供了 100 多种单元类型，单元类型选择的工作就是将单元的选择范围缩小到少数几个单元上；

单元类型选择方法： 

1.设定物理场过滤菜单，将单元全集缩小到该物理场涉及的单元； 

二、单元类型选择方法（续一） 

2.根据模型的几何形状选定单元的大类，如线性结构则只能用“Plane、Shell”这种单元去模拟； 

3.根据模型结构的空间维数细化单元的类别，如确定为“Beam”单元大类之后，在对话框的右栏中，有 2D 和 3D

的单元分类，则根据结构的维数继续缩小单元类型选择的范围； 

三、单元类型选择方法（续二） 

4.确定单元的大类之后，又是也可以根据单元的阶次来细分单元的小类，如确定为“Solid-Quad”，此时有四种

单元类型： Quad 4node 42 Quad 4node 183 Quad 8node 82 Quad 8node 183 前两组即为低阶单元，后两组为高

阶单元； 

四、单元类型选择方法（续三） 

5.根据单元的形状细分单元的小类，如对三维实体，此时则可以根据单元形状是“六面体”还是“四面体”，确

定单元类型为“Brick”还是“Tet”； 

五、单元类型选择方法（续四） 

6.根据分析问题的性质选择单元类型，如确定为 2D 的 Beam 单元后，此时有三种单元类型可供选择，如下：2D 

elastic 3 2Dplastic 23 2D tapered 54，根据分析问题是弹性还是塑性确定为“Beam3”或“Beam4”，若是变

截面的非对称的问题则用“Beam54”。 

六、单元类型选择方法（续五） 

7.进行完前面的选择工作，单元类型就基本上已经定位在 2-3 种单元类型上了，接下来打开这几种单元的帮助手

册，进行以下工作： 

仔细阅读其单元描述，检查是否与分析问题的背景吻合、 

了解单元所需输入的参数、单元关键项和载荷考虑； 

了解单元的输出数据； 

仔细阅读单元使用限制和说明。 
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